gnu: webkitgtk: Update to 2.28.2.
[jackhill/guix/guix.git] / gnu / packages / fabric-management.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2017 Dave Love <fx@gnu.org>
3 ;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
4 ;;; Copyright © 2019 Ricardo Wurmus <rekado@elephly.net>
5 ;;; Copyright © 2019 Ludovic Courtès <ludo@gnu.org>
6 ;;;
7 ;;; This file is part of GNU Guix.
8 ;;;
9 ;;; GNU Guix is free software; you can redistribute it and/or modify it
10 ;;; under the terms of the GNU General Public License as published by
11 ;;; the Free Software Foundation; either version 3 of the License, or (at
12 ;;; your option) any later version.
13 ;;;
14 ;;; GNU Guix is distributed in the hope that it will be useful, but
15 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
16 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
17 ;;; GNU General Public License for more details.
18 ;;;
19 ;;; You should have received a copy of the GNU General Public License
20 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
21
22 (define-module (gnu packages fabric-management)
23 #:use-module (guix packages)
24 #:use-module (guix licenses)
25 #:use-module (guix download)
26 #:use-module (guix git-download)
27 #:use-module (guix utils)
28 #:use-module (guix build-system gnu)
29 #:use-module (gnu packages)
30 #:use-module (gnu packages autotools)
31 #:use-module (gnu packages bison)
32 #:use-module (gnu packages flex)
33 #:use-module (gnu packages glib)
34 #:use-module (gnu packages graphviz)
35 #:use-module (gnu packages linux)
36 #:use-module (gnu packages perl)
37 #:use-module (gnu packages pkg-config)
38 #:use-module (gnu packages swig)
39 #:use-module (gnu packages tcl))
40
41 ;; Fixme: Done for the library, but needs support for running the daemon
42 ;; (shepherd definition).
43 ;; We should probably have a lib output, but that currently generates
44 ;; a cycle.
45 (define-public opensm
46 (package
47 (name "opensm")
48 (version "3.3.22")
49 (source
50 (origin
51 (method url-fetch)
52 (uri
53 (string-append "https://github.com/linux-rdma/opensm/releases/download/"
54 version "/opensm-" version ".tar.gz"))
55 (sha256
56 (base32 "19scwwpwqhqsyq4hbr5cflcmypss828lalxxd36yby7mbimca38y"))))
57 (build-system gnu-build-system)
58 (native-inputs
59 `(("bison" ,bison)
60 ("flex" ,flex)
61
62 ;; The 3.3.21 'release' tarball isn't properly bootstrapped.
63 ("autoconf" ,autoconf)
64 ("automake" ,automake)
65 ("libtool" ,libtool)))
66 (inputs
67 `(("rdma-core" ,rdma-core)))
68 (arguments
69 `(#:configure-flags '("--disable-static")
70 #:phases
71 (modify-phases %standard-phases
72 (add-after 'install 'install-doc
73 (lambda* (#:key outputs #:allow-other-keys)
74 (let* ((base (assoc-ref outputs "out"))
75 (doc (string-append base "/share/doc/"
76 ,name "-" ,version)))
77 (for-each (lambda (file)
78 (install-file file doc))
79 (find-files "doc"))
80 #t))))))
81 (home-page "https://www.openfabrics.org/")
82 (synopsis "OpenIB InfiniBand Subnet Manager and management utilities")
83 (description "\
84 OpenSM is the OpenIB project's Subnet Manager for Infiniband networks.
85 The subnet manager is run as a system daemon on one of the machines in
86 the infiniband fabric to manage the fabric's routing state. This package
87 also contains various tools for diagnosing and testing Infiniband networks
88 that can be used from any machine and do not need to be run on a machine
89 running the opensm daemon.")
90 (license (list gpl2 bsd-2))))
91
92 (define-public infiniband-diags
93 (package
94 (name "infiniband-diags")
95 (version "2.0.0")
96 (source
97 (origin
98 (method url-fetch)
99 (uri (string-append "https://github.com/linux-rdma/infiniband-diags/archive/"
100 version ".tar.gz"))
101 (file-name (string-append name "-" version ".tar.gz"))
102 (sha256
103 (base32 "1ns9sjwvxnklhi47d6k5x8kxdk1n7f5362y45xwxqmr7gwfvpmwa"))))
104 (build-system gnu-build-system)
105 (inputs
106 `(("rdma-core" ,rdma-core)
107 ("opensm" ,opensm)
108 ("glib" ,glib)))
109 (outputs '("out" "lib"))
110 (native-inputs
111 ;; FIXME: needs rst2man for man pages
112 `(("autoconf" ,autoconf)
113 ("automake" ,automake)
114 ("libtool" ,libtool)
115 ("perl" ,perl)
116 ("pkg-config" ,pkg-config)))
117 (arguments
118 '(#:configure-flags
119 (list (string-append "CPPFLAGS=-I" (assoc-ref %build-inputs "opensm")
120 "/include/infiniband")
121 (string-append "--with-perl-installdir=" (assoc-ref %outputs "lib")
122 "/lib/perl5/vendor_perl")
123 "--disable-static")
124 #:phases
125 (modify-phases %standard-phases
126 (add-after 'install 'licence
127 (lambda _
128 (let ((doc (string-append (assoc-ref %outputs "lib") "/share/doc")))
129 (mkdir-p doc)
130 (install-file "COPYING" doc))))
131 (add-after 'install-file 'move-perl
132 ;; Avoid perl in lib closure
133 (lambda _
134 (let ((perlout (string-append (assoc-ref %outputs "out") "/lib"))
135 (perlin (string-append (assoc-ref %outputs "lib")
136 "/lib/perl5")))
137 (mkdir-p perlout)
138 (rename-file perlin perlout)
139 #t))))))
140 (home-page "https://github.com/linux-rdma/infiniband-diags")
141 (synopsis "Infiniband diagnostic tools")
142 (description "This is a set of command-line utilities to help configure,
143 debug, and maintain Infiniband (IB) fabrics.
144
145 In addition to the utilities, a sub-library, @file{libibnetdisc}, is provided
146 to scan an entire IB fabric and return data structures representing it. The
147 interface to this library is not guaranteed to be stable.")
148 (license (list gpl2 bsd-2)))) ; dual
149
150 (define-public ibutils
151 (package
152 (name "ibutils")
153 (version "1.5.7-0.2.gbd7e502")
154 (source
155 (origin
156 (method url-fetch)
157 (uri (string-append "https://www.openfabrics.org/downloads/ibutils/ibutils-"
158 version ".tar.gz"))
159 (sha256
160 (base32 "00x7v6cf8l5y6g9xwh1sg738ch42fhv19msx0h0090nhr0bv98v7"))))
161 (build-system gnu-build-system)
162 (inputs `(("graphviz" ,graphviz)
163 ("tcl" ,tcl)
164 ("tk" ,tk)
165 ("infiniband-diags" ,infiniband-diags)
166 ("rdma-core" ,rdma-core)
167 ("opensm" ,opensm)
168 ("perl" ,perl)))
169 (native-inputs `(("swig" ,swig)))
170 (arguments
171 `(#:configure-flags
172 (list (string-append "--with-osm=" (assoc-ref %build-inputs "opensm"))
173 (string-append "--with-tk-lib=" (assoc-ref %build-inputs "tk") "/lib")
174 "--disable-static")))
175 (synopsis "InfiniBand network utilities")
176 (description "These command-line utilities allow for diagnosing and
177 testing InfiniBand networks.")
178 (home-page "https://www.openfabrics.org/downloads/ibutils/")
179 (license bsd-2)))
180
181 (define-public ucx
182 (package
183 (name "ucx")
184 (version "1.6.1")
185 (source (origin
186 (method git-fetch)
187 (uri (git-reference
188 (url "https://github.com/openucx/ucx.git")
189 (commit (string-append "v" version))))
190 (file-name (git-file-name name version))
191 (sha256
192 (base32
193 "0x3clvy716i7va4m4adgx6ihjsfnzrkdizhxz5v52944dkglpc8n"))
194 (patches (search-patches "ucx-tcp-iface-ioctl.patch"))))
195 (build-system gnu-build-system)
196 (arguments
197 '( ;; These are some of the flags found in 'contrib/configure-release'.
198 #:configure-flags (list
199 "--disable-static"
200
201 ;; XXX: Disable optimizations specific to the build
202 ;; machine (AVX, etc.) There's apparently no way to
203 ;; have them picked up at load time.
204 "--disable-optimizations"
205
206 "--disable-logging"
207 "--disable-debug"
208 "--disable-assertions"
209 "--disable-params-check"
210
211 (string-append "--with-verbs="
212 (assoc-ref %build-inputs
213 "rdma-core"))
214
215 (string-append "--with-rdmacm="
216 (assoc-ref %build-inputs
217 "rdma-core")))
218
219 ;; Be verbose so that compiler flags are displayed.
220 #:make-flags '("V=1")))
221 (native-inputs
222 `(("autoconf" ,autoconf)
223 ("automake" ,automake)
224 ("libtool" ,libtool)
225 ("pkg-config" ,pkg-config)))
226 (inputs
227 `(("numactl" ,numactl)
228 ("rdma-core" ,rdma-core)))
229 (synopsis "Optimized communication layer for message passing in HPC")
230 (description
231 "Unified Communication X (UCX) provides an optimized communication layer
232 for message passing (MPI), portable global address space (PGAS) languages and
233 run-time support libraries, as well as RPC and data-centric applications.
234
235 UCX utilizes high-speed networks for inter-node communication, and shared
236 memory mechanisms for efficient intra-node communication.")
237 (home-page "https://www.openucx.org/")
238 (license bsd-3)
239
240 ;; <ucm/bistro/bistro.h> lists only PowerPC64, AArch64, and x86_64 as
241 ;; supported.
242 (supported-systems '("x86_64-linux" "aarch64-linux"))))