gnu: webkitgtk: Update to 2.28.2.
[jackhill/guix/guix.git] / gnu / packages / cdrom.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013, 2014, 2015, 2018 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2013, 2014 Andreas Enge <andreas@enge.fr>
4 ;;; Copyright © 2015 Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>
5 ;;; Copyright © 2015 Paul van der Walt <paul@denknerd.org>
6 ;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
7 ;;; Copyright © 2016 Alex Kost <alezost@gmail.com>
8 ;;; Copyright © 2016 Marius Bakke <mbakke@fastmail.com>
9 ;;; Copyright © 2017 John Darrington <jmd@gnu.org>
10 ;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
11 ;;; Copyright © 2017, 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
12 ;;; Copyright © 2017 ng0 <ng0@n0.is>
13 ;;; Copyright © 2018 Oleg Pykhalov <go.wigust@gmail.com>
14 ;;; Copyright © 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
15 ;;; Copyright © 2019 Eric Bavier <bavier@member.fsf.org>
16 ;;;
17 ;;; This file is part of GNU Guix.
18 ;;;
19 ;;; GNU Guix is free software; you can redistribute it and/or modify it
20 ;;; under the terms of the GNU General Public License as published by
21 ;;; the Free Software Foundation; either version 3 of the License, or (at
22 ;;; your option) any later version.
23 ;;;
24 ;;; GNU Guix is distributed in the hope that it will be useful, but
25 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
26 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
27 ;;; GNU General Public License for more details.
28 ;;;
29 ;;; You should have received a copy of the GNU General Public License
30 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
31
32 (define-module (gnu packages cdrom)
33 #:use-module (guix download)
34 #:use-module (guix git-download)
35 #:use-module (guix packages)
36 #:use-module ((guix licenses) #:select (lgpl2.1+ gpl2 gpl2+ gpl3+ cddl1.0))
37 #:use-module (guix build-system cmake)
38 #:use-module (guix build-system gnu)
39 #:use-module (guix build-system glib-or-gtk)
40 #:use-module (guix gexp)
41 #:use-module (gnu packages)
42 #:use-module (gnu packages acl)
43 #:use-module (gnu packages audio)
44 #:use-module (gnu packages bison)
45 #:use-module (gnu packages compression)
46 #:use-module (gnu packages flex)
47 #:use-module (gnu packages fontutils)
48 #:use-module (gnu packages gettext)
49 #:use-module (gnu packages docbook)
50 #:use-module (gnu packages xml)
51 #:use-module (gnu packages gtk)
52 #:use-module (gnu packages glib)
53 #:use-module (gnu packages m4)
54 #:use-module (gnu packages man)
55 #:use-module (gnu packages mp3)
56 #:use-module (gnu packages music)
57 #:use-module (gnu packages ncurses)
58 #:use-module (gnu packages elf)
59 #:use-module (gnu packages wxwidgets)
60 #:use-module (gnu packages linux)
61 #:use-module (gnu packages pkg-config)
62 #:use-module (gnu packages readline)
63 #:use-module (gnu packages base)
64 #:use-module (gnu packages perl)
65 #:use-module (gnu packages perl-web)
66 #:use-module (gnu packages python)
67 #:use-module (gnu packages image)
68 #:use-module (gnu packages photo)
69 #:use-module (gnu packages tcl)
70 #:use-module (gnu packages video)
71 #:use-module (gnu packages wget)
72 #:use-module (gnu packages xiph))
73
74 (define-public libcddb
75 (package
76 (name "libcddb")
77 (version "1.3.2")
78 (source (origin
79 (method url-fetch)
80 (uri (string-append "mirror://sourceforge/libcddb/libcddb/" version
81 "/libcddb-" version ".tar.bz2"))
82 (sha256
83 (base32
84 "0fr21a7vprdyy1bq6s99m0x420c9jm5fipsd63pqv8qyfkhhxkim"))))
85 (build-system gnu-build-system)
86 (arguments '(#:tests? #f)) ; tests rely on access to external servers
87 (home-page "http://libcddb.sourceforge.net/")
88 (synopsis "C library to access data on a CDDB server")
89 (description
90 "Libcddb is a C library to access data on a CDDB server (freedb.org). It
91 allows you to:
92
93 1. search the database for possible CD matches;
94
95 2. retrieve detailed information about a specific CD;
96
97 3. submit new CD entries to the database.
98
99 Libcddb supports both the custom CDDB protocol and tunnelling the query and
100 read operations over plain HTTP. It is also possible to use an HTTP proxy
101 server. If you want to speed things up, you can make use of the built-in
102 caching facility provided by the library.")
103 (license lgpl2.1+)))
104
105 (define-public libcdio
106 (package
107 (name "libcdio")
108 (version "2.1.0")
109 (source (origin
110 (method url-fetch)
111 (uri (string-append "mirror://gnu/libcdio/libcdio-"
112 version ".tar.bz2"))
113 (sha256
114 (base32
115 "0avi6apv5ydjy6b9c3z9a46rvp5i57qyr09vr7x4nndxkmcfjl45"))))
116 (build-system gnu-build-system)
117 (inputs
118 `(("ncurses" ,ncurses)
119 ("libcddb" ,libcddb)))
120 (native-inputs
121 `(("help2man" ,help2man)
122 ("pkg-config" ,pkg-config)))
123 (home-page "https://www.gnu.org/software/libcdio/")
124 (synopsis "CD Input and Control library")
125 (description
126 "The GNU Compact Disc Input and Control Library (libcdio) is a library
127 for CD-ROM and CD image file access. It allows the developer to add CD
128 access to an application without having to worry about the OS- and
129 device-dependent properties of CD-ROM or the specific details of CD image
130 formats. It includes pycdio, a Python interface to libcdio, and
131 libcdio-paranoia, a library providing jitter-free and error-free audio
132 extraction from CDs.")
133 (license gpl3+)))
134
135 (define-public libcdio-paranoia
136 (package
137 (name "libcdio-paranoia")
138 (version "10.2+2.0.1")
139 (source (origin
140 (method url-fetch)
141 (uri (string-append "mirror://gnu/libcdio/libcdio-paranoia-"
142 version ".tar.bz2"))
143 (sha256
144 (base32
145 "12hfnrq7amv9qjzc92cr265m7kh0a1hpasck8cxx1gygbhqczc9k"))))
146 (build-system gnu-build-system)
147 (native-inputs `(("pkg-config" ,pkg-config)))
148 (propagated-inputs `(("libcdio" ,libcdio)))
149 (home-page "https://www.gnu.org/software/libcdio/")
150 (synopsis "Jitter- and error-tolerant CD audio extraction")
151 (description
152 "libcdio-paranoia is an implementation of CD paranoia libraries based on
153 libcdio.")
154 (license gpl3+)))
155
156 (define-public xorriso
157 (package
158 (name "xorriso")
159 (version "1.5.2")
160 (outputs '("out" "gui"))
161 (source (origin
162 (method url-fetch)
163 (uri (string-append "mirror://gnu/xorriso/xorriso-"
164 version ".tar.gz"))
165 (sha256
166 (base32
167 "1rqpzj95f70jfwpn4lamasfgqpizjsipz12aprdhri777b4zas9v"))))
168 (build-system gnu-build-system)
169 (arguments
170 `(#:phases
171 (modify-phases %standard-phases
172 (add-after 'install 'install-frontends
173 (lambda* (#:key outputs #:allow-other-keys)
174 (let* ((out (assoc-ref outputs "out"))
175 (out-bin (string-append out "/bin")))
176 (install-file "frontend/grub-mkrescue-sed.sh" out-bin)
177 #t)))
178 (add-after 'install 'move-gui-to-separate-output
179 (lambda* (#:key outputs #:allow-other-keys)
180 (let ((out (assoc-ref outputs "out"))
181 (gui (assoc-ref outputs "gui")))
182 (for-each
183 (lambda (file)
184 (mkdir-p (string-append gui (dirname file)))
185 (rename-file (string-append out file)
186 (string-append gui file)))
187 (list "/bin/xorriso-tcltk"
188 "/share/info/xorriso-tcltk.info"
189 "/share/man/man1/xorriso-tcltk.1"))
190 (wrap-program (string-append gui "/bin/xorriso-tcltk")
191 `("PATH" ":" prefix (,(string-append out "/bin"))))
192 #t))))))
193 (inputs
194 `(("acl" ,acl)
195 ("readline" ,readline)
196 ("tk" ,tk)
197 ("zlib" ,zlib)))
198 (home-page "https://www.gnu.org/software/xorriso/")
199 (synopsis "Create, manipulate, burn ISO-9660 file systems")
200 (description
201 "GNU Xorriso is a tool for copying files to and from ISO 9660 Rock
202 Ridge, a.k.a. Compact Disc File System, file systems and it allows
203 session-wise manipulation of them. It features a formatter and burner for
204 CD, DVD and BD. It can operate on existing ISO images or it can create new
205 ones. xorriso can then be used to copy files directly into or out of ISO
206 files.")
207 (license gpl3+)))
208
209 (define-public cdparanoia
210 (package
211 (name "cdparanoia")
212 (version "10.2")
213 (source (origin
214 (method url-fetch)
215 (uri (string-append "http://downloads.xiph.org/releases/"
216 "cdparanoia/cdparanoia-III-"
217 version ".src.tgz"))
218 (sha256
219 (base32
220 "1pv4zrajm46za0f6lv162iqffih57a8ly4pc69f7y0gfyigb8p80"))
221 (patches (search-patches "cdparanoia-fpic.patch"))
222 (modules '((guix build utils)))
223 (snippet
224 '(begin
225 ;; Make libraries respect LDFLAGS.
226 (substitute* '("paranoia/Makefile.in" "interface/Makefile.in")
227 (("-Wl,-soname") "$(LDFLAGS) -Wl,-soname"))
228 #t))))
229 (build-system gnu-build-system)
230 (arguments
231 `(#:tests? #f ; there is no check target
232 #:configure-flags ; Add $libdir to the RUNPATH of all the executables.
233 (list (string-append "LDFLAGS=-Wl,-rpath=" %output "/lib"))))
234 (home-page "https://www.xiph.org/paranoia/")
235 (synopsis "Audio CD reading utility")
236 (description "Cdparanoia retrieves audio tracks from CDDA capable CDROM
237 drives. The data can be saved to a file or directed to standard output
238 in WAV, AIFF, AIFF-C or raw format. Most ATAPI, SCSI and several
239 proprietary CDROM drive makes are supported; cdparanoia can determine if the
240 target drive is CDDA capable. In addition to simple reading, cdparanoia adds
241 extra-robust data verification, synchronization, error handling and scratch
242 reconstruction capability.")
243 (license gpl2))) ; libraries under lgpl2.1
244
245 (define-public cdrtools
246 (package
247 (name "cdrtools")
248 (version "3.01")
249 (source (origin
250 (method url-fetch)
251 (uri (string-append
252 "mirror://sourceforge/cdrtools/cdrtools-" version ".tar.bz2"))
253 (sha256
254 (base32
255 "03w6ypsmwwy4d7vh6zgwpc60v541vc5ywp8bdb758hbc4yv2wa7d"))
256 (modules '((guix build utils)))
257 (snippet
258 '(begin
259 ;; By default 'cdda2wav --help' would print a string like
260 ;; "Version 3.01_linux_4.19.10-gnu_x86_64_x86_64". Change
261 ;; it to not capture the kernel version of the build
262 ;; machine, to allow for reproducible builds.
263 (substitute* "cdda2wav/local.cnf.in"
264 (("^VERSION_OS=.*")
265 (string-append
266 "actual_os := $(shell uname -o)\n"
267 "actual_arch := $(shell uname -m)\n"
268 "VERSION_OS = _$(actual_os)_$(actual_arch)\n")))
269 #t))
270 (patches (search-patches "cdrtools-3.01-mkisofs-isoinfo.patch"))))
271 (build-system gnu-build-system)
272 ;; XXX cdrtools bundles a modified, relicensed early version of cdparanoia.
273 (inputs
274 `(("linux-headers" ,linux-libre-headers)))
275 (arguments
276 `(#:make-flags
277 (list "RM=rm" "LN=ln" "SYMLINK=ln -s"
278 "CONFIG_SHELL=sh" "CCOM=gcc"
279 (string-append "INS_BASE=" (assoc-ref %outputs "out"))
280 (string-append "INS_RBASE=" (assoc-ref %outputs "out")))
281 ;; Parallel builds appear to be unsafe, see
282 ;; https://hydra.gnu.org/build/3346840/log/raw
283 #:parallel-build? #f
284 #:phases
285 (modify-phases %standard-phases
286 (delete 'configure)
287 (add-before 'build 'set-linux-headers
288 (lambda _
289 (substitute* "autoconf/configure"
290 (("/usr/src/linux")
291 (assoc-ref %build-inputs "linux-headers")))
292 #t))
293 (add-before 'build 'substitute-dirs
294 (lambda _
295 (substitute* (append (find-files "DEFAULTS" "^Defaults\\.")
296 (find-files "DEFAULTS_ENG" "^Defaults\\.")
297 (find-files "TEMPLATES" "^Defaults\\."))
298 (("/opt/schily") (assoc-ref %outputs "out")))
299 #t)))
300 #:tests? #f)) ; no tests
301 (synopsis "Command line utilities to manipulate and burn CD/DVD/BD images")
302 (description "cdrtools is a collection of command line utilities to create
303 CD's, DVD's or Blue Ray discs. The most important components are
304 @command{cdrecord}, a burning program, @command{cdda2wav}, a CD audio ripper
305 which uses libparanoia, and @command{mkisofs}, which can create various disc
306 images.")
307 (home-page "http://cdrtools.sourceforge.net/private/cdrecord.html")
308
309 ;; mkisofs is GPL, the other programs are CDDL.
310 (license (list cddl1.0 gpl2))))
311
312 (define-public dvd+rw-tools
313 (package
314 (name "dvd+rw-tools")
315 (version "7.1")
316 (source (origin
317 (method url-fetch)
318 (uri (string-append
319 "http://fy.chalmers.se/~appro/linux/DVD+RW/tools/dvd+rw-tools-"
320 version ".tar.gz"))
321 (sha256
322 (base32
323 "1jkjvvnjcyxpql97xjjx0kwvy70kxpiznr2zpjy2hhci5s10zmpq"))
324 (patches (search-patches "dvd+rw-tools-add-include.patch"))))
325 (build-system gnu-build-system)
326 (inputs
327 `(("cdrtools" ,cdrtools)))
328 (native-inputs
329 `(("m4" ,m4)))
330 (arguments
331 `(#:tests? #f ; No tests.
332 #:phases
333 (modify-phases %standard-phases
334 (add-after 'unpack 'fix-glibc-compatability
335 (lambda* (#:key inputs #:allow-other-keys)
336 ;; We use sed --in-place because substitute* cannot handle the
337 ;; character encoding used by growisofs.c.
338 (invoke "sed" "-i" "-e"
339 (string-append
340 "s,<sys/stat.h>,"
341 "<sys/stat.h>\\\n#include <sys/sysmacros.h>,")
342 "growisofs.c")))
343 (replace 'configure
344 (lambda _ (setenv "prefix" (assoc-ref %outputs "out")) #t))
345 (add-before 'build 'embed-mkisofs
346 (lambda* (#:key inputs #:allow-other-keys)
347 ;; We use sed --in-place because substitute* cannot handle the
348 ;; character encoding used by growisofs.c.
349 (invoke "sed" "-i" "-e"
350 (string-append
351 "s,\"mkisofs\","
352 "\"" (which "mkisofs") "\",")
353 "growisofs.c"))))))
354 (home-page "http://fy.chalmers.se/~appro/linux/DVD+RW/")
355 (synopsis "DVD and Blu-ray Disc burning tools")
356 (description "dvd+rw-tools, mostly known for its command
357 @command{growisofs}, is a collection of DVD and Blu-ray Disc burning tools.
358 It requires another program, such as @command{mkisofs}, @command{genisoimage},
359 or @command{xorrisofs} to create ISO 9660 images.")
360 (license gpl2)))
361
362 (define-public dvdisaster
363 (package
364 (name "dvdisaster")
365 (version "0.79.5")
366 (source
367 (origin
368 (method url-fetch)
369 ;; Update this (and update HOME-PAGE) when/if one reappears.
370 (uri (string-append "https://web.archive.org/web/20180428070843/"
371 "http://dvdisaster.net/downloads/dvdisaster-"
372 version ".tar.bz2"))
373 (sha256
374 (base32 "0f8gjnia2fxcbmhl8b3qkr5b7idl8m855dw7xw2fnmbqwvcm6k4w"))))
375 (build-system gnu-build-system)
376 (inputs
377 `(("gtk+" ,gtk+-2)))
378 (native-inputs
379 `(("gettext" ,gettext-minimal)
380 ("pkg-config" ,pkg-config)
381 ("which" ,which)))
382 (arguments
383 `(;; Parallel builds appear to be unsafe, see
384 ;; <http://hydra.gnu.org/build/49331/nixlog/1/raw>.
385 #:parallel-build? #f
386 #:phases
387 (modify-phases %standard-phases
388 (replace 'check
389 (lambda _
390 (with-directory-excursion "regtest"
391 (substitute* "common.bash"
392 (("ISODIR=/var/tmp/regtest") "ISODIR=/tmp"))
393 (for-each invoke (find-files "." "rs.*\\.bash")))
394 #t))
395 (add-after 'install 'install-desktop
396 (lambda* (#:key outputs #:allow-other-keys)
397 (let* ((datadir (string-append (assoc-ref outputs "out") "/share")))
398 (substitute* "contrib/dvdisaster.desktop"
399 (("dvdisaster48.png") "dvdisaster.png"))
400 (install-file "contrib/dvdisaster.desktop"
401 (string-append datadir "/applications"))
402 (for-each
403 (lambda (png)
404 (let* ((size (substring png
405 (string-index png char-set:digit)
406 (string-rindex png #\.)))
407 (icondir (string-append datadir "/icons/"
408 size "x" size "/apps")))
409 (mkdir-p icondir)
410 (copy-file png (string-append icondir "/dvdisaster.png"))))
411 (find-files "contrib" "dvdisaster[0-9]*\\.png"))
412 (mkdir-p (string-append datadir "/pixmaps"))
413 (copy-file "contrib/dvdisaster48.xpm"
414 (string-append datadir "/pixmaps/dvdisaster.xpm"))
415 #t))))))
416 (home-page (string-append "https://web.archive.org/web/20180428070843/"
417 "http://dvdisaster.net/en/index.html"))
418 (synopsis "Error correcting codes for optical media images")
419 (description "Optical media (CD,DVD,BD) keep their data only for a
420 finite time (typically for many years). After that time, data loss develops
421 slowly with read errors growing from the outer media region towards the
422 inside.
423
424 Dvdisaster stores data on CD/DVD/BD (supported media) in a way that it is
425 fully recoverable even after some read errors have developed. This enables
426 you to rescue the complete data to a new medium.
427
428 Data loss is prevented by using error correcting codes. Error correction
429 data is either added to the medium or kept in separate error correction
430 files. Dvdisaster works at the image level so that the recovery does not
431 depend on the file system of the medium. The maximum error correction
432 capacity is user-selectable.")
433 (license gpl2+)))
434
435 (define-public dvdstyler
436 (package
437 (name "dvdstyler")
438 (version "3.0.4")
439 (source
440 (origin
441 (method url-fetch)
442 (uri (string-append "mirror://sourceforge/dvdstyler/dvdstyler/"
443 version "/DVDStyler-" version ".tar.bz2"))
444 (sha256
445 (base32
446 "0lwc0hn94m9r8fi07sjqz3fr618l6lnw3zsakxw7nlgnxbjsk7pi"))))
447 (build-system gnu-build-system)
448 (arguments
449 `(#:configure-flags
450 (list (string-append "XMLTO="
451 (assoc-ref %build-inputs "xmlto")
452 "/bin/xmlto --searchpath "
453 (assoc-ref %build-inputs "docbook-xsl")
454 "/xml/xsl/docbook-xsl-" ,(package-version docbook-xsl)
455 "/htmlhelp:"
456 (assoc-ref %build-inputs "docbook-xml")
457 "/xml/dtd/docbook"))
458 #:phases
459 (modify-phases %standard-phases
460 (add-after 'install 'wrap-program
461 (lambda* (#:key inputs outputs #:allow-other-keys)
462 (wrap-program (string-append (assoc-ref outputs "out") "/bin/dvdstyler")
463 `("PATH" ":" prefix
464 (,(string-join
465 (map (lambda (in) (string-append (assoc-ref inputs in) "/bin"))
466 '("cdrtools" "dvdauthor" "dvd+rw-tools" "ffmpeg"))
467 ":"))))
468 #t)))
469 #:tests? #f)) ; No tests.
470 (inputs ; TODO package bundled wxvillalib
471 `(("wxwidgets" ,wxwidgets-3.1)
472 ("wssvg" ,wxsvg)
473 ("dbus" ,dbus)
474 ("cdrtools" ,cdrtools)
475 ("dvd+rw-tools" ,dvd+rw-tools)
476 ("dvdauthor" ,dvdauthor)
477 ("eudev" ,eudev)
478 ("fontconfig" ,fontconfig)
479 ("libexif" ,libexif)
480 ("libjpeg" ,libjpeg)
481 ("ffmpeg" ,ffmpeg-3.4)))
482 (native-inputs
483 `(("pkg-config" ,pkg-config)
484 ("flex" ,flex)
485 ("python" ,python-2)
486 ("xmlto" ,xmlto)
487 ("gettext" ,gettext-minimal)
488 ("docbook-xml" ,docbook-xml)
489 ("docbook-xsl" ,docbook-xsl)
490 ("zip" ,zip)))
491 (synopsis "DVD authoring application")
492 (description "DVDStyler is a DVD authoring application which allows users
493 to burn video files in many formats to DVD discs, complete with individually
494 designed menus. It can be used to create professional-looking DVD's with
495 custom buttons, backgrounds and animations, from within a user-friendly
496 graphical interface.")
497 (home-page "https://www.dvdstyler.org")
498 (license gpl2)))
499
500 (define-public libcue
501 (package
502 (name "libcue")
503 (version "2.2.1")
504 (source (origin
505 (method git-fetch)
506 (uri (git-reference
507 (url "https://github.com/lipnitsk/libcue.git")
508 (commit (string-append "v" version))))
509 (file-name (git-file-name name version))
510 (sha256
511 (base32
512 "1iqw4n01rv2jyk9lksagyxj8ml0kcfwk67n79zy1r6zv1xfp5ywm"))))
513 (build-system cmake-build-system)
514 (arguments
515 `(#:configure-flags '("-DBUILD_SHARED_LIBS=ON")))
516 (native-inputs
517 `(("bison" ,bison)
518 ("flex" ,flex)))
519 (home-page "https://github.com/lipnitsk/libcue")
520 (synopsis "C library to parse cue sheets")
521 (description "Libcue is a C library to parse so-called @dfn{cue sheets}
522 which contain meta-data for CD/DVD tracks. It provides an API to manipulate
523 the data.")
524 (license gpl2+)))
525
526 (define-public cd-discid
527 (package
528 (name "cd-discid")
529 (version "1.4")
530 (home-page "http://linukz.org/cd-discid.shtml")
531 (source (origin
532 (method url-fetch)
533 (uri (string-append "http://linukz.org/download/cd-discid-"
534 version ".tar.gz"))
535 (sha256
536 (base32
537 "0qrcvn7227qaayjcd5rm7z0k5q89qfy5qkdgwr5pd7ih0va8rmpz"))
538 (modules '((guix build utils)))
539 (snippet
540 '(begin
541 (substitute* "Makefile"
542 (("/usr/bin/install")
543 "install"))
544 #t))))
545 (build-system gnu-build-system)
546 (arguments
547 '(#:tests? #f
548 #:phases (modify-phases %standard-phases (delete 'configure))
549 #:make-flags (list "CC=gcc"
550 (string-append "PREFIX="
551 (assoc-ref %outputs "out")))))
552 (synopsis "Get CDDB discid information from an audio CD")
553 (description
554 "cd-discid is a command-line tool to retrieve CDDB discid information
555 from an audio CD.")
556 (license gpl2+)))
557
558 (define-public abcde
559 (package
560 (name "abcde")
561 (version "2.9.3")
562 (home-page "https://abcde.einval.com/")
563 (source (origin
564 (method url-fetch)
565 (uri (string-append home-page "/download/abcde-"
566 version ".tar.gz"))
567 (sha256
568 (base32
569 "091ip2iwb6b67bhjsj05l0sxyq2whqjycbzqpkfbpm4dlyxx0v04"))
570 (modules '((guix build utils)))
571 (snippet
572 '(begin
573 (substitute* "Makefile"
574 (("/usr/bin/install")
575 "install"))
576 #t))))
577 (build-system gnu-build-system)
578 (arguments
579 '(#:phases
580 (modify-phases %standard-phases
581 (replace 'configure
582 (lambda* (#:key outputs inputs #:allow-other-keys)
583 (substitute* "Makefile"
584 (("^prefix = .*$")
585 (string-append "prefix = "
586 (assoc-ref outputs "out")
587 "\n"))
588 (("^sysconfdir = .*$")
589 (string-append "sysconfdir = "
590 (assoc-ref outputs "out")
591 "/etc/\n")))
592 #t))
593 (add-after 'install 'wrap
594 (lambda* (#:key inputs outputs #:allow-other-keys)
595 (let ((wget (assoc-ref inputs "wget"))
596 (vorbis (assoc-ref inputs "vorbis-tools"))
597 (parano (assoc-ref inputs "cdparanoia"))
598 (which (assoc-ref inputs "which"))
599 (discid (assoc-ref inputs "cd-discid"))
600 (perl-discid (assoc-ref inputs "perl-musicbrainz-discid"))
601 (perl-ws (assoc-ref inputs "perl-webservice-musicbrainz"))
602 (perl-mojo (assoc-ref inputs "perl-mojolicious"))
603 (flac (assoc-ref inputs "flac"))
604 (out (assoc-ref outputs "out")))
605 (define (wrap file)
606 (wrap-program file
607 `("PATH" ":" prefix
608 (,(string-append out "/bin:"
609 wget "/bin:"
610 flac "/bin:"
611 which "/bin:"
612 vorbis "/bin:"
613 discid "/bin:"
614 parano "/bin")))
615 `("PERL5LIB" ":" prefix
616 (,(string-append perl-discid
617 "/lib/perl5/site_perl:"
618 perl-ws
619 "/lib/perl5/site_perl:"
620 perl-mojo
621 "/lib/perl5/site_perl")))))
622
623 (for-each wrap
624 (find-files (string-append out "/bin")
625 ".*")))
626 #t)))
627 #:tests? #f)) ; no test target
628
629 (inputs `(("wget" ,wget)
630 ("which" ,which)
631 ("cdparanoia" ,cdparanoia)
632 ("cd-discid" ,cd-discid)
633 ("vorbis-tools" ,vorbis-tools)
634 ("flac" ,flac)
635
636 ("perl-musicbrainz-discid" ,perl-musicbrainz-discid)
637 ("perl-webservice-musicbrainz" ,perl-webservice-musicbrainz)
638 ("perl-mojolicious" ,perl-mojolicious) ;indirect dependency
639
640 ;; A couple of Python and Perl scripts are included.
641 ("python" ,python)
642 ("perl" ,perl)))
643
644 (synopsis "Command-line audio CD ripper")
645 (description
646 "abcde is a front-end command-line utility (actually, a shell script)
647 that grabs tracks off a CD, encodes them to Ogg/Vorbis, MP3, FLAC, Ogg/Speex
648 and/or MPP/MP+ (Musepack) format, and tags them, all in one go.")
649 (license gpl2+)))
650
651 (define-public geteltorito
652 (package
653 (name "geteltorito")
654 (version "0.6")
655 (home-page
656 "https://userpages.uni-koblenz.de/~krienke/ftp/noarch/geteltorito/")
657 (source (origin
658 (method url-fetch)
659 (uri (string-append home-page name "-" version ".tar.gz"))
660 (sha256
661 (base32
662 "1gkbm9ahj2mgqrkrfpibzclsriqgsbsvjh19fr815vpd9f6snkxv"))))
663 (build-system gnu-build-system)
664 (arguments
665 `(#:tests? #f ; No tests.
666 #:phases
667 (modify-phases %standard-phases
668 (delete 'configure)
669 (delete 'build)
670 (replace 'install
671 (lambda* (#:key outputs #:allow-other-keys)
672 (let ((out (assoc-ref outputs "out")))
673 (install-file "geteltorito"
674 (string-append out "/bin"))))))))
675 (inputs `(("perl" ,perl)))
676 (synopsis "Extract the boot image from a CD-ROM")
677 (description
678 "@command{geteltorito} can extract the initial/default boot
679 image from CDs (and ISOs) that follow the El Torito specification
680 for bootable CD-ROMs.
681
682 Image data is written to standard output by default and all other
683 information is written to standard error.")
684 (license gpl2+)))
685
686 (define-public asunder
687 (package
688 (name "asunder")
689 (version "2.9.5")
690 (source (origin
691 (method url-fetch)
692 (uri
693 (string-append "http://www.littlesvr.ca/asunder/releases/asunder-"
694 version
695 ".tar.bz2"))
696 (sha256
697 (base32
698 "069x6az2r3wlb2hd07iz0hxpxwknw7s9h7pyhnkmzv1pw9ci3kk4"))))
699 (build-system glib-or-gtk-build-system)
700 (arguments
701 '(#:out-of-source? #f
702 #:phases (modify-phases %standard-phases
703 (add-after 'install 'wrap
704 (lambda* (#:key inputs outputs #:allow-other-keys)
705 (let ((program (string-append (assoc-ref outputs "out")
706 "/bin/asunder")))
707 (define (bin-directory input-name)
708 (string-append (assoc-ref inputs input-name) "/bin"))
709 (wrap-program program
710 `("PATH" ":" prefix
711 ,(map bin-directory (list "cdparanoia"
712 "lame"
713 "vorbis-tools"
714 "flac"
715 "opus-tools"
716 "wavpack"))))))))))
717 (native-inputs `(("intltool" ,intltool)
718 ("pkg-config" ,pkg-config)))
719 ;; TODO: Add the necessary packages for Musepack encoding.
720 (inputs `(("gtk+-2" ,gtk+-2)
721 ("glib" ,glib)
722 ("libcddb" ,libcddb)
723 ("cdparanoia" ,cdparanoia)
724 ("lame" ,lame)
725 ("vorbis-tools" ,vorbis-tools)
726 ("flac" ,flac)
727 ("opus-tools" ,opus-tools)
728 ("wavpack" ,wavpack)))
729 (home-page "http://www.littlesvr.ca/asunder/")
730 (synopsis "Graphical audio CD ripper and encoder")
731 (description
732 "Asunder is a graphical audio CD ripper and encoder. It can save audio
733 tracks as WAV, MP3, Ogg Vorbis, FLAC, Opus, Wavpack, and Musepack. It can use
734 CDDB to name and tag each track automatically, and it allows for each track to
735 be by a different artist. Asunder can encode to multiple formats in one
736 session, and it can create M3U playlists.")
737 (license gpl2)))
738
739 (define-public ripit
740 (package
741 (name "ripit")
742 (version "3.9.0")
743 (source
744 (origin
745 (method url-fetch)
746 ;; The original suwald.com domain has expired.
747 (uri (list
748 (string-append "https://web.archive.org/web/20160327050927/"
749 "http://suwald.com/ripit/ripit-" version ".tar.gz")
750 (string-append "https://ponce.cc/slackware/sources/repo/ripit-"
751 version ".tar.gz")))
752 (sha256
753 (base32 "0ap71x477jy9c4jiqazb3y45hxdxm3jbq24x05g3vjyqzigi4x1b"))))
754 (build-system gnu-build-system)
755 (arguments
756 `(#:tests? #f ; no test suite
757 #:phases
758 (modify-phases %standard-phases
759 (delete 'configure)
760 (add-after 'unpack 'patch-usr-bin-install
761 (lambda* (#:key inputs outputs #:allow-other-keys)
762 (substitute* "Makefile"
763 (("/usr/bin/install") (string-append
764 (assoc-ref inputs "coreutils")
765 "/bin/install"))
766 (("\\$\\(DESTDIR\\)/usr/local") (assoc-ref outputs "out"))
767 (("../../etc") "etc")))))))
768 (native-inputs
769 `(("coreutils" ,coreutils)))
770 (inputs
771 `(("perl" ,perl)))
772 (propagated-inputs
773 `(("cdparanoia" ,cdparanoia)
774 ("flac" ,flac)
775 ("vorbis-tools" ,vorbis-tools)
776 ("wavpack" ,wavpack)
777 ("perl-cddb-get" ,perl-cddb-get)))
778 (home-page (string-append "https://web.archive.org/web/20170119092156/"
779 "http://www.suwald.com/ripit/about.php"))
780 (synopsis "Command-line program to extract audio CDs")
781 (description "RipIT is used to extract audio from CDs.")
782 (license gpl2)))
783
784 (define-public ccd2cue
785 (package
786 (name "ccd2cue")
787 (version "0.5")
788 (source
789 (origin
790 (method url-fetch)
791 (uri (string-append
792 "mirror://gnu/ccd2cue/ccd2cue-" version
793 ".tar.gz"))
794 (sha256
795 (base32
796 "1icrkg25hwx4gsn3dski2172ia4ywjh8m1sa17zmjclnrgdwy9c7"))))
797 (build-system gnu-build-system)
798 (synopsis "CCD to CUE sheet conversion")
799 (description
800 "GNU ccd2cue is a preprocessor for CD burning software that allows
801 the conversion of the proprietary CCD format to the CUE format, which
802 is well-supported by free software. These files are commonly
803 distributed with CD images and are used to describe how tracks are
804 laid out on the image.")
805 (home-page "https://www.gnu.org/software/ccd2cue/")
806 (license gpl3+)))
807
808 (define-public libburn
809 (package
810 (name "libburn")
811 (version "1.5.2")
812 (source (origin
813 (method url-fetch)
814 (uri (string-append "http://files.libburnia-project.org/releases/"
815 "libburn-" version ".tar.gz"))
816 (sha256
817 (base32
818 "09sjrvq8xsj1gnl2wwyv4lbmicyzzl6x1ac2rrn53xnp34bxnckv"))))
819 (build-system gnu-build-system)
820 (native-inputs
821 `(("pkg-config" ,pkg-config)))
822 (home-page "https://dev.lovelyhq.com/libburnia/libburn")
823 (synopsis "Library for reading and writing optical discs")
824 (description
825 "Libburn is a library for reading and writing optical discs.
826 Supported media are: CD-R, CD-RW, DVD-RAM, DVD+RW, DVD+R, DVD+R/DL,
827 DVD-RW, DVD-R, DVD-R/DL, BD-R, and BD-RE.")
828 (license gpl2)))
829
830 (define-public libisofs
831 (package
832 (name "libisofs")
833 (version "1.5.2")
834 (source (origin
835 (method url-fetch)
836 (uri (string-append "http://files.libburnia-project.org/releases/"
837 "libisofs-" version ".tar.gz"))
838 (sha256
839 (base32
840 "002mcyqwg625a8hqvsrmgm26mhhfwj0j7rahfhsqirmk02b16npg"))))
841 (build-system gnu-build-system)
842 (inputs
843 `(("zlib" ,zlib)
844 ("acl" ,acl)))
845 (native-inputs
846 `(("pkg-config" ,pkg-config)))
847 (home-page "https://dev.lovelyhq.com/libburnia/libisofs")
848 (synopsis "Library to create ISO 9660 images")
849 (description
850 "Libisofs creates ISO 9660 (also known as ECMA-119) file system images
851 which can either be written to POSIX file objects or handed over to
852 libburn for being written directly to optical media.
853 It can read metadata of ISO 9660 filesystems, manipulate them, and use them
854 to produce new complete file system images or add-on images to be appended
855 to the read file system image.
856 Supported extensions to ISO 9660 are Rock Ridge, Joliet, AAIP, zisofs.")
857 (license gpl2+)))
858
859 (define-public cdrkit-libre
860 (package
861 (name "cdrkit-libre")
862 (version "1.1.11")
863 (source (origin
864 (method url-fetch)
865 ;; cdrkit.org is dead.
866 ;;
867 ;; ‘cdrkit-libre’ removes a couple of problematic files,
868 ;; see <https://debbugs.gnu.org/cgi/bugreport.cgi?bug=32165#14>.
869 (uri (string-append
870 "https://repo.parabola.nu/other/cdrkit-libre/cdrkit-libre-"
871 version ".tar.gz"))
872 (sha256
873 (base32
874 "0g2zyzb56czh429qy87lvaddzjnlcq8c616ddxsmsshz3clhyzrh"))))
875 (build-system cmake-build-system)
876 (inputs
877 `(("bzip2" ,bzip2)
878 ("libcap" ,libcap)
879 ("perl" ,perl)
880 ("zlib" ,zlib)))
881 (arguments
882 `(#:tests? #f ;no tests
883 #:phases
884 (modify-phases %standard-phases
885 (add-after 'install 'old-cdrecord
886 (lambda* (#:key outputs #:allow-other-keys)
887 (with-directory-excursion (string-append (assoc-ref outputs "out")
888 "/bin")
889 (symlink "genisoimage" "mkisofs")
890 (symlink "wodim" "cdrecord"))
891 #t)))))
892 (home-page "https://repo.parabola.nu/other/cdrkit-libre/")
893 (synopsis "Command-line CD/DVD recorder")
894 (description "Cdrkit is a suite of programs for recording CDs and DVDs,
895 blanking CD-RW media, creating ISO-9660 file system images, extracting audio
896 CD data, and more. It's mostly compatible with @code{cdrtools}.")
897 (license gpl2+)))
898
899 (define-public libmirage
900 (package
901 (name "libmirage")
902 (version "3.2.4")
903 (source (origin
904 (method url-fetch)
905 (uri (string-append
906 "https://downloads.sourceforge.net/cdemu/libmirage-"
907 version ".tar.bz2"))
908 (sha256
909 (base32
910 "0md3f71x2dbgyw5s254vx1s80slh3f25r9pvjihkrmj0rn53nnzw"))))
911 (build-system cmake-build-system)
912 (native-inputs
913 `(("pkg-config" ,pkg-config)
914 ("intltool" ,intltool)))
915 (inputs
916 `(("glib" ,glib)))
917 (arguments
918 ;; No tests.
919 '(#:tests? #f))
920 (home-page "https://cdemu.sourceforge.io/")
921 (synopsis "CD-ROM image access library")
922 (description "libMirage is a CD-ROM image access library. It supports the
923 following formats: B6T, C2D, CCD, CDI, CIF, CUE, ISO, MDS, MDX, NRG, TOC. It
924 is written in C and based on GLib. Its aim is to provide uniform access to
925 the data stored in various image formats.")
926 (license gpl2+)))
927
928 (define-public cdemu-daemon
929 (package
930 (name "cdemu-daemon")
931 (version "3.2.4")
932 (source (origin
933 (method url-fetch)
934 (uri (string-append
935 "https://downloads.sourceforge.net/cdemu/cdemu-daemon/"
936 "cdemu-daemon-" version ".tar.bz2"))
937 (sha256
938 (base32
939 "02yyj8sr7d5briamhzrqh8zdsiiggxmx5y05kx25y7k3g15jvcx6"))))
940 (build-system cmake-build-system)
941 (native-inputs
942 `(("pkg-config" ,pkg-config)
943 ("intltool" ,intltool)))
944 (inputs
945 `(("libmirage" ,libmirage)
946 ("glib" ,glib)
947 ("ao" ,ao)))
948 (arguments
949 ;; No tests.
950 '(#:tests? #f))
951 (home-page "https://cdemu.sourceforge.io/")
952 (synopsis "CD/DVD-ROM device emulator")
953 (description "CDemu is a software suite designed to emulate an optical
954 drive and disc (including CD-ROMs and DVD-ROMs).")
955 (license gpl2+)))
956
957 (define-public cdemu-client
958 (package
959 (name "cdemu-client")
960 (version "3.2.4")
961 (source (origin
962 (method url-fetch)
963 (uri (string-append
964 "https://downloads.sourceforge.net/cdemu/cdemu-client-"
965 version ".tar.bz2"))
966 (sha256
967 (base32
968 "1swylaja1p1jfjf3s58c9hsk1cyy20i7mrq32kcg6kzp88grs8my"))))
969 (build-system cmake-build-system)
970 (native-inputs
971 `(("pkg-config" ,pkg-config)
972 ("intltool" ,intltool)))
973 (inputs
974 `(("python" ,python)
975 ("python-pygobject" ,python-pygobject)
976 ("cdemu-daemon" ,cdemu-daemon)))
977 (arguments
978 ;; No tests.
979 `(#:tests? #f
980 #:phases
981 (modify-phases %standard-phases
982 (add-after 'install 'patch-shebang
983 (lambda* (#:key outputs #:allow-other-keys)
984 (patch-shebang (string-append (assoc-ref outputs "out")
985 "/bin/cdemu"))
986 #t))
987 (add-after 'patch-shebang 'wrap-program
988 (lambda* (#:key outputs #:allow-other-keys)
989 (let ((prog (string-append (assoc-ref outputs "out")
990 "/bin/cdemu")))
991 (wrap-program prog
992 `("PYTHONPATH" = (,(getenv "PYTHONPATH"))))
993 #t))))))
994 (home-page "https://cdemu.sourceforge.io/")
995 (synopsis "Command-line client for controlling cdemu-daemon")
996 (description "CDEmu client is a simple command-line client for controlling
997 CDEmu daemon.
998
999 It provides a way to perform the key tasks related to controlling the CDEmu
1000 daemon, such as loading and unloading devices, displaying devices' status and
1001 retrieving/setting devices' debug masks.")
1002 (license gpl2+)))