gnu: nano: Update to 2.7.0.
[jackhill/guix/guix.git] / gnu / packages / nano.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
3 ;;; Copyright © 2015, 2016 Efraim Flashner <efraim@flashner.co.il>
4 ;;; Copyright © 2016 Rene Saavedra <rennes@openmailbox.org>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20
21 (define-module (gnu packages nano)
22 #:use-module (guix licenses)
23 #:use-module (gnu packages gettext)
24 #:use-module (gnu packages ncurses)
25 #:use-module (guix packages)
26 #:use-module (guix download)
27 #:use-module (guix build-system gnu))
28
29 (define-public nano
30 (package
31 (name "nano")
32 (version "2.7.0")
33 (source
34 (origin
35 (method url-fetch)
36 (uri (string-append "mirror://gnu/nano/nano-"
37 version ".tar.gz"))
38 (sha256
39 (base32
40 "1hzazcrbwjqiw89jjvlj97q0wf385qqkzcm0870pdrixiv7yklax"))))
41 (build-system gnu-build-system)
42 (inputs
43 `(("gettext" ,gnu-gettext)
44 ("ncurses" ,ncurses)))
45 (home-page "http://www.nano-editor.org/")
46 (synopsis "Small, user-friendly console text editor")
47 (description
48 "GNU Nano is a small and simple text editor. In addition to basic
49 editing, it supports interactive search and replace, go to line and column
50 number, auto-indentation and more.")
51 (license gpl3+))) ; some files are under GPLv2+