Merge branch 'master' into core-updates
[jackhill/guix/guix.git] / gnu / packages / pdf.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013, 2015, 2016 Andreas Enge <andreas@enge.fr>
3 ;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
4 ;;; Copyright © 2014, 2015, 2016 Ricardo Wurmus <rekado@elephly.net>
5 ;;; Copyright © 2015 Paul van der Walt <paul@denknerd.org>
6 ;;; Copyright © 2016 Roel Janssen <roel@gnu.org>
7 ;;; Coypright © 2016 ng0 <ng0@we.make.ritual.n0.is>
8 ;;; Coypright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
9 ;;; Coypright © 2016, 2017 Marius Bakke <mbakke@fastmail.com>
10 ;;; Coypright © 2016, 2017 Ludovic Courtès <ludo@gnu.org>
11 ;;; Coypright © 2016 Julien Lepiller <julien@lepiller.eu>
12 ;;; Copyright © 2016 Arun Isaac <arunisaac@systemreboot.net>
13 ;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
14 ;;; Copyright © 2017 Alex Vong <alexvong1995@gmail.com>
15 ;;; Copyright © 2017 Rene Saavedra <rennes@openmailbox.org>
16 ;;;
17 ;;; This file is part of GNU Guix.
18 ;;;
19 ;;; GNU Guix is free software; you can redistribute it and/or modify it
20 ;;; under the terms of the GNU General Public License as published by
21 ;;; the Free Software Foundation; either version 3 of the License, or (at
22 ;;; your option) any later version.
23 ;;;
24 ;;; GNU Guix is distributed in the hope that it will be useful, but
25 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
26 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
27 ;;; GNU General Public License for more details.
28 ;;;
29 ;;; You should have received a copy of the GNU General Public License
30 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
31
32 (define-module (gnu packages pdf)
33 #:use-module ((guix licenses) #:prefix license:)
34 #:use-module (guix packages)
35 #:use-module (guix download)
36 #:use-module (guix utils)
37 #:use-module (guix build-system gnu)
38 #:use-module (guix build-system cmake)
39 #:use-module (guix build-system python)
40 #:use-module (guix build-system trivial)
41 #:use-module (gnu packages)
42 #:use-module (gnu packages autotools)
43 #:use-module (gnu packages backup)
44 #:use-module (gnu packages base)
45 #:use-module (gnu packages bash)
46 #:use-module (gnu packages compression)
47 #:use-module (gnu packages curl)
48 #:use-module (gnu packages databases)
49 #:use-module (gnu packages djvu)
50 #:use-module (gnu packages fontutils)
51 #:use-module (gnu packages game-development)
52 #:use-module (gnu packages gettext)
53 #:use-module (gnu packages ghostscript)
54 #:use-module (gnu packages gl)
55 #:use-module (gnu packages glib)
56 #:use-module (gnu packages gnome)
57 #:use-module (gnu packages gnupg)
58 #:use-module (gnu packages gtk)
59 #:use-module (gnu packages image)
60 #:use-module (gnu packages imagemagick)
61 #:use-module (gnu packages javascript)
62 #:use-module (gnu packages lesstif)
63 #:use-module (gnu packages linux)
64 #:use-module (gnu packages lua)
65 #:use-module (gnu packages pcre)
66 #:use-module (gnu packages perl)
67 #:use-module (gnu packages photo)
68 #:use-module (gnu packages pkg-config)
69 #:use-module (gnu packages python)
70 #:use-module (gnu packages qt)
71 #:use-module (gnu packages sdl)
72 #:use-module (gnu packages tls)
73 #:use-module (gnu packages xdisorg)
74 #:use-module (gnu packages xorg)
75 #:use-module (srfi srfi-1))
76
77 (define-public poppler
78 (package
79 (name "poppler")
80 (version "0.62.0")
81 (source (origin
82 (method url-fetch)
83 (uri (string-append "https://poppler.freedesktop.org/poppler-"
84 version ".tar.xz"))
85 (sha256
86 (base32
87 "1ii9ly1pngyvs0aiq2wxpya08hidpl54y7nsb8b1vxnnskgp76jv"))))
88 (build-system cmake-build-system)
89 ;; FIXME:
90 ;; use libcurl: no
91 (inputs `(("fontconfig" ,fontconfig)
92 ("freetype" ,freetype)
93 ("libjpeg" ,libjpeg)
94 ("libpng" ,libpng)
95 ("libtiff" ,libtiff)
96 ("lcms" ,lcms)
97 ("openjpeg" ,openjpeg)
98 ("zlib" ,zlib)
99
100 ;; To build poppler-glib (as needed by Evince), we need Cairo and
101 ;; GLib. But of course, that Cairo must not depend on Poppler.
102 ("cairo" ,(package (inherit cairo)
103 (inputs (alist-delete "poppler"
104 (package-inputs cairo)))))
105 ("glib" ,glib)))
106 (native-inputs
107 `(("pkg-config" ,pkg-config)
108 ("glib" ,glib "bin") ; glib-mkenums, etc.
109 ("gobject-introspection" ,gobject-introspection)))
110 (arguments
111 `(#:tests? #f ; no test data provided with the tarball
112 #:configure-flags
113 (let* ((out (assoc-ref %outputs "out"))
114 (lib (string-append out "/lib")))
115 (list "-DENABLE_XPDF_HEADERS=ON" ; to install header files
116 "-DENABLE_ZLIB=ON"
117 (string-append "-DCMAKE_INSTALL_LIBDIR=" lib)
118 (string-append "-DCMAKE_INSTALL_RPATH=" lib)))))
119 (synopsis "PDF rendering library")
120 (description
121 "Poppler is a PDF rendering library based on the xpdf-3.0 code base.")
122 (license license:gpl2+)
123 (home-page "https://poppler.freedesktop.org/")))
124
125 (define-public poppler-qt4
126 (package (inherit poppler)
127 (name "poppler-qt4")
128 (inputs `(("qt-4" ,qt-4)
129 ,@(package-inputs poppler)))
130 (synopsis "Qt4 frontend for the Poppler PDF rendering library")))
131
132 (define-public poppler-qt5
133 (package (inherit poppler)
134 (name "poppler-qt5")
135 (inputs `(("qtbase" ,qtbase)
136 ,@(package-inputs poppler)))
137 (synopsis "Qt5 frontend for the Poppler PDF rendering library")))
138
139 (define-public python-poppler-qt4
140 (package
141 (name "python-poppler-qt4")
142 (version "0.24.0")
143 (source
144 (origin
145 (method url-fetch)
146 (uri (string-append "https://pypi.python.org/packages/source/p"
147 "/python-poppler-qt4/python-poppler-qt4-"
148 version ".tar.gz"))
149 (sha256
150 (base32
151 "0x63niylkk4q3h3ay8zrk3m1xiik0x3hlr4gvj7kswx48qi1vb99"))))
152 (build-system python-build-system)
153 (arguments
154 `(#:phases
155 (modify-phases %standard-phases
156 (add-after
157 'unpack 'patch-poppler-include-paths
158 (lambda _
159 (substitute* (find-files "." "poppler-.*\\.sip")
160 (("qt4/poppler-.*\\.h" header)
161 (string-append "poppler/" header)))
162 #t)))))
163 (native-inputs
164 `(("pkg-config" ,pkg-config)))
165 (inputs
166 `(("python-sip" ,python-sip)
167 ("python-pyqt-4" ,python-pyqt-4)
168 ("poppler-qt4" ,poppler-qt4)))
169 (home-page "https://pypi.python.org/pypi/python-poppler-qt4")
170 (synopsis "Python bindings for Poppler-Qt4")
171 (description
172 "This package provides Python bindings for the Qt4 interface of the
173 Poppler PDF rendering library.")
174 (license license:lgpl2.1+)))
175
176 (define-public python-poppler-qt5
177 (package
178 (name "python-poppler-qt5")
179 (version "0.24.2")
180 (source
181 (origin
182 (method url-fetch)
183 (uri (pypi-uri "python-poppler-qt5" version))
184 (sha256
185 (base32
186 "0l69llw1fzwz8y90q0qp9q5pifbrqjjbwii7di54dwghw5fc6w1r"))))
187 (build-system python-build-system)
188 (arguments
189 `(;; There are no tests. The check phase just causes a rebuild.
190 #:tests? #f
191 #:phases
192 (modify-phases %standard-phases
193 (replace 'build
194 (lambda* (#:key inputs #:allow-other-keys)
195 (substitute* "setup.py"
196 ;; This check always fails, so disable it.
197 (("if not check_qtxml\\(\\)")
198 "if True")
199 ;; Enable C++11, which is needed because of Qt5.
200 (("\\*\\*ext_args" line)
201 (string-append "extra_compile_args=['-std=gnu++11'], " line)))
202 ;; We need to pass an extra flag here. This cannot be in
203 ;; configure-flags because it should not be passed for the
204 ;; installation phase.
205 ((@@ (guix build python-build-system) call-setuppy)
206 "build_ext" (list (string-append "--pyqt-sip-dir="
207 (assoc-ref inputs "python-pyqt")
208 "/share/sip")) #t))))))
209 (native-inputs
210 `(("pkg-config" ,pkg-config)))
211 (inputs
212 `(("python-sip" ,python-sip)
213 ("python-pyqt" ,python-pyqt)
214 ("poppler-qt5" ,poppler-qt5)
215 ("qtbase" ,qtbase)))
216 (home-page "https://pypi.python.org/pypi/python-poppler-qt5")
217 (synopsis "Python bindings for Poppler-Qt5")
218 (description
219 "This package provides Python bindings for the Qt5 interface of the
220 Poppler PDF rendering library.")
221 (license license:lgpl2.1+)))
222
223 (define-public libharu
224 (package
225 (name "libharu")
226 (version "2.3.0")
227 (source (origin
228 (method url-fetch)
229 (uri (string-append "https://github.com/libharu/libharu/archive/"
230 "RELEASE_"
231 (string-join (string-split version #\.) "_")
232 ".tar.gz"))
233 (file-name (string-append name "-" version ".tar.gz"))
234 (sha256
235 (base32
236 "1lm4v539y9cb1lvbq387j57sy7yxda3yv8b1pk8m6zazbp66i7lg"))))
237 (build-system gnu-build-system)
238 (arguments
239 `(#:configure-flags
240 (list (string-append "--with-zlib="
241 (assoc-ref %build-inputs "zlib"))
242 (string-append "--with-png="
243 (assoc-ref %build-inputs "libpng")))
244 #:phases
245 (modify-phases %standard-phases
246 (add-after 'unpack 'autogen
247 (lambda _ (zero? (system* "autoreconf" "-vif")))))))
248 (inputs
249 `(("zlib" ,zlib)
250 ("libpng" ,libpng)))
251 (native-inputs
252 `(("autoconf" ,autoconf)
253 ("automake" ,automake)
254 ("libtool" ,libtool)))
255 (home-page "http://libharu.org/")
256 (synopsis "Library for generating PDF files")
257 (description
258 "libHaru is a library for generating PDF files. libHaru does not support
259 reading and editing of existing PDF files.")
260 (license license:zlib)))
261
262 (define-public xpdf
263 (package
264 (name "xpdf")
265 (version "3.04")
266 (source (origin
267 (method url-fetch)
268 (uri (string-append "ftp://ftp.foolabs.com/pub/xpdf/xpdf-"
269 version ".tar.gz"))
270 (sha256 (base32
271 "1rbp54mr3z2x3a3a1qmz8byzygzi223vckfam9ib5g1sfds0qf8i"))))
272 (build-system gnu-build-system)
273 (inputs `(("freetype" ,freetype)
274 ("gs-fonts" ,gs-fonts)
275 ("lesstif" ,lesstif)
276 ("libpaper" ,libpaper)
277 ("libx11" ,libx11)
278 ("libxext" ,libxext)
279 ("libxp" ,libxp)
280 ("libxpm" ,libxpm)
281 ("libxt" ,libxt)
282 ("libpng" ,libpng)
283 ("zlib" ,zlib)))
284 (arguments
285 `(#:tests? #f ; there is no check target
286 #:parallel-build? #f ; build fails randomly on 8-way machines
287 #:configure-flags
288 (list (string-append "--with-freetype2-includes="
289 (assoc-ref %build-inputs "freetype")
290 "/include/freetype2"))
291 #:phases
292 (modify-phases %standard-phases
293 (replace 'install
294 (lambda* (#:key outputs inputs #:allow-other-keys #:rest args)
295 (let* ((install (assoc-ref %standard-phases 'install))
296 (out (assoc-ref outputs "out"))
297 (xpdfrc (string-append out "/etc/xpdfrc"))
298 (gs-fonts (assoc-ref inputs "gs-fonts")))
299 (apply install args)
300 (substitute* xpdfrc
301 (("/usr/local/share/ghostscript/fonts")
302 (string-append gs-fonts "/share/fonts/type1/ghostscript"))
303 (("#fontFile") "fontFile")))
304 #t)))))
305 (synopsis "Viewer for PDF files based on the Motif toolkit")
306 (description
307 "Xpdf is a viewer for Portable Document Format (PDF) files.")
308 (license license:gpl3) ; or gpl2, but not gpl2+
309 (home-page "http://www.foolabs.com/xpdf/")))
310
311 (define-public zathura-cb
312 (package
313 (name "zathura-cb")
314 (version "0.1.6")
315 (source (origin
316 (method url-fetch)
317 (uri
318 (string-append "https://pwmt.org/projects/zathura-cb/download/zathura-cb-"
319 version ".tar.gz"))
320 (sha256
321 (base32
322 "1fim4mpm8l2g3msj1vg70ks3c9lrwllv3yh4jv8l9f8k3r19b3l8"))))
323 (native-inputs `(("pkg-config" ,pkg-config)))
324 (propagated-inputs `(("girara" ,girara)))
325 (inputs `(("libarchive" ,libarchive)
326 ("gtk+" ,gtk+)
327 ("zathura" ,zathura)))
328 (build-system gnu-build-system)
329 (arguments
330 `(#:make-flags (list (string-append "PREFIX=" %output)
331 (string-append "PLUGINDIR=" %output "/lib/zathura")
332 "CC=gcc")
333 #:tests? #f ; Package does not contain tests.
334 #:phases
335 (modify-phases %standard-phases (delete 'configure))))
336 (home-page "https://pwmt.org/projects/zathura-cb/")
337 (synopsis "Comic book support for zathura (libarchive backend)")
338 (description "The zathura-cb plugin adds comic book support to zathura
339 using libarchive.")
340 (license license:zlib)))
341
342 (define-public zathura-ps
343 (package
344 (name "zathura-ps")
345 (version "0.2.4")
346 (source (origin
347 (method url-fetch)
348 (uri
349 (string-append "https://pwmt.org/projects/zathura-ps/download/zathura-ps-"
350 version ".tar.gz"))
351 (sha256
352 (base32
353 "1nxbl0glnzpan78fhdfzhkcd0cikcvrkzf9m56mb0pvnwzlwg7zv"))))
354 (native-inputs `(("pkg-config" ,pkg-config)))
355 (propagated-inputs `(("girara" ,girara)))
356 (inputs `(("libspectre" ,libspectre)
357 ("gtk+" ,gtk+)
358 ("zathura" ,zathura)))
359 (build-system gnu-build-system)
360 (arguments
361 `(#:make-flags (list (string-append "PREFIX=" %output)
362 (string-append "PLUGINDIR=" %output "/lib/zathura")
363 "CC=gcc")
364 #:tests? #f ; Package does not contain tests.
365 #:phases
366 (modify-phases %standard-phases (delete 'configure))))
367 (home-page "https://pwmt.org/projects/zathura-ps/")
368 (synopsis "PS support for zathura (libspectre backend)")
369 (description "The zathura-ps plugin adds PS support to zathura
370 using libspectre.")
371 (license license:zlib)))
372
373 (define-public zathura-djvu
374 (package
375 (name "zathura-djvu")
376 (version "0.2.6")
377 (source (origin
378 (method url-fetch)
379 (uri
380 (string-append "https://pwmt.org/projects/zathura-djvu/download/zathura-djvu-"
381 version ".tar.gz"))
382 (sha256
383 (base32
384 "0py0ra44f65cg064xzds0qr6vnglj2a5bwhnbwa0dyh2nyizdzmf"))))
385 (native-inputs `(("pkg-config" ,pkg-config)))
386 (propagated-inputs `(("girara" ,girara)))
387 (inputs
388 `(("djvulibre" ,djvulibre)
389 ("gtk+" ,gtk+)
390 ("zathura" ,zathura)))
391 (build-system gnu-build-system)
392 (arguments
393 `(#:make-flags (list (string-append "PREFIX=" %output)
394 (string-append "PLUGINDIR=" %output "/lib/zathura")
395 "CC=gcc")
396 #:tests? #f ; Package does not contain tests.
397 #:phases
398 (modify-phases %standard-phases (delete 'configure))))
399 (home-page "https://pwmt.org/projects/zathura-djvu/")
400 (synopsis "DjVu support for zathura (DjVuLibre backend)")
401 (description "The zathura-djvu plugin adds DjVu support to zathura
402 using the DjVuLibre library.")
403 (license license:zlib)))
404
405 (define-public zathura-pdf-mupdf
406 (package
407 (name "zathura-pdf-mupdf")
408 (version "0.3.1")
409 (source (origin
410 (method url-fetch)
411 (uri
412 (string-append "https://pwmt.org/projects/zathura-pdf-mupdf"
413 "/download/zathura-pdf-mupdf-" version ".tar.gz"))
414 (sha256
415 (base32
416 "06zqn8z6a0hfsx3s1kzqvqzb73afgcl6z5r062sxv7kv570fvffr"))))
417 (native-inputs `(("pkg-config" ,pkg-config)))
418 (propagated-inputs `(("girara" ,girara)))
419 (inputs
420 `(("gtk+" ,gtk+)
421 ("jbig2dec" ,jbig2dec)
422 ("libjpeg" ,libjpeg)
423 ("mupdf" ,mupdf)
424 ("openjpeg" ,openjpeg)
425 ("openssl" ,openssl)
426 ("zathura" ,zathura)))
427 (build-system gnu-build-system)
428 (arguments
429 `(#:make-flags (list (string-append "PREFIX=" %output)
430 (string-append "PLUGINDIR=" %output "/lib/zathura")
431 "CC=gcc")
432 #:tests? #f ;No tests.
433 #:phases (modify-phases %standard-phases (delete 'configure))))
434 (home-page "https://pwmt.org/projects/zathura-pdf-mupdf/")
435 (synopsis "PDF support for zathura (mupdf backend)")
436 (description "The zathura-pdf-mupdf plugin adds PDF support to zathura
437 by using the @code{mupdf} rendering library.")
438 (license license:zlib)))
439
440 (define-public zathura-pdf-poppler
441 (package
442 (name "zathura-pdf-poppler")
443 (version "0.2.7")
444 (source (origin
445 (method url-fetch)
446 (uri
447 (string-append "https://pwmt.org/projects/zathura-pdf-poppler/download/zathura-pdf-poppler-"
448 version ".tar.gz"))
449 (sha256
450 (base32
451 "1h43sgxpsbrsnn5z19661642plzhpv6b0y3f4kyzshv1rr6lwplq"))))
452 (native-inputs `(("pkg-config" ,pkg-config)))
453 (propagated-inputs `(("girara" ,girara)))
454 (inputs
455 `(("poppler" ,poppler)
456 ("gtk+" ,gtk+)
457 ("zathura" ,zathura)
458 ("cairo" ,cairo)))
459 (build-system gnu-build-system)
460 (arguments
461 `(#:make-flags (list (string-append "PREFIX=" %output)
462 (string-append "PLUGINDIR=" %output "/lib/zathura")
463 "CC=gcc")
464 #:tests? #f ; Package does not include tests.
465 #:phases
466 (modify-phases %standard-phases (delete 'configure))))
467 (home-page "https://pwmt.org/projects/zathura-pdf-poppler/")
468 (synopsis "PDF support for zathura (poppler backend)")
469 (description "The zathura-pdf-poppler plugin adds PDF support to zathura
470 by using the poppler rendering engine.")
471 (license license:zlib)))
472
473 (define-public zathura
474 (package
475 (name "zathura")
476 (version "0.3.7")
477 (source (origin
478 (method url-fetch)
479 (uri
480 (string-append "https://pwmt.org/projects/zathura/download/zathura-"
481 version ".tar.gz"))
482 (sha256
483 (base32
484 "1w0g74dq4z2vl3f99s2gkaqrb5pskgzig10qhbxj4gq9yj4zzbr2"))
485 (patches (search-patches
486 "zathura-plugindir-environment-variable.patch"))))
487 (native-inputs `(("pkg-config" ,pkg-config)
488 ("gettext" ,gettext-minimal)))
489 (inputs `(("girara" ,girara)
490 ("sqlite" ,sqlite)
491 ("gtk+" ,gtk+)))
492 (native-search-paths
493 (list (search-path-specification
494 (variable "ZATHURA_PLUGIN_PATH")
495 (files '("lib/zathura")))))
496 (build-system gnu-build-system)
497 (arguments
498 `(#:make-flags
499 `(,(string-append "PREFIX=" (assoc-ref %outputs "out"))
500 "CC=gcc" "COLOR=0")
501 #:tests? #f ; Tests fail: "Gtk cannot open display".
502 #:test-target "test"
503 #:phases
504 (modify-phases %standard-phases (delete 'configure))))
505 (home-page "https://pwmt.org/projects/zathura/")
506 (synopsis "Lightweight keyboard-driven PDF viewer")
507 (description "Zathura is a customizable document viewer. It provides a
508 minimalistic interface and an interface that mainly focuses on keyboard
509 interaction.")
510 (license license:zlib)))
511
512 (define-public podofo
513 (package
514 (name "podofo")
515 (version "0.9.5")
516 (source (origin
517 (method url-fetch)
518 (uri (string-append "mirror://sourceforge/podofo/podofo/" version
519 "/podofo-" version ".tar.gz"))
520 (sha256
521 (base32
522 "012kgfx5j5n6w4zkc1d290d2cwjk60jhzsjlr2x19g3yi75q2jc5"))))
523 (build-system cmake-build-system)
524 (inputs ; TODO: Add cppunit for tests
525 `(("lua" ,lua-5.1)
526 ("libpng" ,libpng)
527 ("openssl" ,openssl)
528 ("fontconfig" ,fontconfig)
529 ("libtiff" ,libtiff)
530 ("libjpeg" ,libjpeg-8)
531 ("freetype" ,freetype)
532 ("zlib" ,zlib)))
533 (arguments
534 `(#:configure-flags '("-DPODOFO_BUILD_SHARED=ON"
535 "-DPODOFO_BUILD_STATIC=ON")
536 #:phases
537 (modify-phases %standard-phases
538 (add-before 'configure 'patch
539 (lambda* (#:key inputs #:allow-other-keys)
540 (let ((freetype (assoc-ref inputs "freetype")))
541 ;; Look for freetype include files in the correct place.
542 (substitute* "cmake/modules/FindFREETYPE.cmake"
543 (("/usr/local") freetype)))
544 #t)))))
545 (home-page "http://podofo.sourceforge.net")
546 (synopsis "Tools to work with the PDF file format")
547 (description
548 "PoDoFo is a C++ library and set of command-line tools to work with the
549 PDF file format. It can parse PDF files and load them into memory, and makes
550 it easy to modify them and write the changes to disk. It is primarily useful
551 for applications that wish to do lower level manipulation of PDF, such as
552 extracting content or merging files.")
553 (license license:lgpl2.0+)))
554
555 (define-public mupdf
556 (package
557 (name "mupdf")
558 (version "1.12.0")
559 (source
560 (origin
561 (method url-fetch)
562 (uri (string-append "https://mupdf.com/downloads/archive/"
563 name "-" version "-source.tar.xz"))
564 (patches (search-patches "mupdf-build-with-latest-openjpeg.patch"))
565 (sha256
566 (base32
567 "0b9j0gqbc3jhmx87r6idcsh8lnb30840c3hyx6dk2gdjqqh3hysp"))
568 (modules '((guix build utils)))
569 (snippet '(delete-file-recursively "thirdparty"))))
570 (build-system gnu-build-system)
571 (inputs
572 `(("curl" ,curl)
573 ("freeglut" ,freeglut)
574 ("freetype" ,freetype)
575 ("harfbuzz" ,harfbuzz)
576 ("jbig2dec" ,jbig2dec)
577 ("libjpeg" ,libjpeg)
578 ("libx11" ,libx11)
579 ("libxext" ,libxext)
580 ("mujs" ,mujs)
581 ("openjpeg" ,openjpeg)
582 ("openssl" ,openssl)
583 ("zlib" ,zlib)))
584 (native-inputs
585 `(("pkg-config" ,pkg-config)))
586 (arguments
587 '(#:tests? #f ; no check target
588 #:make-flags (list "CC=gcc"
589 "XCFLAGS=-fpic"
590 (string-append "prefix=" (assoc-ref %outputs "out")))
591 #:phases (modify-phases %standard-phases
592 (delete 'configure))))
593 (home-page "https://mupdf.com")
594 (synopsis "Lightweight PDF viewer and toolkit")
595 (description
596 "MuPDF is a C library that implements a PDF and XPS parsing and
597 rendering engine. It is used primarily to render pages into bitmaps,
598 but also provides support for other operations such as searching and
599 listing the table of contents and hyperlinks.
600
601 The library ships with a rudimentary X11 viewer, and a set of command
602 line tools for batch rendering @command{pdfdraw}, rewriting files
603 @command{pdfclean}, and examining the file structure @command{pdfshow}.")
604 (license license:agpl3+)))
605
606 (define-public qpdf
607 (package
608 (name "qpdf")
609 (version "6.0.0")
610 (source (origin
611 (method url-fetch)
612 (uri (string-append "mirror://sourceforge/qpdf/qpdf/" version
613 "/qpdf-" version ".tar.gz"))
614 (sha256
615 (base32
616 "0csj2p2gkxrc0rk8ykymlsdgfas96vzf1dip3y1x7z1q9plwgzd9"))
617 (modules '((guix build utils)))
618 (snippet
619 ;; Replace shebang with the bi-lingual shell/Perl trick to remove
620 ;; dependency on Perl.
621 '(substitute* "qpdf/fix-qdf"
622 (("#!/usr/bin/env perl")
623 "\
624 eval '(exit $?0)' && eval 'exec perl -wS \"$0\" ${1+\"$@\"}'
625 & eval 'exec perl -wS \"$0\" $argv:q'
626 if 0;\n")))))
627 (build-system gnu-build-system)
628 (arguments
629 `(#:disallowed-references (,perl)
630 #:phases
631 (modify-phases %standard-phases
632 (add-before 'configure 'patch-paths
633 (lambda _
634 (substitute* "make/libtool.mk"
635 (("SHELL=/bin/bash")
636 (string-append "SHELL=" (which "bash"))))
637 (substitute* (append
638 '("qtest/bin/qtest-driver")
639 (find-files "." "\\.test"))
640 (("/usr/bin/env") (which "env"))))))))
641 (native-inputs
642 `(("pkg-config" ,pkg-config)
643 ("perl" ,perl)))
644 (propagated-inputs
645 `(("pcre" ,pcre)))
646 (inputs
647 `(("zlib" ,zlib)))
648 (synopsis "Command-line tools and library for transforming PDF files")
649 (description
650 "QPDF is a command-line program that does structural, content-preserving
651 transformations on PDF files. It could have been called something like
652 pdf-to-pdf. It includes support for merging and splitting PDFs and to
653 manipulate the list of pages in a PDF file. It is not a PDF viewer or a
654 program capable of converting PDF into other formats.")
655 (license license:clarified-artistic)
656 (home-page "http://qpdf.sourceforge.net/")))
657
658 (define-public xournal
659 (package
660 (name "xournal")
661 (version "0.4.8")
662 (source
663 (origin
664 (method url-fetch)
665 (uri (string-append "mirror://sourceforge/xournal/xournal/" version
666 "/xournal-" version ".tar.gz"))
667 (sha256
668 (base32
669 "0c7gjcqhygiyp0ypaipdaxgkbivg6q45vhsj8v5jsi9nh6iqff13"))))
670 (build-system gnu-build-system)
671 (inputs
672 `(("gtk" ,gtk+-2)
673 ("pango" ,pango)
674 ("poppler" ,poppler)
675 ("glib" ,glib)
676 ("libgnomecanvas" ,libgnomecanvas)))
677 (native-inputs
678 `(("pkg-config" ,pkg-config)))
679 (home-page "http://xournal.sourceforge.net/")
680 (synopsis "Notetaking using a stylus")
681 (description
682 "Xournal is an application for notetaking, sketching, keeping a journal
683 using a stylus.")
684 (license license:gpl2+)))
685
686 (define-public python-reportlab
687 (package
688 (name "python-reportlab")
689 (version "3.3.0")
690 (source (origin
691 (method url-fetch)
692 (uri (pypi-uri "reportlab" version))
693 (sha256
694 (base32
695 "0rz2pg04wnzjjm2f5a8ik9v8s54mv4xrjhv5liqjijqv6awh12gl"))))
696 (build-system python-build-system)
697 (arguments
698 '(;; FIXME: There is one test failure, but it does not cause the
699 ;; build to fail. No time to investigate right now.
700 #:test-target "tests"))
701 (propagated-inputs
702 `(("python-pillow" ,python-pillow)))
703 (home-page "http://www.reportlab.com")
704 (synopsis "Python library for generating PDFs and graphics")
705 (description "This is the ReportLab PDF Toolkit. It allows rapid creation
706 of rich PDF documents, and also creation of charts in a variety of bitmap and
707 vector formats.")
708 (license license:bsd-3)))
709
710 (define-public python2-reportlab
711 (package-with-python2 python-reportlab))
712
713 (define-public impressive
714 (package
715 (name "impressive")
716 (version "0.11.1")
717 (source (origin
718 (method url-fetch)
719 (uri (string-append
720 "mirror://sourceforge/impressive/Impressive/"
721 version "/Impressive-" version ".tar.gz"))
722 (sha256
723 (base32
724 "0b3rmy6acp2vmf5nill3aknxvr9a5aawk1vnphkah61anxp62gsr"))))
725 (build-system python-build-system)
726
727 ;; TODO: Add dependency on pdftk.
728 (inputs `(("python2-pygame" ,python2-pygame)
729 ("python2-pillow" ,python2-pillow)
730 ("sdl" ,sdl)
731 ("xpdf" ,xpdf)))
732
733 (arguments
734 `(#:python ,python-2
735 #:phases (modify-phases %standard-phases
736 (delete 'build)
737 (delete 'configure)
738 (delete 'check)
739 (replace 'install
740 (lambda* (#:key inputs outputs #:allow-other-keys)
741 ;; There's no 'setup.py' so install things manually.
742 (let* ((out (assoc-ref outputs "out"))
743 (bin (string-append out "/bin"))
744 (man1 (string-append out "/share/man/man1"))
745 (sdl (assoc-ref inputs "sdl"))
746 (xpdf (assoc-ref inputs "xpdf")))
747 (mkdir-p bin)
748 (copy-file "impressive.py"
749 (string-append bin "/impressive"))
750 (wrap-program (string-append bin "/impressive")
751 `("LIBRARY_PATH" ":" prefix ;for ctypes
752 (,(string-append sdl "/lib")))
753 `("PATH" ":" prefix ;for pdftoppm
754 (,(string-append xpdf "/bin"))))
755 (install-file "impressive.1" man1)
756 #t))))))
757 (home-page "http://impressive.sourceforge.net")
758 (synopsis "PDF presentation tool with visual effects")
759 (description
760 "Impressive is a tool to display PDF files that provides visual effects
761 such as smooth alpha-blended slide transitions. It provides additional tools
762 such as zooming, highlighting an area of the screen, and a tool to navigate
763 the PDF pages.")
764 (license license:gpl2)))
765
766 (define-public fbida
767 (package
768 (name "fbida")
769 (version "2.12")
770 (home-page "https://www.kraxel.org/blog/linux/fbida/")
771 (source (origin
772 (method url-fetch)
773 (uri (string-append "https://www.kraxel.org/releases/fbida/"
774 name "-" version ".tar.gz"))
775 (sha256
776 (base32
777 "0bw224vb7jh0lrqaf4jgxk48xglvxs674qcpj5y0axyfbh896cfk"))))
778 (build-system gnu-build-system)
779 (arguments
780 '(#:phases
781 (modify-phases %standard-phases
782 (add-after 'unpack 'patch-ldconfig
783 (lambda _
784 (substitute* "mk/Autoconf.mk"
785 (("/sbin/ldconfig -p") "echo lib")) #t))
786 (delete 'configure))
787 #:tests? #f
788 #:make-flags (list "CC=gcc"
789 (string-append "prefix=" (assoc-ref %outputs "out")))))
790 (inputs `(("libjpeg" ,libjpeg)
791 ("curl" ,curl)
792 ("libtiff" ,libtiff)
793 ("libudev" ,eudev)
794 ("libwebp" ,libwebp)
795 ("libdrm" ,libdrm)
796 ("imagemagick" ,imagemagick)
797 ("giflib" ,giflib)
798 ("glib" ,glib)
799 ("cairo-xcb" ,cairo-xcb)
800 ("freetype" ,freetype)
801 ("fontconfig" ,fontconfig)
802 ("libexif" ,libexif)
803 ("mesa" ,mesa)
804 ("libepoxy" ,libepoxy)
805 ("libpng" ,libpng)
806 ("poppler" ,poppler)))
807 (native-inputs `(("pkg-config" ,pkg-config)))
808 (synopsis "Framebuffer and drm-based image viewer")
809 (description
810 "fbida contains a few applications for viewing and editing images on
811 the framebuffer.")
812
813 (license license:gpl2+)))
814
815 (define-public pdf2svg
816 (package
817 (name "pdf2svg")
818 (version "0.2.3")
819 (source (origin
820 (method url-fetch)
821 (uri (string-append
822 "https://github.com/dawbarton/pdf2svg/archive/v"
823 version ".tar.gz"))
824 (file-name (string-append name "-" version ".tar.gz"))
825 (sha256
826 (base32
827 "12pa1pajirnlrkz2il3h4l30lc2prryk1qr132jk6z9y1c3qdcag"))))
828 (build-system gnu-build-system)
829 (inputs
830 `(("cairo" ,cairo)
831 ("poppler" ,poppler)))
832 (native-inputs
833 `(("pkg-config" ,pkg-config)))
834 (home-page "http://www.cityinthesky.co.uk/opensource/pdf2svg/")
835 (synopsis "PDF to SVG converter")
836 (description "@command{pdf2svg} is a simple command-line PDF to SVG
837 converter using the Poppler and Cairo libraries.")
838 (license license:gpl2+)))
839
840 (define-public python-pypdf2
841 (package
842 (name "python-pypdf2")
843 (version "1.26.0")
844 (source (origin
845 (method url-fetch)
846 (uri (pypi-uri "PyPDF2" version))
847 (sha256
848 (base32
849 "11a3aqljg4sawjijkvzhs3irpw0y67zivqpbjpm065ha5wpr13z2"))))
850 (build-system python-build-system)
851 (arguments
852 `(#:phases
853 (modify-phases %standard-phases
854 (add-after
855 'unpack 'patch-test-suite
856 (lambda _
857 ;; The text-file needs to be opened in binary mode for Python 3,
858 ;; so patch in the "b"
859 (substitute* "Tests/tests.py"
860 (("pdftext_file = open\\(.* 'crazyones.txt'\\), 'r" line)
861 (string-append line "b")))
862 #t))
863 (replace 'check
864 (lambda _
865 (zero? (system* "python" "-m" "unittest" "Tests.tests")))))))
866 (home-page "http://mstamy2.github.com/PyPDF2")
867 (synopsis "Pure Python PDF toolkit")
868 (description "PyPDF2 is a pure Python PDF library capable of:
869
870 @enumerate
871 @item extracting document information (title, author, …)
872 @item splitting documents page by page
873 @item merging documents page by page
874 @item cropping pages
875 @item merging multiple pages into a single page
876 @item encrypting and decrypting PDF files
877 @end enumerate
878
879 By being pure Python, it should run on any Python platform without any
880 dependencies on external libraries. It can also work entirely on
881 @code{StringIO} objects rather than file streams, allowing for PDF
882 manipulation in memory. It is therefore a useful tool for websites that
883 manage or manipulate PDFs.")
884 (license license:bsd-3)))
885
886 (define-public python2-pypdf2
887 (package-with-python2 python-pypdf2))
888
889 (define-public python2-pypdf
890 (package
891 (name "python2-pypdf")
892 (version "1.13")
893 (source (origin
894 (method url-fetch)
895 (uri (pypi-uri "pyPdf" version))
896 (sha256
897 (base32
898 "0fqfvamir7k41w84c73rghzkiv891gdr17q5iz4hgbf6r71y9v9s"))))
899 (build-system python-build-system)
900 (arguments
901 `(#:tests? #f ; no tests
902 #:python ,python-2))
903 (home-page "http://pybrary.net/pyPdf/")
904 (synopsis "Pure Python PDF toolkit")
905 (description "PyPDF2 is a pure Python PDF toolkit.
906
907 Note: This module isn't maintained anymore. For new projects please use
908 python-pypdf2 instead.")
909 (license license:bsd-3)))
910
911 (define-public pdfposter
912 (package
913 (name "pdfposter")
914 (version "0.6.0")
915 (source (origin
916 (method url-fetch)
917 (uri (pypi-uri "pdftools.pdfposter" version ".tar.bz2"))
918 (sha256
919 (base32
920 "1i9jqawf279va089ykicglcq4zlsnwgcnsdzaa8vnm836lqhywma"))))
921 (build-system python-build-system)
922 (arguments
923 `(#:tests? #f ; no test suite, only for visual control
924 #:python ,python-2))
925 (inputs
926 ;; pdfposter 0.6.0 still uses the old pyPdf
927 `(("python2-pypdf" ,python2-pypdf)))
928 (home-page "https://pythonhosted.org/pdftools.pdfposter/")
929 (synopsis "Scale and tile PDF images/pages to print on multiple pages")
930 (description "@command{pdfposter} can be used to create a large poster by
931 building it from multple pages and/or printing it on large media. It expects
932 as input a PDF file, normally printing on a single page. The output is again
933 a PDF file, maybe containing multiple pages together building the poster. The
934 input page will be scaled to obtain the desired size.
935
936 This is much like @command{poster} does for Postscript files, but working with
937 PDF. Since sometimes @command{poster} does not like your files converted from
938 PDF. Indeed @command{pdfposter} was inspired by @command{poster}.")
939 (license license:gpl3+)))
940
941 (define-public pdfgrep
942 (package
943 (name "pdfgrep")
944 (version "2.0.1")
945 (source
946 (origin
947 (method url-fetch)
948 (uri (string-append "https://pdfgrep.org/download/"
949 name "-" version ".tar.gz"))
950 (sha256
951 (base32
952 "07llkrkcfjwd3ybai9ad10ybhr0biffcplmy7lw4fb87nd2dfw03"))))
953 (build-system gnu-build-system)
954 (native-inputs
955 `(("pkg-config" ,pkg-config)))
956 (inputs
957 `(("libgcrypt" ,libgcrypt)
958 ("pcre" ,pcre)
959 ("poppler" ,poppler)))
960 (home-page "https://pdfgrep.org")
961 (synopsis "Command-line utility to search text in PDF files")
962 (description
963 "Pdfgrep searches in pdf files for strings matching a regular expression.
964 Support some GNU grep options as file name output, page number output,
965 optional case insensitivity, count occurrences, color highlights and search in
966 multiple files.")
967 (license license:gpl2+)))