Merge branch 'master' into core-updates
[jackhill/guix/guix.git] / gnu / packages / patches / python-unittest2-python3-compat.patch
1 Skip tests that fail with newer versions of Python.
2
3 Patch copied from Gentoo:
4
5 https://gitweb.gentoo.org/repo/gentoo.git/tree/dev-python/unittest2/files/unittest2-1.1.0-python3.5-test.patch
6
7 diff --git a/unittest2/test/test_loader.py b/unittest2/test/test_loader.py
8 index 683f662..347eea5 100644
9 --- a/unittest2/test/test_loader.py
10 +++ b/unittest2/test/test_loader.py
11 @@ -509,6 +509,7 @@ class Test_TestLoader(unittest2.TestCase):
12 #
13 # What happens when an impossible name is given, relative to the provided
14 # `module`?
15 + @unittest.skipIf(sys.version_info[:2] >= (3, 5), "python 3.5 has problems here")
16 def test_loadTestsFromName__relative_malformed_name(self):
17 loader = unittest.TestLoader()
18
19 @@ -811,6 +812,7 @@ class Test_TestLoader(unittest2.TestCase):
20 # TestCase or TestSuite instance."
21 #
22 # What happens when presented with an impossible module name?
23 + @unittest.skipIf(sys.version_info[:2] >= (3, 5), "python 3.5 has problems here")
24 def test_loadTestsFromNames__malformed_name(self):
25 loader = unittest2.TestLoader()
26
27 @@ -918,6 +920,7 @@ class Test_TestLoader(unittest2.TestCase):
28 # "The method optionally resolves name relative to the given module"
29 #
30 # What happens when presented with an impossible attribute name?
31 + @unittest.skipIf(sys.version_info[:2] >= (3, 5), "python 3.5 has problems here")
32 def test_loadTestsFromNames__relative_malformed_name(self):
33 loader = unittest.TestLoader()
34