Merge branch 'staging' into core-updates
[jackhill/guix/guix.git] / gnu / packages / mes.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2017,2018 Jan Nieuwenhuizen <janneke@gnu.org>
3 ;;; Copyright © 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
4 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20
21 (define-module (gnu packages mes)
22 #:use-module (gnu packages)
23 #:use-module (gnu packages base)
24 #:use-module (gnu packages cross-base)
25 #:use-module (gnu packages gcc)
26 #:use-module (gnu packages graphviz)
27 #:use-module (gnu packages guile)
28 #:use-module (gnu packages man)
29 #:use-module (gnu packages package-management)
30 #:use-module (gnu packages perl)
31 #:use-module (gnu packages texinfo)
32 #:use-module (guix build-system gnu)
33 #:use-module (guix download)
34 #:use-module (guix git-download)
35 #:use-module (guix licenses)
36 #:use-module (guix packages))
37
38 (define-public nyacc
39 (package
40 (name "nyacc")
41 (version "0.86.0")
42 (source (origin
43 (method url-fetch)
44 (uri (string-append "mirror://savannah/nyacc/"
45 name "-" version ".tar.gz"))
46 (patches (search-patches "nyacc-binary-literals.patch"))
47 (sha256
48 (base32
49 "0lkd9lyspvhxlfs0496gsllwinh62jk9wij6gpadvx9gwz6yavd9"))))
50 (build-system gnu-build-system)
51 (native-inputs
52 `(("guile" ,guile-2.2)))
53 (synopsis "LALR(1) Parser Generator in Guile")
54 (description
55 "NYACC is an LALR(1) parser generator implemented in Guile.
56 The syntax and nomenclature should be considered not stable. It comes with
57 extensive examples, including parsers for the Javascript and C99 languages.")
58 (home-page "https://savannah.nongnu.org/projects/nyacc")
59 (license (list gpl3+ lgpl3+))))
60
61 (define-public mes
62 (let ((triplet "i686-unknown-linux-gnu"))
63 (package
64 (name "mes")
65 (version "0.19")
66 (source (origin
67 (method url-fetch)
68 (uri (string-append "mirror://gnu/mes/"
69 "mes-" version ".tar.gz"))
70 (sha256
71 (base32
72 "15h4yhaywdc0djpjlin2jz1kzahpqxfki0r0aav1qm9nxxmnp1l0"))))
73 (build-system gnu-build-system)
74 (supported-systems '("i686-linux" "x86_64-linux"))
75 (propagated-inputs
76 `(("mescc-tools" ,mescc-tools)
77 ("nyacc" ,nyacc)))
78 (native-inputs
79 `(("guile" ,guile-2.2)
80 ,@(if (not (string-prefix? "i686-linux" (or (%current-target-system)
81 (%current-system))))
82 ;; Use cross-compiler rather than #:system "i686-linux" to get
83 ;; MesCC 64 bit .go files installed ready for use with Guile.
84 `(("i686-linux-binutils" ,(cross-binutils triplet))
85 ("i686-linux-gcc" ,(cross-gcc triplet)))
86 '())
87 ("graphviz" ,graphviz)
88 ("help2man" ,help2man)
89 ("perl" ,perl) ; build-aux/gitlog-to-changelog
90 ("texinfo" ,texinfo)))
91 (arguments
92 `(#:strip-binaries? #f)) ; binutil's strip b0rkes MesCC/M1/hex2 binaries
93 (synopsis "Scheme interpreter and C compiler for full source bootstrapping")
94 (description
95 "GNU Mes--Maxwell Equations of Software--brings the Reduced Binary Seed
96 bootstrap to Guix and aims to help create full source bootstrapping for
97 GNU/Linux distributions. It consists of a mutual self-hosting Scheme
98 interpreter in C and a Nyacc-based C compiler in Scheme and is compatible with
99 Guile.")
100 (home-page "https://gnu.org/software/mes")
101 (license gpl3+))))
102
103 (define-public mescc-tools
104 (let ((commit "bb062b0da7bf2724ca40f9002b121579898d4ef7")
105 (revision "0")
106 (version "0.5.2"))
107 (package
108 (name "mescc-tools")
109 (version (string-append version "-" revision "." (string-take commit 7)))
110 (source (origin
111 (method url-fetch)
112 (uri (string-append
113 "https://git.savannah.nongnu.org/cgit/mescc-tools.git/snapshot/"
114 name "-" commit
115 ".tar.gz"))
116 (sha256
117 (base32
118 "1h6j57wyf91i42b26f8msbv6451cw3nm4nmpl1fckp9c7vi8mwkh"))))
119 (build-system gnu-build-system)
120 (supported-systems '("i686-linux" "x86_64-linux"))
121 (arguments
122 `(#:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out")))
123 #:test-target "test"
124 #:phases (modify-phases %standard-phases
125 (delete 'configure))))
126 (synopsis "Tools for the full source bootstrapping process")
127 (description
128 "Mescc-tools is a collection of tools for use in a full source
129 bootstrapping process. It consists of the M1 macro assembler, the hex2
130 linker, the blood-elf symbol table generator, the kaem shell, exec_enable and
131 get_machine.")
132 (home-page "https://savannah.nongnu.org/projects/mescc-tools")
133 (license gpl3+))))