gnu: Add libpagemaker.
[jackhill/guix/guix.git] / gnu / packages / libreoffice.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
3 ;;; Copyright © 2014 John Darrington <jmd@gnu.org>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages libreoffice)
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module ((guix licenses) #:select (lgpl2.1+ mpl2.0 non-copyleft))
24 #:use-module (guix build-system gnu)
25 #:use-module (gnu packages boost)
26 #:use-module (gnu packages check)
27 #:use-module (gnu packages compression)
28 #:use-module (gnu packages doxygen)
29 #:use-module (gnu packages ghostscript)
30 #:use-module (gnu packages gperf)
31 #:use-module (gnu packages icu4c)
32 #:use-module (gnu packages perl)
33 #:use-module (gnu packages pkg-config)
34 #:use-module (gnu packages python)
35 #:use-module (gnu packages xml))
36
37 (define-public ixion
38 (package
39 (name "ixion")
40 (version "0.9.1")
41 (source
42 (origin
43 (method url-fetch)
44 (uri (string-append "http://kohei.us/files/ixion/src/libixion-"
45 version ".tar.xz"))
46 (sha256 (base32
47 "18g3nk29ljiqbyi0ml49j2x3f3xrqckdm9i66sw5fxnj7hb5rqvp"))))
48 (build-system gnu-build-system)
49 (native-inputs
50 `(("pkg-config" ,pkg-config)))
51 (inputs
52 `(("mdds" ,mdds)
53 ("python" ,python-2))) ; looks for python.pc, not python3.pc
54 (home-page "https://gitlab.com/ixion/ixion")
55 (synopsis "General purpose formula parser and interpreter")
56 (description "Ixion is a library for calculating the results of formula
57 expressions stored in multiple named targets, or \"cells\". The cells can
58 be referenced from each other, and the library takes care of resolving
59 their dependencies automatically upon calculation.")
60 (license mpl2.0)))
61
62 (define-public orcus
63 (package
64 (name "orcus")
65 (version "0.7.1")
66 (source
67 (origin
68 (method url-fetch)
69 (uri (string-append "http://kohei.us/files/" name "/src/lib"
70 name "-" version ".tar.xz"))
71 (sha256 (base32
72 "0hva4qalg3dk6n1118ncr5fy8cqnj2f7fwldw7aa04124rj6p104"))))
73 (build-system gnu-build-system)
74 (native-inputs
75 `(("pkg-config" ,pkg-config)))
76 (inputs
77 `(("ixion" ,ixion)
78 ("mdds" ,mdds)
79 ("zlib" ,zlib)))
80 (home-page "https://gitlab.com/orcus/orcus")
81 (synopsis "File import filter library for spreadsheet documents")
82 (description "Orcus is a library that provides a collection of standalone
83 file processing filters. It is currently focused on providing filters for
84 spreadsheet documents. The library includes import filters for
85 Microsoft Excel 2007 XML, Microsoft Excel 2003 XML, Open Document Spreadsheet,
86 Plain Text, Gnumeric XML, Generic XML. It also includes low-level parsers for
87 CSV, CSS and XML.")
88 (license mpl2.0)))
89
90 (define-public librevenge
91 (package
92 (name "librevenge")
93 (version "0.0.2")
94 (source
95 (origin
96 (method url-fetch)
97 (uri (string-append "mirror://sourceforge/libwpd/" name "/" name "-"
98 version ".tar.xz"))
99 (sha256 (base32
100 "03ygxyb0vfjv8raif5q62sl33b54wkr5rzgadb8slijm6k281wpn"))))
101 (build-system gnu-build-system)
102 (native-inputs
103 `(("boost" ,boost)
104 ("cppunit" ,cppunit)
105 ("doxygen" ,doxygen)
106 ("pkg-config" ,pkg-config)))
107 (inputs
108 `(("zlib" ,zlib)))
109 (arguments
110 ;; avoid triggering configure errors by simple inclusion of boost headers
111 `(#:configure-flags '("--disable-werror")))
112 (home-page "http://sourceforge.net/p/libwpd/wiki/librevenge/")
113 (synopsis "Document importer for office suites")
114 (description "Librevenge is a base library for writing document import
115 filters. It has interfaces for text documents, vector graphics,
116 spreadsheets and presentations.")
117 (license (list mpl2.0 lgpl2.1+)))) ;dual licensed
118
119 (define-public libwpd
120 (package
121 (name "libwpd")
122 (version "0.10.0")
123 (source
124 (origin
125 (method url-fetch)
126 (uri (string-append "mirror://sourceforge/libwpd/" name "/" name "-"
127 version ".tar.xz"))
128 (sha256 (base32
129 "0b6krzr6kxzm89g6bapn805kdayq70hn16n5b5wfs2lwrf0ag2wx"))))
130 (build-system gnu-build-system)
131 (native-inputs
132 `(("doxygen" ,doxygen)
133 ("pkg-config" ,pkg-config)))
134 (inputs
135 `(("librevenge" ,librevenge)
136 ("zlib" ,zlib)))
137 (home-page "http://libwpd.sourceforge.net/")
138 (synopsis "Library for importing WordPerfect documents")
139 (description "Libwpd is a C++ library designed to help process
140 WordPerfect documents. It is most commonly used to import such documents
141 into other word processors.")
142 (license (list mpl2.0 lgpl2.1+)))) ;dual licensed
143
144 (define-public libe-book
145 (package
146 (name "libe-book")
147 (version "0.1.2")
148 (source
149 (origin
150 (method url-fetch)
151 (uri (string-append "mirror://sourceforge/libebook/libe-book-"
152 version "/libe-book-" version ".tar.xz"))
153 (sha256
154 (base32
155 "1v48pd32r2pfysr3a3igc4ivcf6vvb26jq4pdkcnq75p70alp2bz"))))
156 (build-system gnu-build-system)
157 (native-inputs
158 `(("cppunit" ,cppunit)
159 ("gperf" ,gperf)
160 ("pkg-config" ,pkg-config)))
161 (inputs `(("boost" ,boost)
162 ("icu4c" ,icu4c)
163 ("librevenge" ,librevenge)
164 ("libxml2" ,libxml2)))
165 (arguments
166 ;; avoid triggering configure errors by simple inclusion of boost headers
167 `(#:configure-flags '("--disable-werror")))
168 (home-page "http://libebook.sourceforge.net")
169 (synopsis "Library for import of reflowable e-book formats")
170 (description "Libe-book is a library and a set of tools for reading and
171 converting various reflowable e-book formats. Currently supported are:
172 Broad Band eBook, eReader .pdb, FictionBook v. 2 (including zipped files),
173 PalmDoc Ebook, Plucker .pdb, QiOO (mobile format, for java-enabled
174 cellphones), TCR (simple compressed text format), TealDoc, zTXT,
175 ZVR (simple compressed text format).")
176 (license mpl2.0)))
177
178 (define-public libwpg
179 (package
180 (name "libwpg")
181 (version "0.3.0")
182 (source
183 (origin
184 (method url-fetch)
185 (uri (string-append "mirror://sourceforge/libwpg/" name "/" name "-"
186 version ".tar.xz"))
187 (sha256 (base32
188 "097jx8a638fwwfrzf6v29r1yhc34rq9526py7wf0ck2z4fcr2w3g"))))
189 (build-system gnu-build-system)
190 (native-inputs
191 `(("doxygen" ,doxygen)
192 ("pkg-config" ,pkg-config)))
193 (inputs
194 `(("librevenge" ,librevenge)
195 ("libwpd" ,libwpd)
196 ("perl" ,perl)
197 ("zlib" ,zlib)))
198 (home-page "http://libwpg.sourceforge.net/")
199 (synopsis "Library and tools for the WordPerfect Graphics format")
200 (description "The libwpg project provides a library and tools for
201 working with graphics in the WPG (WordPerfect Graphics) format.")
202 (license (list mpl2.0 lgpl2.1+)))) ;dual licensed
203
204 (define-public libabw
205 (package
206 (name "libabw")
207 (version "0.1.1")
208 (source
209 (origin
210 (method url-fetch)
211 (uri (string-append "http://dev-www.libreoffice.org/src/" name "/"
212 name "-" version ".tar.xz"))
213 (sha256 (base32
214 "0zi1zj4fpxgpglbbb5n1kg3dmhqq5rpf46lli89r5daavp19iing"))))
215 (build-system gnu-build-system)
216 (native-inputs
217 `(("doxygen" ,doxygen)
218 ("gperf" ,gperf)
219 ("perl" ,perl)
220 ("pkg-config" ,pkg-config)))
221 (inputs
222 `(("boost" ,boost)
223 ("librevenge" ,librevenge)
224 ("libxml2" ,libxml2)))
225 (arguments
226 ;; avoid triggering configure errors by simple inclusion of boost headers
227 `(#:configure-flags '("--disable-werror")))
228 (home-page "https://wiki.documentfoundation.org/DLP/Libraries/libabw")
229 (synopsis "Library for parsing the AbiWord format")
230 (description "Libabw is a library that parses the file format of
231 AbiWord documents.")
232 (license mpl2.0)))
233
234 (define-public libcdr
235 (package
236 (name "libcdr")
237 (version "0.1.1")
238 (source
239 (origin
240 (method url-fetch)
241 (uri (string-append "http://dev-www.libreoffice.org/src/" name "/"
242 name "-" version ".tar.xz"))
243 (sha256 (base32
244 "07yzb1yr5kzv0binzj5swz3zzay2gw3xb0fbkc2zwdssgrkf19nh"))))
245 (build-system gnu-build-system)
246 (native-inputs
247 `(("doxygen" ,doxygen)
248 ("pkg-config" ,pkg-config)))
249 (inputs
250 `(("boost" ,boost)
251 ("icu4c" ,icu4c)
252 ("lcms" ,lcms)
253 ("librevenge" ,librevenge)
254 ("zlib" ,zlib)))
255 (arguments
256 ;; avoid triggering a build failure due to warnings
257 `(#:configure-flags '("--disable-werror")))
258 (home-page "https://wiki.documentfoundation.org/DLP/Libraries/libcdr")
259 (synopsis "Library for parsing the CorelDRAW format")
260 (description "Libcdr is a library that parses the file format of
261 CorelDRAW documents of all versions.")
262 (license mpl2.0)))
263
264 (define-public libetonyek
265 (package
266 (name "libetonyek")
267 (version "0.1.1")
268 (source
269 (origin
270 (method url-fetch)
271 (uri (string-append "http://dev-www.libreoffice.org/src/" name "/"
272 name "-" version ".tar.xz"))
273 (sha256 (base32
274 "0gn8v24jb9r9kxppbws6xlc7knpd9mk2n9xjvziccv5f2l7mlslw"))))
275 (build-system gnu-build-system)
276 (native-inputs
277 `(("cppunit" ,cppunit)
278 ("doxygen" ,doxygen)
279 ("gperf" ,gperf)
280 ("pkg-config" ,pkg-config)))
281 (inputs
282 `(("boost" ,boost)
283 ("librevenge" ,librevenge)
284 ("libxml2" ,libxml2)))
285 (home-page "https://wiki.documentfoundation.org/DLP/Libraries/libetonyek")
286 (synopsis "Library for parsing the Apple Keynote format")
287 (description "Libetonyek is a library that parses the file format of
288 Apple Keynote documents. It currently supports Keynote versions 2 to 5.")
289 (license mpl2.0)))
290
291 (define-public libexttextcat
292 (package
293 (name "libexttextcat")
294 (version "3.4.4")
295 (source
296 (origin
297 (method url-fetch)
298 (uri (string-append "http://dev-www.libreoffice.org/src/" name "/"
299 name "-" version ".tar.xz"))
300 (sha256 (base32
301 "14v2hkygnmf1zgahfm1fha47cr67iikrz2ymiqi28d2jydn0hk7j"))))
302 (build-system gnu-build-system)
303 (home-page "http://www.freedesktop.org/wiki/Software/libexttextcat/")
304 (synopsis "Text Categorization library")
305 (description "Libexttextcat is an N-Gram-Based Text Categorization
306 library primarily intended for language guessing.")
307 (license (non-copyleft "file://LICENSE"
308 "See LICENSE in the distribution."))))
309
310 (define-public libfreehand
311 (package
312 (name "libfreehand")
313 (version "0.1.0")
314 (source
315 (origin
316 (method url-fetch)
317 (uri (string-append "http://dev-www.libreoffice.org/src/" name "/"
318 name "-" version ".tar.xz"))
319 (sha256 (base32
320 "01j7mxi4lmf72w1mv2r098p8l0csdd94w2gq0ncp93djn34al6ai"))))
321 (build-system gnu-build-system)
322 (native-inputs
323 `(("doxygen" ,doxygen)
324 ("gperf" ,gperf)
325 ("perl" ,perl)
326 ("pkg-config" ,pkg-config)))
327 (inputs
328 `(("librevenge" ,librevenge)
329 ("zlib" ,zlib)))
330 (home-page "https://wiki.documentfoundation.org/DLP/Libraries/libfreehand")
331 (synopsis "Library for parsing the FreeHand format")
332 (description "Libfreehand is a library that parses the file format of
333 Aldus/Macromedia/Adobe FreeHand documents.")
334 (license mpl2.0)))
335
336 (define-public libmspub
337 (package
338 (name "libmspub")
339 (version "0.1.2")
340 (source
341 (origin
342 (method url-fetch)
343 (uri (string-append "http://dev-www.libreoffice.org/src/" name "/"
344 name "-" version ".tar.xz"))
345 (sha256 (base32
346 "03sn6lxpr49sdq6j8q7fw7yjybyfahhs03z80388mh105pwapfmh"))))
347 (build-system gnu-build-system)
348 (native-inputs
349 `(("doxygen" ,doxygen)
350 ("pkg-config" ,pkg-config)))
351 (inputs
352 `(("boost" ,boost)
353 ("icu4c" ,icu4c)
354 ("librevenge" ,librevenge)
355 ("zlib" ,zlib)))
356 (home-page "https://wiki.documentfoundation.org/DLP/Libraries/libmspub")
357 (synopsis "Library for parsing the Microsoft Publisher format")
358 (description "Libmspub is a library that parses the file format of
359 Microsoft Publisher documents of all versions.")
360 (license mpl2.0)))
361
362 (define-public libpagemaker
363 (package
364 (name "libpagemaker")
365 (version "0.0.2")
366 (source
367 (origin
368 (method url-fetch)
369 (uri (string-append "http://dev-www.libreoffice.org/src/" name "/"
370 name "-" version ".tar.xz"))
371 (sha256 (base32
372 "05zgj5ngg9z4b7dnrfs59nm0macm99lzyxv4mg53jcvp0mkgigfd"))))
373 (build-system gnu-build-system)
374 (native-inputs
375 `(("doxygen" ,doxygen)
376 ("pkg-config" ,pkg-config)))
377 (inputs
378 `(("boost" ,boost)
379 ("librevenge" ,librevenge)
380 ("zlib" ,zlib)))
381 (arguments
382 ;; avoid triggering a build failure due to warnings
383 `(#:configure-flags '("--disable-werror")))
384 (home-page "https://wiki.documentfoundation.org/DLP/Libraries/libpagemaker")
385 (synopsis "Library for parsing the PageMaker format")
386 (description "Libpagemaker is a library that parses the file format of
387 Aldus/Adobe PageMaker documents. Currently it only understands documents
388 created by PageMaker version 6.x and 7.")
389 (license mpl2.0)))