gnu: Use synopses from the Womb.
[jackhill/guix/guix.git] / gnu / packages / ssh.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages ssh)
20 #:use-module ((guix licenses)
21 #:renamer (symbol-prefix-proc 'license:))
22 #:use-module (gnu packages compression)
23 #:use-module (gnu packages gnupg)
24 #:use-module (gnu packages groff)
25 #:use-module (gnu packages openssl)
26 #:use-module (guix packages)
27 #:use-module (guix download)
28 #:use-module (guix build-system gnu))
29
30 (define-public libssh2
31 (package
32 (name "libssh2")
33 (version "1.4.3")
34 (source (origin
35 (method url-fetch)
36 (uri (string-append
37 "http://www.libssh2.org/download/libssh2-"
38 version ".tar.gz"))
39 (sha256 (base32
40 "0vdr478dbhbdgnniqmirawjb7mrcxckn4slhhrijxnzrkmgziipa"))))
41 (build-system gnu-build-system)
42 (inputs `(("libgcrypt" ,libgcrypt)
43 ("zlib" ,zlib)))
44 (synopsis "libssh2, a client-side C library implementing the SSH2 protocol")
45 (description
46 "libssh2 is a library intended to allow software developers access to
47 the SSH-2 protocol in an easy-to-use self-contained package. It can be built
48 into an application to perform many different tasks when communicating with
49 a server that supports the SSH-2 protocol.")
50 (license license:bsd-3)
51 (home-page "http://www.libssh2.org/")))
52
53 (define-public openssh
54 (package
55 (name "openssh")
56 (version "6.1p1")
57 (source (origin
58 (method url-fetch)
59 (uri (string-append
60 "ftp://ftp.fr.openbsd.org/pub/OpenBSD/OpenSSH/portable/openssh-"
61 version ".tar.gz"))
62 (sha256 (base32
63 "04f4l4vx6f964v5qjm03nhyixdc3llc90z6cj70r0bl5q3v5ghfi"))))
64 (build-system gnu-build-system)
65 (inputs `(("groff" ,groff)
66 ("openssl" ,openssl)
67 ("zlib" ,zlib)))
68 (arguments
69 `(#:test-target "tests"
70 #:phases
71 (alist-replace
72 'configure
73 (lambda* (#:key outputs #:allow-other-keys #:rest args)
74 (let ((configure (assoc-ref %standard-phases 'configure))
75 (out (assoc-ref outputs "out")))
76 (apply configure args)
77 (substitute* "Makefile"
78 (("PRIVSEP_PATH=/var/empty")
79 (string-append "PRIVSEP_PATH=" out "/var/empty")))))
80 (alist-replace
81 'check
82 (lambda* (#:key #:allow-other-keys #:rest args)
83 (let ((check (assoc-ref %standard-phases 'check)))
84 ;; remove tests that require the user sshd
85 (substitute* "regress/Makefile"
86 (("t9 t-exec") "t9"))
87 (apply check args)))
88 (alist-replace
89 'install
90 (lambda* (#:key (make-flags '()) #:allow-other-keys)
91 ;; install without host keys and system configuration files
92 (zero? (apply system* "make" "install-nosysconf" make-flags)))
93 %standard-phases)))))
94 (synopsis "OpenSSH, a client and server for the secure shell (ssh) protocol")
95 (description
96 "The SSH2 protocol implemented in OpenSSH is standardised by the
97 IETF secsh working group and is specified in several RFCs and drafts.
98 It is composed of three layered components:
99
100 The transport layer provides algorithm negotiation and a key exchange.
101 The key exchange includes server authentication and results in a
102 cryptographically secured connection: it provides integrity, confidentiality
103 and optional compression.
104
105 The user authentication layer uses the established connection and relies on
106 the services provided by the transport layer. It provides several mechanisms
107 for user authentication. These include traditional password authentication
108 as well as public-key or host-based authentication mechanisms.
109
110 The connection layer multiplexes many different concurrent channels over the
111 authenticated connection and allows tunneling of login sessions and
112 TCP-forwarding. It provides a flow control service for these channels.
113 Additionally, various channel-specific options can be negotiated.")
114 (license (license:bsd-style "file://LICENSE"
115 "See LICENSE in the distribution."))
116 (home-page "http://www.openssh.org/")))
117