gnu: Use synopses from the Womb.
[jackhill/guix/guix.git] / gnu / packages / mailutils.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages mailutils)
20 #:use-module (gnu packages)
21 #:use-module (gnu packages linux)
22 #:use-module (gnu packages gnutls)
23 #:use-module (gnu packages gdbm)
24 #:use-module (gnu packages guile)
25 #:use-module (gnu packages ncurses)
26 #:use-module (gnu packages readline)
27 #:use-module (gnu packages dejagnu)
28 #:use-module (gnu packages m4)
29 #:use-module (gnu packages texinfo)
30 #:use-module (gnu packages mysql)
31 #:use-module (gnu packages autotools)
32 #:use-module (guix licenses)
33 #:use-module (guix packages)
34 #:use-module (guix download)
35 #:use-module (guix build-system gnu))
36
37 (define-public mailutils
38 (package
39 (name "mailutils")
40 (version "2.2")
41 (source (origin
42 (method url-fetch)
43 (uri (string-append "mirror://gnu/mailutils/mailutils-"
44 version ".tar.bz2"))
45 (sha256
46 (base32
47 "0szbqa12zqzldqyw97lxqax3ja2adis83i7brdfsxmrfw68iaf65"))))
48 (build-system gnu-build-system)
49 (arguments
50 '(;; TODO: Add `--with-sql'.
51 #:patches (list (assoc-ref %build-inputs
52 "patch/gets-undeclared"))
53 #:phases (alist-cons-before
54 'build 'pre-build
55 (lambda _
56 ;; Use Guile 2.0's public API.
57 (substitute* "libmu_scm/mu_message.c"
58 (("scm_i_string_length")
59 "scm_c_string_length"))
60
61 ;; This file should be generated to use the right
62 ;; value of $(libdir) et al.
63 (delete-file "libmu_scm/mailutils.scm")
64
65 ;; Use the right file name for `cat'.
66 (substitute* "testsuite/lib/mailutils.exp"
67 (("/bin/cat")
68 (which "cat"))))
69 %standard-phases)
70 #:parallel-tests? #f))
71 (inputs
72 `(("dejagnu" ,dejagnu)
73 ("m4" ,m4)
74 ("texinfo" ,texinfo)
75 ("guile" ,guile-2.0)
76 ("gnutls" ,gnutls)
77 ("ncurses" ,ncurses)
78 ("readline" ,readline)
79 ("linux-pam" ,linux-pam)
80 ("libtool" ,libtool)
81 ("gdbm" ,gdbm)
82 ("patch/gets-undeclared"
83 ,(search-patch "m4-gets-undeclared.patch"))))
84 (home-page "http://www.gnu.org/software/mailutils/")
85 (synopsis "Utilities and library for reading and serving mail")
86 (description
87 "GNU Mailutils is a rich and powerful protocol-independent mail
88 framework. It contains a series of useful mail libraries, clients, and
89 servers. These are the primary mail utilities for the GNU system. The
90 central library is capable of handling electronic mail in various
91 mailbox formats and protocols, both local and remote. Specifically,
92 this project contains a POP3 server, an IMAP4 server, and a Sieve mail
93 filter. It also provides a POSIX `mailx' client, and a collection of
94 other handy tools.
95
96 The GNU Mailutils libraries supply an ample set of primitives for
97 handling electronic mail in programs written in C, C++, Python or
98 Scheme.
99
100 The utilities provided by Mailutils include imap4d and pop3d mail
101 servers, mail reporting utility comsatd, general-purpose mail delivery
102 agent maidag, mail filtering program sieve, and an implementation of MH
103 message handling system.")
104 (license
105 ;; Libraries are under LGPLv3+, and programs under GPLv3+.
106 (list gpl3+ lgpl3+))))