gnu: Use synopses from the Womb.
[jackhill/guix/guix.git] / gnu / packages / less.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages less)
20 #:use-module (guix licenses)
21 #:use-module (gnu packages ncurses)
22 #:use-module (guix packages)
23 #:use-module (guix download)
24 #:use-module (guix build-system gnu))
25
26 (define-public less
27 (package
28 (name "less")
29 (version "451")
30 (source
31 (origin
32 (method url-fetch)
33 (uri (string-append "mirror://gnu/less/less-"
34 version ".tar.gz"))
35 (sha256
36 (base32
37 "0mszdd9m1dsbg59pav62swg9f87xmjpfspcw2jsazzksciy2is4z"))))
38 (build-system gnu-build-system)
39 (inputs `(("ncurses" ,ncurses)))
40 (home-page "https://www.gnu.org/software/less/")
41 (synopsis "Paginator for terminals")
42 (description
43 "GNU less is a program similar to more, but which allows backward
44 movement in the file as well as forward movement. Also, less does not
45 have to read the entire input file before starting, so with large input
46 files it starts up faster than text editors like vi. Less uses
47 termcap (or terminfo on some systems), so it can run on a variety of
48 terminals. There is even limited support for hardcopy terminals.")
49 (license gpl3+))) ; some files are under GPLv2+