gnu: Use synopses from the Womb.
[jackhill/guix/guix.git] / gnu / packages / groff.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages groff)
20 #:use-module (guix licenses)
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (guix build-system gnu)
24 #:use-module (gnu packages)
25 #:use-module (gnu packages bison)
26 #:use-module (gnu packages ghostscript)
27 #:use-module (gnu packages netpbm)
28 #:use-module (gnu packages perl)
29 #:use-module (gnu packages texinfo))
30
31 (define-public groff
32 (package
33 (name "groff")
34 (version "1.22.1")
35 (source (origin
36 (method url-fetch)
37 (uri (string-append "mirror://gnu/groff/groff-" version
38 ".tar.gz"))
39 (sha256 (base32
40 "1kihja9sj182pqms8lah2nn3y96rqccws7w04f7f7wpy84vs5bvn"))))
41 (build-system gnu-build-system)
42 (inputs `(("bison" ,bison)
43 ("ghostscript" ,ghostscript)
44 ("netpbm" ,netpbm)
45 ("perl" ,perl)
46 ("psutils" ,psutils)
47 ("texinfo" ,texinfo)))
48 (synopsis "Typesetting from plain text mixed with formatting commands")
49 (description
50 "GNU Troff (Groff) is a software typesetting package which reads plain
51 text mixed with formatting commands and produces formatted output.")
52 (license gpl3+)
53 (home-page "http://www.gnu.org/software/groff/")))