gnu: Use synopses from the Womb.
[jackhill/guix/guix.git] / gnu / packages / gdb.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages gdb)
20 #:use-module (gnu packages ncurses)
21 #:use-module (gnu packages readline)
22 #:use-module (gnu packages dejagnu)
23 #:use-module (gnu packages texinfo)
24 #:use-module (gnu packages multiprecision)
25 #:use-module (gnu packages xml)
26 #:use-module (gnu packages python)
27 #:use-module ((guix licenses) #:select (gpl3+))
28 #:use-module (guix packages)
29 #:use-module (guix download)
30 #:use-module (guix build-system gnu))
31
32 (define-public gdb
33 (package
34 (name "gdb")
35 (version "7.5.1")
36 (source (origin
37 (method url-fetch)
38 (uri (string-append "mirror://gnu/gdb/gdb-"
39 version ".tar.bz2"))
40 (sha256
41 (base32
42 "084xs90545an51biyy4qd53hsw6p1k6arviq2wlz1a4z526q02q7"))))
43 (build-system gnu-build-system)
44 (arguments
45 '(#:phases (alist-cons-after
46 'configure 'post-configure
47 (lambda _
48 (patch-makefile-SHELL "gdb/gdbserver/Makefile.in"))
49 %standard-phases)))
50 (inputs
51 `(("expat" ,expat)
52 ("mpfr" ,mpfr)
53 ("gmp" ,gmp)
54 ("readline" ,readline)
55 ("ncurses" ,ncurses)
56 ("python" ,python)
57 ("texinfo" ,texinfo)
58 ("dejagnu" ,dejagnu)))
59 (home-page "http://www.gnu.org/software/gdb/")
60 (synopsis "The GNU debugger")
61 (description
62 "GDB, the GNU Project debugger, allows you to see what is going
63 on `inside' another program while it executes -- or what another
64 program was doing at the moment it crashed.")
65 (license gpl3+)))