gnu: Use synopses from the Womb.
[jackhill/guix/guix.git] / gnu / packages / emacs.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages emacs)
20 #:use-module (guix licenses)
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (guix build-system gnu)
24 #:use-module (gnu packages)
25 #:use-module (gnu packages ncurses)
26 #:use-module (gnu packages texinfo)
27 #:use-module (gnu packages gnutls)
28 #:use-module (gnu packages pkg-config)
29 #:use-module (gnu packages guile))
30
31 (define-public emacs
32 (package
33 (name "emacs")
34 (version "24.3")
35 (source (origin
36 (method url-fetch)
37 (uri (string-append "mirror://gnu/emacs/emacs-"
38 version ".tar.xz"))
39 (sha256
40 (base32
41 "1385qzs3bsa52s5rcncbrkxlydkw0ajzrvfxgv8rws5fx512kakh"))))
42 (build-system gnu-build-system)
43 (arguments
44 '(#:configure-flags
45 (list (string-append "--with-crt-dir=" (assoc-ref %build-inputs "libc")
46 "/lib"))
47 #:patches (list (assoc-ref %build-inputs "patch/epaths"))
48 #:phases (alist-cons-before
49 'configure 'fix-/bin/pwd
50 (lambda _
51 ;; Use `pwd', not `/bin/pwd'.
52 (substitute* (find-files "." "^Makefile\\.in$")
53 (("/bin/pwd")
54 "pwd")))
55 %standard-phases)))
56 (inputs
57 `(("pkg-config" ,pkg-config)
58 ("gnutls" ,gnutls)
59 ("texinfo" ,texinfo)
60 ("ncurses" ,ncurses)
61
62 ;; TODO: Add the optional dependencies.
63 ;; ("xlibs" ,xlibs)
64 ;; ("gtk+" ,gtk+)
65 ;; ("libXft" ,libXft)
66 ;; ("libtiff" ,libtiff)
67 ;; ("libungif" ,libungif)
68 ;; ("libjpeg" ,libjpeg)
69 ;; ("libpng" ,libpng)
70 ;; ("libXpm" ,libXpm)
71 ;; ("libxml2" ,libxml2)
72 ;; ("dbus-library" ,dbus-library)
73
74 ("patch/epaths" ,(search-patch "emacs-configure-sh.patch"))
75 ))
76 (home-page "http://www.gnu.org/software/emacs/")
77 (synopsis "The extensible, customizable, self-documenting text editor")
78 (description
79 "GNU Emacs is an extensible, customizable text editor—and more. At its
80 core is an interpreter for Emacs Lisp, a dialect of the Lisp
81 programming language with extensions to support text editing.
82
83 The features of GNU Emacs include: content-sensitive editing modes,
84 including syntax coloring, for a wide variety of file types including
85 plain text, source code, and HTML; complete built-in documentation,
86 including a tutorial for new users; full Unicode support for nearly all
87 human languages and their scripts; highly customizable, using Emacs
88 Lisp code or a graphical interface; a large number of extensions that
89 add other functionality, including a project planner, mail and news
90 reader, debugger interface, calendar, and more. Many of these
91 extensions are distributed with GNU Emacs; others are available
92 separately.")
93 (license gpl3+)))
94
95 \f
96 ;;;
97 ;;; Emacs hacking.
98 ;;;
99
100 (define-public geiser
101 (package
102 (name "geiser")
103 (version "0.3")
104 (source (origin
105 (method url-fetch)
106 (uri (string-append "mirror://savannah/geiser/0.3/geiser-"
107 version ".tar.gz"))
108 (sha256
109 (base32 "1yzx0k1y5dq0m9dr3zdrxd8li0pddzblzj1ngd0spvsvvzz6v13j"))))
110 (build-system gnu-build-system)
111 (inputs `(("guile" ,guile-2.0)
112 ("emacs" ,emacs)))
113 (home-page "http://nongnu.org/geiser/")
114 (synopsis "Collection of Emacs modes for Guile and Racket hacking")
115 (description
116 "Geiser is a collection of Emacs major and minor modes that
117 conspire with one or more Scheme interpreters to keep the Lisp Machine
118 Spirit alive. It draws inspiration (and a bit more) from environments
119 such as Common Lisp’s Slime, Factor’s FUEL, Squeak or Emacs itself, and
120 does its best to make Scheme hacking inside Emacs (even more) fun.
121
122 Or, to be precise, what i consider fun. Geiser is thus my humble
123 contribution to the dynamic school of expression, and a reaction against
124 what i perceive as a derailment, in modern times, of standard Scheme
125 towards the static camp. Because i prefer growing and healing to poking
126 at corpses, the continuously running Scheme interpreter takes the center
127 of the stage in Geiser. A bundle of Elisp shims orchestrates the dialog
128 between the Scheme interpreter, Emacs and, ultimately, the schemer,
129 giving her access to live metadata.")
130 (license bsd-3)))