gnu: Use synopses from the Womb.
[jackhill/guix/guix.git] / gnu / packages / aspell.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages aspell)
20 #:use-module (guix packages)
21 #:use-module (guix download)
22 #:use-module (guix build-system gnu)
23 #:use-module (guix licenses)
24 #:use-module (gnu packages perl))
25
26 (define-public aspell
27 (package
28 (name "aspell")
29 (version "0.60.6.1")
30 (source
31 (origin
32 (method url-fetch)
33 (uri (string-append "mirror://gnu/aspell/aspell-"
34 version ".tar.gz"))
35 (sha256
36 (base32
37 "1qgn5psfyhbrnap275xjfrzppf5a83fb67gpql0kfqv37al869gm"))))
38 (build-system gnu-build-system)
39 (inputs `(("perl" ,perl)))
40 (home-page "http://aspell.net/")
41 (synopsis "Spell checker")
42 (description
43 "GNU Aspell is a free spell checker designed to eventually replace
44 Ispell. It can either be used as a library or as an independent spell
45 checker. Its main feature is that it does a superior job of suggesting
46 possible replacements for a misspelled word than just about any other
47 spell checker out there for the English language. Unlike Ispell, Aspell
48 can also easily check documents in UTF-8 without having to use a special
49 dictionary. Aspell will also do its best to respect the current locale
50 setting. Other advantages over Ispell include support for using
51 multiple dictionaries at once and intelligently handling personal
52 dictionaries when more than one Aspell process is open at once.")
53 (license lgpl2.1+)))