Merge branch 'master' into core-updates
[jackhill/guix/guix.git] / gnu / packages / xiph.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013, 2014 Andreas Enge <andreas@enge.fr>
3 ;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
4 ;;; Copyright © 2013 David Thompson <dthompson2@worcester.edu>
5 ;;; Copyright © 2014 Sree Harsha Totakura <sreeharsha@totakura.in>
6 ;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
7 ;;; Copyright © 2015 Paul van der Walt <paul@denknerd.org>
8 ;;; Copyright © 2015, 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
9 ;;; Copyright © 2017, 2018 Marius Bakke <mbakke@fastmail.com>
10 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
11 ;;; Copyright © 2018 Leo Famulari <leo@famulari.name>
12 ;;;
13 ;;; This file is part of GNU Guix.
14 ;;;
15 ;;; GNU Guix is free software; you can redistribute it and/or modify it
16 ;;; under the terms of the GNU General Public License as published by
17 ;;; the Free Software Foundation; either version 3 of the License, or (at
18 ;;; your option) any later version.
19 ;;;
20 ;;; GNU Guix is distributed in the hope that it will be useful, but
21 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
22 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
23 ;;; GNU General Public License for more details.
24 ;;;
25 ;;; You should have received a copy of the GNU General Public License
26 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
27
28 (define-module (gnu packages xiph)
29 #:use-module (gnu packages)
30 #:use-module (gnu packages bison)
31 #:use-module (gnu packages compression)
32 #:use-module (gnu packages curl)
33 #:use-module (gnu packages documentation)
34 #:use-module (gnu packages image)
35 #:use-module (gnu packages pkg-config)
36 #:use-module (gnu packages python)
37 #:use-module (gnu packages linux)
38 #:use-module (gnu packages pulseaudio)
39 #:use-module (gnu packages tls)
40 #:use-module (gnu packages xml)
41 #:use-module ((guix licenses) #:prefix license:)
42 #:use-module (guix packages)
43 #:use-module (guix download)
44 #:use-module (guix build-system gnu)
45 #:export (libogg
46 libvorbis
47 libtheora
48 speex
49 speexdsp
50 ao
51 flac
52 libkate
53 vorbis-tools
54 opus
55 opusfile
56 opus-tools))
57
58 (define libogg
59 (package
60 (name "libogg")
61 (version "1.3.3")
62 (source (origin
63 (method url-fetch)
64 (uri (string-append "https://downloads.xiph.org/releases/ogg/libogg-"
65 version ".tar.xz"))
66 (sha256
67 (base32
68 "022wjlzn8fx7mfby4pcgyjwx8zir7jr7cizichh3jgaki8bwcgsg"))))
69 (build-system gnu-build-system)
70 (synopsis "Library for manipulating the ogg multimedia format")
71 (description
72 "The libogg library allows to manipulate the ogg multimedia container
73 format, which encapsulates raw compressed data and allows the interleaving of
74 audio and video data. In addition to encapsulation and interleaving of
75 multiple data streams, ogg provides packet framing, error detection, and
76 periodic timestamps for seeking.")
77 (license (license:non-copyleft "file://COPYING"
78 "See COPYING in the distribution."))
79 (home-page "https://xiph.org/ogg/")))
80
81 (define libvorbis
82 (package
83 (name "libvorbis")
84 (version "1.3.6")
85 (source (origin
86 (method url-fetch)
87 (uri (string-append "https://downloads.xiph.org/releases/vorbis/"
88 "libvorbis-" version ".tar.xz"))
89 (sha256
90 (base32
91 "05dlzjkdpv46zb837wysxqyn8l636x3dw8v8ymlrwz2fg1dbn05g"))))
92 (build-system gnu-build-system)
93 (propagated-inputs `(("libogg" ,libogg)))
94 (arguments `(#:configure-flags '("LDFLAGS=-lm")
95 #:parallel-tests? #f))
96 (synopsis "Library implementing the vorbis audio format")
97 (description
98 "The libvorbis library implements the ogg vorbis audio format,
99 a fully open, non-proprietary, patent-and-royalty-free, general-purpose
100 compressed audio format for mid to high quality (8kHz-48.0kHz, 16+ bit,
101 polyphonic) audio and music at fixed and variable bitrates from 16 to
102 128 kbps/channel.")
103 (license (license:non-copyleft "file://COPYING"
104 "See COPYING in the distribution."))
105 (home-page "https://xiph.org/vorbis/")))
106
107 (define libtheora
108 (package
109 (name "libtheora")
110 (version "1.1.1")
111 (source (origin
112 (method url-fetch)
113 (uri (string-append "https://downloads.xiph.org/releases/theora/"
114 "libtheora-" version ".tar.xz"))
115 (sha256
116 (base32
117 "0q8wark9ribij57dciym5vdikg2464p8q2mgqvfb78ksjh4s8vgk"))
118 (patches (search-patches "libtheora-config-guess.patch"))))
119 (build-system gnu-build-system)
120 (inputs `(("libvorbis" ,libvorbis)))
121 ;; The .pc files refer to libogg.
122 (propagated-inputs `(("libogg" ,libogg)))
123 (synopsis "Library implementing the Theora video format")
124 (description
125 "The libtheora library implements the ogg theora video format,
126 a fully open, non-proprietary, patent-and-royalty-free, general-purpose
127 compressed video format.")
128 (license license:bsd-3)
129 (home-page "https://xiph.org/theora/")))
130
131 (define speex
132 (package
133 (name "speex")
134 (version "1.2.0")
135 (source
136 (origin
137 (method url-fetch)
138 (uri (string-append "https://downloads.xiph.org/releases/speex/speex-"
139 version ".tar.gz"))
140 (sha256
141 (base32
142 "150047wnllz4r94whb9r73l5qf0z5z3rlhy98bawfbblmkq8mbpa"))))
143 (build-system gnu-build-system)
144 (native-inputs
145 `(("pkg-config" ,pkg-config)))
146 (inputs
147 `(("libogg" ,libogg)
148 ("speexdsp" ,speexdsp)))
149 (home-page "https://gnu.org/software/speex")
150 (synopsis "Library for patent-free audio compression format")
151 (description
152 "GNU Speex is a patent-free audio compression codec specially designed
153 for speech. It is well-adapted to internet applications, such as VoIP. It
154 features compression of different bands in the same bitstream, intensity
155 stereo encoding, and voice activity detection.")
156 ;; 'src/getopt.c' is under LGPLv2+
157 (license (license:non-copyleft "file://COPYING"
158 "See COPYING in the distribution."))))
159
160 (define speexdsp
161 (package
162 (name "speexdsp")
163 (version "1.2rc3")
164 (source (origin
165 (method url-fetch)
166 (uri (string-append "https://downloads.xiph.org/releases/speex/"
167 "speexdsp-" version ".tar.gz"))
168 (sha256
169 (base32
170 "1wcjyrnwlkayb20zdhp48y260rfyzg925qpjpljd5x9r01h8irja"))))
171 (build-system gnu-build-system)
172 (arguments
173 `(#:configure-flags '(,@(if (string=? "aarch64-linux"
174 (%current-system))
175 '("--enable-neon=no") ; neon defaults to armv7-a
176 '()))))
177 (home-page "https://speex.org/")
178 (synopsis "Speex processing library")
179 (description
180 "SpeexDSP is a @dfn{DSP} (Digital Signal Processing) library based on
181 work from the @code{speex} codec.")
182 (license (license:non-copyleft "file://COPYING"
183 "See COPYING in the distribution."))))
184
185 (define ao
186 (package
187 (name "ao")
188 (version "1.2.0")
189 (source
190 (origin
191 (method url-fetch)
192 (uri (string-append "https://downloads.xiph.org/releases/ao/libao-"
193 version ".tar.gz"))
194 (sha256
195 (base32
196 "1bwwv1g9lchaq6qmhvj1pp3hnyqr64ydd4j38x94pmprs4d27b83"))))
197 (build-system gnu-build-system)
198 ;; FIXME: Add further backends, see the summary printed after configure.
199 ;; XXX: Should back-ends be pushed to different outputs? For instance,
200 ;; "out" would include only the ALSA back-end, while "pulse" would
201 ;; contain 'lib/ao/plugins-4/libpulse.*'.
202 (inputs
203 `(("alsa-lib" ,alsa-lib)
204 ("pulseaudio" ,pulseaudio)))
205 (native-inputs
206 `(("pkg-config" ,pkg-config)))
207 (synopsis "Cross platform audio library")
208 (description
209 "Libao is a cross-platform audio library that allows programs to
210 output audio using a simple API on a wide variety of platforms.
211 It currently supports:
212 @enumerate
213 @item Null output (handy for testing without a sound device),
214 @item WAV files,
215 @item AU files,
216 @item RAW files,
217 @item OSS (Open Sound System, used on Linux and FreeBSD),
218 @item ALSA (Advanced Linux Sound Architecture),
219 @item aRts (Analog RealTime Synth, used by KDE),
220 @item PulseAudio (next generation GNOME sound server),
221 @item esd (EsounD or Enlightened Sound Daemon),
222 @item Mac OS X,
223 @item Windows (98 and later),
224 @item AIX,
225 @item Sun/NetBSD/OpenBSD,
226 @item IRIX,
227 @item NAS (Network Audio Server),
228 @item RoarAudio (Modern, multi-OS, networked Sound System),
229 @item OpenBSD's sndio.
230 @end enumerate
231 ")
232 (license license:gpl2+)
233 (home-page "https://www.xiph.org/ao/")))
234
235 (define flac
236 (package
237 (name "flac")
238 (version "1.3.2")
239 (source (origin
240 (method url-fetch)
241 (uri (string-append "https://downloads.xiph.org/releases/flac/flac-"
242 version ".tar.xz"))
243 (sha256
244 (base32
245 "0gymm2j3276kr9nz6vmgfwsdfrq6c449n40a0mzz8h6wc7nw7kwi"))))
246 (build-system gnu-build-system)
247 (arguments
248 `(#:parallel-tests? #f))
249 ;; FIXME: configure also looks for xmms, input could be added once it exists
250 (propagated-inputs `(("libogg" ,libogg))) ; required by flac.pc
251 (synopsis "Free lossless audio codec")
252 (description
253 "FLAC stands for Free Lossless Audio Codec, an audio format that is lossless,
254 meaning that audio is compressed in FLAC without any loss in quality.")
255 (license (license:non-copyleft "file://COPYING"
256 "See COPYING in the distribution.")) ; and LGPL and GPL
257 (home-page "https://xiph.org/flac/")))
258
259 (define libkate
260 (package
261 (name "libkate")
262 (version "0.4.1")
263 (source (origin
264 (method url-fetch)
265 (uri (string-append "https://downloads.xiph.org/releases/kate/"
266 "libkate-" version ".tar.gz"))
267 (sha256
268 (base32
269 "0s3vr2nxfxlf1k75iqpp4l78yf4gil3f0v778kvlngbchvaq23n4"))))
270 (build-system gnu-build-system)
271 (native-inputs `(("doxygen" ,doxygen)
272 ("pkg-config" ,pkg-config)))
273 ;; FIXME: Add optional input liboggz
274 (inputs `(("bison" ,bison)
275 ("libogg" ,libogg)
276 ("libpng" ,libpng)
277 ("python" ,python-wrapper)
278 ("zlib" ,zlib)))
279 (synopsis "Karaoke and text codec for embedding in ogg")
280 (description
281 "Kate is an overlay codec, originally designed for karaoke and text,
282 that can be multiplixed in Ogg. Text and images can be carried by a Kate
283 stream, and animated. Most of the time, this would be multiplexed with
284 audio/video to carry subtitles, song lyrics (with or without karaoke data),
285 etc., but doesn't have to be.
286
287 Series of curves (splines, segments, etc.) may be attached to various
288 properties (text position, font size, etc.) to create animated overlays.
289 This allows scrolling or fading text to be defined. This can even be used
290 to draw arbitrary shapes, so hand drawing can also be represented by a
291 Kate stream.")
292 (license license:bsd-3)
293 (home-page "https://wiki.xiph.org/OggKate")))
294
295 (define vorbis-tools
296 (package
297 (name "vorbis-tools")
298 (version "1.4.0")
299 (source (origin
300 (method url-fetch)
301 (uri (string-append "https://downloads.xiph.org/releases/vorbis/"
302 "vorbis-tools-" version ".tar.gz"))
303 (sha256
304 (base32
305 "1g12bnh5ah08v529y72kfdz5lhvy75iaz7f9jskyby23m9dkk2d3"))
306 (patches (search-patches
307 "vorbis-tools-CVE-2014-9638+CVE-2014-9639.patch"
308 "vorbis-tools-CVE-2014-9640.patch"
309 "vorbis-tools-CVE-2015-6749.patch"))))
310 (build-system gnu-build-system)
311 (inputs `(("ao" ,ao)
312 ("curl" ,curl)
313 ("flac" ,flac)
314 ("libkate" ,libkate)
315 ("libogg" ,libogg)
316 ("libvorbis" ,libvorbis)
317 ("speex" ,speex)))
318 (native-inputs `(("pkg-config" ,pkg-config)))
319 (synopsis "Ogg vorbis tools")
320 (description
321 "Ogg vorbis is a non-proprietary, patent-and-royalty-free,
322 general-purpose compressed audio format.
323
324 The package vorbis-tools contains
325 ogg123, an ogg vorbis command line audio player;
326 oggenc, the ogg vorbis encoder;
327 oggdec, a simple, portable command line decoder (to wav and raw);
328 ogginfo, to obtain information (tags, bitrate, length, etc.) about
329 an ogg vorbis file.")
330 (license license:gpl2)
331 (home-page "https://xiph.org/vorbis/")))
332
333 (define opus
334 (package
335 (name "opus")
336 (version "1.3")
337 (source (origin
338 (method url-fetch)
339 (uri (string-append "https://archive.mozilla.org/pub/opus/opus-"
340 version ".tar.gz"))
341 (sha256
342 (base32
343 "0l651n19h0vhc0sn6w2c95hgqks1i8m4b3j04ncaznzjznp6jgag"))))
344 (build-system gnu-build-system)
345 (synopsis "Versatile audio codec")
346 (description
347 "Opus is a totally open, royalty-free, highly versatile audio codec. Opus
348 is unmatched for interactive speech and music transmission over the Internet,
349 but is also intended for storage and streaming applications. It is
350 standardized by the Internet Engineering Task Force (IETF) as RFC 6716 which
351 incorporated technology from Skype's SILK codec and Xiph.Org's CELT codec.")
352 (license license:bsd-3)
353 (home-page "https://www.opus-codec.org")))
354
355 (define opus-tools
356 (package
357 (name "opus-tools")
358 (version "0.2")
359 (source (origin
360 (method url-fetch)
361 (uri (string-append
362 "https://downloads.xiph.org/releases/opus/opus-tools-"
363 version ".tar.gz"))
364 (sha256
365 (base32
366 "11pzl27s4vcz4m18ch72nivbhww2zmzn56wspb7rll1y1nq6rrdl"))))
367 (build-system gnu-build-system)
368 (arguments
369 ;; The package developers misuse pkg-config such that it doesn't work
370 ;; when cross compiling. Therefore we avoid it completly and set the
371 ;; necessary flags ourselves.
372 `(#:configure-flags (list (string-append "CFLAGS=-I"
373 (assoc-ref %build-inputs "libogg")
374 "/include -I"
375 (assoc-ref %build-inputs "opus")
376 "/include/opus"))))
377 (native-inputs
378 `(("pkg-config" ,pkg-config)))
379 (inputs
380 `(("libopusenc" ,libopusenc)
381 ("opusfile" ,opusfile)
382 ("flac" ,flac)))
383 (synopsis
384 "Command line utilities to encode, inspect, and decode .opus files")
385 (description "Opus is a royalty-free, highly versatile audio codec.
386 Opus-tools provide command line utilities for creating, inspecting and
387 decoding .opus files.")
388 (license license:bsd-3)
389 (home-page "https://www.opus-codec.org")))
390
391 (define opusfile
392 (package
393 (name "opusfile")
394 (version "0.11")
395 (source (origin
396 (method url-fetch)
397 (uri (string-append
398 "https://downloads.xiph.org/releases/opus/opusfile-" version
399 ".tar.gz"))
400 (sha256
401 (base32
402 "1gq3aszzl5glgbajw5p1f5a1kdyf23w5vjdmwwrk246syin9pkkl"))))
403 (build-system gnu-build-system)
404 ;; Required by opusfile.pc and opusurl.pc.
405 (propagated-inputs
406 `(("libogg" ,libogg)
407 ("openssl" ,openssl)
408 ("opus" ,opus)))
409 (native-inputs
410 `(("pkg-config" ,pkg-config)))
411 (synopsis "Versatile audio codec")
412 (description
413 "The opusfile library provides seeking, decode, and playback of Opus
414 streams in the Ogg container (.opus files) including over http(s) on posix and
415 windows systems.")
416 (license license:bsd-3)
417 (home-page "https://www.opus-codec.org")))
418
419 (define-public libopusenc
420 (package
421 (name "libopusenc")
422 (version "0.2.1")
423 (source (origin
424 (method url-fetch)
425 (uri (string-append "https://archive.mozilla.org/pub/opus/"
426 "libopusenc-" version ".tar.gz"))
427 (sha256
428 (base32
429 "1ffb0vhlymlsq70pxsjj0ksz77yfm2x0a1x8q50kxmnkm1hxp642"))))
430 (build-system gnu-build-system)
431 (native-inputs
432 `(("pkg-config" ,pkg-config)))
433 (propagated-inputs
434 `(("opus" ,opus)))
435 (synopsis "Library for encoding Opus audio files and streams ")
436 (description "The libopusenc libraries provide a high-level API for
437 encoding Opus files and streams.")
438 (home-page "https://www.opus-codec.org/")
439 (license license:bsd-3)))
440
441 (define-public icecast
442 (package
443 (name "icecast")
444 (version "2.4.4")
445 (source (origin
446 (method url-fetch)
447 (uri (string-append
448 "https://downloads.xiph.org/releases/icecast/icecast-"
449 version ".tar.gz"))
450 (sha256
451 (base32
452 "0i2d9rhav0x6js2qhjf5iy6j2a7f0d11ail0lfv40hb1kygrgda9"))))
453 (build-system gnu-build-system)
454 (native-inputs
455 `(("pkg-config" ,pkg-config)))
456 (inputs
457 `(("libxslt" ,libxslt)
458 ("libxml2" ,libxml2)
459 ("openssl" ,openssl)
460 ("curl" ,curl)
461 ("libogg" ,libogg)
462 ("libvorbis" ,libvorbis)
463 ("libtheora" ,libtheora)
464 ("speex" ,speex)))
465 (synopsis "Streaming media server")
466 (description "Icecast is a streaming media server which currently supports
467 Ogg (Vorbis and Theora), Opus, WebM and MP3 audio streams. It can be used to
468 create an Internet radio station or a privately running jukebox and many
469 things in between.")
470 (home-page "https://icecast.org/")
471 (license license:gpl2)))
472
473 (define-public libshout
474 (package
475 (name "libshout")
476 (version "2.4.1")
477 (source (origin
478 (method url-fetch)
479 (uri (string-append
480 "https://downloads.xiph.org/releases/libshout/"
481 name "-" version ".tar.gz"))
482 (sha256
483 (base32
484 "0kgjpf8jkgyclw11nilxi8vyjk4s8878x23qyxnvybbgqbgbib7k"))))
485 (build-system gnu-build-system)
486 (native-inputs
487 `(("pkg-config" ,pkg-config)))
488 (propagated-inputs
489 ;; shout.pc refers to all these.
490 `(("libtheora" ,libtheora)
491 ("libvorbis" ,libvorbis)
492 ("speex" ,speex)))
493 (home-page "https://icecast.org/")
494 (synopsis "Audio streaming library for icecast encoders")
495 (description
496 "Libshout is a library for communicating with and sending data to an
497 icecast server. It handles the socket connection, the timing of the data,
498 and prevents bad data from getting to the icecast server.")
499 (license license:gpl2+)))