gnu: Add GNU APL.
[jackhill/guix/guix.git] / gnu / packages / apl.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages apl)
20 #:use-module (guix licenses)
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (guix build-system gnu)
24 #:use-module ((gnu packages gettext)
25 #:renamer (symbol-prefix-proc 'guix:))
26 #:use-module (gnu packages maths)
27 #:use-module (gnu packages readline))
28
29 (define-public apl
30 (package
31 (name "apl")
32 (version "1.1")
33 (source
34 (origin
35 (method url-fetch)
36 (uri (string-append "mirror://gnu/apl/apl-" version ".tar.gz"))
37 (sha256
38 (base32
39 "1myinxa0m3y4fanpxflfakfk3m1s8641wdlbwbs0vg5yp10xm0m3"))))
40 (build-system gnu-build-system)
41 (home-page "http://www.gnu.org/software/apl/")
42 (inputs
43 `(("gettext" ,guix:gettext)
44 ("lapack" ,lapack)
45 ("readline" ,readline)))
46 (synopsis "APL interpreter")
47 (description
48 "GNU APL is a free interpreter for the programming language APL. It is
49 an implementation of the ISO standard 13751.")
50 (license gpl3+)))