Merge branch 'master' into staging
[jackhill/guix/guix.git] / gnu / packages / finance.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015, 2016 Andreas Enge <andreas@enge.fr>
3 ;;; Copyright © 2016, 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
4 ;;; Copyright © 2016 Alex Griffin <a@ajgrf.com>
5 ;;; Copyright © 2016 Hartmut Goebel <h.goebel@crazy-compilers.com>
6 ;;; Copyright © 2017 Carlo Zancanaro <carlo@zancanaro.id.au>
7 ;;; Copyright © 2017 Theodoros Foradis <theodoros@foradis.org>
8 ;;; Copyright © 2017 Vasile Dumitrascu <va511e@yahoo.com>
9 ;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
10 ;;; Copyright © 2018 Eric Bavier <bavier@member.fsf.org>
11 ;;; Copyright © 2018 Adriano Peluso <catonano@gmail.com>
12 ;;; Copyright © 2018 Nicolas Goaziou <mail@nicolasgoaziou.fr>
13 ;;; Copyright © 2018 Arun Isaac <arunisaac@systemreboot.net>
14 ;;;
15 ;;; This file is part of GNU Guix.
16 ;;;
17 ;;; GNU Guix is free software; you can redistribute it and/or modify it
18 ;;; under the terms of the GNU General Public License as published by
19 ;;; the Free Software Foundation; either version 3 of the License, or (at
20 ;;; your option) any later version.
21 ;;;
22 ;;; GNU Guix is distributed in the hope that it will be useful, but
23 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
24 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
25 ;;; GNU General Public License for more details.
26 ;;;
27 ;;; You should have received a copy of the GNU General Public License
28 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
29
30 (define-module (gnu packages finance)
31 #:use-module ((guix licenses) #:prefix license:)
32 #:use-module (guix packages)
33 #:use-module (guix download)
34 #:use-module (guix git-download)
35 #:use-module (guix build-system gnu)
36 #:use-module (guix build-system cmake)
37 #:use-module (guix build-system python)
38 #:use-module (gnu packages)
39 #:use-module (gnu packages base)
40 #:use-module (gnu packages boost)
41 #:use-module (gnu packages check)
42 #:use-module (gnu packages crypto)
43 #:use-module (gnu packages databases)
44 #:use-module (gnu packages documentation)
45 #:use-module (gnu packages dns)
46 #:use-module (gnu packages emacs)
47 #:use-module (gnu packages graphviz)
48 #:use-module (gnu packages groff)
49 #:use-module (gnu packages libedit)
50 #:use-module (gnu packages libevent)
51 #:use-module (gnu packages libunwind)
52 #:use-module (gnu packages libusb)
53 #:use-module (gnu packages linux)
54 #:use-module (gnu packages multiprecision)
55 #:use-module (gnu packages networking)
56 #:use-module (gnu packages pkg-config)
57 #:use-module (gnu packages protobuf)
58 #:use-module (gnu packages python)
59 #:use-module (gnu packages python-crypto)
60 #:use-module (gnu packages python-web)
61 #:use-module (gnu packages qt)
62 #:use-module (gnu packages readline)
63 #:use-module (gnu packages texinfo)
64 #:use-module (gnu packages textutils)
65 #:use-module (gnu packages tls)
66 #:use-module (gnu packages upnp)
67 #:use-module (gnu packages web)
68 #:use-module (gnu packages xml)
69 #:use-module (gnu packages gnuzilla))
70
71 (define-public bitcoin-core
72 (package
73 (name "bitcoin-core")
74 (version "0.16.1")
75 (source (origin
76 (method url-fetch)
77 (uri
78 (string-append "https://bitcoin.org/bin/bitcoin-core-"
79 version "/bitcoin-" version ".tar.gz"))
80 (sha256
81 (base32
82 "1zkqp93yircd3pbxczxfnibkpq0sgcv5r7wg6d196b9pwgr9zd39"))))
83 (build-system gnu-build-system)
84 (native-inputs
85 `(("pkg-config" ,pkg-config)
86 ("python" ,python) ; for the tests
87 ("util-linux" ,util-linux) ; provides the hexdump command for tests
88 ("qttools" ,qttools)))
89 (inputs
90 `(("bdb" ,bdb-5.3) ; with 6.2.23, there is an error: ambiguous overload
91 ("boost" ,boost)
92 ("libevent" ,libevent)
93 ("miniupnpc" ,miniupnpc)
94 ("openssl" ,openssl)
95 ("protobuf" ,protobuf)
96 ("qtbase" ,qtbase)))
97 (arguments
98 `(#:configure-flags
99 (list
100 ;; We use a bdb version newer than 4.8.
101 "--with-incompatible-bdb"
102 ;; Boost is not found unless specified manually.
103 (string-append "--with-boost="
104 (assoc-ref %build-inputs "boost"))
105 ;; XXX: The configure script looks up Qt paths by
106 ;; `pkg-config --variable=host_bins Qt5Core`, which fails to pick
107 ;; up executables residing in 'qttools', so we specify them here.
108 (string-append "ac_cv_path_LRELEASE="
109 (assoc-ref %build-inputs "qttools")
110 "/bin/lrelease")
111 (string-append "ac_cv_path_LUPDATE="
112 (assoc-ref %build-inputs "qttools")
113 "/bin/lupdate"))
114 #:phases
115 (modify-phases %standard-phases
116 (add-before 'check 'set-home
117 (lambda _
118 (setenv "HOME" (getenv "TMPDIR"))))))) ; Tests write to $HOME.
119 (home-page "https://bitcoin.org/en/")
120 (synopsis "Bitcoin peer-to-peer client")
121 (description
122 "Bitcoin is a digital currency that enables instant payments to anyone
123 anywhere in the world. It uses peer-to-peer technology to operate without
124 central authority: managing transactions and issuing money are carried out
125 collectively by the network. Bitcoin Core is the reference implementation
126 of the bitcoin protocol. This package provides the Bitcoin Core command
127 line client and a client based on Qt.")
128 (license license:expat)))
129
130 (define-public ledger
131 (package
132 (name "ledger")
133 (version "3.1.1")
134 (source (origin
135 (method url-fetch)
136 (uri (string-append
137 "https://github.com/ledger/ledger/archive/v"
138 version ".tar.gz"))
139 (file-name (string-append name "-" version ".tar.gz"))
140 (sha256
141 (base32
142 "12jlv3gsjhrja25q9hrwh73cdacd2l3c2yyn8qnijav9mdhnbw4h"))
143 (patches (search-patches "ledger-revert-boost-python-fix.patch"
144 "ledger-fix-uninitialized.patch"))))
145 (build-system cmake-build-system)
146 (arguments
147 `(#:modules ((guix build cmake-build-system)
148 ((guix build gnu-build-system) #:prefix gnu:)
149 (guix build utils)
150 (guix build emacs-utils))
151 #:imported-modules (,@%cmake-build-system-modules
152 (guix build emacs-utils))
153 #:configure-flags
154 `("-DBUILD_DOCS:BOOL=ON"
155 "-DBUILD_WEB_DOCS:BOOL=ON"
156 "-DBUILD_EMACSLISP:BOOL=ON"
157 "-DUSE_PYTHON:BOOL=ON"
158 "-DCMAKE_INSTALL_LIBDIR:PATH=lib"
159 ,(string-append "-DUTFCPP_INCLUDE_DIR:PATH="
160 (assoc-ref %build-inputs "utfcpp")
161 "/include"))
162 ;; Skip failing test BaselineTest_cmd-org during the check phase.
163 ;; This is a known upstream issue. See
164 ;; https://github.com/ledger/ledger/issues/550
165 #:make-flags (list "ARGS=-E BaselineTest_cmd-org")
166 #:phases
167 (modify-phases %standard-phases
168 (add-after 'unpack 'boost-compat
169 (lambda _
170 (substitute* "src/utils.h"
171 ;; This library moved in Boost 1.66. Remove for Ledger
172 ;; versions > 3.1.1.
173 (("boost/uuid/sha1.hpp") "boost/uuid/detail/sha1.hpp"))
174 #t))
175 (add-before 'configure 'install-examples
176 (lambda* (#:key outputs #:allow-other-keys)
177 (let ((examples (string-append (assoc-ref outputs "out")
178 "/share/doc/ledger/examples")))
179 (install-file "test/input/sample.dat" examples)
180 (install-file "test/input/demo.ledger" examples))
181 #t))
182 (add-after 'build 'build-doc
183 (lambda _ (invoke "make" "doc")))
184 (add-before 'check 'check-setup
185 ;; One test fails if it can't set the timezone.
186 (lambda* (#:key inputs #:allow-other-keys)
187 (setenv "TZDIR"
188 (string-append (assoc-ref inputs "tzdata")
189 "/share/zoneinfo"))
190 #t))
191 (replace 'check (assoc-ref gnu:%standard-phases 'check))
192 (add-after 'install 'relocate-elisp
193 (lambda* (#:key outputs #:allow-other-keys)
194 (let* ((site-dir (string-append (assoc-ref outputs "out")
195 "/share/emacs/site-lisp"))
196 (guix-dir (string-append site-dir "/guix.d"))
197 (orig-dir (string-append site-dir "/ledger-mode"))
198 (dest-dir (string-append guix-dir "/ledger-mode")))
199 (mkdir-p guix-dir)
200 (rename-file orig-dir dest-dir)
201 (emacs-generate-autoloads ,name dest-dir)))))))
202 (inputs
203 `(("boost" ,boost)
204 ("gmp" ,gmp)
205 ("libedit" ,libedit)
206 ("mpfr" ,mpfr)
207 ("python" ,python-2)
208 ("tzdata" ,tzdata)
209 ("utfcpp" ,utfcpp)))
210 (native-inputs
211 `(("emacs" ,emacs-minimal)
212 ("groff" ,groff)
213 ("texinfo" ,texinfo)))
214 (home-page "https://ledger-cli.org/")
215 (synopsis "Command-line double-entry accounting program")
216 (description
217 "Ledger is a powerful, double-entry accounting system that is
218 accessed from the UNIX command-line. This may put off some users, since
219 there is no flashy UI, but for those who want unparalleled reporting
220 access to their data there are few alternatives.
221
222 Ledger uses text files for input. It reads the files and generates
223 reports; there is no other database or stored state. To use Ledger,
224 you create a file of your account names and transactions, run from the
225 command line with some options to specify input and requested reports, and
226 get output. The output is generally plain text, though you could generate
227 a graph or html instead. Ledger is simple in concept, surprisingly rich
228 in ability, and easy to use.")
229 ;; There are some extra licenses in files which do not presently get
230 ;; installed when you build this package. Different versions of the GPL
231 ;; are used in the contrib and python subdirectories. The bundled version
232 ;; of utfcpp is under the Boost 1.0 license. Also the file
233 ;; `tools/update_copyright_year` has an Expat license.
234 (license (list license:bsd-3
235 license:asl2.0 ; src/strptime.cc
236 (license:non-copyleft
237 "file://src/wcwidth.cc"
238 "See src/wcwidth.cc in the distribution.")
239 license:gpl2+)))) ; lisp/*
240
241 (define-public geierlein
242 (package
243 (name "geierlein")
244 (version "0.9.13")
245 (source
246 (origin
247 (method url-fetch)
248 (uri (string-append "https://github.com/stesie/geierlein"
249 "/archive/V" version ".tar.gz"))
250 (file-name (string-append name "-" version ".tar.gz"))
251 (sha256
252 (base32
253 "11jfa7mxvvf0ldhx0hsvjbx3xwvzvn2wrfjpms8c7qmrnqhwh4wp"))))
254 (build-system gnu-build-system)
255 (arguments
256 `(#:tests? #f ; would require npm, python and a lot more
257 #:phases
258 (modify-phases %standard-phases
259 (delete 'configure) ; no configure script
260 (add-after 'unpack 'override-target-directory-and-tool-paths
261 (lambda* (#:key inputs outputs #:allow-other-keys)
262 (substitute* "Makefile"
263 (("prefix := .*")
264 (string-append "prefix := " (assoc-ref outputs "out") "\n"))
265 ;; Required for tests, unused for now:
266 ;;(("PYTHON := .*")
267 ;; (string-append (which "python") "\n")))
268 (("INSTALL := .*")
269 (string-append "INSTALL := " (which "install") "\n")))
270 (substitute* "bin/xgeierlein.in"
271 ;; Use icecat as XULRUNNER
272 (("^for search ")
273 (string-append "XULRUNNER=" (which "icecat") "\n"
274 "for search ")))
275 #t)))))
276 (inputs
277 `(("icecat" ,icecat)))
278 (home-page "https://stesie.github.io/geierlein/")
279 (synopsis "Free Elster client, for sending Germany VAT declarations")
280 (description
281 "Geierlein is a free Elster client, i.e. an application that
282 allows to send VAT declarations to Germany's fiscal authorities.
283
284 Currently it is *not* possible to send returns that are due annually
285 (especially the income tax return) since the fiscal authority doesn't
286 allow to do that off the ERiC library (which is proprietary however).
287 It's not clear at the moment whether one day it will be possible to
288 do so.")
289 (license license:agpl3+)))
290
291 (define-public electrum
292 (package
293 (name "electrum")
294 (version "3.2.2")
295 (source
296 (origin
297 (method url-fetch)
298 (uri (string-append "https://download.electrum.org/"
299 version "/Electrum-"
300 version ".tar.gz"))
301 (sha256
302 (base32
303 "1fxaxlf5vm2zydj678ls3pazyriym188iwzk60kyk26cz2p3xk39"))
304 (modules '((guix build utils)))
305 (snippet
306 '(begin
307 ;; Delete the bundled dependencies.
308 (delete-file-recursively "packages")
309 #t))))
310 (build-system python-build-system)
311 (inputs
312 `(("python-pyaes" ,python-pyaes)
313 ("python-pysocks" ,python-pysocks)
314 ("python-sip" ,python-sip)
315 ("python-pyqt" ,python-pyqt)
316 ("python-ecdsa" ,python-ecdsa)
317 ("python-pbkdf2" ,python-pbkdf2)
318 ("python-requests" ,python-requests)
319 ("python-qrcode" ,python-qrcode)
320 ("python-protobuf" ,python-protobuf)
321 ("python-dnspython" ,python-dnspython)
322 ("python-jsonrpclib-pelix" ,python-jsonrpclib-pelix)))
323 (arguments
324 `(#:tests? #f ;; package doesn't have any tests
325 #:phases
326 (modify-phases %standard-phases
327 (add-before 'build 'patch-home
328 (lambda* (#:key outputs #:allow-other-keys)
329 (substitute* "setup.py"
330 (("~/.local/share")
331 (string-append (assoc-ref outputs "out") "/local/share"))))))))
332 (home-page "https://electrum.org/")
333 (synopsis "Bitcoin wallet")
334 (description
335 "Electrum is a lightweight Bitcoin client, based on a client-server
336 protocol. It supports Simple Payment Verification (SPV) and deterministic key
337 generation from a seed. Your secret keys are encrypted and are never sent to
338 other machines/servers. Electrum does not download the Bitcoin blockchain.")
339 (license license:expat)))
340
341 (define-public electron-cash
342 (package
343 (inherit electrum)
344 (name "electron-cash")
345 (version "3.3.1")
346 (source
347 (origin
348 (method url-fetch)
349 (uri (string-append "https://electroncash.org/downloads/"
350 version
351 "/win-linux/ElectronCash-"
352 version
353 ".tar.gz"))
354 (sha256
355 (base32
356 "1jdy89rfdwc2jadx3rqj5yvynpcn90cx6482ax9f1cj9gfxp9j2b"))
357 (modules '((guix build utils)))
358 (snippet
359 '(begin
360 ;; Delete the bundled dependencies.
361 (delete-file-recursively "packages")
362 #t))))
363 (home-page "https://electroncash.org/")
364 (synopsis "Bitcoin Cash wallet")
365 (description
366 "Electroncash is a lightweight Bitcoin Cash client, based on a client-server
367 protocol. It supports Simple Payment Verification (SPV) and deterministic key
368 generation from a seed. Your secret keys are encrypted and are never sent to
369 other machines/servers. Electroncash does not download the Bitcoin Cash blockchain.")
370 (license license:expat)))
371
372 (define-public monero
373 ;; This package bundles easylogging++ and lmdb.
374 ;; The bundled easylogging++ is modified, and the changes will not be upstreamed.
375 ;; The devs deem the lmdb driver too critical a consenus component, to use
376 ;; the system's dynamically linked library.
377 (package
378 (name "monero")
379 (version "0.12.3.0")
380 (source
381 (origin
382 (method git-fetch)
383 (uri (git-reference
384 (url "https://github.com/monero-project/monero")
385 (commit (string-append "v" version))))
386 (file-name (git-file-name name version))
387 (patches (search-patches "monero-use-system-miniupnpc.patch"))
388 (sha256
389 (base32
390 "14db9kgjm2ha93c2x5fjdw01xaqshn756qr3x2cnzyyjh7caz5qd"))))
391 (build-system cmake-build-system)
392 (native-inputs
393 `(("doxygen" ,doxygen)
394 ("googletest" ,googletest)
395 ("graphviz" ,graphviz)
396 ("pkg-config" ,pkg-config)))
397 (inputs
398 `(("bind" ,isc-bind)
399 ("boost" ,boost)
400 ("zeromq" ,zeromq)
401 ("cppzmq" ,cppzmq)
402 ("expat" ,expat)
403 ("libsodium" ,libsodium)
404 ("libunwind" ,libunwind)
405 ("lmdb" ,lmdb)
406 ("miniupnpc" ,monero-miniupnpc)
407 ("openssl" ,openssl)
408 ("rapidjson" ,rapidjson)
409 ("unbound" ,unbound)))
410 (arguments
411 `(#:out-of-source? #t
412 #:build-type "release"
413 #:configure-flags '("-DBUILD_TESTS=ON"
414 ,@(if (string=? "aarch64-linux" (%current-system))
415 '("-DARCH=armv8-a")
416 '())
417 "-DBUILD_GUI_DEPS=ON")
418 #:phases
419 (modify-phases %standard-phases
420 ;; tests/core_tests need a valid HOME
421 (add-before 'configure 'set-home
422 (lambda _
423 (setenv "HOME" (getcwd))
424 #t))
425 (add-after 'set-home 'fix-wallet-path-for-unit-tests
426 (lambda _
427 (substitute* "tests/unit_tests/serialization.cpp"
428 (("\\.\\./\\.\\./\\.\\./\\.\\./") "../../"))
429 #t))
430 (add-after 'fix-wallet-path-for-unit-tests 'change-log-path
431 (lambda _
432 (substitute* "contrib/epee/src/mlog.cpp"
433 (("epee::string_tools::get_current_module_folder\\(\\)")
434 "\".bitmonero\""))
435 (substitute* "contrib/epee/src/mlog.cpp"
436 (("return \\(") "return ((std::string(getenv(\"HOME\"))) / "))
437 #t))
438 (replace 'check
439 (lambda _
440 (invoke "make" "ARGS=-E 'unit_tests|libwallet_api_tests'"
441 "test")))
442 ;; The excluded unit tests need network access
443 (add-after 'check 'unit-tests
444 (lambda _
445 (let ((excluded-unit-tests
446 (string-join
447 '("AddressFromURL.Success"
448 "AddressFromURL.Failure"
449 "DNSResolver.IPv4Success"
450 "DNSResolver.DNSSECSuccess"
451 "DNSResolver.DNSSECFailure"
452 "DNSResolver.GetTXTRecord")
453 ":")))
454 (invoke "tests/unit_tests/unit_tests"
455 (string-append "--gtest_filter=-"
456 excluded-unit-tests)))))
457 (add-after 'install 'install-blockchain-import-export
458 (lambda* (#:key outputs #:allow-other-keys)
459 (let* ((out (assoc-ref outputs "out"))
460 (bin (string-append out "/bin")))
461 (install-file "bin/monero-blockchain-import" bin)
462 (install-file "bin/monero-blockchain-export" bin)))))))
463 (home-page "https://getmonero.org/")
464 (synopsis "Command-line interface to the Monero currency")
465 (description
466 "Monero is a secure, private, untraceable currency. This package provides the
467 Monero command line client and daemon.")
468 (license license:bsd-3)))
469
470 (define-public monero-gui
471 (package
472 (name "monero-gui")
473 (version "0.12.2.0")
474 (source
475 (origin
476 (method git-fetch)
477 (uri (git-reference
478 (url "https://github.com/monero-project/monero-gui")
479 (commit (string-append "v" version))))
480 (file-name (git-file-name name version))
481 (sha256
482 (base32
483 "1cnrkwh7kp64lnzz1xfmkf1mhsgm5gls292gpqai3jr8jydpkahl"))))
484 (build-system gnu-build-system)
485 (native-inputs
486 `(("doxygen" ,doxygen)
487 ("graphviz" ,graphviz)
488 ("pkg-config" ,pkg-config)
489 ("qttools" ,qttools)))
490 (inputs
491 `(("boost" ,boost)
492 ("libunwind" ,libunwind)
493 ("openssl" ,openssl)
494 ("qtbase" ,qtbase)
495 ("qtdeclarative" ,qtdeclarative)
496 ("qtgraphicaleffects" ,qtgraphicaleffects)
497 ("qtquickcontrols" ,qtquickcontrols)
498 ("readline" ,readline)
499 ("unbound" ,unbound)))
500 (propagated-inputs
501 `(("monero" ,monero)))
502 (arguments
503 `(#:phases
504 (modify-phases %standard-phases
505 (delete 'configure)
506 (delete 'check)
507 (add-before 'build 'fix-makefile-vars
508 (lambda _
509 (substitute* "src/zxcvbn-c/makefile"
510 (("\\?=") "="))
511 #t))
512 (add-after 'fix-makefile-vars 'fix-library-paths
513 (lambda* (#:key inputs #:allow-other-keys)
514 (substitute* "monero-wallet-gui.pro"
515 (("-L/usr/local/lib") "")
516 (("-L/usr/local/opt/openssl/lib")
517 (string-append "-L"
518 (assoc-ref inputs "openssl")
519 "/lib"))
520 (("-L/usr/local/opt/boost/lib")
521 (string-append "-L"
522 (assoc-ref inputs "boost")
523 "/lib")))
524 #t))
525 (add-after 'fix-library-paths 'fix-monerod-path
526 (lambda* (#:key inputs #:allow-other-keys)
527 (substitute* "src/daemon/DaemonManager.cpp"
528 (("QApplication::applicationDirPath\\(\\) \\+ \"/monerod")
529 (string-append "\""(assoc-ref inputs "monero")
530 "/bin/monerod")))
531 #t))
532 (add-after 'fix-monerod-path 'fix-qt-paths
533 (lambda* (#:key inputs #:allow-other-keys)
534 (let* ((qttools (assoc-ref inputs "qttools"))
535 (lrelease (string-append qttools "/bin/lrelease"))
536 (lupdate (string-append qttools "/bin/lupdate")))
537 (substitute* "monero-wallet-gui.pro"
538 (("\\$\\$\\[QT_INSTALL_BINS\\]/lrelease") lrelease)
539 (("\\$\\$\\[QT_INSTALL_BINS\\]/lupdate") lupdate))
540 #t)))
541 (replace 'build
542 (lambda _
543 (invoke "./build.sh")))
544 (add-after 'build 'fix-install-path
545 (lambda* (#:key outputs #:allow-other-keys)
546 (substitute* "build/Makefile"
547 (("/opt/monero-wallet-gui")
548 (assoc-ref outputs "out")))
549 #t))
550 (add-before 'install 'change-dir
551 (lambda _
552 (chdir "build")))
553 (add-after 'install 'wrap-executable
554 (lambda* (#:key inputs outputs #:allow-other-keys)
555 (let ((out (assoc-ref outputs "out")))
556 (wrap-program (string-append out "/bin/monero-wallet-gui")
557 `("QT_PLUGIN_PATH" ":" prefix
558 ,(map (lambda (label)
559 (string-append (assoc-ref inputs label)
560 "/lib/qt5/plugins"))
561 '("qtbase" "qtdeclarative")))
562 `("QML2_IMPORT_PATH" ":" prefix
563 ,(map (lambda (label)
564 (string-append (assoc-ref inputs label)
565 "/lib/qt5/qml"))
566 '("qtdeclarative" "qtgraphicaleffects"
567 "qtquickcontrols"))))
568 #t))))))
569 (home-page "https://getmonero.org/")
570 (synopsis "Graphical user interface for the Monero currency")
571 (description
572 "Monero is a secure, private, untraceable currency. This package provides the
573 Monero GUI client.")
574 (license license:bsd-3)))
575
576 (define-public monero-core
577 (deprecated-package "monero-core" monero-gui))
578
579 (define-public python-trezor-agent
580 (package
581 (name "python-trezor-agent")
582 (version "0.9.4")
583 (source
584 (origin
585 (method url-fetch)
586 (uri (string-append "https://github.com/romanz/trezor-agent/archive/v"
587 version ".tar.gz"))
588 (file-name (string-append name "-" version ".tar.gz"))
589 (sha256
590 (base32
591 "0h8jb147vpjk7mqbl4za0xdh7lblhx07n9dfk80kn2plwnvrry1x"))))
592 (build-system python-build-system)
593 (arguments
594 `(#:phases
595 (modify-phases %standard-phases
596 (delete 'check)
597 (add-after 'install 'check
598 (lambda* (#:key outputs inputs #:allow-other-keys)
599 ;; Make installed package available for running the tests
600 (add-installed-pythonpath inputs outputs)
601 (invoke "py.test"))))))
602 (propagated-inputs
603 `(("python-ecdsa" ,python-ecdsa)
604 ("python-ed25519" ,python-ed25519)
605 ("python-semver" ,python-semver)
606 ("python-unidecode" ,python-unidecode)))
607 (native-inputs
608 `(("python-mock" ,python-mock)
609 ("python-pytest" ,python-pytest)))
610 (home-page "https://github.com/romanz/trezor-agent")
611 (synopsis "TREZOR SSH and GPG host support")
612 (description
613 "@code{libagent} is a library that allows using TREZOR, Keepkey and
614 Ledger Nano as a hardware SSH/GPG agent.")
615 (license license:lgpl3)))
616
617 (define-public python2-trezor-agent
618 (package-with-python2 python-trezor-agent))
619
620 (define-public python-mnemonic
621 (package
622 (name "python-mnemonic")
623 (version "0.18")
624 (source
625 (origin
626 (method url-fetch)
627 (uri (pypi-uri "mnemonic" version))
628 (sha256
629 (base32
630 "07bzfa5di6nv5xwwcwbypnflpj50wlfczhh6q6hg8w13g5m319q2"))))
631 (build-system python-build-system)
632 (propagated-inputs
633 `(("python-pbkdf2" ,python-pbkdf2)))
634 (home-page "https://github.com/trezor/python-mnemonic")
635 (synopsis "Implementation of Bitcoin BIP-0039")
636 (description "@code{mnemonic} is a library that provides an implementation
637 of Bitcoin BIP-0039.")
638 (license license:expat)))
639
640 (define-public python2-mnemonic
641 (package-with-python2 python-mnemonic))
642
643 (define-public python-ledgerblue
644 (package
645 (name "python-ledgerblue")
646 (version "0.1.16")
647 (source
648 (origin
649 (method url-fetch)
650 (uri (pypi-uri "ledgerblue" version))
651 (sha256
652 (base32
653 "010mghaqh1cmz3a0ifc3f40mmyplilwlw7kpha2mzyrrff46p9gb"))))
654 (build-system python-build-system)
655 (propagated-inputs
656 `(("python-ecpy" ,python-ecpy)
657 ("python-future" ,python-future)
658 ("python-hidapi" ,python-hidapi)
659 ("python-pillow" ,python-pillow)
660 ("python-protobuf" ,python-protobuf)
661 ("python-pycrypto" ,python-pycrypto)))
662 (home-page "https://github.com/LedgerHQ/blue-loader-python")
663 (synopsis "Python library to communicate with Ledger Blue/Nano S")
664 (description "@code{ledgerblue} is a Python library to communicate with
665 Ledger Blue/Nano S.")
666 (license license:asl2.0)))
667
668 (define-public python2-ledgerblue
669 (package-with-python2 python-ledgerblue))
670
671 (define-public python-trezor
672 (package
673 (name "python-trezor")
674 (version "0.10.2")
675 (source
676 (origin
677 (method url-fetch)
678 (uri (pypi-uri "trezor" version))
679 (sha256
680 (base32
681 "138k6zsqqpb46k3rcpyslm9q7yq5i6k4myvr9n425jnkadf4vfjd"))))
682 (build-system python-build-system)
683 (arguments
684 `(#:phases
685 (modify-phases %standard-phases
686 ;; Default tests run device-specific tests which fail, only run specific tests.
687 (replace 'check
688 (lambda* (#:key inputs outputs #:allow-other-keys)
689 (invoke "python" "-m" "pytest" "--pyarg" "trezorlib.tests.unit_tests")
690 (invoke "python" "-m" "pytest" "-m" "slow_cosi" "--pyarg" "trezorlib.tests.unit_tests")
691 )))))
692 (propagated-inputs
693 `(("python-click" ,python-click)
694 ("python-ecdsa" ,python-ecdsa)
695 ("python-hidapi" ,python-hidapi)
696 ("python-libusb1" ,python-libusb1)
697 ("python-mnemonic" ,python-mnemonic)
698 ("python-protobuf" ,python-protobuf)
699 ("python-pyblake2" ,python-pyblake2)
700 ("python-requests" ,python-requests)
701 ("python-typing" ,python-typing)))
702 (native-inputs
703 `(("python-mock" ,python-mock) ; Tests
704 ("python-pyqt" ,python-pyqt) ; Tests
705 ("python-pytest" ,python-pytest))) ; Tests
706 (home-page "https://github.com/trezor/python-trezor")
707 (synopsis "Python library for communicating with TREZOR Hardware Wallet")
708 (description "@code{trezor} is a Python library for communicating with
709 TREZOR Hardware Wallet.")
710 (license license:lgpl3)))
711
712 (define-public python2-trezor
713 (package-with-python2 python-trezor))
714
715 (define-public python-keepkey
716 (package
717 (name "python-keepkey")
718 (version "4.0.2")
719 (source
720 (origin
721 (method url-fetch)
722 (uri (pypi-uri "keepkey" version))
723 (sha256
724 (base32
725 "0f4iqqjlqmamw4mhyhik4qlb5bnfd10wbjw9yzgir105wh5fdpnd"))))
726 (build-system python-build-system)
727 (arguments
728 `(#:phases
729 (modify-phases %standard-phases
730 (delete 'check)
731 (add-after 'install 'check
732 (lambda* (#:key inputs outputs #:allow-other-keys)
733 (add-installed-pythonpath inputs outputs)
734 (apply invoke "python" (find-files "tests/unit" "\\.py$")))))))
735 (propagated-inputs
736 `(("python-ecdsa" ,python-ecdsa)
737 ("python-hidapi" ,python-hidapi)
738 ("python-mnemonic" ,python-mnemonic)
739 ("python-protobuf" ,python-protobuf)))
740 (home-page "https://github.com/keepkey/python-keepkey")
741 (synopsis "Python library for communicating with KeepKey Hardware Wallet")
742 (description "@code{keepkey} is a Python library for communicating with
743 the KeepKey Hardware Wallet.")
744 (license license:lgpl3)))
745
746 (define-public python2-keepkey
747 (package-with-python2 python-keepkey))
748
749 (define-public ledger-agent
750 (package
751 (name "ledger-agent")
752 (version "0.9.0")
753 (source
754 (origin
755 (method url-fetch)
756 (uri (pypi-uri "ledger_agent" version))
757 (sha256
758 (base32
759 "03zj602m2rln9yvr08dswy56vzkbldp8b074ixwzz525dafblr92"))))
760 (build-system python-build-system)
761 (inputs
762 `(("python-ledgerblue" ,python-ledgerblue)
763 ("python-trezor-agent" ,python-trezor-agent)))
764 (home-page "http://github.com/romanz/trezor-agent")
765 (synopsis "Ledger as hardware SSH/GPG agent")
766 (description "This package allows using Ledger as hardware SSH/GPG agent.
767
768 Usage for SSH: trezor-agent foo@@example.com --connect
769 Usage for GPG: Initialize using trezor-gpg init \"Foo <foo@@example.com>\"
770 Then set the environment variable GNUPGHOME to
771 \"${HOME}/.gnupg/trezor\".")
772 (license license:lgpl3)))
773
774 (define-public trezor-agent
775 (package
776 (name "trezor-agent")
777 (version "0.9.0")
778 (source
779 (origin
780 (method url-fetch)
781 (uri (pypi-uri "trezor_agent" version))
782 (sha256
783 (base32
784 "1i5cdamlf3c0ym600pjklij74p8ifj9cv7xrpnrfl1b8nkadswbz"))))
785 (build-system python-build-system)
786 (inputs
787 `(("python-trezor" ,python-trezor)
788 ("python-trezor-agent" ,python-trezor-agent)))
789 (home-page "http://github.com/romanz/trezor-agent")
790 (synopsis "Using Trezor as hardware SSH/GPG agent")
791 (description "This package allows using Trezor as a hardware SSH/GPG
792 agent.")
793 (license license:lgpl3)))
794
795 (define-public keepkey-agent
796 (package
797 (name "keepkey-agent")
798 (version "0.9.0")
799 (source
800 (origin
801 (method url-fetch)
802 (uri (pypi-uri "keepkey_agent" version))
803 (sha256
804 (base32
805 "03779gvlx70i0nnry98i4pl1d92604ix5x6jgdfkrdgzqbh5vj27"))))
806 (build-system python-build-system)
807 (inputs
808 `(("python-keepkey" ,python-keepkey)
809 ("python-trezor-agent" ,python-trezor-agent)))
810 (home-page "http://github.com/romanz/trezor-agent")
811 (synopsis "KeepKey as hardware SSH/GPG agent")
812 (description "This package allows using KeepKey as a hardware SSH/GPG
813 agent.")
814 (license license:lgpl3)))
815
816 (define-public python-stdnum
817 (package
818 (name "python-stdnum")
819 (version "1.8.1")
820 (source
821 (origin
822 (method url-fetch)
823 (uri (pypi-uri "python-stdnum" version))
824 (sha256
825 (base32
826 "0hvr47q32xbyiznpmbg4r8rcvxhnf0lwf33hcpnynyik57djy5np"))))
827 (build-system python-build-system)
828 (home-page
829 "https://arthurdejong.org/python-stdnum/")
830 (synopsis
831 "Python module to handle standardized number and code formats")
832 (description
833 "This is a Python library that aims to provide functions to handle,
834 parse and validate standard numbers.
835 The module supports more than 100 different number formats
836 amongst which a great number of VAT and other tax numbers,
837 personal identity and company identification codes,
838 international standard numbers (ISBN, IBAN, EAN, etc.)
839 and various other formats.
840 The module also inclused implementations of the Verhoeff,
841 Luhn and family of ISO/IEC 7064 check digit algorithms. ")
842 (license license:lgpl2.1+)))
843
844 (define-public python2-stdnum
845 (package-with-python2 python-stdnum))
846
847 (define-public python-duniterpy
848 (package
849 (name "python-duniterpy")
850 (version "0.51.0")
851 (source
852 (origin
853 (method git-fetch)
854 ;; Pypi's default URI is missing "requirements.txt" file.
855 (uri (git-reference
856 (url "https://git.duniter.org/clients/python/duniterpy.git")
857 (commit version)))
858 (file-name (git-file-name name version))
859 (sha256
860 (base32
861 "074mh2kh3s00ib0h99050ss3j4c51v57py6dzm7crida6l0iydbv"))))
862 (build-system python-build-system)
863 (arguments
864 ;; Tests fail with "AttributeError: module 'attr' has no attribute 's'".
865 `(#:tests? #f
866 #:phases
867 (modify-phases %standard-phases
868 (add-after 'build 'build-documentation
869 (lambda _
870 (invoke "make" "docs")))
871 (add-after 'build-documentation 'install-documentation
872 (lambda* (#:key inputs outputs #:allow-other-keys)
873 (let* ((out (assoc-ref outputs "out"))
874 (doc (string-append out "/share/doc/" ,name)))
875 (mkdir-p doc)
876 (copy-recursively "docs/_build/html" doc))
877 #t)))))
878 (native-inputs
879 `(("python-sphinx" ,python-sphinx)
880 ("python-sphinx-rtd-theme" ,python-sphinx-rtd-theme)))
881 (propagated-inputs
882 `(("python-aiohttp" ,python-aiohttp)
883 ("python-attr" ,python-attr)
884 ("python-base58" ,python-base58)
885 ("python-jsonschema" ,python-jsonschema)
886 ("python-libnacl" ,python-libnacl)
887 ("python-pylibscrypt" ,python-pylibscrypt)
888 ("python-pypeg2" ,python-pypeg2)))
889 (home-page "https://git.duniter.org/clients/python/duniterpy")
890 (synopsis "Python implementation of Duniter API")
891 (description "@code{duniterpy} is an implementation of
892 @uref{https://github.com/duniter/duniter/, duniter} API. Its
893 main features are:
894 @itemize
895 @item Support Duniter's Basic Merkle API and protocol
896 @item Asynchronous/synchronous without threads
897 @item Support HTTP, HTTPS and Web Socket transport for Basic Merkle API
898 @item Support Elasticsearch Duniter4j API
899 @item Duniter signing key
900 @item Sign/verify and encrypt/decrypt messages with the Duniter credentials
901 @end itemize")
902 (license license:gpl3+)))
903
904 (define-public silkaj
905 (package
906 (name "silkaj")
907 (version "0.6.1")
908 (source
909 (origin
910 (method git-fetch)
911 (uri (git-reference
912 (url "https://git.duniter.org/clients/python/silkaj.git")
913 (commit (string-append "v" version))))
914 (file-name (git-file-name name version))
915 (sha256
916 (base32
917 "0a99gbgdd7m9wisqhqpfyaim0rlv9gkp8gmrppkagqf6j0683igh"))))
918 (build-system python-build-system)
919 (arguments
920 `(#:tests? #f)) ;no test
921 (inputs
922 `(("python-commandlines" ,python-commandlines)
923 ("python-ipaddress" ,python-ipaddress)
924 ("python-pyaes" ,python-pyaes)
925 ("python-pynacl" ,python-pynacl)
926 ("python-scrypt" ,python-scrypt)
927 ("python-tabulate" ,python-tabulate)))
928 (home-page "https://silkaj.duniter.org/")
929 (synopsis "Command line client for Duniter network")
930 (description "@code{Silkaj} is a command line client for the
931 @uref{https://github.com/duniter/duniter/, Duniter} network.
932
933 Its features are:
934 @itemize
935 @item information about currency,
936 @item issuers difficulty to generate next block,
937 @item network view of nodes,
938 @item list of last issuers,
939 @item send transactions,
940 @item get account amount.
941 @end itemize")
942 (license license:agpl3+)))