gnu: make-lua-filesystem: Don't use unstable tarball.
[jackhill/guix/guix.git] / gnu / packages / lua.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Cyril Roelandt <tipecaml@gmail.com>
3 ;;; Copyright © 2014 Raimon Grau <raimonster@gmail.com>
4 ;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
5 ;;; Copyright © 2014 Andreas Enge <andreas@enge.fr>
6 ;;; Copyright © 2016, 2017, 2020 Efraim Flashner <efraim@flashner.co.il>
7 ;;; Copyright © 2016, 2019 Ricardo Wurmus <rekado@elephly.net>
8 ;;; Copyright © 2016 doncatnip <gnopap@gmail.com>
9 ;;; Copyright © 2016, 2017, 2019 Clément Lassieur <clement@lassieur.org>
10 ;;; Copyright © 2016 José Miguel Sánchez García <jmi2k@openmailbox.org>
11 ;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
12 ;;; Copyright © 2018 Fis Trivial <ybbs.daans@hotmail.com>
13 ;;;
14 ;;; This file is part of GNU Guix.
15 ;;;
16 ;;; GNU Guix is free software; you can redistribute it and/or modify it
17 ;;; under the terms of the GNU General Public License as published by
18 ;;; the Free Software Foundation; either version 3 of the License, or (at
19 ;;; your option) any later version.
20 ;;;
21 ;;; GNU Guix is distributed in the hope that it will be useful, but
22 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
23 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
24 ;;; GNU General Public License for more details.
25 ;;;
26 ;;; You should have received a copy of the GNU General Public License
27 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
28
29 (define-module (gnu packages lua)
30 #:use-module ((guix licenses) #:prefix license:)
31 #:use-module (guix packages)
32 #:use-module (guix download)
33 #:use-module (guix git-download)
34 #:use-module (guix utils)
35 #:use-module (guix build-system gnu)
36 #:use-module (guix build-system cmake)
37 #:use-module (gnu packages)
38 #:use-module (gnu packages readline)
39 #:use-module (gnu packages tls)
40 #:use-module (gnu packages xml)
41 #:use-module (gnu packages glib)
42 #:use-module (gnu packages libevent)
43 #:use-module (gnu packages libffi)
44 #:use-module (gnu packages pkg-config)
45 #:use-module (gnu packages xorg)
46 #:use-module (gnu packages gtk))
47
48 (define-public lua
49 (package
50 (name "lua")
51 (version "5.3.5")
52 (source (origin
53 (method url-fetch)
54 (uri (string-append "https://www.lua.org/ftp/lua-"
55 version ".tar.gz"))
56 (sha256
57 (base32 "1b2qn2rv96nmbm6zab4l877bd4zq7wpwm8drwjiy2ih4jqzysbhc"))
58 (patches (search-patches "lua-pkgconfig.patch"
59 "lua-liblua-so.patch"))))
60 (build-system gnu-build-system)
61 (inputs `(("readline" ,readline)))
62 (arguments
63 '(#:modules ((guix build gnu-build-system)
64 (guix build utils)
65 (srfi srfi-1))
66 #:test-target "test"
67 #:make-flags
68 '("MYCFLAGS=-fPIC -DLUA_DL_DLOPEN"
69 "linux")
70 #:phases
71 (modify-phases %standard-phases
72 (delete 'configure)
73 (replace 'install
74 (lambda* (#:key outputs #:allow-other-keys)
75 (let ((out (assoc-ref outputs "out")))
76 (invoke "make" "install"
77 (string-append "INSTALL_TOP=" out)
78 (string-append "INSTALL_MAN=" out
79 "/share/man/man1"))))))))
80 (home-page "https://www.lua.org/")
81 (synopsis "Embeddable scripting language")
82 (description
83 "Lua is a powerful, fast, lightweight, embeddable scripting language. Lua
84 combines simple procedural syntax with powerful data description constructs
85 based on associative arrays and extensible semantics. Lua is dynamically typed,
86 runs by interpreting bytecode for a register-based virtual machine, and has
87 automatic memory management with incremental garbage collection, making it ideal
88 for configuration, scripting, and rapid prototyping.")
89 (license license:x11)))
90
91 (define-public lua-5.2
92 (package (inherit lua)
93 (version "5.2.4")
94 (source
95 (origin
96 (method url-fetch)
97 (uri (string-append "https://www.lua.org/ftp/lua-"
98 version ".tar.gz"))
99 (sha256
100 (base32 "0jwznq0l8qg9wh5grwg07b5cy3lzngvl5m2nl1ikp6vqssmf9qmr"))
101 (patches (search-patches "lua-pkgconfig.patch"
102 "lua-liblua-so.patch"))))))
103
104 (define-public lua-5.1
105 (package (inherit lua)
106 (version "5.1.5")
107 (source (origin
108 (method url-fetch)
109 (uri (string-append "https://www.lua.org/ftp/lua-"
110 version ".tar.gz"))
111 (sha256
112 (base32 "0cskd4w0g6rdm2q8q3i4n1h3j8kylhs3rq8mxwl9vwlmlxbgqh16"))
113 (patches (search-patches "lua51-liblua-so.patch"
114 "lua-CVE-2014-5461.patch"
115 "lua51-pkgconfig.patch"))))))
116
117 (define-public luajit
118 (package
119 (name "luajit")
120 (version "2.1.0-beta3")
121 (source (origin
122 (method url-fetch)
123 (uri (string-append "http://luajit.org/download/LuaJIT-"
124 version ".tar.gz"))
125 (sha256
126 (base32 "1hyrhpkwjqsv54hnnx4cl8vk44h9d6c9w0fz1jfjz00w255y7lhs"))
127 (patches (search-patches "luajit-no_ldconfig.patch"))))
128 (build-system gnu-build-system)
129 (arguments
130 `(#:tests? #f ; luajit is distributed without tests
131 #:phases
132 (modify-phases %standard-phases
133 (delete 'configure) ; no configure script
134 (add-after 'install 'create-luajit-symlink
135 (lambda* (#:key outputs #:allow-other-keys)
136 (let* ((out (assoc-ref outputs "out"))
137 (bin (string-append out "/bin")))
138 (with-directory-excursion bin
139 (symlink ,(string-append name "-" version)
140 ,name)
141 #t)))))
142 #:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out")))))
143 (home-page "https://www.luajit.org/")
144 (synopsis "Just in time compiler for Lua programming language version 5.1")
145 (description
146 "LuaJIT is a Just-In-Time Compiler (JIT) for the Lua
147 programming language. Lua is a powerful, dynamic and light-weight programming
148 language. It may be embedded or used as a general-purpose, stand-alone
149 language.")
150 (license license:x11)))
151
152 (define (make-lua-expat name lua)
153 (package
154 (name name)
155 (version "1.3.0")
156 (source (origin
157 (method url-fetch)
158 (uri (string-append "https://matthewwild.co.uk/projects/"
159 "luaexpat/luaexpat-" version ".tar.gz"))
160 (sha256
161 (base32
162 "1hvxqngn0wf5642i5p3vcyhg3pmp102k63s9ry4jqyyqc1wkjq6h"))))
163 (build-system gnu-build-system)
164 (arguments
165 `(#:make-flags
166 (let ((out (assoc-ref %outputs "out"))
167 (lua-version ,(version-major+minor (package-version lua))))
168 (list "CC=gcc"
169 (string-append "LUA_LDIR=" out "/share/lua/" lua-version)
170 (string-append "LUA_CDIR=" out "/lib/lua/" lua-version)))
171 #:phases
172 (modify-phases %standard-phases
173 (delete 'configure)
174 (replace 'check
175 (lambda _
176 (setenv "LUA_CPATH" "src/?.so;;")
177 (setenv "LUA_PATH" "src/?.lua;;")
178 (invoke "lua" "tests/test.lua")
179 (invoke "lua" "tests/test-lom.lua"))))))
180 (inputs
181 `(("lua" ,lua)
182 ("expat" ,expat)))
183 (home-page "http://matthewwild.co.uk/projects/luaexpat/")
184 (synopsis "SAX XML parser based on the Expat library")
185 (description "LuaExpat is a SAX XML parser based on the Expat library.")
186 (license (package-license lua-5.1))))
187
188 (define-public lua5.1-expat
189 (make-lua-expat "lua5.1-expat" lua-5.1))
190
191 (define-public lua5.2-expat
192 (make-lua-expat "lua5.2-expat" lua-5.2))
193
194 (define (make-lua-socket name lua)
195 (package
196 (name name)
197 (version "3.0-rc1")
198 (source (origin
199 (method url-fetch)
200 (uri (string-append
201 "https://github.com/diegonehab/luasocket/archive/v"
202 version ".tar.gz"))
203 (file-name (string-append name "-" version ".tar.gz"))
204 (sha256
205 (base32
206 "0j8jx8bjicvp9khs26xjya8c495wrpb7parxfnabdqa5nnsxjrwb"))))
207 (build-system gnu-build-system)
208 (arguments
209 `(#:make-flags
210 (let ((out (assoc-ref %outputs "out"))
211 (lua-version ,(version-major+minor (package-version lua))))
212 (list (string-append "INSTALL_TOP=" out)
213 (string-append "LUAV?=" lua-version)))
214 #:phases
215 (modify-phases %standard-phases
216 (delete 'configure)
217 (replace 'check
218 (lambda _
219 (setenv "LUA_CPATH" (string-append "src/?.so." ,version ";;"))
220 (setenv "LUA_PATH" "src/?.lua;;")
221 (when (zero? (primitive-fork))
222 (invoke "lua" "test/testsrvr.lua"))
223 (invoke "lua" "test/testclnt.lua"))))))
224 (inputs
225 `(("lua" ,lua)))
226 (home-page "http://www.tecgraf.puc-rio.br/~diego/professional/luasocket/")
227 (synopsis "Socket library for Lua")
228 (description "LuaSocket is a Lua extension library that is composed by two
229 parts: a C core that provides support for the TCP and UDP transport layers,
230 and a set of Lua modules that add support for functionality commonly needed by
231 applications that deal with the Internet.
232
233 Among the supported modules, the most commonly used implement the
234 SMTP (sending e-mails), HTTP (WWW access) and FTP (uploading and downloading
235 files) client protocols. These provide a very natural and generic interface
236 to the functionality defined by each protocol. In addition, you will find
237 that the MIME (common encodings), URL (anything you could possible want to do
238 with one) and LTN12 (filters, sinks, sources and pumps) modules can be very
239 handy.")
240 (license license:expat)))
241
242 (define-public lua5.1-socket
243 (make-lua-socket "lua5.1-socket" lua-5.1))
244
245 (define-public lua5.2-socket
246 (make-lua-socket "lua5.2-socket" lua-5.2))
247
248 (define (make-lua-filesystem name lua)
249 (package
250 (name name)
251 (version "1.6.3")
252 (source (origin
253 (method git-fetch)
254 (uri (git-reference
255 (url "https://github.com/keplerproject/luafilesystem")
256 (commit (string-append "v_"
257 (string-join
258 (string-split version #\.) "_")))))
259 (file-name (git-file-name name version))
260 (sha256
261 (base32
262 "1hxcnqj53540ysyw8fzax7f09pl98b8f55s712gsglcdxp2g2pri"))))
263 (build-system gnu-build-system)
264 (arguments
265 `(#:make-flags
266 (let ((out (assoc-ref %outputs "out"))
267 (lua-version ,(version-major+minor (package-version lua))))
268 (list (string-append "PREFIX=" out)
269 (string-append "LUA_LIBDIR=" out "/lib/lua/" lua-version)))
270 #:test-target "test"
271 #:phases
272 (modify-phases %standard-phases
273 (delete 'configure))))
274 (inputs
275 `(("lua" ,lua)))
276 (home-page "https://keplerproject.github.io/luafilesystem/index.html")
277 (synopsis "File system library for Lua")
278 (description "LuaFileSystem is a Lua library developed to complement the
279 set of functions related to file systems offered by the standard Lua
280 distribution. LuaFileSystem offers a portable way to access the underlying
281 directory structure and file attributes.")
282 (license (package-license lua-5.1))))
283
284 (define-public lua-filesystem
285 (make-lua-filesystem "lua-filesystem" lua))
286
287 (define-public lua5.1-filesystem
288 (make-lua-filesystem "lua5.1-filesystem" lua-5.1))
289
290 (define-public lua5.2-filesystem
291 (make-lua-filesystem "lua5.2-filesystem" lua-5.2))
292
293 (define (make-lua-sec name lua)
294 (package
295 (name name)
296 (version "0.7")
297 (source (origin
298 (method url-fetch)
299 (uri (string-append "https://github.com/brunoos/luasec/archive/"
300 "luasec-" version ".tar.gz"))
301 (sha256
302 (base32
303 "0c9sdz3gvrsbvvdqzpnsappgwl40hfljlpfybqis6wia3mdyjxi1"))))
304 (build-system gnu-build-system)
305 (arguments
306 `(#:make-flags
307 (let ((out (assoc-ref %outputs "out"))
308 (lua-version ,(version-major+minor (package-version lua))))
309 (list "linux"
310 "CC=gcc"
311 "LD=gcc"
312 (string-append "LUAPATH=" out "/share/lua/" lua-version)
313 (string-append "LUACPATH=" out "/lib/lua/" lua-version)))
314 #:tests? #f ; no tests included
315 #:phases
316 (modify-phases %standard-phases
317 (delete 'configure))))
318 (inputs
319 `(("lua" ,lua)
320 ("openssl" ,openssl)))
321 (propagated-inputs
322 `(("lua-socket"
323 ,(make-lua-socket
324 (format #f "lua~a-socket"
325 (version-major+minor (package-version lua))) lua))))
326 (home-page "https://github.com/brunoos/luasec/wiki")
327 (synopsis "OpenSSL bindings for Lua")
328 (description "LuaSec is a binding for OpenSSL library to provide TLS/SSL
329 communication. It takes an already established TCP connection and creates a
330 secure session between the peers.")
331 (license license:expat)))
332
333 (define-public lua5.1-sec
334 (make-lua-sec "lua5.1-sec" lua-5.1))
335
336 (define-public lua5.2-sec
337 (make-lua-sec "lua5.2-sec" lua-5.2))
338
339 (define-public lua-lgi
340 (package
341 (name "lua-lgi")
342 (version "0.9.2")
343 (source
344 (origin
345 (method url-fetch)
346 (uri (string-append
347 "https://github.com/pavouk/lgi/archive/"
348 version ".tar.gz"))
349 (file-name (string-append name "-" version ".tar.gz"))
350 (sha256
351 (base32
352 "0kwcaj3ahi9gxfyp0lr5zgr6vi1mgsg9sz0980x0nwxlh9a11i6g"))))
353 (build-system gnu-build-system)
354 (arguments
355 '(#:make-flags (list "CC=gcc"
356 (string-append "PREFIX=" (assoc-ref %outputs "out")))
357 #:phases
358 (modify-phases %standard-phases
359 (delete 'configure) ; no configure script
360 (add-before 'build 'set-env
361 (lambda* (#:key inputs #:allow-other-keys)
362 ;; we need to load cairo dynamically
363 (let* ((cairo (string-append
364 (assoc-ref inputs "cairo") "/lib" )))
365 (setenv "LD_LIBRARY_PATH" cairo)
366 #t)))
367 (add-before 'build 'set-lua-version
368 (lambda _
369 ;; lua version and therefore install directories are hardcoded
370 ;; FIXME: This breaks when we update lua to >=5.3
371 (substitute* "./lgi/Makefile"
372 (("LUA_VERSION=5.1") "LUA_VERSION=5.2"))
373 #t))
374 (add-before 'check 'skip-test-gtk
375 (lambda _
376 ;; FIXME: Skip GTK tests:
377 ;; gtk3 - can't get it to run with the xorg-server config below
378 ;; and some non-gtk tests will also fail
379 ;; gtk2 - lots of functions aren't implemented
380 ;; We choose gtk2 as the lesser evil and simply skip the test.
381 ;; Currently, awesome is the only package that uses lua-lgi but
382 ;; it doesn't need or interact with GTK using lua-lgi.
383 (substitute* "./tests/test.lua"
384 (("'gtk.lua',") "-- 'gtk.lua',"))
385 #t))
386 (add-before 'check 'start-xserver-instance
387 (lambda* (#:key inputs #:allow-other-keys)
388 ;; There must be a running X server during tests.
389 (system (format #f "~a/bin/Xvfb :1 &"
390 (assoc-ref inputs "xorg-server")))
391 (setenv "DISPLAY" ":1")
392 #t)))))
393 (inputs
394 `(("gobject-introspection" ,gobject-introspection)
395 ("glib" ,glib)
396 ("pango" ,pango)
397 ("gtk" ,gtk+-2)
398 ("lua" ,lua)
399 ("cairo" ,cairo)
400 ("libffi" ,libffi)
401 ("xorg-server" ,xorg-server)))
402 (native-inputs
403 `(("pkg-config" ,pkg-config)
404 ("dbus" ,dbus))) ;tests use 'dbus-run-session'
405 (home-page "https://github.com/pavouk/lgi/")
406 (synopsis "Lua bridge to GObject based libraries")
407 (description
408 "LGI is gobject-introspection based dynamic Lua binding to GObject
409 based libraries. It allows using GObject-based libraries directly from Lua.
410 Notable examples are GTK+, GStreamer and Webkit.")
411 (license license:expat)))
412
413 (define (make-lua-lpeg name lua)
414 (package
415 (name name)
416 (version "1.0.2")
417 (source (origin
418 (method url-fetch)
419 (uri (string-append "http://www.inf.puc-rio.br/~roberto/lpeg/lpeg-"
420 version ".tar.gz"))
421 (sha256
422 (base32 "1zjzl7acvcdavmcg5l7wi12jd4rh95q9pl5aiww7hv0v0mv6bmj8"))))
423 (build-system gnu-build-system)
424 (arguments
425 `(#:phases
426 (modify-phases %standard-phases
427 (delete 'configure)
428 ;; `make install` isn't available, so we have to do it manually
429 (replace 'install
430 (lambda* (#:key outputs #:allow-other-keys)
431 (let ((out (assoc-ref outputs "out"))
432 (lua-version ,(version-major+minor (package-version lua))))
433 (install-file "lpeg.so"
434 (string-append out "/lib/lua/" lua-version))
435 (install-file "re.lua"
436 (string-append out "/share/lua/" lua-version))
437 #t))))
438 #:test-target "test"))
439 (inputs `(("lua" ,lua)))
440 (synopsis "Pattern-matching library for Lua")
441 (description
442 "LPeg is a pattern-matching library for Lua, based on Parsing Expression
443 Grammars (PEGs).")
444 (home-page "http://www.inf.puc-rio.br/~roberto/lpeg")
445 (license license:expat)))
446
447 (define-public lua-lpeg
448 (make-lua-lpeg "lua-lpeg" lua))
449
450 (define-public lua5.1-lpeg
451 (make-lua-lpeg "lua5.1-lpeg" lua-5.1))
452
453 (define-public lua5.2-lpeg
454 (make-lua-lpeg "lua5.2-lpeg" lua-5.2))
455
456 (define (make-lua-luv name lua)
457 (package
458 (name name)
459 (version "1.30.1-1")
460 (source (origin
461 ;; The release tarball includes the sources of libuv but does
462 ;; not include the pkg-config files.
463 (method git-fetch)
464 (uri (git-reference
465 (url "https://github.com/luvit/luv.git")
466 (commit version)))
467 (file-name (git-file-name name version))
468 (sha256
469 (base32
470 "0b2zxrsjxzhzwfp28lchplrp272v6zkbpq1ddz7a0rf20l7dbls1"))))
471 (build-system cmake-build-system)
472 (arguments
473 `(#:tests? #f ; there are none
474 #:configure-flags
475 '("-DWITH_LUA_ENGINE=Lua"
476 "-DWITH_SHARED_LIBUV=On"
477 "-DBUILD_MODULE=Off"
478 "-DBUILD_SHARED_LIBS=On"
479 "-DLUA_BUILD_TYPE=System")
480 #:phases
481 (modify-phases %standard-phases
482 (add-after 'unpack 'copy-lua-compat
483 (lambda* (#:key inputs #:allow-other-keys)
484 (copy-recursively (assoc-ref inputs "lua-compat")
485 "lua-compat")
486 (setenv "CPATH"
487 (string-append (getcwd) "/lua-compat:"
488 (or (getenv "CPATH") "")))
489 #t)))))
490 (inputs
491 `(("lua" ,lua)
492 ("libuv" ,libuv)))
493 (native-inputs
494 `(("lua-compat"
495 ,(origin
496 (method git-fetch)
497 (uri (git-reference
498 (url "https://github.com/keplerproject/lua-compat-5.3.git")
499 (commit "daebe77a2f498817713df37f0bb316db1d82222f")))
500 (file-name "lua-compat-5.3-checkout")
501 (sha256
502 (base32
503 "02a14nvn7aggg1yikj9h3dcf8aqjbxlws1bfvqbpfxv9d5phnrpz"))))))
504 (home-page "https://github.com/luvit/luv/")
505 (synopsis "Libuv bindings for Lua")
506 (description
507 "This library makes libuv available to Lua scripts.")
508 (license license:asl2.0)))
509
510 (define-public lua-luv
511 (make-lua-luv "lua-luv" lua))
512
513 (define-public lua5.1-luv
514 (make-lua-luv "lua5.1-luv" lua-5.1))
515
516 (define-public lua5.2-luv
517 (make-lua-luv "lua5.2-luv" lua-5.2))
518
519 ;; Lua 5.3 is not supported.
520 (define (make-lua-bitop name lua)
521 (package
522 (name name)
523 (version "1.0.2")
524 (source (origin
525 (method url-fetch)
526 (uri (string-append "http://bitop.luajit.org/download/"
527 "LuaBitOp-" version ".tar.gz"))
528 (sha256
529 (base32
530 "16fffbrgfcw40kskh2bn9q7m3gajffwd2f35rafynlnd7llwj1qj"))))
531 (build-system gnu-build-system)
532 (arguments
533 `(#:test-target "test"
534 #:make-flags
535 (list "INSTALL=install -pD"
536 (string-append "INSTALLPATH=printf "
537 (assoc-ref %outputs "out")
538 "/lib/lua/"
539 ,(version-major+minor (package-version lua))
540 "/bit/bit.so"))
541 #:phases
542 (modify-phases %standard-phases
543 (delete 'configure))))
544 (inputs `(("lua" ,lua)))
545 (home-page "https://bitop.luajit.org/index.html")
546 (synopsis "Bitwise operations on numbers for Lua")
547 (description
548 "Lua BitOp is a C extension module for Lua which adds bitwise operations
549 on numbers.")
550 (license license:expat)))
551
552 (define-public lua5.2-bitop
553 (make-lua-bitop "lua5.2-bitop" lua-5.2))
554
555 (define-public lua5.1-bitop
556 (make-lua-bitop "lua5.1-bitop" lua-5.1))
557
558 (define-public selene
559 (package
560 (name "selene")
561 (version "2017.08.25")
562 (source (origin
563 (method git-fetch)
564 (uri (git-reference
565 (url "https://github.com/jeremyong/Selene.git")
566 ;; The release is quite old.
567 (commit "ffe1ade2568d4cff5894552be8f43e63e379a4c9")))
568 (file-name "Selene")
569 (sha256
570 (base32
571 "1axrgv3rxxdsaf807lwvklfzicn6x6gpf35narllrnz9lg6hn508"))))
572 (build-system cmake-build-system)
573 (arguments
574 `(#:configure-flags
575 ;; lua pc file in CMakeLists.txt is lua5.3.pc
576 '("-DLUA_PC_CFG=lua;lua-5.3;lua-5.1")
577 #:test-target "all"
578 #:phases
579 ;; This is a header only library
580 (modify-phases %standard-phases
581 (delete 'build)
582 (replace 'install
583 (lambda* (#:key inputs outputs #:allow-other-keys)
584 (let* ((output (assoc-ref outputs "out"))
585 (source (assoc-ref inputs "source"))
586 (includedir (string-append output "/include")))
587 (copy-recursively
588 (string-append source "/include")
589 includedir))
590 #t))
591 ;; The path of test files are hard coded.
592 (replace 'check
593 (lambda* (#:key inputs outputs #:allow-other-keys)
594 (let* ((output (assoc-ref outputs "out"))
595 (source (assoc-ref inputs "source"))
596 (builddir (getcwd))
597 (testdir (string-append builddir "/test")))
598 (copy-recursively (string-append source "/test") testdir)
599 (invoke "make")
600 (mkdir-p "runner")
601 (copy-file "./test_runner" "./runner/test_runner")
602 (chdir "./runner")
603 (invoke "./test_runner")))))))
604 (native-inputs
605 `(("lua" ,lua)
606 ("pkg-config" ,pkg-config)))
607 (home-page "https://github.com/jeremyong/Selene")
608 (synopsis "Lua C++11 bindings")
609 (description
610 "Selene is a simple C++11 header-only library enabling seamless
611 interoperability between C++ and Lua programming language.")
612 (license license:zlib)))