gnu: Add poppler-qt5.
[jackhill/guix/guix.git] / gnu / packages / xfce.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014, 2015 Sou Bunnbu <iyzsong@gmail.com>
3 ;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
4 ;;; Copyright © 2016 Andreas Enge <andreas@enge.fr>
5 ;;; Copyright © 2016 Florian Paul Schmidt <mista.tapas@gmx.net>
6 ;;; Copyright © 2016 Kei Kebreau <kei@openmailbox.org>
7 ;;;
8 ;;; This file is part of GNU Guix.
9 ;;;
10 ;;; GNU Guix is free software; you can redistribute it and/or modify it
11 ;;; under the terms of the GNU General Public License as published by
12 ;;; the Free Software Foundation; either version 3 of the License, or (at
13 ;;; your option) any later version.
14 ;;;
15 ;;; GNU Guix is distributed in the hope that it will be useful, but
16 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
17 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
18 ;;; GNU General Public License for more details.
19 ;;;
20 ;;; You should have received a copy of the GNU General Public License
21 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
22
23 (define-module (gnu packages xfce)
24 #:use-module ((guix licenses) #:hide (freetype))
25 #:use-module (guix packages)
26 #:use-module (guix download)
27 #:use-module (guix utils)
28 #:use-module (guix build-system gnu)
29 #:use-module (guix build-system trivial)
30 #:use-module (gnu packages)
31 #:use-module (gnu packages pkg-config)
32 #:use-module (gnu packages glib)
33 #:use-module (gnu packages gtk)
34 #:use-module (gnu packages xorg)
35 #:use-module (gnu packages xdisorg)
36 #:use-module (gnu packages web)
37 #:use-module (gnu packages fontutils)
38 #:use-module (gnu packages image)
39 #:use-module (gnu packages gnome)
40 #:use-module (gnu packages pdf)
41 #:use-module (gnu packages polkit)
42 #:use-module (gnu packages gstreamer)
43 #:use-module (gnu packages linux)
44 #:use-module (gnu packages photo)
45 #:use-module (gnu packages pcre)
46 #:use-module (gnu packages pulseaudio))
47
48 (define-public gtk-xfce-engine
49 (package
50 (name "gtk-xfce-engine")
51 (version "2.10.1")
52 (source (origin
53 (method url-fetch)
54 (uri (string-append "http://archive.xfce.org/src/xfce/"
55 name "/" (version-major+minor version) "/"
56 name "-" version ".tar.bz2"))
57 (sha256
58 (base32
59 "0g86ywkx0ghzhhn96k88p67bbzlm1aqckly85izp07w80l1934ja"))))
60 (build-system gnu-build-system)
61 (native-inputs
62 `(("pkg-config" ,pkg-config)
63 ("intltool" ,intltool)))
64 (inputs `(("gtk+" ,gtk+-2)))
65 (home-page "http://www.xfce.org/")
66 (synopsis "GTK+ theme engine for Xfce")
67 (description
68 "Default GTK+ engine and themes for Xfce Desktop Environment.")
69 (license gpl2+)))
70
71 (define-public libxfce4util
72 (package
73 (name "libxfce4util")
74 (version "4.12.1")
75 (source (origin
76 (method url-fetch)
77 (uri (string-append "http://archive.xfce.org/xfce/"
78 (version-major+minor version)
79 "/src/" name "-" version ".tar.bz2"))
80 (sha256
81 (base32
82 "07c8r3xwx5is298zk77m3r784gmr5y4mh8bbca5zdjqk5vxdwsw7"))))
83 (build-system gnu-build-system)
84 (native-inputs
85 `(("pkg-config" ,pkg-config)
86 ("intltool" ,intltool)))
87 (propagated-inputs `(("glib" ,glib))) ; required by libxfce4util-1.0.pc
88 (home-page "http://www.xfce.org/")
89 (synopsis "Basic utility library for Xfce")
90 (description
91 "A general-purpose utility library with core application support for the
92 Xfce Desktop Environment.")
93 (license lgpl2.0+)))
94
95 (define-public xfconf
96 (package
97 (name "xfconf")
98 (version "4.12.0")
99 (source (origin
100 (method url-fetch)
101 (uri (string-append "http://archive.xfce.org/xfce/"
102 (version-major+minor version)
103 "/src/" name "-" version ".tar.bz2"))
104 (sha256
105 (base32
106 "0mmi0g30aln3x98y5p507g17pipq0dj0bwypshan8cq5hkmfl44r"))))
107 (build-system gnu-build-system)
108 (arguments
109 '(#:phases
110 ;; Run check after install phase to test dbus activation.
111 (alist-cons-after
112 'install 'check
113 (lambda _
114 (setenv "HOME" (getenv "TMPDIR")) ; xfconfd requires a writable HOME
115 ;; Run test-suite under a dbus session.
116 (setenv "XDG_DATA_DIRS" ; for finding org.xfce.Xfconf.service
117 (string-append %output "/share"))
118 ;; For the missing '/etc/machine-id'.
119 (setenv "DBUS_FATAL_WARNINGS" "0");
120 (zero? (system* "dbus-launch" "make" "check")))
121 (alist-delete 'check %standard-phases))))
122 (native-inputs
123 `(("pkg-config" ,pkg-config)
124 ("intltool" ,intltool)))
125 (propagated-inputs
126 ;; libxfconf-0.pc refers to all these.
127 `(("glib" ,glib)
128 ("dbus" ,dbus)
129 ("dbus-glib" ,dbus-glib)))
130 (inputs
131 `(("libxfce4util" ,libxfce4util)))
132 (home-page "http://www.xfce.org/")
133 (synopsis "Configuration storage and query system for Xfce")
134 (description
135 "Settings daemon for Xfce, implemented as a D-Bus-based configuration
136 storage system.")
137 (license lgpl2.0+)))
138
139 (define-public libxfce4ui
140 (package
141 (name "libxfce4ui")
142 (version "4.12.0")
143 (source (origin
144 (method url-fetch)
145 (uri (string-append "http://archive.xfce.org/xfce/"
146 (version-major+minor version)
147 "/src/" name "-" version ".tar.bz2"))
148 (sha256
149 (base32
150 "11rrhqxnfwx5jls3nlg9s2x8saag9f2zqk9cdm6hr3bs6cr9a781"))))
151 (build-system gnu-build-system)
152 (native-inputs
153 `(("pkg-config" ,pkg-config)
154 ("intltool" ,intltool)))
155 (propagated-inputs
156 `(("gtk+-2" ,gtk+-2) ; required by libxfce4ui-1.pc
157 ("gtk+-3" ,gtk+) ; required by libxfce4ui-2.pc
158 ;; libxfce4kbd-private-2.pc refers to all these.
159 ("libxfce4util" ,libxfce4util)
160 ("xfconf" ,xfconf)))
161 (inputs `(("libsm" ,libsm)
162 ("libice" ,libice)
163 ("startup-notification" ,startup-notification)))
164 (home-page "http://www.xfce.org/")
165 (synopsis "Widgets library for Xfce")
166 (description
167 "Libxfce4ui is the replacement of the old libxfcegui4 library. It is used
168 to share commonly used Xfce widgets among the Xfce applications.")
169 (license lgpl2.0+)))
170
171 (define-public exo
172 (package
173 (name "exo")
174 (version "0.10.3")
175 (source (origin
176 (method url-fetch)
177 (uri (string-append "http://archive.xfce.org/xfce/4.12/src/"
178 name "-" version ".tar.bz2"))
179 (sha256
180 (base32
181 "1g9651ra395v2fmzb943l68b9pg0rfxc19x97a62crchxwa4nw4m"))))
182 (build-system gnu-build-system)
183 (native-inputs
184 `(("pkg-config" ,pkg-config)
185 ("intltool" ,intltool)))
186 (propagated-inputs
187 ;; exo-1.pc refers to all these.
188 `(("gtk+" ,gtk+-2)
189 ("libxfce4util" ,libxfce4util)))
190 (inputs
191 `(("libxfce4ui" ,libxfce4ui)
192 ("perl-uri" ,perl-uri)))
193 (home-page "http://www.xfce.org/")
194 (synopsis "Extension library for Xfce")
195 (description
196 "An extension library to Xfce. While Xfce comes with quite a few libraries
197 that are targeted at desktop development, libexo is targeted at application
198 development.")
199 ;; Libraries are under LGPLv2+, and programs under GPLv2+.
200 (license (list gpl2+ lgpl2.1+))))
201
202 (define-public garcon
203 (package
204 (name "garcon")
205 (version "0.4.0")
206 (source (origin
207 (method url-fetch)
208 (uri (string-append "http://archive.xfce.org/xfce/4.12/src/"
209 name "-" version ".tar.bz2"))
210 (sha256
211 (base32
212 "0wm9pjbwq53s3n3nwvsyf0q8lbmhiy2ln3bn5ncihr9vf5cwhzbq"))))
213 (build-system gnu-build-system)
214 (native-inputs
215 `(("pkg-config" ,pkg-config)
216 ("intltool" ,intltool)
217 ("glib:bin" ,glib "bin")))
218 (propagated-inputs
219 `(("libxfce4ui" ,libxfce4ui))) ; required by garcon-gtk2-1.pc
220 (home-page "http://www.xfce.org/")
221 (synopsis "Implementation of the freedesktop.org menu specification")
222 (description
223 "Garcon is a freedesktop.org compliant menu implementation based on
224 GLib and GIO. It was started as a complete rewrite of the former Xfce menu
225 library called libxfce4menu, which, in contrast to garcon, was lacking menu
226 merging features essential for loading menus modified with menu editors.")
227 (license lgpl2.0+)))
228
229 (define-public tumbler
230 (package
231 (name "tumbler")
232 (version "0.1.31")
233 (source (origin
234 (method url-fetch)
235 (uri (string-append "http://archive.xfce.org/src/xfce/tumbler/0.1/"
236 name "-" version ".tar.bz2"))
237 (sha256
238 (base32
239 "0wvip28gm2w061hn84zp2q4dv947ihylrppahn4cjspzff935zfh"))))
240 (build-system gnu-build-system)
241 (native-inputs
242 `(("pkg-config" ,pkg-config)
243 ("intltool" ,intltool)
244 ("glib:bin" ,glib "bin") ; need glib-genmarshal
245 ("dbus-glib" ,dbus-glib))) ; need dbus-binding-tool
246 (propagated-inputs
247 `(("glib" ,glib))) ; required by tumbler-1.pc
248 (inputs
249 `(("dbus" ,dbus)
250 ("gdk-pixbuf" ,gdk-pixbuf)
251 ("freetype" ,freetype)
252 ("libjpeg" ,libjpeg)
253 ("libgsf" ,libgsf)
254 ("poppler" ,poppler)
255 ("gstreamer" ,gstreamer)))
256 (home-page "http://www.xfce.org/")
257 (synopsis "D-Bus service for applications to request thumbnails")
258 (description
259 "Tumbler is a D-Bus service for applications to request thumbnails for
260 various URI schemes and MIME types. It is an implementation of the thumbnail
261 management D-Bus specification.")
262 (license gpl2+)))
263
264 (define-public xfce4-panel
265 (package
266 (name "xfce4-panel")
267 (version "4.12.0")
268 (source (origin
269 (method url-fetch)
270 (uri (string-append "http://archive.xfce.org/xfce/"
271 (version-major+minor version)
272 "/src/" name "-" version ".tar.bz2"))
273 (sha256
274 (base32
275 "1c4p3ckghvsad1sj5v8wmar5mh9cbhail9mmhad2f9pwwb10z4ih"))
276 (patches (search-patches "xfce4-panel-plugins.patch"))))
277 (build-system gnu-build-system)
278 (arguments
279 '(#:configure-flags '("--enable-gtk3")))
280 (native-inputs
281 `(("pkg-config" ,pkg-config)
282 ("intltool" ,intltool)))
283 (propagated-inputs
284 `(("libxfce4util" ,libxfce4util))) ; required by libxfce4panel-1.0.pc
285 (inputs
286 `(("exo" ,exo)
287 ("garcon" ,garcon)
288 ("libwnck" ,libwnck-2)
289 ("libxfce4ui" ,libxfce4ui)))
290 (native-search-paths
291 (list (search-path-specification
292 (variable "X_XFCE4_LIB_DIRS")
293 (files '("lib/xfce4")))))
294 (home-page "http://www.xfce.org/")
295 (synopsis "Xfce desktop panel")
296 (description
297 "Desktop panel for Xfce, which contains program launchers, window buttons,
298 applications menu, workspace switcher and more.")
299 ;; Libraries are under LGPLv2.1+, and programs under GPLv2+.
300 (license (list gpl2+ lgpl2.1+))))
301
302 (define-public xfce4-battery-plugin
303 (package
304 (name "xfce4-battery-plugin")
305 (version "1.0.5")
306 (source (origin
307 (method url-fetch)
308 (uri (string-append "http://archive.xfce.org/src/panel-plugins/"
309 name "/" (version-major+minor version) "/"
310 name "-" version ".tar.bz2"))
311 (sha256
312 (base32
313 "04gbplcj8z4vg5xbks8cc2jjf62mmf9sdymg90scjwmb82pv2ngn"))))
314 (build-system gnu-build-system)
315 (native-inputs `(("pkg-config" ,pkg-config)
316 ("intltool" ,intltool)))
317 (inputs `(("glib" ,glib)
318 ("gtk+" ,gtk+-2)
319 ("libxfce4util" ,libxfce4util)
320 ("libxfce4ui" ,libxfce4ui)
321 ("xfce4-panel" ,xfce4-panel)))
322 (home-page
323 "http://goodies.xfce.org/projects/panel-plugins/xfce4-battery-plugin")
324 (synopsis "Battery monitor panel plugin for Xfce4")
325 (description
326 "A battery monitor panel plugin for Xfce4, compatible with APM and ACPI.")
327 ;; The main plugin code is covered by gpl2+, but the files containing code
328 ;; to read the battery state via ACPI or APM are covered by lgpl2.0+.
329 (license (list gpl2+ lgpl2.0+))))
330
331 (define-public xfce4-clipman-plugin
332 (package
333 (name "xfce4-clipman-plugin")
334 (version "1.2.6")
335 (source (origin
336 (method url-fetch)
337 (uri (string-append "http://archive.xfce.org/src/panel-plugins/"
338 name "/" (version-major+minor version) "/"
339 name "-" version ".tar.bz2"))
340 (sha256
341 (base32
342 "19a8gwcqc0r5qqi8w28dc8arqip34m8yxdb87lgps9g5qfcky113"))))
343 (build-system gnu-build-system)
344 (native-inputs
345 `(("intltool" ,intltool)
346 ("pkg-config" ,pkg-config)))
347 (inputs
348 `(("exo" ,exo)
349 ("libxfce4ui" ,libxfce4ui)
350 ("libxtst" ,libxtst)
351 ("xfce4-panel" ,xfce4-panel)))
352 (home-page
353 "http://goodies.xfce.org/projects/panel-plugins/xfce4-clipman-plugin")
354 (synopsis "Clipboard manager for Xfce")
355 (description
356 "Clipman is a clipboard manager for Xfce. It keeps the clipboard contents
357 around while it is usually lost when you close an application. It is able to
358 handle text and images, and has a feature to execute actions on specific text by
359 matching them against regular expressions.")
360 (license (list gpl2+))))
361
362 (define-public xfce4-pulseaudio-plugin
363 (package
364 (name "xfce4-pulseaudio-plugin")
365 (version "0.2.3")
366 (source (origin
367 (method url-fetch)
368 (uri (string-append "http://archive.xfce.org/src/panel-plugins/"
369 name "/" (version-major+minor version) "/"
370 name "-" version ".tar.bz2"))
371 (sha256
372 (base32
373 "0crvb2gyxbnlf46712arg3m2vqx81dixqhqdwss0bngpijy3ca78"))))
374 (build-system gnu-build-system)
375 (native-inputs
376 `(("intltool" ,intltool)
377 ("pkg-config" ,pkg-config)))
378 (inputs
379 `(("exo" ,exo)
380 ("libnotify" ,libnotify)
381 ("libxfce4ui" ,libxfce4ui)
382 ("pulseaudio" ,pulseaudio)
383 ("xfce4-panel" ,xfce4-panel)))
384 (home-page "http://git.xfce.org/panel-plugins/xfce4-pulseaudio-plugin/")
385 (synopsis "PulseAudio panel plugin for Xfce")
386 (description
387 "Xfce PulseAudio plugin is a plugin for the Xfce panel which provides a
388 convenient way to adjust the audio volume of the PulseAudio sound system and
389 to an auto mixer tool like pavucontrol. It can optionally handle multimedia
390 keys for controlling the audio volume.")
391 (license gpl2+)))
392
393 (define-public xfce4-xkb-plugin
394 (package
395 (name "xfce4-xkb-plugin")
396 (version "0.7.1")
397 (source (origin
398 (method url-fetch)
399 (uri (string-append "http://archive.xfce.org/src/panel-plugins/"
400 name "/" (version-major+minor version) "/"
401 name "-" version ".tar.bz2"))
402 (sha256
403 (base32
404 "10g65j5ia389ahhn3b9hr52ghpp0817fk0m60rfrv4wrzqrjxzk1"))))
405 (build-system gnu-build-system)
406 (native-inputs
407 `(("intltool" ,intltool)
408 ("pkg-config" ,pkg-config)))
409 (inputs
410 `(("garcon" ,garcon)
411 ("librsvg" ,librsvg)
412 ("libwnck" ,libwnck-2)
413 ("libx11" ,libx11)
414 ("libxfce4ui" ,libxfce4ui)
415 ("libxklavier" ,libxklavier)
416 ("xfce4-panel" ,xfce4-panel)))
417 (home-page "http://git.xfce.org/panel-plugins/xfce4-xkb-plugin/")
418 (synopsis "XKB layout switching panel plug-in for Xfce")
419 (description
420 "Xfce XKB plugin makes it possible to set up and use multiple
421 keyboard layouts.
422
423 One can choose the keyboard model, what key combination to
424 use to switch between the layouts, the actual keyboard layouts,
425 the way in which the current layout is being displayed (country
426 flag image or text) and the layout policy, which is whether to
427 store the layout globally (for all windows), per application or
428 per window.")
429 (license bsd-2)))
430
431 (define-public xfce4-appfinder
432 (package
433 (name "xfce4-appfinder")
434 (version "4.12.0")
435 (source (origin
436 (method url-fetch)
437 (uri (string-append "http://archive.xfce.org/xfce/"
438 (version-major+minor version)
439 "/src/" name "-" version ".tar.bz2"))
440 (sha256
441 (base32
442 "0ry5hin8xhgnkmm9vs7jq8blk1cnbyr0s18nm1j6nsm7360abm1a"))))
443 (build-system gnu-build-system)
444 (native-inputs
445 `(("pkg-config" ,pkg-config)
446 ("intltool" ,intltool)))
447 (inputs
448 `(("garcon" ,garcon)
449 ("libxfce4ui" ,libxfce4ui)))
450 (home-page "http://www.xfce.org/")
451 (synopsis "Xfce application finder")
452 (description
453 "Application finder for Xfce, it will show the applications installed on
454 your system in categories, so you can quickly find and launch them.")
455 (license gpl2+)))
456
457 (define-public xfce4-session
458 (package
459 (name "xfce4-session")
460 (version "4.12.0")
461 (source (origin
462 (method url-fetch)
463 (uri (string-append "http://archive.xfce.org/xfce/"
464 (version-major+minor version)
465 "/src/" name "-" version ".tar.bz2"))
466 (sha256
467 (base32
468 "01kvbd09c06j20n155hracsgrq06rlmfgdywffjsvlwpn19m9j38"))
469 (patches
470 ;; See: https://bugzilla.xfce.org/show_bug.cgi?id=12282
471 (search-patches "xfce4-session-fix-xflock4.patch"))
472 (modules '((guix build utils)))
473 (snippet
474 '(begin
475 (substitute* "xfsm-shutdown-helper/main.c"
476 (("/sbin/shutdown -h now") "halt")
477 (("/sbin/shutdown -r now") "restart")
478 (("/usr/sbin/pm-suspend") "pm-suspend")
479 (("/usr/sbin/pm-hibernate") "pm-hibernate"))
480 #t))))
481 (build-system gnu-build-system)
482 (arguments
483 '(#:configure-flags
484 (list (string-append "--with-xsession-prefix=" %output))))
485 (native-inputs
486 `(("pkg-config" ,pkg-config)
487 ("intltool" ,intltool)))
488 (inputs
489 `(("iceauth" ,iceauth)
490 ("upower" ,upower)
491 ("polkit" ,polkit)
492 ("libsm" ,libsm)
493 ("libwnck" ,libwnck-2)
494 ("libxfce4ui" ,libxfce4ui)))
495 (home-page "http://www.xfce.org/")
496 (synopsis "Xfce session manager")
497 (description
498 "Session manager for Xfce, it will restore your session on startup and
499 allows you to shutdown the computer from Xfce.")
500 (license gpl2+)))
501
502 (define-public xfce4-settings
503 (package
504 (name "xfce4-settings")
505 (version "4.12.0")
506 (source (origin
507 (method url-fetch)
508 (uri (string-append "http://archive.xfce.org/xfce/"
509 (version-major+minor version)
510 "/src/" name "-" version ".tar.bz2"))
511 (sha256
512 (base32
513 "108za1cmjslwzkdl76x9kwxkq8z734kg9nz8rxk057f10pqwxgh4"))
514 (patches (search-patches "xfce4-settings-defaults.patch"))))
515 (build-system gnu-build-system)
516 (native-inputs
517 `(("pkg-config" ,pkg-config)
518 ("intltool" ,intltool)))
519 (inputs
520 `(("exo" ,exo)
521 ("garcon" ,garcon)
522 ("libnotify" ,libnotify)
523 ("libxcursor" ,libxcursor)
524 ("libxi" ,libxi)
525 ("libxklavier" ,libxklavier)
526 ("libxrandr" ,libxrandr)
527 ("libxfce4ui" ,libxfce4ui)
528 ("upower" ,upower)
529 ("xf86-input-libinput" ,xf86-input-libinput)))
530 (home-page "http://www.xfce.org/")
531 (synopsis "Xfce settings manager")
532 (description
533 "Settings manager for Xfce, it can control various aspects of the desktop
534 like appearance, display, keyboard and mouse settings.")
535 (license gpl2+)))
536
537 (define-public thunar
538 (package
539 (name "thunar")
540 (version "1.6.6")
541 (source (origin
542 (method url-fetch)
543 (uri (string-append "http://archive.xfce.org/xfce/4.12/src/"
544 "Thunar-" version ".tar.bz2"))
545 (sha256
546 (base32
547 "1cl9v3rdzipyyxml3pyrzspxfmmssz5h5snpj18irq4an42539dr"))))
548 (build-system gnu-build-system)
549 (native-inputs
550 `(("pkg-config" ,pkg-config)
551 ("intltool" ,intltool)))
552 (inputs
553 `(("exo" ,exo)
554 ("libexif" ,libexif)
555 ("libgudev" ,libgudev)
556 ("libnotify" ,libnotify)
557 ("libxfce4ui" ,libxfce4ui)
558 ("pcre" ,pcre)
559 ("xfce4-panel" ,xfce4-panel)
560 ("startup-notification" ,startup-notification)))
561 (home-page "http://www.xfce.org/")
562 (synopsis "Xfce file manager")
563 (description
564 "A modern file manager for graphical desktop, aiming to be easy-to-use and
565 fast.")
566 (license gpl2+)))
567
568 (define-public thunar-volman
569 (package
570 (name "thunar-volman")
571 (version "0.8.1")
572 (source (origin
573 (method url-fetch)
574 (uri (string-append "http://archive.xfce.org/xfce/4.12/src/"
575 name "-" version ".tar.bz2"))
576 (sha256
577 (base32
578 "1gf259n1v3y23n1zlkhyr6r0i8j59rnl1cmxvxj6la9cwdfbn22s"))))
579 (build-system gnu-build-system)
580 (native-inputs
581 `(("pkg-config" ,pkg-config)
582 ("intltool" ,intltool)))
583 (inputs
584 `(("exo" ,exo)
585 ("libgudev" ,libgudev)
586 ("libnotify" ,libnotify)
587 ("libxfce4ui" ,libxfce4ui)))
588 (home-page "http://www.xfce.org/")
589 (synopsis "Removable media manager for Thunar")
590 (description
591 "Thunar-volman is an extension for the Thunar File Manager, which enables
592 automatic management of removable drives and media. For example, if
593 thunar-volman is installed and configured properly, and you plug in your
594 digital camera, it will automatically spawn your preferred photo application
595 and import the new pictures from your camera.")
596 (license gpl2+)))
597
598 (define-public xfwm4
599 (package
600 (name "xfwm4")
601 (version "4.12.0")
602 (source (origin
603 (method url-fetch)
604 (uri (string-append "http://archive.xfce.org/xfce/"
605 (version-major+minor version)
606 "/src/" name "-" version ".tar.bz2"))
607 (sha256
608 (base32
609 "0fnc2ps4k733n9qfpxrz047h1myyqjzxczl7fmkjmqwshvicpx19"))))
610 (build-system gnu-build-system)
611 (native-inputs
612 `(("pkg-config" ,pkg-config)
613 ("intltool" ,intltool)))
614 (inputs
615 `(("libdrm" ,libdrm)
616 ("libwnck" ,libwnck-2)
617 ("libxcomposite" ,libxcomposite)
618 ("libxdamage" ,libxdamage)
619 ("libxfce4ui" ,libxfce4ui)
620 ("libxrandr" ,libxrandr)))
621 (home-page "http://www.xfce.org/")
622 (synopsis "Xfce window manager")
623 (description
624 "Window manager for Xfce, it handles the placement of windows
625 on the screen.")
626 (license gpl2+)))
627
628 (define-public xfdesktop
629 (package
630 (name "xfdesktop")
631 (version "4.12.0")
632 (source (origin
633 (method url-fetch)
634 (uri (string-append "http://archive.xfce.org/xfce/"
635 (version-major+minor version)
636 "/src/" name "-" version ".tar.bz2"))
637 (sha256
638 (base32
639 "1ivzgg4792nid6wcgd1nq5vc3z0y5ip6ymq7ci5j2qkp663qnykf"))))
640 (build-system gnu-build-system)
641 (native-inputs
642 `(("pkg-config" ,pkg-config)
643 ("intltool" ,intltool)))
644 (inputs
645 `(("exo" ,exo)
646 ("garcon" ,garcon)
647 ("libnotify" ,libnotify)
648 ("libwnck" ,libwnck-2)
649 ("libxfce4ui" ,libxfce4ui)
650 ("thunar" ,thunar)))
651 (home-page "http://www.xfce.org/")
652 (synopsis "Xfce desktop manager")
653 (description
654 "Desktop manager for Xfce, it sets the background color or image with
655 optional application menu or icons for minimized applications or launchers,
656 devices and folders.")
657 (license gpl2+)))
658
659 (define-public xfce4-terminal
660 (package
661 (name "xfce4-terminal")
662 (version "0.6.3")
663 (source (origin
664 (method url-fetch)
665 (uri (string-append "http://archive.xfce.org/src/apps/" name "/"
666 (version-major+minor version) "/"
667 name "-" version ".tar.bz2"))
668 (sha256
669 (base32
670 "023y0lkfijifh05yz8grimxadqpi98mrivr00sl18nirq8b4fbwi"))))
671 (build-system gnu-build-system)
672 (native-inputs
673 `(("pkg-config" ,pkg-config)
674 ("intltool" ,intltool)))
675 (inputs
676 `(("libxfce4ui" ,libxfce4ui)
677 ("vte" ,vte/gtk+-2)))
678 (home-page "http://www.xfce.org/")
679 (synopsis "Xfce terminal emulator")
680 (description
681 "A lightweight and easy to use terminal emulator for Xfce. Features
682 include a simple configuration interface, the ability to use multiple tabs
683 with terminals within a single window, the possibility to have a
684 pseudo-transparent terminal background, and a compact mode (where both the
685 menubar and the window decorations are hidden) that helps you to save space
686 on your desktop.")
687 (license gpl2+)))
688
689 (define-public xfce
690 (package
691 (name "xfce")
692 (version (package-version xfce4-session))
693 (source #f)
694 (build-system trivial-build-system)
695 (arguments '(#:builder (mkdir %output)))
696 (propagated-inputs
697 `(("exo" ,exo)
698 ("garcon" ,garcon)
699 ("gnome-icon-theme" ,gnome-icon-theme)
700 ("gtk-xfce-engine" ,gtk-xfce-engine)
701 ("hicolor-icon-theme" ,hicolor-icon-theme)
702 ("ristretto" ,ristretto)
703 ("shared-mime-info" ,shared-mime-info)
704 ("thunar" ,thunar)
705 ("thunar-volman" ,thunar-volman)
706 ("tumlber" ,tumbler)
707 ("xfce4-appfinder" ,xfce4-appfinder)
708 ("xfce4-panel" ,xfce4-panel)
709 ("xfce4-power-manager" ,xfce4-power-manager)
710 ("xfce4-session" ,xfce4-session)
711 ("xfce4-settings" ,xfce4-settings)
712 ("xfce4-terminal" ,xfce4-terminal)
713 ("xfconf" ,xfconf)
714 ("xfdesktop" ,xfdesktop)
715 ("xfwm4" ,xfwm4)
716 ;; Panel plugins.
717 ("xfce4-battery-plugin" ,xfce4-battery-plugin)
718 ("xfce4-clipman-plugin" ,xfce4-clipman-plugin)
719 ("xfce4-pulseaudio-plugin" ,xfce4-pulseaudio-plugin)
720 ("xfce4-xkb-plugin" ,xfce4-xkb-plugin)))
721 (home-page "http://www.xfce.org/")
722 (synopsis "Desktop environment (meta-package)")
723 (description
724 "Xfce is a lightweight desktop environment. It aims to be fast and low on
725 system resources, while still being visually appealing and user friendly.")
726 (license gpl2+)))
727
728 (define-public xfce4-power-manager
729 (package
730 (name "xfce4-power-manager")
731 (version "1.4.3")
732 (source (origin
733 (method url-fetch)
734 (uri (string-append "http://archive.xfce.org/xfce/4.12"
735 "/src/" name "-" version ".tar.bz2"))
736 (sha256
737 (base32
738 "04909sfc2nrj2wg9cw6y9y2r9yrp3l3vc201sy1gaiap67fi33h1"))))
739 (build-system gnu-build-system)
740 (arguments
741 '(#:configure-flags '("--enable-gtk3")))
742 (native-inputs
743 `(("pkg-config" ,pkg-config)
744 ("intltool" ,intltool)))
745 (inputs
746 `(("lbxrandr" ,libxrandr)
747 ("upower" ,upower)
748 ("libnotify" ,libnotify)
749 ("libxfce4ui" ,libxfce4ui)))
750 (home-page "http://www.xfce.org/")
751 (synopsis "Xfce Power Manager")
752 (description
753 "This is a power manager for the Xfce desktop. It manages the power
754 sources on the computer and the devices that can be controlled to reduce their
755 power consumption (such as LCD brightness level, monitor sleep, CPU frequency
756 scaling, etc). In addition, xfce4-power-manager provides a set of
757 freedesktop-compliant DBus interfaces to inform other applications about current
758 power level so that they can adjust their power consumption, and it provides the
759 inhibit interface which allows applications to prevent automatic sleep.")
760 (license gpl2+)))
761
762 (define-public ristretto
763 (package
764 (name "ristretto")
765 (version "0.8.0")
766 (source (origin
767 (method url-fetch)
768 (uri (string-append "http://archive.xfce.org/src/apps/ristretto/"
769 (version-major+minor version) "/"
770 name "-" version ".tar.bz2"))
771 (sha256
772 (base32
773 "0a7kwhx51fd2kqh7l7kp13wcn39d2fjkwnn9rfd1k9ydrqj56qki"))))
774 (build-system gnu-build-system)
775 (native-inputs
776 `(("intltool" ,intltool)
777 ("pkg-config" ,pkg-config)))
778 (inputs
779 `(("desktop-file-utils" ,desktop-file-utils)
780 ("libexif" ,libexif)
781 ("libxfce4ui" ,libxfce4ui)
782 ("librsvg" ,librsvg)
783 ("tumbler" ,tumbler)))
784 (home-page "http://docs.xfce.org/apps/ristretto/start")
785 (synopsis "Fast and lightweight picture-viewer")
786 (description
787 "The Ristretto Image Viewer is an application that can be used to view,
788 and scroll through images. It can be used to run a slideshow of images, open
789 images with other applications like an image-editor or configure an image as
790 the desktop wallpaper.")
791 (license gpl2+)))
792
793 (define-public xfce4-taskmanager
794 (package
795 (name "xfce4-taskmanager")
796 (version "1.1.0")
797 (source (origin
798 (method url-fetch)
799 (uri (string-append "http://archive.xfce.org/src/apps/"
800 name "/" (version-major+minor version) "/"
801 name "-" version ".tar.bz2"))
802 (sha256
803 (base32
804 "1jwywmkkkmz7406m1jq40w6apiav25cznafhigbgpjv6z5hv27if"))))
805 (build-system gnu-build-system)
806 (native-inputs
807 `(("intltool" ,intltool)
808 ("pkg-config" ,pkg-config)))
809 (inputs
810 `(("libwnck" ,libwnck-2)
811 ("gtk+" ,gtk+-2)))
812 (home-page "http://goodies.xfce.org/projects/applications/xfce4-taskmanager")
813 (synopsis "Easy to use task manager")
814 (description
815 "This is a task manager for the Xfce desktop. It displays the CPU and
816 memory usage graphically, and it can display processes as a tree.")
817 (license gpl2+)))