gnu: Add poppler-qt5.
[jackhill/guix/guix.git] / gnu / packages / geeqie.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages geeqie)
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module ((guix licenses) #:prefix l:)
24 #:use-module (guix build-system gnu)
25 #:use-module (gnu packages pkg-config)
26 #:use-module (gnu packages glib)
27 #:use-module (gnu packages gtk)
28 #:use-module (gnu packages image)
29 #:use-module (gnu packages ghostscript)
30 #:use-module (gnu packages compression)
31 #:use-module (gnu packages xml))
32
33 (define-public exiv2 ; XXX: move elsewhere?
34 (package
35 (name "exiv2")
36 (version "0.23")
37 (source (origin
38 (method url-fetch)
39 (uri (string-append "http://www.exiv2.org/exiv2-"
40 version ".tar.gz"))
41 (sha256
42 (base32
43 "04bbg2cg6mgcyz435zamx37sp5zw44n2alb59ki1daz71f851yl1"))))
44 (build-system gnu-build-system)
45 (arguments '(#:tests? #f)) ; no `check' target
46 (propagated-inputs
47 `(("expat" ,expat) ("zlib" ,zlib)))
48 (home-page "http://www.exiv2.org/")
49 (synopsis "Library and command-line utility to manage image metadata")
50 (description
51 "Exiv2 is a C++ library and a command line utility to manage image
52 metadata. It provides fast and easy read and write access to the Exif, IPTC
53 and XMP metadata of images in various formats.")
54
55 ;; Files under `xmpsdk' are a copy of Adobe's XMP SDK, licensed under the
56 ;; 3-clause BSD license: <http://www.adobe.com/devnet/xmp/sdk/eula.html>.
57 ;; The core is GPLv2+:
58 ;; <https://launchpad.net/ubuntu/precise/+source/exiv2/+copyright>.
59 (license l:gpl2+)))
60
61 (define-public geeqie
62 (package
63 (name "geeqie")
64 (version "1.1")
65 (source (origin
66 (method url-fetch)
67 (uri (string-append "https://github.com/BestImageViewer/geeqie/"
68 "archive/" version ".tar.gz"))
69 (file-name (string-append name "-" version ".tar.gz"))
70 (sha256
71 (base32
72 "1kzy39z9505xkayyx7rjj2wda76xy3ch1s5z35zn8yli54ffhi2m"))))
73 (build-system gnu-build-system)
74 (inputs
75 `(;; ("libchamplain" ,libchamplain)
76 ("lcms" ,lcms)
77 ("exiv2" ,exiv2)
78 ("libpng" ,libpng)
79 ("gtk+" ,gtk+-2)))
80 (native-inputs
81 `(("intltool" ,intltool)
82 ("pkg-config" ,pkg-config)))
83 (home-page "http://www.geeqie.org/")
84 (synopsis "Lightweight GTK+ based image viewer")
85 (description
86 "Geeqie is a lightweight GTK+ based image viewer for Unix like operating
87 systems. It features: EXIF, IPTC and XMP metadata browsing and editing
88 interoperability; easy integration with other software; geeqie works on files
89 and directories, there is no need to import images; fast preview for many raw
90 image formats; tools for image comparison, sorting and managing photo
91 collection. Geeqie was initially based on GQview.")
92 (license l:gpl2+)))