gnu: kodi: Increase test timeout.
[jackhill/guix/guix.git] / gnu / packages / patches / kodi-increase-test-timeout.patch
1 Increase thread timeout to reduce flakiness.
2
3 Taken from upstream:
4 https://github.com/xbmc/xbmc/commit/574b0182d8b641fd24029f372ebdcccc897123e2
5
6 diff --git a/xbmc/threads/test/TestEvent.cpp b/xbmc/threads/test/TestEvent.cpp
7 index 42fb8c2fc609..40e644c0ed3c 100644
8 --- a/xbmc/threads/test/TestEvent.cpp
9 +++ b/xbmc/threads/test/TestEvent.cpp
10 @@ -484,7 +484,7 @@ TEST(TestEvent, GroupTimedWait)
11 EXPECT_TRUE(w3.result == NULL);
12
13 // this should end given the wait is for only 50 millis
14 - EXPECT_TRUE(waitThread3.timed_join(MILLIS(100)));
15 + EXPECT_TRUE(waitThread3.timed_join(MILLIS(200)));
16
17 EXPECT_TRUE(!w3.waiting);
18 EXPECT_TRUE(w3.result == NULL);