Merge branch 'master' into core-updates
[jackhill/guix/guix.git] / gnu / packages / aidc.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014 John Darringon <jmd@gnu.org>
3 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
4 ;;; Copyright © 2017 Hartmut Goebel <h.goebel@crazy-compilers.com>
5 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
6 ;;;
7 ;;; This file is part of GNU Guix.
8 ;;;
9 ;;; GNU Guix is free software; you can redistribute it and/or modify it
10 ;;; under the terms of the GNU General Public License as published by
11 ;;; the Free Software Foundation; either version 3 of the License, or (at
12 ;;; your option) any later version.
13 ;;;
14 ;;; GNU Guix is distributed in the hope that it will be useful, but
15 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
16 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
17 ;;; GNU General Public License for more details.
18 ;;;
19 ;;; You should have received a copy of the GNU General Public License
20 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
21
22 (define-module (gnu packages aidc)
23 #:use-module (gnu packages)
24 #:use-module ((guix licenses) #:prefix license:)
25 #:use-module (guix packages)
26 #:use-module (guix download)
27 #:use-module (gnu packages pkg-config)
28 #:use-module (gnu packages image)
29 #:use-module (guix build-system gnu))
30
31
32 (define-public barcode
33 (package
34 (name "barcode")
35 (version "0.99")
36 (source (origin
37 (method url-fetch)
38 (uri (string-append "mirror://gnu/barcode/barcode-"
39 version ".tar.xz"))
40 (sha256
41 (base32
42 "1indapql5fjz0bysyc88cmc54y8phqrbi7c76p71fgjp45jcyzp8"))))
43 (build-system gnu-build-system)
44 (synopsis "Convert text strings to printed bars in various standards")
45 (description "GNU Barcode is a flexible tool to produce printed barcodes
46 from text strings. It supports a variety of encoding standards and sizing
47 measurements. Barcodes can be output in PostScript or Encapsulated PostScript
48 formats.")
49 (license license:gpl3+)
50 (home-page "https://www.gnu.org/software/barcode/")))
51
52 (define-public qrencode
53 (package
54 (name "qrencode")
55 (version "4.0.2")
56 (source (origin
57 (method url-fetch)
58 (uri (string-append
59 "https://fukuchi.org/works/qrencode/qrencode-" version
60 ".tar.bz2"))
61 (sha256
62 (base32
63 "1d2q5d3v8g3hsi3h5jq4n177bjhf3kawms09immw7p187f6jgjy9"))))
64 (build-system gnu-build-system)
65 (inputs `(("libpng" ,libpng)))
66 (native-inputs `(("pkg-config" ,pkg-config)))
67 (synopsis "Encode data into a QR Code symbol")
68 (description "Libqrencode is a C library for encoding data in a QR Code
69 symbol, a kind of 2D symbology that can be scanned by handy terminals such as
70 a mobile phone with CCD. The capacity of QR Code is up to 7000 digits or 4000
71 characters, and is highly robust.")
72 (license license:lgpl2.1+)
73 (home-page "https://fukuchi.org/works/qrencode")))
74
75 (define-public libdmtx
76 (package
77 (name "libdmtx")
78 (version "0.7.4")
79 (source
80 (origin
81 (method url-fetch)
82 (uri (string-append
83 "mirror://sourceforge/libdmtx/" name "/" version "/"
84 name "-" version ".tar.bz2"))
85 (sha256
86 (base32 "0xnxx075ycy58n92yfda2z9zgd41h3d4ik5d9l197lzsqim5hb5n"))))
87 (build-system gnu-build-system)
88 (native-inputs
89 `(("pkg-config" ,pkg-config)))
90 (home-page "http://libdmtx.sourceforge.net/")
91 (synopsis "Library for reading and writing Data Matrix 2D barcodes")
92 (description "libdmtx is software for reading and writing Data Matrix 2D
93 barcodes on Linux and Unix. At its core libdmtx is a shared library, allowing
94 C/C++ programs to use its capabilities without restrictions or overhead.")
95 (license license:bsd-3)))