Merge branch 'master' into staging
[jackhill/guix/guix.git] / gnu / packages / libusb.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
3 ;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
4 ;;; Copyright © 2015 Andy Wingo <wingo@igalia.com>
5 ;;; Copyright © 2015, 2016, 2017, 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
6 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
7 ;;; Copyright © 2016 Theodoros Foradis <theodoros@foradis.org>
8 ;;; Copyright © 2017 Jonathan Brielmaier <jonathan.brielmaier@web.de>
9 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
10 ;;; Copyright © 2018 Vagrant Cascadian <vagrant@debian.org>
11 ;;;
12 ;;; This file is part of GNU Guix.
13 ;;;
14 ;;; GNU Guix is free software; you can redistribute it and/or modify it
15 ;;; under the terms of the GNU General Public License as published by
16 ;;; the Free Software Foundation; either version 3 of the License, or (at
17 ;;; your option) any later version.
18 ;;;
19 ;;; GNU Guix is distributed in the hope that it will be useful, but
20 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
21 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
22 ;;; GNU General Public License for more details.
23 ;;;
24 ;;; You should have received a copy of the GNU General Public License
25 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
26
27 (define-module (gnu packages libusb)
28 #:use-module (gnu packages)
29 #:use-module ((guix licenses) #:prefix license:)
30 #:use-module (guix packages)
31 #:use-module (guix utils)
32 #:use-module (guix download)
33 #:use-module (guix git-download)
34 #:use-module (guix build-system ant)
35 #:use-module (guix build-system cmake)
36 #:use-module (guix build-system gnu)
37 #:use-module (guix build-system glib-or-gtk)
38 #:use-module (guix build-system python)
39 #:use-module (gnu packages autotools)
40 #:use-module (gnu packages gnupg)
41 #:use-module (gnu packages gtk)
42 #:use-module (gnu packages java)
43 #:use-module (gnu packages linux)
44 #:use-module (gnu packages mp3)
45 #:use-module (gnu packages pkg-config)
46 #:use-module (gnu packages python)
47 #:use-module (gnu packages python-xyz)
48 #:use-module (gnu packages tls)
49 #:use-module (gnu packages xiph))
50
51 (define-public libusb
52 (package
53 (name "libusb")
54 (version "1.0.23")
55 (source
56 (origin
57 (method url-fetch)
58 (uri (string-append "https://github.com/libusb/libusb/"
59 "releases/download/v" version
60 "/libusb-" version ".tar.bz2"))
61 (sha256
62 (base32 "13dd2a9x290d1q8nb1lqiaf36grcvns5ripk5k2xm0lajmpc04fv"))))
63 (build-system gnu-build-system)
64
65 ;; XXX: Enabling udev is now recommended, but eudev indirectly depends on
66 ;; libusb.
67 (arguments `(#:configure-flags '("--disable-udev")))
68 ;; (inputs `(("eudev" ,eudev)))
69
70 (home-page "https://libusb.info")
71 (synopsis "User-space USB library")
72 (description
73 "Libusb is a library that gives applications easy access to USB
74 devices on various operating systems.")
75 (license license:lgpl2.1+)))
76
77 (define-public libusb-compat
78 (package
79 (name "libusb-compat")
80 (version "0.1.5")
81 (source
82 (origin
83 (method url-fetch)
84 (uri (string-append "mirror://sourceforge/libusb/"
85 "libusb-compat-" (version-major+minor version) "/"
86 "libusb-compat-" version "/"
87 "libusb-compat-" version ".tar.bz2"))
88 (sha256
89 (base32
90 "0nn5icrfm9lkhzw1xjvaks9bq3w6mjg86ggv3fn7kgi4nfvg8kj0"))))
91 (build-system gnu-build-system)
92 (native-inputs
93 `(("pkg-config" ,pkg-config)))
94 (inputs
95 `(("libusb" ,libusb)))
96 (home-page "https://libusb.info")
97 (synopsis "Compatibility shim for libusb")
98 (description
99 "Libusb-compat provides a shim allowing applications based on older
100 version of libusb to run with newer libusb.")
101 (license license:lgpl2.1+)))
102
103 ;; required by 0xffff, which compiles with libusb-compat, but executes only
104 ;; with libusb-0.1
105 (define-public libusb-0.1
106 (package (inherit libusb)
107 (version "0.1.12")
108 (source
109 (origin
110 (method url-fetch)
111 (uri (string-append "mirror://sourceforge/libusb/libusb-0.1 (LEGACY)/"
112 version "/libusb-" version ".tar.gz"))
113 (sha256
114 (base32
115 "0i4bacxkyr7xyqxbmb00ypkrv4swkgm0mghbzjsnw6blvvczgxip"))
116 (patches (search-patches "libusb-0.1-disable-tests.patch"))))))
117
118 (define-public libusb4java
119 ;; There is no public release so we take the latest version from git.
120 (let ((commit "396d642a57678a0d9663b062c980fe100cc0ea1e")
121 (revision "1"))
122 (package
123 (name "libusb4java")
124 (version (string-append "0-" revision "." (string-take commit 9)))
125 (source (origin
126 (method git-fetch)
127 (uri (git-reference
128 (url "https://github.com/usb4java/libusb4java.git")
129 (commit commit)))
130 (file-name (git-file-name name version))
131 (sha256
132 (base32
133 "0wqgapalhfh9v38ycbl6i2f5lh1wpr6fzwn5dwd0rdacypkd1gml"))))
134 (build-system cmake-build-system)
135 (arguments
136 `(#:tests? #f ; there are no tests
137 #:phases
138 (modify-phases %standard-phases
139 ;; FIXME: libusb 1.0.22 deprecated libusb_set_debug, so the build
140 ;; fails because libusb4java uses a deprecated procedure.
141 (add-after 'unpack 'disable-Werror
142 (lambda _
143 (substitute* "CMakeLists.txt"
144 (("-Werror") ""))
145 #t))
146 (add-before 'configure 'set-JAVA_HOME
147 (lambda* (#:key inputs #:allow-other-keys)
148 (setenv "JAVA_HOME" (assoc-ref inputs "jdk"))
149 #t)))))
150 (inputs
151 `(("libusb" ,libusb)))
152 (native-inputs
153 `(("jdk" ,icedtea "jdk")))
154 (home-page "https://github.com/usb4java/libusb4java/")
155 (synopsis "JNI bindings to libusb")
156 (description
157 "This package provides Java JNI bindings to the libusb library for use
158 with usb4java.")
159 (license license:expat))))
160
161 (define-public java-usb4java
162 (package
163 (name "java-usb4java")
164 (version "1.2.0")
165 (source (origin
166 (method url-fetch)
167 (uri (string-append "https://github.com/usb4java/usb4java/"
168 "archive/usb4java-" version ".tar.gz"))
169 (sha256
170 (base32
171 "0gzpsnzwgsdyra3smq288yvxnwrgvdwxr6g8jbknnsk56kv6wc34"))))
172 (build-system ant-build-system)
173 (arguments
174 `(#:jar-name "usb4java.jar"
175 #:phases
176 (modify-phases %standard-phases
177 ;; Usually, native libusb4java libraries for all supported systems
178 ;; would be included in the jar and extracted at runtime. Since we
179 ;; build everything from source we cannot just bundle pre-built
180 ;; binaries for other systems. Instead, we patch the loader to
181 ;; directly return the appropriate library for this system. The
182 ;; downside is that the jar will only work on the same architecture
183 ;; that it was built on.
184 (add-after 'unpack 'copy-libusb4java
185 (lambda* (#:key inputs #:allow-other-keys)
186 (substitute* "src/main/java/org/usb4java/Loader.java"
187 (("private static String extractLibrary" line)
188 (string-append
189 line "(final String a, final String b) {"
190 "return \""
191 (assoc-ref inputs "libusb4java") "/lib/libusb4java.so"
192 "\"; }\n"
193 "private static String _extractLibrary")))
194 #t))
195 (add-after 'unpack 'disable-broken-tests
196 (lambda _
197 (with-directory-excursion "src/test/java/org/usb4java"
198 ;; These tests should only be run when USB devices are present.
199 (substitute* '("LibUsbGlobalTest.java"
200 "TransferTest.java")
201 (("this.context = new Context\\(\\);")
202 "this.context = null;")
203 (("LibUsb.init") "//"))
204 (substitute* "DeviceListIteratorTest.java"
205 (("this.iterator.remove" line)
206 (string-append "assumeUsbTestsEnabled();" line))))
207 #t)))))
208 (inputs
209 `(("libusb4java" ,libusb4java)
210 ("java-commons-lang3" ,java-commons-lang3)
211 ("java-junit" ,java-junit)
212 ("java-hamcrest-core" ,java-hamcrest-core)))
213 (home-page "http://usb4java.org/")
214 (synopsis "USB library for Java")
215 (description
216 "This package provides a USB library for Java based on libusb and
217 implementing @code{javax.usb} (JSR-80).")
218 (license license:expat)))
219
220 (define-public python-libusb1
221 (package
222 (name "python-libusb1")
223 (version "1.6.4")
224 (source
225 (origin
226 (method url-fetch)
227 (uri (pypi-uri "libusb1" version))
228 (sha256
229 (base32
230 "03b7xrz8vqg8w0za5r503jhcmbd1ls5610jcja1rqz833nf0v4wc"))))
231 (build-system python-build-system)
232 (arguments
233 `(#:modules ((srfi srfi-1)
234 (guix build utils)
235 (guix build python-build-system))
236 #:phases
237 (modify-phases %standard-phases
238 (add-before 'install-license-files 'remove-incorrect-license
239 (lambda* (#:key out #:allow-other-keys)
240 ;; Was relicensed to LGPL 2.1+, but old COPYING file still left
241 ;; in source. Remove it so it does not get installed.
242 (delete-file "COPYING")
243 #t))
244 (add-after 'unpack 'fix-libusb-reference
245 (lambda* (#:key inputs #:allow-other-keys)
246 (substitute* "usb1/libusb1.py"
247 (("libusb_path = ctypes.util.find_library\\(base_name\\)")
248 (string-append
249 "libusb_path = \""
250 (find (negate symbolic-link?)
251 (find-files (assoc-ref inputs "libusb")
252 "^libusb.*\\.so\\..*"))
253 "\"")))
254 #t)))))
255 (inputs `(("libusb" ,libusb)))
256 (home-page "https://github.com/vpelletier/python-libusb1")
257 (synopsis "Pure-python wrapper for libusb-1.0")
258 (description "Libusb is a library that gives applications easy access to
259 USB devices on various operating systems. This package provides a Python
260 wrapper for accessing libusb-1.0.")
261 (license license:lgpl2.1+)))
262
263 (define-public python-pyusb
264 (package
265 (name "python-pyusb")
266 (version "1.0.2")
267 (source
268 (origin
269 (method url-fetch)
270 (uri (pypi-uri "pyusb" version))
271 (sha256
272 (base32
273 "0qkk2jn270jwwl1x26hmdhb14m9kkbrzzwzizdjcl1a29b6756sf"))))
274 (build-system python-build-system)
275 (arguments
276 `(#:tests? #f ; no tests
277 #:modules ((srfi srfi-1)
278 (srfi srfi-26)
279 (guix build utils)
280 (guix build python-build-system))
281 #:phases
282 (modify-phases %standard-phases
283 (add-after 'unpack 'fix-libusb-reference
284 (lambda* (#:key inputs #:allow-other-keys)
285 (substitute* "usb/libloader.py"
286 (("lib = locate_library\\(candidates, find_library\\)")
287 (string-append
288 "lib = \""
289 (find (negate symbolic-link?)
290 (find-files (assoc-ref inputs "libusb")
291 "^libusb-.*\\.so\\..*"))
292 "\"")))
293 #t)))))
294 (inputs
295 `(("libusb" ,libusb)))
296 (home-page "https://pyusb.github.io/pyusb/")
297 (synopsis "Python bindings to the libusb library")
298 (description
299 "PyUSB aims to be an easy to use Python module to access USB devices.")
300 (license license:bsd-3)))
301
302 (define-public python2-pyusb
303 (package-with-python2 python-pyusb))
304
305 (define-public libplist
306 (package
307 (name "libplist")
308 (version "2.1.0")
309 (source
310 (origin
311 (method git-fetch)
312 (uri (git-reference
313 (url "https://github.com/libimobiledevice/libplist.git")
314 (commit version)))
315 (file-name (git-file-name name version))
316 (sha256
317 (base32 "02vraf4j46bp746s0gz7vga2gv2dy3zd1v1bsy9x8algg9fpcb7n"))))
318 (build-system gnu-build-system)
319 (arguments
320 `(#:phases
321 (modify-phases %standard-phases
322 (add-before 'bootstrap 'configure-later
323 ;; Don't run ./configure during bootstrap.
324 (lambda _
325 (setenv "NOCONFIGURE" "set")
326 #t)))
327 ;; Tests fail randomly when run in parallel because several of them write
328 ;; and read to/from the same file--e.g., "4.plist" is accessed by
329 ;; 'large.test' and 'largecmp.test'.
330 #:parallel-tests? #f))
331 (inputs
332 `(("python" ,python)))
333 (native-inputs
334 `(("autoconf" ,autoconf)
335 ("automake" ,automake)
336 ("libtool" ,libtool)
337 ("pkg-config" ,pkg-config)
338 ("python-cython" ,python-cython))) ; to build Python bindings
339 (home-page "https://www.libimobiledevice.org/")
340 (synopsis "C library to handle Apple Property List files")
341 (description "This package provides a small portable C library to handle
342 Apple Property List files in binary or XML.")
343 (license license:lgpl2.1+)))
344
345 (define-public libusbmuxd
346 (package
347 (name "libusbmuxd")
348 (version "1.0.10")
349 (source (origin
350 (method url-fetch)
351 (uri (string-append "https://www.libimobiledevice.org/downloads/"
352 "libusbmuxd-" version ".tar.bz2"))
353 (sha256
354 (base32
355 "1wn9zq2224786mdr12c5hxad643d29wg4z6b7jn888jx4s8i78hs"))))
356 (build-system gnu-build-system)
357 (native-inputs
358 `(("pkg-config" ,pkg-config)
359 ("libplist" ,libplist)))
360 (home-page "https://www.libimobiledevice.org/")
361 (synopsis "Library to multiplex connections from and to iOS devices")
362 (description "This package provides a client library to multiplex
363 connections from and to iOS devices by connecting to a socket provided by a
364 @code{usbmuxd} daemon.")
365 (license license:lgpl2.1+)))
366
367 (define-public libimobiledevice
368 (package
369 (name "libimobiledevice")
370 (version "1.2.0")
371 (source (origin
372 (method url-fetch)
373 (uri (string-append "https://www.libimobiledevice.org/downloads/"
374 "libimobiledevice-" version ".tar.bz2"))
375 (sha256
376 (base32
377 "0dqhy4qwj30mw8pwckvjmgnj1qqrh6p8c6jknmhvylshhzh0ssvq"))))
378 (build-system gnu-build-system)
379 (arguments
380 `(#:configure-flags
381 (list (string-append "PYTHON_LDFLAGS=-L"
382 (assoc-ref %build-inputs "python")
383 "/lib -lpython"
384 ,(version-major+minor (package-version python))
385 "m"))))
386 (propagated-inputs
387 `(("openssl" ,openssl-1.0)
388 ("libplist" ,libplist)
389 ("libusbmuxd" ,libusbmuxd)))
390 (inputs
391 `(("python" ,python)))
392 (native-inputs
393 `(("pkg-config" ,pkg-config)
394 ("python-cython" ,python-cython)
395 ("libtool" ,libtool)))
396 (home-page "https://www.libimobiledevice.org/")
397 (synopsis "Protocol library and tools to communicate with Apple devices")
398 (description "libimobiledevice is a software library that talks the
399 protocols to support Apple devices. It allows other software to easily access
400 the device's file system, retrieve information about the device and its
401 internals, backup/restore the device, manage installed applications, retrieve
402 address books, calendars, notes, and bookmarks, and (using libgpod) synchronize
403 music and video to the device.")
404 (license license:lgpl2.1+)))
405
406 (define-public ifuse
407 (package
408 (name "ifuse")
409 (version "1.1.3")
410 (source (origin
411 (method url-fetch)
412 (uri (string-append "https://www.libimobiledevice.org/downloads/"
413 "ifuse-" version ".tar.bz2"))
414 (sha256
415 (base32
416 "1p9a4n36jb194cnp6v57cz2bggwbywaz8pbpb95ch83pzdkdx257"))))
417 (inputs
418 `(("fuse" ,fuse)
419 ("libimobiledevice" ,libimobiledevice)))
420 (native-inputs
421 `(("pkg-config" ,pkg-config)))
422 (build-system gnu-build-system)
423 (home-page "https://www.libimobiledevice.org/")
424 (synopsis "Mount iOS devices")
425 (description "This package provides @command{ifuse}, a command to mount
426 iOS devices and access their contents.")
427 (license license:lgpl2.1+)))
428
429 (define-public usbmuxd
430 (package
431 (name "usbmuxd")
432 (version "1.1.0")
433 (source (origin
434 (method url-fetch)
435 (uri (string-append "https://www.libimobiledevice.org/downloads/"
436 "usbmuxd-" version ".tar.bz2"))
437 (sha256
438 (base32
439 "0bdlc7a8plvglqqx39qqampqm6y0hcdws76l9dffwl22zss4i29y"))))
440 (inputs
441 `(("libplist" ,libplist)
442 ("libusb" ,libusb)
443 ("libimobiledevice" ,libimobiledevice)))
444 (native-inputs
445 `(("pkg-config" ,pkg-config)))
446 (build-system gnu-build-system)
447 (home-page "https://www.libimobiledevice.org/")
448 (synopsis "Multiplex connections over USB to an iOS device")
449 (description "This package provides the @code{usbmuxd} daemon
450 which multiplexes connections over USB to an iOS device. To
451 users, it means you can sync your music, contacts, photos, etc.
452 over USB.")
453 (license license:gpl2+)))
454
455 (define-public libmtp
456 (package
457 (name "libmtp")
458 (version "1.1.17")
459 (source (origin
460 (method url-fetch)
461 (uri (string-append "mirror://sourceforge/libmtp/libmtp/" version
462 "/libmtp-" version ".tar.gz"))
463 (sha256
464 (base32
465 "1p3r38nvdip40ab1h4scj3mzfjkx6kd14szjqyw9r6wz5pslr8zq"))))
466 (build-system gnu-build-system)
467 (native-inputs
468 `(("pkg-config" ,pkg-config)))
469 (inputs
470 `(("libgcrypt" ,libgcrypt)))
471 (propagated-inputs
472 ;; libmtp.pc refers to all these.
473 `(("libusb" ,libusb)))
474 (arguments
475 `(#:configure-flags
476 (list "--disable-static"
477 (string-append "--with-udev="
478 (assoc-ref %outputs "out")
479 "/lib/udev"))))
480 (home-page "http://libmtp.sourceforge.net/")
481 (synopsis "Library implementing the Media Transfer Protocol")
482 (description "Libmtp implements an MTP (Media Transfer Protocol)
483 initiator, which means that it initiates MTP sessions with devices. The
484 devices responding are known as MTP responders. Libmtp runs on devices
485 with a USB host controller interface. It implements MTP Basic, which was
486 proposed for standardization.")
487 ;; COPYING contains lgpl2.1, while files headers give
488 ;; "GNU Lesser General Public License as published by the Free Software
489 ;; Foundation; either version 2 of the License, or (at your option) any
490 ;; later version."
491 (license license:lgpl2.1+)))
492
493 (define-public gmtp
494 (package
495 (name "gmtp")
496 (version "1.3.11")
497 (source (origin
498 (method url-fetch)
499 (uri (string-append "mirror://sourceforge/gmtp/gMTP-" version
500 "/gmtp-" version ".tar.gz"))
501 (sha256
502 (base32
503 "04q6byyq002fhzkc2rkkahwh5b6272xakaj4m3vwm8la8jf0r0ss"))))
504 (build-system glib-or-gtk-build-system)
505 (arguments
506 '(#:configure-flags
507 (let ((libid3tag (assoc-ref %build-inputs "libid3tag")))
508 (list
509 ;; libid3tag provides no .pc file, so pkg-config fails to find them.
510 (string-append "ID3TAG_CFLAGS=-I" libid3tag "/include")
511 (string-append "ID3TAG_LIBS=-L" libid3tag "/lib -lid3tag -lz")))))
512 (inputs
513 `(("gtk+" ,gtk+)
514 ("flac" ,flac)
515 ("libvorbis" ,libvorbis)
516 ("libid3tag" ,libid3tag)
517 ("libmtp" ,libmtp)))
518 (native-inputs
519 `(("pkg-config" ,pkg-config)))
520 (home-page "http://gmtp.sourceforge.net/")
521 (synopsis "Simple graphical MTP client")
522 (description "gMTP is a simple graphical client for the Media Transfer Protocol
523 (MTP), which allows media files to be transferred to and from many portable
524 devices.")
525 (license license:bsd-3)))
526
527 (define-public hidapi
528 (package
529 (name "hidapi")
530 (version "0.9.0")
531 (source
532 (origin
533 (method git-fetch)
534 (uri (git-reference
535 (url "https://github.com/libusb/hidapi.git")
536 (commit (string-append "hidapi-" version))))
537 (file-name (git-file-name name version))
538 (sha256
539 (base32 "1p4g8lgwj4rki6lbn5l6rvwj0xlbn1xfh4d255bg5pvgczmwmc4i"))))
540 (build-system gnu-build-system)
541 (inputs
542 `(("libusb" ,libusb)
543 ("udev" ,eudev)))
544 (native-inputs
545 `(("autoconf" ,autoconf)
546 ("automake" ,automake)
547 ("libtool" ,libtool)
548 ("pkg-config" ,pkg-config)))
549 (home-page "https://github.com/libusb/hidapi")
550 (synopsis "HID API library")
551 (description
552 "HIDAPI is a library which allows an application to interface with USB and Bluetooth
553 HID-Class devices.")
554 ;; HIDAPI can be used under one of three licenses.
555 (license (list license:gpl3
556 license:bsd-3
557 (license:non-copyleft "file://LICENSE-orig.txt")))))
558
559 (define-public python-hidapi
560 (package
561 (name "python-hidapi")
562 (version "0.7.99.post21")
563 (source
564 (origin
565 (method url-fetch)
566 (uri (pypi-uri "hidapi" version))
567 (sha256
568 (base32
569 "15ws59zdrxahf3k7z5rcrwc4jgv1307anif8ixm2cyb9ask1mgp0"))
570 (modules '((guix build utils)))
571 (snippet
572 ;; Remove bundled libraries.
573 '(begin
574 (delete-file-recursively "hidapi")
575 #t))))
576 (build-system python-build-system)
577 (arguments
578 `(#:phases
579 (modify-phases %standard-phases
580 (add-after 'unpack 'patch-configuration
581 (lambda* (#:key inputs #:allow-other-keys)
582 (substitute* "setup.py"
583 (("'/usr/include/libusb-1.0'")
584 (string-append "'" (assoc-ref inputs "libusb")
585 "/include/libusb-1.0'"))
586 (("'/usr/include/hidapi'")
587 (string-append "'" (assoc-ref inputs "hidapi")
588 "/include/hidapi'")))
589 #t))
590 ;; XXX Necessary because python-build-system drops the arguments.
591 (replace 'build
592 (lambda _
593 (invoke "python" "setup.py" "build" "--with-system-hidapi")))
594 (replace 'check
595 (lambda _
596 (invoke "python" "setup.py" "test" "--with-system-hidapi")))
597 (replace 'install
598 (lambda* (#:key outputs #:allow-other-keys)
599 (invoke "python" "setup.py" "install" "--with-system-hidapi"
600 (string-append "--prefix=" (assoc-ref outputs "out"))
601 "--single-version-externally-managed" "--root=/"))))))
602 (inputs
603 `(("hidapi" ,hidapi)
604 ("libusb" ,libusb)
605 ("eudev" ,eudev)))
606 (native-inputs
607 `(("python-cython" ,python-cython)))
608 (home-page "https://github.com/trezor/cython-hidapi")
609 (synopsis "Cython interface to hidapi")
610 (description "This package provides a Cython interface to @code{hidapi}.")
611 ;; The library can be used under either of these licenses.
612 (license (list license:gpl3
613 license:bsd-3
614 (license:non-copyleft
615 "https://github.com/trezor/cython-hidapi/blob/master/LICENSE-orig.txt"
616 "You are free to use cython-hidapi code for any purpose.")))))
617
618 (define-public python2-hidapi
619 (package-with-python2 python-hidapi))