gnu: eudev: Fix build failure caused by conflicting function type declaration.
[jackhill/guix/guix.git] / gnu / packages / fontutils.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013, 2014, 2015 Andreas Enge <andreas@enge.fr>
3 ;;; Copyright © 2014, 2016 Eric Bavier <bavier@member.fsf.org>
4 ;;; Copyright © 2016 Mark H Weaver <mhw@netris.org>
5 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
6 ;;;
7 ;;; This file is part of GNU Guix.
8 ;;;
9 ;;; GNU Guix is free software; you can redistribute it and/or modify it
10 ;;; under the terms of the GNU General Public License as published by
11 ;;; the Free Software Foundation; either version 3 of the License, or (at
12 ;;; your option) any later version.
13 ;;;
14 ;;; GNU Guix is distributed in the hope that it will be useful, but
15 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
16 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
17 ;;; GNU General Public License for more details.
18 ;;;
19 ;;; You should have received a copy of the GNU General Public License
20 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
21
22 (define-module (gnu packages fontutils)
23 #:use-module (gnu packages)
24 #:use-module (gnu packages compression)
25 #:use-module (gnu packages ghostscript)
26 #:use-module (gnu packages perl)
27 #:use-module (gnu packages pkg-config)
28 #:use-module (gnu packages autotools)
29 #:use-module (gnu packages gettext)
30 #:use-module (gnu packages python)
31 #:use-module (gnu packages image)
32 #:use-module (gnu packages bison)
33 #:use-module (gnu packages flex)
34 #:use-module (gnu packages glib)
35 #:use-module (gnu packages xorg)
36 #:use-module (gnu packages gtk)
37 #:use-module (gnu packages xml)
38 #:use-module ((guix licenses) #:prefix license:)
39 #:use-module (guix packages)
40 #:use-module (guix download)
41 #:use-module (guix svn-download)
42 #:use-module (guix git-download)
43 #:use-module (guix build-system cmake)
44 #:use-module (guix build-system gnu))
45
46 (define-public freetype
47 (package
48 (name "freetype")
49 (version "2.7")
50 (source (origin
51 (method url-fetch)
52 (uri (string-append "mirror://savannah/freetype/freetype-"
53 version ".tar.bz2"))
54 (sha256 (base32
55 "0j3xgzn6pchgg1nm294vhx7cdicb7x3x8kwnlcm7v1alnzsm396n"))))
56 (build-system gnu-build-system)
57 (native-inputs
58 `(("pkg-config" ,pkg-config)))
59 (propagated-inputs
60 ;; These are all in the Requires.private field of freetype2.pc.
61 ;; XXX: add harfbuzz.
62 `(("libpng" ,libpng)
63 ("zlib" ,zlib)))
64 (synopsis "Font rendering library")
65 (description
66 "Freetype is a library that can be used by applications to access the
67 contents of font files. It provides a uniform interface to access font files.
68 It supports both bitmap and scalable formats, including TrueType, OpenType,
69 Type1, CID, CFF, Windows FON/FNT, X11 PCF, and others. It supports high-speed
70 anti-aliased glyph bitmap generation with 256 gray levels.")
71 (license license:freetype) ; some files have other licenses
72 (home-page "https://www.freetype.org/")))
73
74 (define-public ttfautohint
75 (package
76 (name "ttfautohint")
77 (version "1.5")
78 (source
79 (origin
80 (method url-fetch)
81 (uri (string-append "mirror://savannah/freetype/ttfautohint-"
82 version ".tar.gz"))
83 (sha256
84 (base32
85 "1lgghck46p33z3hg8dnl76jryig4fh6d8rhzms837zp7x4hyfkv4"))
86 (patches (list (search-patch "ttfautohint-source-date-epoch.patch")))))
87 (build-system gnu-build-system)
88 (native-inputs
89 `(("flex" ,flex)
90 ("bison" ,bison)
91 ("pkg-config" ,pkg-config)))
92 (inputs
93 `(("freetype" ,freetype)
94 ("harfbuzz" ,harfbuzz)))
95 (arguments
96 `(#:configure-flags '("--with-qt=no"))) ;no gui
97 (synopsis "Automated font hinting")
98 (description
99 "ttfautohint provides a 99% automated hinting process and a platform for
100 finely hand-hinting the last 1%. It is ideal for web fonts and supports many
101 scripts.")
102 (license (list license:gpl2+ license:freetype)) ;choose one or the other
103 (home-page "http://www.freetype.org/ttfautohint/")))
104
105 (define-public woff-tools
106 (package
107 (name "woff-tools")
108 (version "2009.10.04")
109 (source
110 (origin
111 (method url-fetch)
112 ;; Upstream source is unversioned, so use Debian's versioned tarball
113 (uri (string-append "mirror://debian/pool/main/w/woff-tools/"
114 "woff-tools_" version ".orig.tar.gz"))
115 (file-name (string-append name "-" version ".tar.gz"))
116 (sha256
117 (base32
118 "1i97gkqa6jfzlslsngqf556kx60knlgf7yc9pzsq2pizc6f0d4zl"))))
119 (build-system gnu-build-system)
120 (inputs
121 `(("zlib" ,zlib)))
122 (arguments
123 `(#:make-flags '("CC=gcc")
124 #:tests? #f ;no tests
125 #:phases
126 (modify-phases %standard-phases
127 (delete 'configure) ;no configuration
128 (replace 'install
129 (lambda* (#:key outputs #:allow-other-keys)
130 (let* ((out (assoc-ref outputs "out"))
131 (bin (string-append out "/bin")))
132 (install-file "sfnt2woff" bin)
133 (install-file "woff2sfnt" bin)))))))
134 (synopsis "Convert between OpenType and WOFF fonts")
135 (description
136 "This package provides two tools:
137 @table @code
138 @item sfnt2woff
139 Converts OpenType fonts to WOFF fonts
140 @item woff2sfnt
141 Converts WOFF fonts to OpenType fonts
142 @end table")
143 (license (list license:mpl1.1 license:gpl2+ license:lgpl2.1+))
144 (home-page "https://people.mozilla.com/~jkew/woff/")))
145
146 (define-public ttf2eot
147 (package
148 (name "ttf2eot")
149 (version "0.0.2-2")
150 (source
151 (origin
152 (method url-fetch)
153 (uri (string-append "https://storage.googleapis.com/"
154 "google-code-archive-downloads/v2/"
155 "code.google.com/ttf2eot/"
156 "ttf2eot-" version ".tar.gz"))
157 (sha256
158 (base32
159 "1f4dzzmhn0208dvbm3ia5ar6ls9apwc6ampy5blmfxkigi6z0g02"))
160 (patches (list (search-patch "ttf2eot-cstddef.patch")))))
161 (build-system gnu-build-system)
162 (arguments
163 `(#:tests? #f ;no tests
164 #:phases
165 (modify-phases %standard-phases
166 (delete 'configure) ;no configuration
167 (replace 'install
168 (lambda* (#:key outputs #:allow-other-keys)
169 (let* ((out (assoc-ref outputs "out"))
170 (bin (string-append out "/bin")))
171 (install-file "ttf2eot" bin)))))))
172 (synopsis "Convert from TrueType to Embeddable Open Type")
173 (description
174 "This package contains a commandline wrapper around OpenTypeUtilities.cpp
175 from Chromium, used to make EOT (Embeddable Open Type) files from
176 TTF (TrueType/OpenType Font) files.")
177 ;; While the README states "License: Derived from WebKit, so BSD/LGPL
178 ;; 2/LGPL 2.1", the single derived source file includes only BSD in its
179 ;; license header, and the wrapper source contains no license header.
180 (license license:bsd-2)
181 (home-page "https://code.google.com/archive/p/ttf2eot/")))
182
183 (define-public woff2
184 (let ((commit "4e698b8c6c5e070d53c340db9ddf160e21070ede")
185 (revision "1"))
186 (package
187 (name "woff2")
188 (version (string-append "20160306-" revision "."
189 (string-take commit 7)))
190 (source (origin
191 (method git-fetch)
192 (uri (git-reference
193 (url "https://github.com/google/woff2.git")
194 (commit commit)))
195 (file-name (string-append name "-" version ".tar.xz"))
196 (sha256
197 (base32
198 "0wka0yhf0cjmd4rv2jckxpyv6lb5ckj4nj0k1ajq5hrjy7f30lcp"))
199 (patches (list (search-patch "woff2-libbrotli.patch")))))
200 (build-system gnu-build-system)
201 (native-inputs
202 `(("pkg-config" ,pkg-config)))
203 (inputs
204 `(("brotli" ,brotli)))
205 (arguments
206 `(#:tests? #f ;no tests
207 #:phases (modify-phases %standard-phases
208 (delete 'configure)
209 (replace 'install
210 (lambda* (#:key outputs #:allow-other-keys)
211 (let* ((out (assoc-ref outputs "out"))
212 (bin (string-append out "/bin")))
213 (install-file "woff2_compress" bin)
214 (install-file "woff2_decompress" bin)
215 #t))))))
216 (synopsis "Compress TrueType fonts to WOFF2")
217 (description
218 "This package provides utilities for compressing/decompressing TrueType
219 fonts to/from the WOFF2 format.")
220 (license license:asl2.0)
221 (home-page "https://github.com/google/woff2"))))
222
223 (define-public fontconfig
224 (package
225 (name "fontconfig")
226 (version "2.12.1")
227 (source (origin
228 (method url-fetch)
229 (uri (string-append
230 "https://www.freedesktop.org/software/fontconfig/release/fontconfig-"
231 version ".tar.bz2"))
232 (sha256 (base32
233 "1wy7svvp7df6bjpg1m5vizb3ngd7rhb20vpclv3x3qa71khs6jdl"))))
234 (build-system gnu-build-system)
235 (propagated-inputs `(("expat" ,expat)
236 ("freetype" ,freetype)))
237 (inputs `(("gs-fonts" ,gs-fonts)))
238 (native-inputs
239 `(("pkg-config" ,pkg-config)))
240 (arguments
241 `(#:configure-flags
242 (list "--with-cache-dir=/var/cache/fontconfig"
243 ;; register gs-fonts as default fonts
244 (string-append "--with-default-fonts="
245 (assoc-ref %build-inputs "gs-fonts")
246 "/share/fonts")
247
248 ;; Register fonts from user and system profiles.
249 (string-append "--with-add-fonts="
250 "~/.guix-profile/share/fonts,"
251 "/run/current-system/profile/share/fonts")
252
253 ;; python is not actually needed
254 "PYTHON=false")
255 #:phases
256 (modify-phases %standard-phases
257 (replace 'install
258 (lambda _
259 ;; Don't try to create /var/cache/fontconfig.
260 (zero? (system* "make" "install"
261 "fc_cachedir=$(TMPDIR)"
262 "RUN_FC_CACHE_TEST=false")))))))
263 (synopsis "Library for configuring and customizing font access")
264 (description
265 "Fontconfig can discover new fonts when installed automatically;
266 perform font name substitution, so that appropriate alternative fonts can
267 be selected if fonts are missing;
268 identify the set of fonts required to completely cover a set of languages;
269 have GUI configuration tools built as it uses an XML-based configuration file;
270 efficiently and quickly find needed fonts among the set of installed fonts;
271 be used in concert with the X Render Extension and FreeType to implement
272 high quality, anti-aliased and subpixel rendered text on a display.")
273 ; The exact license is more X11-style than BSD-style.
274 (license (license:non-copyleft "file://COPYING"
275 "See COPYING in the distribution."))
276 (home-page "http://www.freedesktop.org/wiki/Software/fontconfig")))
277
278 (define-public t1lib
279 (package
280 (name "t1lib")
281 (version "5.1.2")
282 (source (origin
283 (method url-fetch)
284 (uri (list (string-append "ftp://sunsite.unc.edu/pub/Linux/libs/"
285 "graphics/" name "-" version ".tar.gz")
286 (string-append "https://fossies.org/linux/misc/old/"
287 name "-" version ".tar.gz")))
288 (sha256 (base32
289 "0nbvjpnmcznib1nlgg8xckrmsw3haa154byds2h90y2g0nsjh4w2"))
290 (patches (search-patches
291 "t1lib-CVE-2010-2642.patch"
292 "t1lib-CVE-2011-0764.patch"
293 "t1lib-CVE-2011-1552+CVE-2011-1553+CVE-2011-1554.patch"))))
294 (build-system gnu-build-system)
295 (arguments
296 ;; Making the documentation requires latex, but t1lib is also an input
297 ;; for building texlive.
298 `(#:tests? #f ; no test target
299 #:make-flags
300 '("without_doc")))
301 (synopsis "Library for generating bitmaps from Type 1 fonts")
302 (description
303 "T1lib is a library for generating/rasterising bitmaps from Type 1 fonts.
304 It is based on the code of the X11 rasteriser of the X11 project.
305
306 The bitmaps created by t1lib are returned in a data structure with type
307 GLYPH. This special GLYPH-type is also used in the X11 window system to
308 describe character bitmaps. It contains the bitmap data as well as some
309 metric information. But t1lib is in itself entirely independent of the
310 X11-system or any other graphical user interface.")
311 (license license:gpl2)
312 (home-page "http://www.t1lib.org/")))
313
314 (define-public teckit
315 (package
316 (name "teckit")
317 (version "2.5.4")
318 (source (origin
319 ;; Downloaded tarballs vary with each download, so we use an
320 ;; svn snapshot. The 2.5.4 release seems to be made in r128,
321 ;; but r132 updates additional files to contain the correct
322 ;; version number (r129 to r131 do not concern TRUNK).
323 (method svn-fetch)
324 (uri (svn-reference
325 (url "https://scripts.sil.org/svn-public/teckit/TRUNK")
326 (revision 132)))
327 (file-name (string-append name "-" version))
328 (sha256
329 (base32
330 "1xqkqgw30pb24snh46srmjs2j4zhz2dfi5pf7znia0k34mrpwivz"))))
331 (build-system gnu-build-system)
332 (inputs `(("zlib" ,zlib)))
333 (native-inputs
334 `(("autoconf" ,autoconf)
335 ("automake" ,automake)
336 ("libtool" ,libtool)
337 ("perl" ,perl))) ; for the tests
338 (arguments
339 `(#:phases
340 (modify-phases %standard-phases
341 (add-after 'unpack 'autogen
342 (lambda _
343 (zero? (system* "sh" "autogen.sh")))))))
344 (synopsis "Toolkit for encoding conversions")
345 (description
346 "TECkit is a low-level toolkit intended to be used by other applications
347 that need to perform encoding conversions (e.g., when importing legacy data
348 into a Unicode-based application). The primary component of the TECkit
349 package is therefore a library that performs conversions; this is the
350 \"TECkit engine\". The engine relies on mapping tables in a specific binary
351 format (for which documentation is available); there is a compiler that
352 creates such tables from a human-readable mapping description (a simple
353 text file).
354
355 To facilitate the development and testing of mapping tables for TECkit,
356 several applications are also included in the current package; these
357 include simple tools for applying conversions to plain-text and Standard
358 Format files, as well as both command-line and simple GUI versions of the
359 TECkit compiler. However, it is not intended that these tools will be the
360 primary means by which end users perform conversions, and they have not
361 been designed, tested, and debugged to the extent that general-purpose
362 applications should be.")
363 (license license:lgpl2.1+)
364 (home-page "http://scripts.sil.org/cms/scripts/page.php?cat_id=teckit")))
365
366 (define-public graphite2
367 (package
368 (name "graphite2")
369 (version "1.3.9")
370 (source
371 (origin
372 (method url-fetch)
373 (uri (string-append "https://github.com/silnrsi/graphite/releases/"
374 "download/" version "/" name "-" version ".tgz"))
375 (sha256
376 (base32
377 "0rs5h7m340z75kygx8d72cps0q6yvvqa9i788vym7585cfv8a0gc"))))
378 (build-system cmake-build-system)
379 (native-inputs
380 `(("python" ,python-2) ; because of "import imap" in tests
381 ("python-fonttools" ,python2-fonttools)))
382 (inputs
383 `(("freetype" ,freetype)))
384 (synopsis "Reimplementation of the SIL Graphite text processing engine")
385 (description
386 "Graphite2 is a reimplementation of the SIL Graphite text processing
387 engine. Graphite is a smart font technology designed to facilitate the
388 process known as shaping. This process takes an input Unicode text string
389 and returns a sequence of positioned glyphids from the font.")
390 (license license:lgpl2.1+)
391 (home-page "https://github.com/silnrsi/graphite")))
392
393 (define-public potrace
394 (package
395 (name "potrace")
396 (version "1.13")
397 (source
398 (origin
399 (method url-fetch)
400 (uri (string-append "mirror://sourceforge/potrace/" version
401 "/potrace-" version ".tar.gz"))
402 (sha256
403 (base32
404 "115p2vgyq7p2mf4nidk2x3aa341nvv2v8ml056vbji36df5l6lk2"))))
405 (build-system gnu-build-system)
406 (native-inputs `(("ghostscript" ,ghostscript))) ;for tests
407 (inputs `(("zlib" ,zlib)))
408 (arguments
409 `(#:configure-flags
410 `("--with-libpotrace"))) ; install library and headers
411 (synopsis "Transform bitmaps into vector graphics")
412 (description
413 "Potrace is a tool for tracing a bitmap, which means, transforming a
414 bitmap into a smooth, scalable image. The input is a bitmap (PBM, PGM, PPM,
415 or BMP format), and the default output is an encapsulated PostScript
416 file (EPS). A typical use is to create EPS files from scanned data, such as
417 company or university logos, handwritten notes, etc. The resulting image is
418 not \"jaggy\" like a bitmap, but smooth. It can then be rendered at any
419 resolution.")
420 (license license:gpl2+)
421 (home-page "http://potrace.sourceforge.net/")))
422
423 (define-public libotf
424 (package
425 (name "libotf")
426 (version "0.9.13")
427 (source (origin
428 (method url-fetch)
429 (uri (string-append "mirror://savannah/m17n/libotf-"
430 version ".tar.gz"))
431 (sha256
432 (base32 "0239zvfan56w7vrppriwy77fzb10ag9llaz15nsraps2a2x6di3v"))))
433 (build-system gnu-build-system)
434 (propagated-inputs
435 `(("freetype" ,freetype)))
436 (home-page "http://www.nongnu.org/m17n/")
437 (synopsis "Library for handling OpenType Font")
438 (description "This library can read Open Type Layout Tables from an OTF
439 file. Currently these tables are supported; head, name, cmap, GDEF, GSUB, and
440 GPOS. It can convert a Unicode character sequence to a glyph code sequence by
441 using the above tables.")
442 (license license:lgpl2.0+)))
443
444 (define-public libspiro
445 (package
446 (name "libspiro")
447 (version "20071029")
448 (source
449 (origin
450 (method url-fetch)
451 (uri (string-append "mirror://sourceforge/libspiro/libspiro/"
452 version "/libspiro_src-" version ".tar.bz2"))
453 (sha256
454 (base32
455 "1kylz8pvwnb85yya150r9i6mhbpzx38f32qy523qg3ylgd9b3zhy"))))
456 (build-system gnu-build-system)
457 (arguments `(#:tests? #f)) ;no tests
458 (synopsis "Clothoid to bezier conversion library")
459 (description
460 "Raph Levien's Spiro package as a library. A mechanism for drawing
461 smooth contours with constant curvature at the spline joins.")
462 (license license:gpl2+)
463 (home-page "http://libspiro.sourceforge.net/")))
464
465 (define-public libuninameslist
466 (package
467 (name "libuninameslist")
468 (version "20160701")
469 (source
470 (origin
471 (method url-fetch)
472 (uri (string-append "https://github.com/fontforge/libuninameslist/"
473 "archive/" version ".tar.gz"))
474 (file-name (string-append name "-" version ".tar.gz"))
475 (sha256
476 (base32
477 "12xxb301a66dh282pywpy00wxiaq5z8z20qm3pr2vql04r2g8d0x"))))
478 (build-system gnu-build-system)
479 (native-inputs `(("autoconf" ,autoconf)
480 ("automake" ,automake)
481 ("libtool" ,libtool)))
482 (arguments
483 `(#:phases
484 (modify-phases %standard-phases
485 (add-after 'unpack 'bootstrap
486 (lambda _ (zero? (system* "autoreconf" "-vi")))))))
487 (synopsis "Unicode names and annotation list")
488 (description
489 "LibUniNamesList holds www.unicode.org Nameslist.txt data which can be
490 useful for programs that need Unicode \"Names\", \"Annotations\", and block
491 definitions.")
492 (license license:gpl2)
493 (home-page "https://github.com/fontforge/libuninameslist")))
494
495 (define-public fontforge
496 (package
497 (name "fontforge")
498 (version "20160404")
499 (source (origin
500 (method url-fetch)
501 (uri (string-append
502 "https://github.com/fontforge/fontforge/releases/download/"
503 version "/fontforge-dist-" version ".tar.gz"))
504 (sha256 (base32
505 "1kavnhbkzc1hk6f39fynq9s0haama81ddrbld4b5x60d0dbaawvc"))
506 (modules '((guix build utils)))
507 (snippet
508 '(begin
509 ;; Make builds bit-reproducible by using fixed date strings.
510 (substitute* "configure"
511 (("^FONTFORGE_MODTIME=.*$")
512 "FONTFORGE_MODTIME=\"1459819518L\"\n")
513 (("^FONTFORGE_MODTIME_STR=.*$")
514 "FONTFORGE_MODTIME_STR=\"20:25 CDT 4-Apr-2016\"\n")
515 (("^FONTFORGE_VERSIONDATE=.*$")
516 "FONTFORGE_VERSIONDATE=\"20160404\"\n"))))
517 (patches (list (search-patch "fontforge-svg-modtime.patch")))))
518 (build-system gnu-build-system)
519 (native-inputs
520 `(("pkg-config" ,pkg-config)))
521 (inputs `(("cairo" ,cairo)
522 ("fontconfig" ,fontconfig) ;dlopen'd
523 ("freetype" ,freetype)
524 ("gettext" ,gettext-minimal)
525 ("glib" ,glib) ;needed for pango detection
526 ("libICE" ,libice)
527 ("libSM" ,libsm)
528 ("libX11" ,libx11)
529 ("libXi" ,libxi)
530 ("libjpeg" ,libjpeg)
531 ("libltdl" ,libltdl)
532 ("libpng" ,libpng)
533 ("libspiro" ,libspiro)
534 ("libtiff" ,libtiff)
535 ("libungif" ,libungif)
536 ("libuninameslist" ,libuninameslist)
537 ("libxft" ,libxft)
538 ("libxml2" ,libxml2)
539 ("pango" ,pango)
540 ("potrace" ,potrace)
541 ("python" ,python)
542 ("zlib" ,zlib)))
543 (arguments
544 '(#:tests? #f
545 #:phases
546 (modify-phases %standard-phases
547 (add-after 'build 'build-contrib
548 (lambda* (#:key outputs #:allow-other-keys)
549 (let* ((out (assoc-ref outputs "out"))
550 (bin (string-append out "/bin")))
551 (and (zero? (system* "make" "-Ccontrib/fonttools"
552 "CC=gcc" "showttf"))
553 (begin (install-file "contrib/fonttools/showttf" bin)
554 #t)))))
555 (add-after 'install 'set-library-path
556 (lambda* (#:key inputs outputs #:allow-other-keys)
557 (let ((out (assoc-ref outputs "out"))
558 (potrace (string-append (assoc-ref inputs "potrace") "/bin")))
559 (wrap-program (string-append out "/bin/fontforge")
560 ;; Fontforge dynamically opens libraries.
561 `("LD_LIBRARY_PATH" ":" prefix
562 ,(map (lambda (input)
563 (string-append (assoc-ref inputs input)
564 "/lib"))
565 '("libtiff" "libjpeg" "libpng" "libungif"
566 "libxml2" "zlib" "libspiro" "freetype"
567 "pango" "cairo" "fontconfig")))
568 ;; Checks for potrace program at runtime
569 `("PATH" ":" prefix (,potrace)))))))))
570 (synopsis "Outline font editor")
571 (description
572 "FontForge allows you to create and modify postscript, truetype and
573 opentype fonts. You can save fonts in many different outline formats, and
574 generate bitmaps.")
575 (license license:gpl3+)
576 (home-page "http://fontforge.org/")))