Merge branch 'master' into staging
[jackhill/guix/guix.git] / gnu / packages / rrdtool.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages rrdtool)
20 #:use-module ((guix licenses) #:prefix license:)
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (guix build-system gnu)
24 #:use-module (gnu packages)
25 #:use-module (gnu packages base)
26 #:use-module (gnu packages pkg-config)
27 #:use-module (gnu packages groff)
28 #:use-module (gnu packages python)
29 #:use-module (gnu packages fontutils)
30 #:use-module (gnu packages glib)
31 #:use-module (gnu packages gtk)
32 #:use-module (gnu packages xml))
33
34 (define-public rrdtool
35 (package
36 (name "rrdtool")
37 (version "1.4.8")
38 (source (origin
39 (method url-fetch)
40 (uri (string-append "http://oss.oetiker.ch/rrdtool/pub/rrdtool-"
41 version ".tar.gz"))
42 (sha256
43 (base32
44 "1mpki7pv5ql73h5al04dps6dky0nqc3mmb8ac21hd2s8mbsvk5fy"))))
45 (build-system gnu-build-system)
46 (inputs `(("cairo" ,cairo)
47 ("glib" ,glib)
48 ("gtk" ,gtk+-2)
49 ("pango" ,pango)
50 ("freetype" ,freetype)
51 ("libxml2" ,libxml2)
52 ("python" ,python-2)))
53 (native-inputs `(("pkg-config" ,pkg-config)
54 ("groff" ,groff)))
55 (arguments
56 '(#:phases
57 (modify-phases %standard-phases
58 (add-before 'configure 'pre-configure
59 (lambda _
60 (substitute* "libtool"
61 (("/bin/sed") (which "sed")))
62 (substitute* "src/Makefile.in"
63 (("^rrdcached_LDADD = librrd_th.la")
64 "rrdcached_LDADD = librrd_th.la -lglib-2.0"))
65 #t)))))
66 (home-page "http://oss.oetiker.ch/rrdtool/")
67 (synopsis "Time-series data storage and display system")
68 (description
69 "The Round Robin Database Tool (RRDtool) is a system to store and display
70 time-series data (e.g. network bandwidth, machine-room temperature, server
71 load average). It stores the data in Round Robin Databases (RRDs), a very
72 compact way that will not expand over time. RRDtool processes the extracted
73 data to enforce a certain data density, allowing for useful graphical
74 representation of data values.")
75 (license license:gpl2+))) ; with license exception that allows combining
76 ; with many other licenses.