gnu: openvpn: Update to 2.5.1 [security fixes].
[jackhill/guix/guix.git] / gnu / packages / vpn.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
3 ;;; Copyright © 2013, 2016, 2018, 2019, 2020 Ludovic Courtès <ludo@gnu.org>
4 ;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
5 ;;; Copyright © 2015 Jeff Mickey <j@codemac.net>
6 ;;; Copyright © 2016, 2017, 2019, 2021 Efraim Flashner <efraim@flashner.co.il>
7 ;;; Copyright © 2016–2021 Tobias Geerinckx-Rice <me@tobias.gr>
8 ;;; Copyright © 2017 Julien Lepiller <julien@lepiller.eu>
9 ;;; Copyright © 2018, 2020 Pierre Langlois <pierre.langlois@gmx.com>
10 ;;; Copyright © 2018 Meiyo Peng <meiyo.peng@gmail.com>
11 ;;; Copyright © 2019, 2020 Leo Famulari <leo@famulari.name>
12 ;;; Copyright © 2019 Rutger Helling <rhelling@mykolab.com>
13 ;;; Copyright © 2019 Ricardo Wurmus <rekado@elephly.net>
14 ;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
15 ;;; Copyright © 2020 Ryan Prior <rprior@protonmail.com>
16 ;;; Copyright © 2020 Ivan Kozlov <kanichos@yandex.ru>
17 ;;; Copyright © 2020 David Dashyan <mail@davie.li>
18 ;;;
19 ;;; This file is part of GNU Guix.
20 ;;;
21 ;;; GNU Guix is free software; you can redistribute it and/or modify it
22 ;;; under the terms of the GNU General Public License as published by
23 ;;; the Free Software Foundation; either version 3 of the License, or (at
24 ;;; your option) any later version.
25 ;;;
26 ;;; GNU Guix is distributed in the hope that it will be useful, but
27 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
28 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
29 ;;; GNU General Public License for more details.
30 ;;;
31 ;;; You should have received a copy of the GNU General Public License
32 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
33
34 (define-module (gnu packages vpn)
35 #:use-module ((guix licenses) #:prefix license:)
36 #:use-module (guix packages)
37 #:use-module (guix download)
38 #:use-module (guix git-download)
39 #:use-module (guix build-system cmake)
40 #:use-module (guix build-system gnu)
41 #:use-module (guix build-system linux-module)
42 #:use-module (guix build-system python)
43 #:use-module (guix utils)
44 #:use-module (gnu packages)
45 #:use-module (gnu packages admin)
46 #:use-module (gnu packages base)
47 #:use-module (gnu packages bash)
48 #:use-module (gnu packages check)
49 #:use-module (gnu packages dns)
50 #:use-module (gnu packages autotools)
51 #:use-module (gnu packages compression)
52 #:use-module (gnu packages freedesktop)
53 #:use-module (gnu packages gettext)
54 #:use-module (gnu packages gnupg)
55 #:use-module (gnu packages guile)
56 #:use-module (gnu packages libevent)
57 #:use-module (gnu packages linux)
58 #:use-module (gnu packages ncurses)
59 #:use-module (gnu packages nss)
60 #:use-module (gnu packages perl)
61 #:use-module (gnu packages pkg-config)
62 #:use-module (gnu packages python)
63 #:use-module (gnu packages python-build)
64 #:use-module (gnu packages python-crypto)
65 #:use-module (gnu packages python-xyz)
66 #:use-module (gnu packages python-web)
67 #:use-module (gnu packages qt)
68 #:use-module (gnu packages samba)
69 #:use-module (gnu packages tls)
70 #:use-module (gnu packages xml))
71
72 (define-public gvpe
73 (package
74 (name "gvpe")
75 (version "3.1")
76 (source (origin
77 (method url-fetch)
78 (uri (string-append "mirror://gnu/gvpe/gvpe-"
79 version ".tar.gz"))
80 (sha256
81 (base32
82 "1cz8n75ksl0l908zc5l3rnfm1hv7130s2w8710799fr5sxrdbszi"))))
83 (build-system gnu-build-system)
84 (home-page "http://software.schmorp.de/pkg/gvpe.html")
85 (native-inputs `(("pkg-config" ,pkg-config)))
86 (inputs `(("openssl" ,openssl)
87 ("zlib" ,zlib)))
88 (synopsis "Secure VPN among multiple nodes over an untrusted network")
89 (description
90 "The GNU Virtual Private Ethernet creates a virtual network
91 with multiple nodes using a variety of transport protocols. It works
92 by creating encrypted host-to-host tunnels between multiple
93 endpoints.")
94 (license license:gpl3+)))
95
96 (define-public vpnc
97 (package
98 (name "vpnc")
99 (version "0.5.3")
100 (source (origin
101 (method url-fetch)
102 (uri (string-append "https://www.unix-ag.uni-kl.de/~massar/vpnc/vpnc-"
103 version ".tar.gz"))
104 (sha256 (base32
105 "1128860lis89g1s21hqxvap2nq426c9j4bvgghncc1zj0ays7kj6"))))
106 (build-system gnu-build-system)
107 (inputs `(("libgcrypt" ,libgcrypt)
108 ("perl" ,perl)
109 ("vpnc-scripts" ,vpnc-scripts)))
110 (arguments
111 `(#:tests? #f ; there is no check target
112 #:phases
113 (modify-phases %standard-phases
114 (add-after 'unpack 'use-store-paths
115 (lambda* (#:key inputs outputs #:allow-other-keys)
116 (let ((out (assoc-ref outputs "out"))
117 (vpnc-scripts (assoc-ref inputs "vpnc-scripts")))
118 (substitute* "config.c"
119 (("/etc/vpnc/vpnc-script")
120 (string-append vpnc-scripts "/etc/vpnc/vpnc-script")))
121 (substitute* "Makefile"
122 (("ETCDIR=.*")
123 (string-append "ETCDIR=" out "/etc/vpnc\n"))
124 (("PREFIX=.*")
125 (string-append "PREFIX=" out "\n")))
126 #t)))
127 (delete 'configure)))) ; no configure script
128 (synopsis "Client for Cisco VPN concentrators")
129 (description
130 "vpnc is a VPN client compatible with Cisco's EasyVPN equipment.
131 It supports IPSec (ESP) with Mode Configuration and Xauth. It supports only
132 shared-secret IPSec authentication with Xauth, AES (256, 192, 128), 3DES,
133 1DES, MD5, SHA1, DH1/2/5 and IP tunneling. It runs entirely in userspace.
134 Only \"Universal TUN/TAP device driver support\" is needed in the kernel.")
135 (license license:gpl2+) ; some file are bsd-2, see COPYING
136 (home-page "https://www.unix-ag.uni-kl.de/~massar/vpnc/")))
137
138 (define-public vpnc-scripts
139 (let ((commit "3885f8bbc4ae03fd6da0ada6de12f7223a59595c"))
140 (package
141 (name "vpnc-scripts")
142 (version (string-append "20200925." (string-take commit 7)))
143 (source (origin
144 (method git-fetch)
145 (uri
146 (git-reference
147 (url "git://git.infradead.org/users/dwmw2/vpnc-scripts.git")
148 (commit commit)))
149 (file-name (git-file-name name version))
150 (sha256
151 (base32
152 "1pmi4n58q81pmn9arvfixhvv6vkkf3rpwac3hwnwyl882q5q0ccx"))))
153 (build-system gnu-build-system)
154 (inputs `(("guile" ,guile-3.0) ; for the wrapper scripts
155 ("coreutils" ,coreutils)
156 ("grep" ,grep)
157 ("iproute2" ,iproute) ; for ‘ip’
158 ("net-tools" ,net-tools) ; for ‘ifconfig’, ‘route’
159 ("sed" ,sed)
160 ("which" ,which)))
161 (arguments
162 `(#:phases
163 (modify-phases %standard-phases
164 (add-after 'unpack 'use-relative-paths
165 ;; Patch the scripts to work with and use relative paths.
166 (lambda* _
167 (for-each (lambda (script)
168 (substitute* script
169 (("^PATH=.*") "")
170 (("/usr/s?bin/") "")
171 (("\\[ +-x +([^]]+) +\\]" _ command)
172 (string-append "command -v >/dev/null 2>&1 "
173 command))))
174 (find-files "." "^vpnc-script"))
175 #t))
176 (delete 'configure) ; no configure script
177 (replace 'build
178 (lambda _
179 (invoke "gcc" "-o" "netunshare" "netunshare.c")))
180 (replace 'install
181 ;; There is no Makefile; manually install the relevant files.
182 (lambda* (#:key outputs #:allow-other-keys)
183 (let* ((out (assoc-ref outputs "out"))
184 (etc (string-append out "/etc/vpnc")))
185 (for-each (lambda (file)
186 (install-file file etc))
187 (append (find-files "." "^vpnc-script")
188 (list "netunshare"
189 "xinetd.netns.conf")))
190 #t)))
191 (add-after 'install 'wrap-scripts
192 ;; Wrap scripts with paths to their common hard dependencies.
193 ;; Optional dependencies will need to be installed by the user.
194 (lambda* (#:key inputs outputs #:allow-other-keys)
195 (let ((out (assoc-ref outputs "out")))
196 (for-each
197 (lambda (script)
198 (wrap-script (string-append out "/etc/vpnc/" script)
199 `("PATH" ":" prefix
200 ,(map (lambda (name)
201 (let ((input (assoc-ref inputs name)))
202 (string-append input "/bin:"
203 input "/sbin")))
204 (list "coreutils"
205 "grep"
206 "iproute2"
207 "net-tools"
208 "sed"
209 "which")))))
210 (list "vpnc-script-ptrtd"
211 "vpnc-script-sshd"
212 "vpnc-script"))
213 #t))))
214 #:tests? #f)) ; no tests
215 (home-page "http://git.infradead.org/users/dwmw2/vpnc-scripts.git")
216 (synopsis "Network configuration scripts for Cisco VPN clients")
217 (description
218 "This set of scripts configures routing and name services when invoked
219 by the VPNC or OpenConnect Cisco @dfn{Virtual Private Network} (VPN) clients.
220
221 The default @command{vpnc-script} automatically configures most common
222 connections, and provides hooks for performing custom actions at various stages
223 of the connection or disconnection process.
224
225 Alternative scripts are provided for more complicated set-ups, or to serve as an
226 example for writing your own. For example, @command{vpnc-script-sshd} contains
227 the entire VPN in a network namespace accessible only through SSH.")
228 (license license:gpl2+))))
229
230 (define-public ocproxy
231 (package
232 (name "ocproxy")
233 (version "1.60")
234 (source (origin
235 (method git-fetch)
236 (uri (git-reference
237 (url "https://github.com/cernekee/ocproxy")
238 (commit (string-append "v" version))))
239 (file-name (git-file-name name version))
240 (sha256
241 (base32
242 "03323nnhb4y9nzwva04mq7xg03dvdrgp689g89f69jqc261skcqx"))))
243 (build-system gnu-build-system)
244 (native-inputs
245 `(("autoconf" ,autoconf)
246 ("automake" ,automake)))
247 (inputs
248 `(("libevent" ,libevent)))
249 (home-page "https://github.com/cernekee/ocproxy")
250 (synopsis "OpenConnect proxy")
251 (description
252 "User-level @dfn{SOCKS} and port forwarding proxy for OpenConnect based
253 on LwIP. When using ocproxy, OpenConnect only handles network activity that
254 the user specifically asks to proxy, so the @dfn{VPN} interface no longer
255 \"hijacks\" all network traffic on the host.")
256 (license license:bsd-3)))
257
258 (define-public openconnect
259 (package
260 (name "openconnect")
261 (version "8.10")
262 (source (origin
263 (method url-fetch)
264 (uri (string-append "ftp://ftp.infradead.org/pub/openconnect/"
265 "openconnect-" version ".tar.gz"))
266 (sha256
267 (base32 "1cdsx4nsrwawbsisfkldfc9i4qn60g03vxb13nzppr2br9p4rrih"))))
268 (build-system gnu-build-system)
269 (propagated-inputs
270 `(("libxml2" ,libxml2)
271 ("gnutls" ,gnutls)
272 ("zlib" ,zlib)))
273 (inputs
274 `(("lz4" ,lz4)
275 ("vpnc-scripts" ,vpnc-scripts)))
276 (native-inputs
277 `(("gettext" ,gettext-minimal)
278 ("pkg-config" ,pkg-config)))
279 (arguments
280 `(#:configure-flags
281 `(,(string-append "--with-vpnc-script="
282 (assoc-ref %build-inputs "vpnc-scripts")
283 "/etc/vpnc/vpnc-script"))))
284 (synopsis "Client for Cisco VPN")
285 (description
286 "OpenConnect is a client for Cisco's AnyConnect SSL VPN, which is
287 supported by the ASA5500 Series, by IOS 12.4(9)T or later on Cisco SR500,
288 870, 880, 1800, 2800, 3800, 7200 Series and Cisco 7301 Routers,
289 and probably others.")
290 (license license:lgpl2.1)
291 (home-page "https://www.infradead.org/openconnect/")))
292
293 (define-public openconnect-sso
294 (package
295 (name "openconnect-sso")
296 (version "0.6.2")
297 (source
298 (origin
299 (method url-fetch)
300 (uri (pypi-uri "openconnect-sso" version))
301 (sha256
302 (base32
303 "1yybmscka3m5yxfkp1m5pqz2m8jlwdq9b0hx2w5l1jj6bzpl9fsf"))))
304 (build-system python-build-system)
305 (arguments
306 `(#:tests? #f ; Tests not included, building from git requires poetry.
307 #:phases
308 (modify-phases %standard-phases
309 (add-after 'unpack 'adjust-package-version-requirements
310 (lambda _
311 (substitute* "setup.py"
312 (("(pyxdg>=0.26),<0.27" _ pyxdg) pyxdg))
313 #t))
314 (add-after 'unpack 'patch-openconnect
315 (lambda _
316 (substitute* "openconnect_sso/app.py"
317 (("\"openconnect\"")
318 (string-append "\"" (which "openconnect") "\"")))
319 #t))
320 (replace 'check
321 (lambda* (#:key tests? #:allow-other-keys)
322 (when tests?
323 (invoke "pytest" "-v"))
324 #t))
325 (add-after 'install 'wrap-qt-process-path
326 (lambda* (#:key inputs outputs #:allow-other-keys)
327 (let* ((out (assoc-ref outputs "out"))
328 (bin (string-append out "/bin/openconnect-sso"))
329 (qt-process-path (string-append
330 (assoc-ref inputs "qtwebengine")
331 "/lib/qt5/libexec/QtWebEngineProcess")))
332 (wrap-program bin
333 `("QTWEBENGINEPROCESS_PATH" = (,qt-process-path)))
334 #t))))))
335 (inputs
336 `(("openconnect" ,openconnect)
337 ("python-attrs" ,python-attrs)
338 ("python-colorama" ,python-colorama)
339 ("python-keyring" ,python-keyring)
340 ("python-lxml" ,python-lxml)
341 ("python-prompt-toolkit" ,python-prompt-toolkit)
342 ("python-requests" ,python-requests)
343 ("python-pyqt" ,python-pyqt)
344 ("python-pyqtwebengine" ,python-pyqtwebengine)
345 ("python-pysocks" ,python-pysocks)
346 ("python-pyxdg" ,python-pyxdg)
347 ("python-structlog" ,python-structlog)
348 ("python-toml" ,python-toml)
349 ("qtwebengine" ,qtwebengine)))
350 (native-inputs
351 `(("python-pytest" ,python-pytest)
352 ("python-setuptools-scm" ,python-setuptools-scm)))
353 (home-page "https://github.com/vlaci/openconnect-sso")
354 (synopsis "OpenConnect wrapper script supporting Azure AD (SAMLv2)")
355 (description
356 "This package provides a wrapper script for OpenConnect supporting Azure AD
357 (SAMLv2) authentication to Cisco SSL-VPNs.")
358 (license license:gpl3)))
359
360 (define-public openfortivpn
361 (package
362 (name "openfortivpn")
363 (version "1.15.0")
364 (source (origin
365 (method git-fetch)
366 (uri (git-reference
367 (url "https://github.com/adrienverge/openfortivpn")
368 (commit (string-append "v" version))))
369 (file-name (git-file-name name version))
370 (sha256
371 (base32
372 "1qsfgpxg553s8rc9cyrc4k96z0pislxsdxb9wyhp8fdprkak2mw2"))))
373 (build-system gnu-build-system)
374 (native-inputs
375 `(("autoconf" ,autoconf)
376 ("autotools" ,automake)
377 ("pkg-config" ,pkg-config)))
378 (inputs
379 `(("openssl" ,openssl)
380 ("ppp" ,ppp)))
381 (home-page "https://github.com/adrienverge/openfortivpn")
382 (synopsis "Client for PPP+SSL VPN tunnel services")
383 (description "Openfortivpn is a client for PPP+SSL VPN tunnel services. It
384 spawns a pppd process and operates the communication between the gateway and
385 this process. It is compatible with Fortinet VPNs.")
386 (license license:gpl3+)))
387
388 (define-public openvpn
389 (package
390 (name "openvpn")
391 (version "2.5.1")
392 (source (origin
393 (method url-fetch)
394 (uri (string-append
395 "https://swupdate.openvpn.org/community/releases/openvpn-"
396 version ".tar.xz"))
397 (sha256
398 (base32
399 "157ikzap2bbkzx34hkh33bpk2i14xjx1x3pkadhmzh1pr24h94s0"))))
400 (build-system gnu-build-system)
401 (arguments
402 '(#:configure-flags '("--enable-iproute2=yes")))
403 (native-inputs
404 `(("iproute2" ,iproute)))
405 (inputs
406 `(("lz4" ,lz4)
407 ("lzo" ,lzo)
408 ("openssl" ,openssl)
409 ("linux-pam" ,linux-pam)))
410 (home-page "https://openvpn.net/")
411 (synopsis "Virtual private network daemon")
412 (description
413 "OpenVPN implements virtual private network (@dfn{VPN}) techniques
414 for creating secure point-to-point or site-to-site connections in routed or
415 bridged configurations and remote access facilities. It uses a custom
416 security protocol that utilizes SSL/TLS for key exchange. It is capable of
417 traversing network address translators (@dfn{NAT}s) and firewalls.")
418 (license license:gpl2)))
419
420 (define-public protonvpn-cli
421 (package
422 (name "protonvpn-cli")
423 (version "2.2.6")
424 (source
425 (origin
426 ;; PyPI has a ".whl" file but not a proper source release.
427 ;; Thus, fetch code from Git.
428 (method git-fetch)
429 (uri (git-reference
430 (url "https://github.com/ProtonVPN/linux-cli")
431 (commit (string-append "v" version))))
432 (file-name (git-file-name name version))
433 (sha256
434 (base32 "0y7v9ikrmy5dbjlpbpacp08gy838i8z54m8m4ps7ldk1j6kyia3n"))))
435 (build-system python-build-system)
436 (arguments
437 '(#:tests? #f ; no tests in repo
438 #:phases
439 (modify-phases %standard-phases
440 (add-after 'wrap 'wrap-wrapper
441 ;; Wrap entrypoint with paths to its hard dependencies.
442 (lambda* (#:key inputs outputs #:allow-other-keys)
443 (let ((entrypoint (string-append (assoc-ref outputs "out")
444 "/bin/.protonvpn-real")))
445 (wrap-program entrypoint
446 `("PATH" ":" prefix
447 ,(map (lambda (name)
448 (let ((input (assoc-ref inputs name)))
449 (string-append input "/bin:"
450 input "/sbin")))
451 (list "dialog"
452 "iproute2"
453 "iptables"
454 "ncurses"
455 "openvpn"
456 "procps"
457 "which")))))
458 #t)))))
459 (native-inputs
460 `(("python-docopt" ,python-docopt)))
461 (inputs
462 `(("dialog" ,dialog)
463 ("iproute2" ,iproute)
464 ("iptables" ,iptables)
465 ("ncurses" ,ncurses)
466 ("openvpn" ,openvpn)
467 ("procps" ,procps)
468 ("python-jinja2" ,python-jinja2)
469 ("python-pythondialog" ,python-pythondialog)
470 ("python-requests" ,python-requests)
471 ("which" ,which)))
472 (synopsis "Command-line client for ProtonVPN")
473 (description
474 "This is the official command-line interface for ProtonVPN, a secure
475 point-to-point virtual private networking (VPN) service with a gratis tier.
476 It can automatically find and connect to the fastest servers or use Tor over
477 VPN. The gratis tier offers unlimited bandwidth for up to 10 devices.")
478 (home-page "https://github.com/ProtonVPN/linux-cli")
479 (license license:gpl3+)))
480
481 (define-public tinc
482 (package
483 (name "tinc")
484 (version "1.0.36")
485 (source (origin
486 (method url-fetch)
487 (uri (string-append "https://tinc-vpn.org/packages/"
488 "tinc-" version ".tar.gz"))
489 (sha256
490 (base32
491 "021i2sl2mjscbm8g59d7vs74iw3gf0m48wg7w3zhwj6czarkpxs0"))))
492 (build-system gnu-build-system)
493 (arguments
494 '(#:configure-flags
495 '("--sysconfdir=/etc"
496 "--localstatedir=/var")))
497 (inputs `(("zlib" ,zlib)
498 ("lzo" ,lzo)
499 ("openssl" ,openssl)))
500 (home-page "https://tinc-vpn.org")
501 (synopsis "Virtual Private Network (VPN) daemon")
502 (description
503 "Tinc is a VPN that uses tunnelling and encryption to create a secure
504 private network between hosts on the internet.")
505 (license license:gpl2+)))
506
507 (define-public sshuttle
508 (package
509 (name "sshuttle")
510 (version "0.78.5")
511 (source
512 (origin
513 (method url-fetch)
514 (uri (pypi-uri name version))
515 (sha256
516 (base32
517 "0vp13xwrhx4m6zgsyzvai84lkq9mzkaw47j58dk0ll95kaymk2x8"))))
518 (build-system python-build-system)
519 (arguments
520 `(#:phases
521 (modify-phases %standard-phases
522 (add-after 'unpack 'patch-FHS-file-names
523 (lambda _
524 (substitute* "sshuttle/client.py"
525 (("/usr/bin/env") (which "env")))
526 (substitute* "sshuttle/ssh.py"
527 (("/bin/sh") "sh"))
528 #t)))))
529 (native-inputs
530 `(("python-setuptools-scm" ,python-setuptools-scm)
531 ;; For tests only.
532 ("python-flake8" ,python-flake8)
533 ("python-mock" ,python-mock)
534 ("python-pytest-cov" ,python-pytest-cov)
535 ("python-pytest-runner" ,python-pytest-runner)))
536 (home-page "https://github.com/sshuttle/sshuttle")
537 (synopsis "VPN that transparently forwards connections over SSH")
538 (description "sshuttle creates an encrypted virtual private network (VPN)
539 connection to any remote server to which you have secure shell (SSH) access.
540 The only requirement is a suitable version of Python on the server;
541 administrative privileges are required only on the client. Unlike most VPNs,
542 sshuttle forwards entire sessions, not packets, using kernel transparent
543 proxying. This makes it faster and more reliable than SSH's own tunneling and
544 port forwarding features. It can forward both TCP and UDP traffic, including
545 DNS domain name queries.")
546 (license license:lgpl2.0))) ; incorrectly identified as GPL in ‘setup.py’
547
548 (define-public sshoot
549 (package
550 (name "sshoot")
551 (version "1.2.6")
552 (source
553 (origin
554 (method url-fetch)
555 (uri (pypi-uri name version))
556 (sha256
557 (base32
558 "1ccgh0hjyxrwkgy3hnxz3hgbjbs0lmfs25d5l5jam0xbpcpj63h0"))))
559 (build-system python-build-system)
560 (arguments
561 '(#:phases
562 (modify-phases %standard-phases
563 (add-after 'unpack 'patch-paths
564 (lambda _
565 (substitute* "sshoot/tests/test_manager.py"
566 (("/bin/sh") (which "sh")))
567 #t)))))
568 (inputs
569 `(("python-argcomplete" ,python-argcomplete)
570 ("python-prettytable" ,python-prettytable)
571 ("python-pyyaml" ,python-pyyaml)))
572 ;; For tests only.
573 (native-inputs
574 `(("python-fixtures" ,python-fixtures)
575 ("python-pbr" ,python-pbr)
576 ("python-testtools" ,python-testtools)))
577 (home-page "https://github.com/albertodonato/sshoot")
578 (synopsis "sshuttle VPN session manager")
579 (description "sshoot provides a command-line interface to manage multiple
580 @command{sshuttle} virtual private networks. It supports flexible profiles
581 with configuration options for most of @command{sshuttle}’s features.")
582 (license license:gpl3+)))
583
584 (define-public badvpn
585 (package
586 (name "badvpn")
587 (version "1.999.130")
588 (source
589 (origin
590 (method git-fetch)
591 (uri (git-reference
592 (url "https://github.com/ambrop72/badvpn")
593 (commit version)))
594 (file-name (git-file-name name version))
595 (sha256
596 (base32 "0rm67xhi7bh3yph1vh07imv5y1pwyldvw3wa5bz471g8mnkc7d3c"))))
597 (build-system cmake-build-system)
598 (arguments
599 '(#:tests? #f)) ; no tests
600 (inputs
601 `(("nspr" ,nspr)
602 ("nss" ,nss)
603 ("openssl" ,openssl)))
604 (native-inputs
605 `(("pkg-config" ,pkg-config)))
606 (home-page "https://github.com/ambrop72/badvpn")
607 (synopsis "Peer-to-peer virtual private network (VPN)")
608 (description "@code{BadVPN} is a collection of virtual private
609 network (VPN) tools. It includes:
610
611 @enumerate
612 @item NCD programming language.\n
613 NCD (Network Configuration Daemon) is a daemon and programming/scripting
614 language for configuration of network interfaces and other aspects of the
615 operating system.
616 @item Tun2socks network-layer proxifier.\n
617 The tun2socks program socksifes TCP connections at the network layer. It
618 implements a TUN device which accepts all incoming TCP connections (regardless
619 of destination IP), and forwards the connections through a SOCKS server.
620 @item Peer-to-peer VPN.\n
621 The peer-to-peer VPN implements a Layer 2 (Ethernet) network between the peers
622 (VPN nodes).
623 @end enumerate")
624 ;; This project contains a bundled lwIP. lwIP is also released under the
625 ;; 3-clause BSD license.
626 (license license:bsd-3)))
627
628 (define-public wireguard-linux-compat
629 (package
630 (name "wireguard-linux-compat")
631 (version "1.0.20201221")
632 (source (origin
633 (method url-fetch)
634 (uri (string-append "https://git.zx2c4.com/wireguard-linux-compat/"
635 "snapshot/wireguard-linux-compat-" version
636 ".tar.xz"))
637 (sha256
638 (base32
639 "0ci13in0fqq32n5qamch4qhjgbdq86ygrgmfhc9szsh2nsl8jlkf"))))
640 (build-system linux-module-build-system)
641 (outputs '("out"
642 "kernel-patch"))
643 (arguments
644 `(#:linux ,linux-libre-5.4 ; mustn't have WG built-in
645 #:tests? #f ; no test suite
646 #:modules ((guix build linux-module-build-system)
647 (guix build utils)
648 (ice-9 popen)
649 (ice-9 textual-ports))
650 #:phases
651 (modify-phases %standard-phases
652 (add-before 'build 'change-directory
653 (lambda _
654 (chdir "./src")
655 #t))
656 (add-after 'build 'build-patch
657 (lambda* (#:key outputs #:allow-other-keys)
658 (let* ((patch-builder "../kernel-tree-scripts/create-patch.sh")
659 (port (open-input-pipe patch-builder))
660 (str (get-string-all port)))
661 (close-pipe port)
662 (call-with-output-file "wireguard.patch"
663 (lambda (port)
664 (format port "~a" str))))
665 #t))
666 (add-after 'install 'install-patch
667 (lambda* (#:key outputs #:allow-other-keys)
668 (install-file "wireguard.patch"
669 (assoc-ref %outputs "kernel-patch"))
670 #t))
671 ;; So that 'install-license-files' works...
672 (add-before 'install-license-files 'reset-cwd
673 (lambda _
674 (chdir "..")
675 #t)))))
676 (home-page "https://git.zx2c4.com/wireguard-linux-compat/")
677 (synopsis "WireGuard kernel module for Linux 3.10 through 5.5")
678 (description "This package contains an out-of-tree kernel patch and
679 a loadable module adding WireGuard to Linux kernel versions 3.10 through 5.5.
680 WireGuard was added to Linux 5.6.")
681 (license license:gpl2)))
682
683 (define-public wireguard-tools
684 (package
685 (name "wireguard-tools")
686 (version "1.0.20200827")
687 (source
688 (origin
689 (method git-fetch)
690 (uri (git-reference
691 (url "https://git.zx2c4.com/wireguard-tools.git")
692 (commit (string-append "v" version))))
693 (file-name (git-file-name name version))
694 (sha256
695 (base32 "1h351hn531z6z85sx9ya27xjz1jszgn1pkwibacjj49mds15f7gn"))))
696 (build-system gnu-build-system)
697 (arguments
698 `(#:make-flags
699 (list ,(string-append "CC=" (cc-for-target))
700 "--directory=src"
701 "WITH_BASHCOMPLETION=yes"
702 ;; Install the ‘simple and dirty’ helper script wg-quick(8).
703 "WITH_WGQUICK=yes"
704 (string-append "PREFIX=" (assoc-ref %outputs "out"))
705 ;; Currently used only to create an empty /etc/wireguard directory.
706 (string-append "SYSCONFDIR=no-thanks"))
707 ;; The test suite is meant to be run interactively. It runs Clang's
708 ;; scan-build static analyzer and then starts a web server to display the
709 ;; results.
710 #:tests? #f
711 #:phases
712 (modify-phases %standard-phases
713 ;; No configure script
714 (delete 'configure)
715 (add-after 'install 'install-contrib-docs
716 (lambda* (#:key outputs #:allow-other-keys)
717 (let ((out (assoc-ref outputs "out")))
718 (copy-recursively "contrib/"
719 (string-append out "/share/doc/wireguard-tools"))
720 #t)))
721 (add-after 'install 'wrap-wg-quick
722 (lambda* (#:key inputs outputs #:allow-other-keys)
723 (let* ((out (assoc-ref outputs "out"))
724 (inputs-sbin (map (lambda (input)
725 (string-append (assoc-ref inputs input) "/sbin"))
726 (list "resolvconf" "iproute" "procps"
727 "iptables")))
728 (coreutils (string-append (assoc-ref inputs "coreutils")
729 "/bin")))
730 (wrap-program (string-append out "/bin/wg-quick")
731 `("PATH" ":" prefix ,(append inputs-sbin
732 (list coreutils))))
733 #t))))))
734 (inputs
735 `(("resolvconf" ,openresolv)
736 ("coreutils" ,coreutils)
737 ("bash" ,bash) ; for scripts using /dev/tcp
738 ("procps" ,procps)
739 ("iproute" ,iproute)
740 ("iptables" ,iptables)))
741 (home-page "https://www.wireguard.com/")
742 (synopsis "Tools for configuring WireGuard tunnels")
743 (description
744 "This package provides the user-space command-line tools for using and
745 configuring WireGuard tunnels.
746
747 WireGuard is a simple and fast general-purpose @acronym{VPN, Virtual Private
748 Network} that securely encapsulates IP packets over UDP. It aims to be as easy
749 to configure and deploy as SSH. VPN connections are made simply by exchanging
750 public keys and can roam across IP addresses.")
751 (license
752 (list license:lgpl2.1+ ; src/netlink.h & contrib/embeddable-wg-library
753 license:gpl2)))) ; everything else
754
755 (define-public wireguard
756 (deprecated-package "wireguard" wireguard-tools))
757
758 (define-public xl2tpd
759 (package
760 (name "xl2tpd")
761 (version "1.3.16")
762 (source (origin
763 (method git-fetch)
764 (uri (git-reference
765 (url "https://github.com/xelerance/xl2tpd")
766 (commit (string-append "v" version))))
767 (file-name (git-file-name name version))
768 (sha256
769 (base32
770 "0is5ccrvijz0pfm45pfrlbb9y8231yz3c4zqs8mkgakl9rxajy6l"))))
771 (build-system gnu-build-system)
772 (arguments
773 `(#:make-flags (list (string-append "PREFIX=" %output)
774 "CC=gcc")
775 #:phases (modify-phases %standard-phases
776 (delete 'configure) ;no configure script
777 (add-before 'build 'setup-environment
778 (lambda* (#:key inputs #:allow-other-keys)
779 (substitute* "l2tp.h"
780 (("/usr/sbin/pppd")
781 (string-append (assoc-ref inputs "ppp")
782 "/sbin/pppd")))
783 (setenv "KERNELSRC"
784 (assoc-ref inputs "linux-libre-headers"))
785 #t)))
786 #:tests? #f)) ; no tests provided
787 (inputs `(("libpcap" ,libpcap)
788 ("linux-libre-headers" ,linux-libre-headers)
789 ("ppp" ,ppp)))
790 (home-page "https://www.xelerance.com/software/xl2tpd/")
791 (synopsis "Layer 2 Tunnelling Protocol Daemon (RFC 2661)")
792 (description
793 "xl2tpd is an implementation of the Layer 2 Tunnelling Protocol (RFC 2661).
794 L2TP allows you to tunnel PPP over UDP.")
795 (license license:gpl2)))