gnu: tremc: Update to 0.9.0-2.e06d08d.
[jackhill/guix/guix.git] / gnu / packages / bittorrent.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014 Taylan Ulrich Bayirli/Kammer <taylanbayirli@gmail.com>
3 ;;; Copyright © 2014, 2015, 2016 Ludovic Courtès <ludo@gnu.org>
4 ;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
5 ;;; Copyright © 2016, 2017 Leo Famulari <leo@famulari.name>
6 ;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
7 ;;; Copyright © 2016 Tomáš Čech <sleep_walker@gnu.org>
8 ;;; Copyright © 2016, 2017 Tobias Geerinckx-Rice <me@tobias.gr>
9 ;;; Copyright © 2017 Jelle Licht <jlicht@fsfe.org>
10 ;;;
11 ;;; This file is part of GNU Guix.
12 ;;;
13 ;;; GNU Guix is free software; you can redistribute it and/or modify it
14 ;;; under the terms of the GNU General Public License as published by
15 ;;; the Free Software Foundation; either version 3 of the License, or (at
16 ;;; your option) any later version.
17 ;;;
18 ;;; GNU Guix is distributed in the hope that it will be useful, but
19 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
20 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
21 ;;; GNU General Public License for more details.
22 ;;;
23 ;;; You should have received a copy of the GNU General Public License
24 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
25
26 (define-module (gnu packages bittorrent)
27 #:use-module (guix packages)
28 #:use-module (guix download)
29 #:use-module (guix git-download)
30 #:use-module (guix build-system gnu)
31 #:use-module (guix build-system python)
32 #:use-module (guix build-system glib-or-gtk)
33 #:use-module ((guix licenses) #:prefix l:)
34 #:use-module (gnu packages)
35 #:use-module (gnu packages adns)
36 #:use-module (gnu packages boost)
37 #:use-module (gnu packages check)
38 #:use-module (gnu packages compression)
39 #:use-module (gnu packages crypto)
40 #:use-module (gnu packages curl)
41 #:use-module (gnu packages cyrus-sasl)
42 #:use-module (gnu packages databases)
43 #:use-module (gnu packages file)
44 #:use-module (gnu packages glib)
45 #:use-module (gnu packages gnome)
46 #:use-module (gnu packages gnupg)
47 #:use-module (gnu packages gstreamer)
48 #:use-module (gnu packages gtk)
49 #:use-module (gnu packages libevent)
50 #:use-module (gnu packages linux)
51 #:use-module (gnu packages multiprecision)
52 #:use-module (gnu packages nettle)
53 #:use-module (gnu packages ncurses)
54 #:use-module (gnu packages pkg-config)
55 #:use-module (gnu packages python)
56 #:use-module (gnu packages ssh)
57 #:use-module (gnu packages tls)
58 #:use-module (gnu packages xml))
59
60 (define-public transmission
61 (package
62 (name "transmission")
63 (version "2.92")
64 (source (origin
65 (method url-fetch)
66 (uri (string-append
67 "https://transmission.cachefly.net/transmission-"
68 version ".tar.xz"))
69 (sha256
70 (base32
71 "0pykmhi7pdmzq47glbj8i2im6iarp4wnj4l1pyvsrnba61f0939s"))))
72 (build-system glib-or-gtk-build-system)
73 (outputs '("out" ; library and command-line interface
74 "gui")) ; graphical user interface
75 (arguments
76 '(#:glib-or-gtk-wrap-excluded-outputs '("out")
77 #:phases
78 (modify-phases %standard-phases
79 (add-after 'install 'move-gui
80 (lambda* (#:key outputs #:allow-other-keys)
81 ;; Move the GUI to its own output, so that "out" doesn't
82 ;; depend on GTK+.
83 (let ((out (assoc-ref outputs "out"))
84 (gui (assoc-ref outputs "gui")))
85 (mkdir-p (string-append gui "/bin"))
86 (rename-file (string-append out "/bin/transmission-gtk")
87 (string-append gui
88 "/bin/transmission-gtk"))
89
90 ;; Move the '.desktop' file as well.
91 (mkdir (string-append gui "/share"))
92 (rename-file (string-append out "/share/applications")
93 (string-append gui "/share/applications")))
94 #t)))))
95 (inputs
96 `(("inotify-tools" ,inotify-tools)
97 ("libevent" ,libevent)
98 ("curl" ,curl)
99 ("cyrus-sasl" ,cyrus-sasl)
100 ("openssl" ,openssl)
101 ("file" ,file)
102 ("zlib" ,zlib)
103 ("gtk+" ,gtk+)))
104 (native-inputs
105 `(("intltool" ,intltool)
106 ("pkg-config" ,pkg-config)))
107 (home-page "http://www.transmissionbt.com/")
108 (synopsis "Fast and easy BitTorrent client")
109 (description
110 "Transmission is a BitTorrent client that comes with graphical,
111 textual, and Web user interfaces. Transmission also has a daemon for
112 unattended operations. It supports local peer discovery, full encryption,
113 DHT, µTP, PEX and Magnet Links.")
114
115 ;; COPYING reads:
116 ;;
117 ;; Transmission can be redistributed and/or modified under the terms of
118 ;; the GNU GPLv2 (http://www.gnu.org/licenses/license-list.html#GPLv2),
119 ;; the GNU GPLv3 (http://www.gnu.org/licenses/license-list.html#GNUGPLv3),
120 ;; or any future license endorsed by Mnemosyne LLC.
121 ;;
122 ;; A few files files carry an MIT/X11 license header.
123 (license l:gpl3+)))
124
125 (define-public libtorrent
126 (package
127 (name "libtorrent")
128 (version "0.13.6")
129 (source (origin
130 (method url-fetch)
131 (uri (string-append
132 "http://rtorrent.net/downloads/libtorrent-"
133 version ".tar.gz"))
134 (sha256
135 (base32
136 "012s1nwcvz5m5r4d2z9klgy2n34kpgn9kgwgzxm97zgdjs6a0f18"))))
137 (build-system gnu-build-system)
138 (inputs `(("openssl" ,openssl)
139 ("zlib" ,zlib)))
140 (native-inputs `(("pkg-config" ,pkg-config)
141 ("cppunit" ,cppunit)))
142 (synopsis "BitTorrent library of rtorrent")
143 (description
144 "LibTorrent is a BitTorrent library used by and developed in parallel
145 with the BitTorrent client rtorrent. It is written in C++ with emphasis on
146 speed and efficiency.")
147 (home-page "https://github.com/rakshasa/libtorrent")
148 (license l:gpl2+)))
149
150 (define-public rtorrent
151 (package
152 (name "rtorrent")
153 (version "0.9.6")
154 (source (origin
155 (method url-fetch)
156 (uri (string-append
157 "http://rtorrent.net/downloads/rtorrent-"
158 version ".tar.gz"))
159 (sha256
160 (base32
161 "03jvzw9pi2mhcm913h8qg0qw9gwjqc6lhwynb1yz1y163x7w4s8y"))))
162 (build-system gnu-build-system)
163 (inputs `(("libtorrent" ,libtorrent)
164 ("ncurses" ,ncurses)
165 ("curl" ,curl)
166 ("cyrus-sasl" ,cyrus-sasl)
167 ("openssl" ,openssl)
168 ("zlib" ,zlib)))
169 (native-inputs `(("pkg-config" ,pkg-config)
170 ("cppunit" ,cppunit)))
171 (synopsis "BitTorrent client with ncurses interface")
172 (description
173 "rTorrent is a BitTorrent client with an ncurses interface. It supports
174 full encryption, DHT, PEX, and Magnet Links. It can also be controlled via
175 XML-RPC over SCGI.")
176 (home-page "https://github.com/rakshasa/rtorrent")
177 (license l:gpl2+)))
178
179 (define-public tremc
180 (let ((commit "e06d08d8d76aa0559593ffc1188f4a90100cdbdb")
181 (revision "2"))
182 (package
183 (name "tremc")
184 (version (git-version "0.9.0" revision commit))
185 (source
186 (origin
187 (method git-fetch)
188 (uri (git-reference
189 (url "https://github.com/louipc/tremc.git")
190 (commit commit)))
191 (file-name (git-file-name name version))
192 (sha256
193 (base32
194 "17rf74sajcn5fl718rgl2qk5mw5yz9hrh58hbcg4p55wrazzrm1i"))))
195 (build-system gnu-build-system)
196 (arguments
197 `(#:tests? #f ; no test suite
198 #:make-flags
199 (list (string-append "PREFIX=" (assoc-ref %outputs "out")))
200 #:phases
201 (modify-phases %standard-phases
202 ;; The software is just a Python script that must be copied into
203 ;; place.
204 (delete 'configure)
205 (delete 'build))))
206 (synopsis "Console client for the Transmission BitTorrent daemon")
207 (description "Tremc is a console client, with a curses interface, for the
208 Transmission BitTorrent daemon.")
209 (home-page "https://github.com/louipc/tremc")
210 (license l:gpl3+))))
211
212 (define-public transmission-remote-cli
213 (package
214 (name "transmission-remote-cli")
215 (version "1.7.1")
216 (source (origin
217 (method url-fetch)
218 (uri (string-append "https://github.com/fagga/"
219 "transmission-remote-cli/archive/v"
220 version ".tar.gz"))
221 (file-name (string-append name "-" version ".tar.gz"))
222 (sha256
223 (base32
224 "1y0hkpcjf6jw9xig8yf484hbhy63nip0pkchx401yxj81m25l4z9"))))
225 (build-system python-build-system)
226 (arguments
227 `(#:python ,python-2 ; only supports Python 2
228 #:tests? #f ; no test suite
229 #:phases (modify-phases %standard-phases
230 ;; The software is just a Python script that must be
231 ;; copied into place.
232 (delete 'build)
233 (replace 'install
234 (lambda* (#:key outputs #:allow-other-keys)
235 (let* ((out (assoc-ref outputs "out"))
236 (bin (string-append out "/bin"))
237 (man (string-append out "/share/man/man1"))
238 ;; FIXME install zsh completions
239 (completions (string-append out "/etc/bash_completion.d")))
240 (install-file "transmission-remote-cli" bin)
241 (install-file "transmission-remote-cli.1" man)
242 (install-file
243 (string-append
244 "completion/bash/"
245 "transmission-remote-cli-bash-completion.sh")
246 completions)))))))
247 (synopsis "Console client for the Transmission BitTorrent daemon")
248 (description "Transmission-remote-cli is a console client, with a curses
249 interface, for the Transmission BitTorrent daemon. This package is no longer
250 maintained upstream.")
251 (home-page "https://github.com/fagga/transmission-remote-cli")
252 (license l:gpl3+)
253 (properties `((superseded . ,tremc)))))
254
255 (define-public aria2
256 (package
257 (name "aria2")
258 (version "1.33.1")
259 (source (origin
260 (method url-fetch)
261 (uri (string-append "https://github.com/tatsuhiro-t/aria2/"
262 "releases/download/release-" version "/"
263 name "-" version ".tar.xz"))
264 (sha256
265 (base32
266 "06syqxia701dk96rcbhnd4x0arjj6d22gm3aqksz38am9y2f8f95"))))
267 (build-system gnu-build-system)
268 (arguments
269 `(#:configure-flags (list "--enable-libaria2"
270 (string-append "--with-bashcompletiondir="
271 %output "/etc/bash_completion.d/"))
272 #:phases
273 (modify-phases %standard-phases
274 (add-after 'unpack 'delete-socket-tests
275 (lambda _
276 (substitute* "test/LpdMessageDispatcherTest.cc"
277 (("CPPUNIT_TEST_SUITE_REGISTRATION\\(LpdMessageDispatcherTest\\);" text)
278 (string-append "// " text)))
279 (substitute* "test/LpdMessageReceiverTest.cc"
280 (("CPPUNIT_TEST_SUITE_REGISTRATION\\(LpdMessageReceiverTest\\);" text)
281 (string-append "// " text)))
282 #t)))))
283 (native-inputs
284 `(("cppunit" ,cppunit) ; for the tests
285 ("pkg-config" ,pkg-config)))
286 (inputs
287 `(("c-ares" ,c-ares)
288 ("gnutls" ,gnutls)
289 ("gmp" ,gmp)
290 ("libssh2" ,libssh2)
291 ("libxml2" ,libxml2)
292 ("nettle" ,nettle)
293 ("sqlite" ,sqlite)
294 ("zlib" ,zlib)))
295 (home-page "https://aria2.github.io/")
296 (synopsis "Utility for parallel downloading files")
297 (description
298 "Aria2 is a lightweight, multi-protocol & multi-source command-line
299 download utility. It supports HTTP/HTTPS, FTP, SFTP, BitTorrent and Metalink.
300 Aria2 can be manipulated via built-in JSON-RPC and XML-RPC interfaces.")
301 (license l:gpl2+)))
302
303 (define-public uget
304 (package
305 (name "uget")
306 (version "2.0.8")
307 (source (origin
308 (method url-fetch)
309 (uri (string-append "mirror://sourceforge/urlget/"
310 "uget%20%28stable%29/" version "/uget-"
311 version ".tar.gz"))
312 (sha256
313 (base32
314 "0919cf7lfk1djdl003cahqjvafdliv7v2l8r5wg95n4isqggdk75"))))
315 (build-system gnu-build-system)
316 (native-inputs
317 `(("intltool" ,intltool)))
318 (inputs
319 `(("curl" ,curl)
320 ("gtk+" ,gtk+)
321 ("glib" ,glib)
322 ("gnutls" ,gnutls)
323 ("gstreamer" ,gstreamer)
324 ("libgcrypt" ,libgcrypt)
325 ("libnotify" ,libnotify)
326 ("openssl" ,openssl)))
327 (native-inputs
328 `(("intltool" ,intltool)
329 ("pkg-config" ,pkg-config)))
330 (home-page "http://ugetdm.com/")
331 (synopsis "Universal download manager with GTK+ interface")
332 (description
333 "uGet is portable download manager with GTK+ interface supporting
334 HTTP, HTTPS, BitTorrent and Metalink, supporting multi-connection
335 downloads, download scheduling, download rate limiting.")
336 (license l:lgpl2.1+)))
337
338 (define-public mktorrent
339 (package
340 (name "mktorrent")
341 (version "1.0")
342 (source (origin
343 (method url-fetch)
344 (uri (string-append "mirror://sourceforge/mktorrent/mktorrent/"
345 version "/" name "-" version ".tar.gz"))
346 (sha256
347 (base32
348 "17qi3nfky240pq6qcmf5qg324mxm83vk9r3nvsdhsvinyqm5d3kg"))))
349 (build-system gnu-build-system)
350 (arguments
351 `(#:phases (modify-phases %standard-phases
352 (delete 'configure)) ; no configure script
353 #:make-flags (list "CC=gcc"
354 (string-append "PREFIX=" (assoc-ref %outputs "out"))
355 "NO_HASH_CHECK=1"
356 "USE_LARGE_FILES=1"
357 "USE_LONG_OPTIONS=1"
358 "USE_PTHREADS=1")
359 #:tests? #f)) ; no tests
360 (home-page "http://mktorrent.sourceforge.net/")
361 (synopsis "Utility to create BitTorrent metainfo files")
362 (description "mktorrent is a simple command-line utility to create
363 BitTorrent @dfn{metainfo} files, often known simply as @dfn{torrents}, from
364 both single files and whole directories. It can add multiple trackers and web
365 seed URLs, and set the @code{private} flag to disallow advertisement through
366 the distributed hash table (DHT) and Peer Exchange. Hashing is multi-threaded
367 and will take advantage of multiple processor cores where possible.")
368 (license (list l:public-domain ; sha1.*, used to build without OpenSSL
369 l:gpl2+)))) ; with permission to link with OpenSSL
370
371 (define-public libtorrent-rasterbar
372 (package
373 (name "libtorrent-rasterbar")
374 (version "1.1.5")
375 (source (origin
376 (method url-fetch)
377 (uri
378 (string-append
379 "https://github.com/arvidn/libtorrent/releases/download/libtorrent-"
380 (string-join (string-split version #\.) "_")
381 "/libtorrent-rasterbar-" version ".tar.gz"))
382 (sha256
383 (base32
384 "0c398b7hsa5dvj4m0jc8h7mn0m3nawmagb6c5c7ml5c9hc338c8h"))))
385 (build-system gnu-build-system)
386 (arguments
387 `(#:configure-flags
388 (list (string-append "--with-boost-libdir="
389 (assoc-ref %build-inputs "boost")
390 "/lib")
391 "--enable-python-binding"
392 "--enable-tests")
393 #:make-flags (list
394 (string-append "LDFLAGS=-Wl,-rpath="
395 (assoc-ref %outputs "out") "/lib"))))
396 (inputs `(("boost" ,boost)
397 ("openssl" ,openssl)))
398 (native-inputs `(("python" ,python-2)
399 ("pkg-config" ,pkg-config)))
400 (home-page "http://www.rasterbar.com/products/libtorrent/")
401 (synopsis "Feature complete BitTorrent implementation")
402 (description
403 "libtorrent-rasterbar is a feature complete C++ BitTorrent implementation
404 focusing on efficiency and scalability. It runs on embedded devices as well as
405 desktops.")
406 (license l:bsd-2)))
407
408