Merge branch 'master' into core-updates
[jackhill/guix/guix.git] / gnu / packages / wv.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014 Marek Benc <merkur32@gmail.com>
3 ;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages wv)
21 #:use-module (gnu packages)
22 #:use-module (gnu packages compression)
23 #:use-module (gnu packages glib)
24 #:use-module (gnu packages gnome)
25 #:use-module (gnu packages image)
26 #:use-module (gnu packages pkg-config)
27 #:use-module (guix packages)
28 #:use-module (guix download)
29 #:use-module (guix build-system gnu)
30 #:use-module ((guix licenses) #:prefix license:))
31
32 (define-public wv
33 (package
34 (name "wv")
35 (version "1.2.4")
36 (source (origin
37 (method url-fetch)
38 (uri (string-append "mirror://sourceforge/wvware/wv/" version
39 "/wv-" version ".tar.gz"))
40 (sha256
41 (base32
42 "1mn2ax6qjy3pvixlnvbkn6ymy6y4l2wxrr4brjaczm121s8hjcb7"))))
43 (build-system gnu-build-system)
44 (inputs
45 `(("glib" ,glib)
46 ("libgsf" ,libgsf)
47 ("libjpeg" ,libjpeg)
48 ("libpng" ,libpng)
49 ("zlib" ,zlib)))
50 (native-inputs
51 `(("glib" ,glib "bin")
52 ("pkg-config" ,pkg-config)))
53 (synopsis "Microsoft Word conversion library and utilities")
54 (description
55 "wv converts Word 2,6,7,8,9 files to HTML and LaTeX. The Word 2
56 conversion is still incomplete (no formatting), but it will do a passable job
57 extracting the text, which is what you probably want anyway.
58
59 libwv can be used as a library by third party programs, AbiWord uses it as its
60 word importer, and KWord may use it in the future.")
61 (home-page "http://wvware.sourceforge.net/")
62 (license license:gpl2+)))