gnu: igt-gpu-tools: Don't use NAME in source URI.
[jackhill/guix/guix.git] / gnu / packages / patches / lirc-reproducible-build.patch
1 Build Lirc reproducibly.
2
3 https://sourceforge.net/p/lirc/tickets/301/
4 https://sourceforge.net/p/lirc/git/merge-requests/33/
5 https://sourceforge.net/p/lirc/git/merge-requests/34/
6 https://sourceforge.net/p/lirc/git/merge-requests/36/
7
8 Index: lirc-0.10.1/tools/lirc-lsplugins.cpp
9 ===================================================================
10 --- lirc-0.10.1.orig/tools/lirc-lsplugins.cpp
11 +++ lirc-0.10.1/tools/lirc-lsplugins.cpp
12 @@ -415,10 +415,9 @@ static void print_header(void)
13 static void print_yaml_header(void)
14 {
15 static const char* const YAML_HEADER =
16 - "#\n# Generated by lirc-lsplugins --yaml (%s) at %s#\n ";
17 - const time_t now = time(NULL);
18 + "#\n# Generated by lirc-lsplugins --yaml (%s)#\n ";
19
20 - printf(YAML_HEADER, VERSION, ctime(&now));
21 + printf(YAML_HEADER, VERSION);
22 printf("\ndrivers:\n");
23 }
24
25 Index: lirc-0.10.1/python-pkg/lirc/database.py
26 ===================================================================
27 --- lirc-0.10.1.orig/python-pkg/lirc/database.py
28 +++ lirc-0.10.1/python-pkg/lirc/database.py
29 @@ -156,7 +156,7 @@ class Database(object):
30 d['device_hint'] = hint
31
32 configs = {}
33 - for path in glob.glob(configdir + '/*.conf'):
34 + for path in sorted(glob.glob(configdir + '/*.conf')):
35 with open(path) as f:
36 cf = yaml.load(f.read())
37 configs[cf['config']['id']] = cf['config']
38 Index: lirc-0.10.1/tools/irdb-get
39 ===================================================================
40 --- lirc-0.10.1.orig/tools/irdb-get
41 +++ lirc-0.10.1/tools/irdb-get
42 @@ -9,7 +9,6 @@ import fnmatch
43 import os
44 import os.path
45 import sys
46 -import time
47 import urllib.error # pylint: disable=no-name-in-module,F0401,E0611
48 import urllib.request # pylint: disable=no-name-in-module,F0401,E0611
49
50 @@ -193,7 +192,7 @@ def do_yaml_config():
51 lircmd_by_driver[driver].append("%s/%s" % (tokens[0], tokens[2]))
52
53 print("#")
54 - print("# Created by 'irdb-get yaml-config' at " + time.ctime())
55 + print("# Created by 'irdb-get yaml-config'")
56 print("#")
57 print("\nlircd_by_driver:")
58 print_yaml_dict(lircd_by_driver)
59 Index: lirc-0.10.1/tools/lirc-make-devinput
60 ===================================================================
61 --- lirc-0.10.1.orig/tools/lirc-make-devinput
62 +++ lirc-0.10.1/tools/lirc-make-devinput
63 @@ -61,8 +61,7 @@ if test -n "$lirc_map"; then
64 fi
65
66
67 -echo "# Generated by $(basename $0) on $(uname -r)"
68 -echo "# Date: $(date)"
69 +echo "# Generated by $(basename $0)"
70 cat <<EOF
71
72 begin remote