gnu: igt-gpu-tools: Don't use NAME in source URI.
[jackhill/guix/guix.git] / gnu / packages / ham-radio.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2017, 2018 Arun Isaac <arunisaac@systemreboot.net>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages ham-radio)
20 #:use-module ((guix licenses) #:prefix license:)
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (gnu packages gtk)
24 #:use-module (gnu packages libusb)
25 #:use-module (gnu packages pkg-config)
26 #:use-module (gnu packages python)
27 #:use-module (gnu packages python-xyz)
28 #:use-module (gnu packages xml)
29 #:use-module (guix build-system cmake)
30 #:use-module (guix build-system python))
31
32 (define-public rtl-sdr
33 (package
34 (name "rtl-sdr")
35 (version "0.5.3")
36 (source
37 (origin
38 (method url-fetch)
39 (uri (string-append "https://cgit.osmocom.org/rtl-sdr/snapshot/rtl-sdr-"
40 version ".tar.xz"))
41 (sha256
42 (base32
43 "08awca3v28sa4lxym4r81pzf0la0j86wbmpyhv3xd53an9gkpjy9"))))
44 (build-system cmake-build-system)
45 (inputs
46 `(("libusb" ,libusb)))
47 (native-inputs
48 `(("pkg-config" ,pkg-config)))
49 (arguments
50 `(#:configure-flags '("-DDETACH_KERNEL_DRIVER=ON")
51 #:tests? #f)) ; No tests
52 (home-page "https://osmocom.org/projects/sdr/wiki/rtl-sdr")
53 (synopsis "Software defined radio driver for Realtek RTL2832U")
54 (description "DVB-T dongles based on the Realtek RTL2832U can be used as a
55 cheap software defined radio, since the chip allows transferring the raw I/Q
56 samples to the host. @code{rtl-sdr} provides drivers for this purpose.")
57 (license license:gpl2+)))
58
59 (define-public chirp
60 (package
61 (name "chirp")
62 (version "20181205")
63 (source
64 (origin
65 (method url-fetch)
66 (uri (string-append "https://trac.chirp.danplanet.com/chirp_daily/daily-"
67 version "/chirp-daily-" version ".tar.gz"))
68 (sha256
69 (base32
70 "1cp280b95j39xaxs50zn55jigg7pyfpm9n098hmsyxrplqn8z43c"))))
71 (build-system python-build-system)
72 (inputs
73 `(("python2-libxml2" ,python2-libxml2)
74 ("python2-pygtk" ,python2-pygtk)
75 ("python2-pyserial" ,python2-pyserial)))
76 (arguments
77 `(#:python ,python-2))
78 (home-page "https://chirp.danplanet.com")
79 (synopsis "Cross-radio programming tool")
80 (description "Chirp is a cross-radio programming tool. It supports a
81 growing list of radios across several manufacturers and allows transferring of
82 memory contents between them.")
83 (license (list license:gpl3+
84 license:lgpl3+)))) ; chirp/elib_intl.py