gnu: igt-gpu-tools: Don't use NAME in source URI.
[jackhill/guix/guix.git] / gnu / packages / dav.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015, 2016, 2017 Leo Famulari <leo@famulari.name>
3 ;;; Copyright © 2018 Efraim Flashner <efraim@flashner.co.il>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages dav)
21 #:use-module (guix build-system python)
22 #:use-module (guix download)
23 #:use-module (guix licenses)
24 #:use-module (guix packages)
25 #:use-module (gnu packages)
26 #:use-module (gnu packages check)
27 #:use-module (gnu packages python)
28 #:use-module (gnu packages python-web)
29 #:use-module (gnu packages python-xyz))
30
31 (define-public radicale
32 (package
33 (name "radicale")
34 (version "1.1.6")
35 (source (origin
36 (method url-fetch)
37 (uri (pypi-uri "Radicale" version))
38 (sha256
39 (base32
40 "0ay90nj6fmr2aq8imi0mbjl4m2rzq7a83ikj8qs9gxsylj71j1y0"))))
41 (build-system python-build-system)
42 (arguments
43 '(#:tests? #f)) ; The tests are not distributed in the PyPi release.
44 (propagated-inputs
45 ;; TODO: Add python-pam
46 `(("python-requests" ,python-requests)))
47 (synopsis "Basic CalDAV and CardDAV server")
48 (description "Radicale is a CalDAV and CardDAV server for UNIX-like
49 platforms. Calendars and address books are available for both local and remote
50 access, possibly limited through authentication policies. They can be viewed
51 and edited by calendar and contact clients on mobile phones or computers.
52
53 Radicale intentionally does not fully comply with the CalDAV and CardDAV RFCs.
54 Instead, it supports the CalDAV and CardDAV implementations of popular
55 clients.")
56 (home-page "http://radicale.org/")
57 (license gpl3+)))
58
59 (define-public vdirsyncer
60 (package
61 (name "vdirsyncer")
62 (version "0.16.7")
63 (source (origin
64 (method url-fetch)
65 (uri (pypi-uri name version))
66 (sha256
67 (base32
68 "1vqjhn2bffy2bx45a1r14crsyn2cylf5by567g44c4mhpjwwz6vc"))))
69 (build-system python-build-system)
70 (arguments
71 `(#:phases (modify-phases %standard-phases
72 (replace 'check
73 (lambda* (#:key inputs outputs #:allow-other-keys)
74 (add-installed-pythonpath inputs outputs)
75 (setenv "DETERMINISTIC_TESTS" "true")
76 (setenv "DAV_SERVER" "radicale")
77 (setenv "REMOTESTORAGE_SERVER" "skip")
78 (invoke "make" "test")))
79 (add-after 'install 'manpage
80 (lambda* (#:key inputs outputs #:allow-other-keys)
81 (invoke "make" "--directory=docs/" "man")
82 (install-file
83 "docs/_build/man/vdirsyncer.1"
84 (string-append
85 (assoc-ref outputs "out")
86 "/share/man/man1"))
87 #t)))))
88 (native-inputs
89 `(("python-setuptools-scm" ,python-setuptools-scm)
90 ("python-sphinx" ,python-sphinx)
91 ;; Required for testing
92 ("python-hypothesis" ,python-hypothesis)
93 ("python-pytest" ,python-pytest)
94 ("python-pytest-localserver" ,python-pytest-localserver)
95 ("python-pytest-subtesthack" ,python-pytest-subtesthack)
96 ("python-urllib3" ,python-urllib3)
97 ("python-wsgi-intercept" ,python-wsgi-intercept)
98 ("radicale" ,radicale)))
99 (propagated-inputs
100 `(("python-atomicwrites" ,python-atomicwrites)
101 ("python-click" ,python-click)
102 ("python-click-log" ,python-click-log)
103 ("python-click-threading" ,python-click-threading)
104 ("python-requests-toolbelt" ,python-requests-toolbelt)))
105 (synopsis "Synchronize calendars and contacts")
106 (description "Vdirsyncer synchronizes your calendars and addressbooks
107 between two storage locations. The most popular purpose is to
108 synchronize a CalDAV or CardDAV server with a local folder or file. The
109 local data can then be accessed via a variety of programs, none of which
110 have to know or worry about syncing to a server.")
111 (home-page "https://github.com/pimutils/vdirsyncer")
112 (license bsd-3)))