gnu: Add setBfree.
[jackhill/guix/guix.git] / gnu / packages / icu4c.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
3 ;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages icu4c)
21 #:use-module (gnu packages)
22 #:use-module (gnu packages perl)
23 #:use-module (guix licenses)
24 #:use-module (guix packages)
25 #:use-module (guix download)
26 #:use-module (guix build-system gnu))
27
28 (define-public icu4c
29 (package
30 (name "icu4c")
31 (version "55.1")
32 (source (origin
33 (method url-fetch)
34 (uri (string-append "http://download.icu-project.org/files/icu4c/"
35 version
36 "/icu4c-"
37 (string-map (lambda (x) (if (char=? x #\.) #\_ x)) version)
38 "-src.tgz"))
39 (sha256
40 (base32 "0ys5f5spizg45qlaa31j2lhgry0jka2gfha527n4ndfxxz5j4sz1"))))
41 (build-system gnu-build-system)
42 (inputs
43 `(("perl" ,perl)))
44 (arguments
45 `(#:configure-flags
46 '("--enable-rpath"
47 ,@(if (string-prefix? "arm" (or (%current-target-system)
48 (%current-system)))
49 '("--with-data-packaging=archive")
50 '()))
51 #:phases
52 (alist-cons-after
53 'unpack 'chdir-to-source
54 (lambda _ (chdir "source"))
55 (alist-cons-before
56 'configure 'patch-configure
57 (lambda _
58 ;; patch out two occurrences of /bin/sh from configure script
59 ;; that might have disappeared in a release later than 54.1
60 (substitute* "configure"
61 (("`/bin/sh")
62 (string-append "`" (which "bash")))))
63 %standard-phases))))
64 (synopsis "International Components for Unicode")
65 (description
66 "ICU is a set of C/C++ and Java libraries providing Unicode and
67 globalisation support for software applications. This package contains the
68 C/C++ part.")
69 (license x11)
70 (home-page "http://site.icu-project.org/")))