gnu: Add setBfree.
[jackhill/guix/guix.git] / gnu / packages / gnu-pw-mgr.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Eric Bavier <bavier@member.fsf.org>
3 ;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages gnu-pw-mgr)
21 #:use-module (guix packages)
22 #:use-module (guix licenses)
23 #:use-module (guix download)
24 #:use-module (guix build-system gnu)
25 #:use-module (gnu packages)
26 #:use-module (gnu packages base)
27 #:use-module (gnu packages autogen))
28
29 (define-public gnu-pw-mgr
30 (package
31 (name "gnu-pw-mgr")
32 (version "1.4")
33 (source
34 (origin
35 (method url-fetch)
36 (uri (string-append "mirror://gnu/gnu-pw-mgr/gnu-pw-mgr-"
37 version ".tar.xz"))
38 (sha256
39 (base32
40 "0a352y1m33vp6zmdbn96fdrq9gr9lchc9vcrj14mfx7g0dsvxjns"))))
41 (build-system gnu-build-system)
42 (native-inputs
43 `(("which" ,which)
44 ("autogen" ,autogen)))
45 (home-page "http://www.gnu.org/software/gnu-pw-mgr/")
46 (synopsis "Retrieve login credentials without recording passwords")
47 (description
48 "This program is designed to make it easy to reconstruct difficult
49 passwords when they are needed while limiting the risk of attack. The
50 user of this program inputs a self-defined transformation of a web
51 site URL and obtains the password and user name hint for that web
52 site.")
53 (license gpl3+)))