gnu: Add setBfree.
[jackhill/guix/guix.git] / gnu / packages / gkrellm.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages gkrellm)
20 #:use-module ((guix licenses) #:prefix license:)
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (guix build-system gnu)
24 #:use-module (gnu packages gettext)
25 #:use-module (gnu packages gtk)
26 #:use-module (gnu packages pkg-config)
27 #:use-module (gnu packages xorg))
28
29 (define-public gkrellm
30 (package
31 (name "gkrellm")
32 (version "2.3.5")
33 (source
34 (origin
35 (method url-fetch)
36 (uri (string-append "http://members.dslextreme.com/users/billw/gkrellm/gkrellm-"
37 version ".tar.bz2"))
38 (sha256
39 (base32
40 "12rc6zaa7kb60b9744lbrlfkxxfniprm6x0mispv63h4kh75navh"))))
41 (build-system gnu-build-system)
42 (inputs
43 `(("gettext" ,gnu-gettext)
44 ("gtk+" ,gtk+-2)
45 ("libice" ,libice)
46 ("libsm" ,libsm)))
47 (native-inputs
48 `(("pkg-config" ,pkg-config)))
49 (arguments
50 `(#:tests? #f ; there is no check target
51 #:phases
52 (alist-delete
53 'configure
54 %standard-phases)
55 #:make-flags
56 (let ((out (assoc-ref %outputs "out")))
57 (list (string-append "INSTALLROOT=" out)
58 "CC=gcc"
59 "X11_LIBS = -lX11 -lSM -lICE -lgmodule-2.0"))))
60 (home-page "http://members.dslextreme.com/users/billw/gkrellm/gkrellm.html")
61 (synopsis "System monitors")
62 (description
63 "GKrellM is a single process stack of system monitors which supports
64 applying themes to match its appearance to your window manager, Gtk, or any
65 other theme.")
66 (license license:gpl3+)))