Merge branch 'master' into core-updates
[jackhill/guix/guix.git] / gnu / packages / glib.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013, 2014, 2015, 2016, 2019 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2013, 2015 Andreas Enge <andreas@enge.fr>
4 ;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
5 ;;; Copyright © 2014, 2015, 2016, 2017, 2018 Mark H Weaver <mhw@netris.org>
6 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
7 ;;; Copyright © 2016 Lukas Gradl <lgradl@openmailbox.org>
8 ;;; Copyright © 2017, 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
9 ;;; Copyright © 2017 Petter <petter@mykolab.ch>
10 ;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
11 ;;; Copyright © 2018 Alex Vong <alexvong1995@gmail.com>
12 ;;; Copyright © 2019 Maxim Cournoyer <maxim.cournoyer@gmail.com>
13 ;;; Copyright © 2019 Giacomo Leidi <goodoldpaul@autistici.org>
14 ;;; Copyright © 2019, 2020 Marius Bakke <mbakke@fastmail.com>
15 ;;;
16 ;;; This file is part of GNU Guix.
17 ;;;
18 ;;; GNU Guix is free software; you can redistribute it and/or modify it
19 ;;; under the terms of the GNU General Public License as published by
20 ;;; the Free Software Foundation; either version 3 of the License, or (at
21 ;;; your option) any later version.
22 ;;;
23 ;;; GNU Guix is distributed in the hope that it will be useful, but
24 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
25 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
26 ;;; GNU General Public License for more details.
27 ;;;
28 ;;; You should have received a copy of the GNU General Public License
29 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
30
31 (define-module (gnu packages glib)
32 #:use-module (gnu packages)
33 #:use-module (gnu packages backup)
34 #:use-module (gnu packages base)
35 #:use-module (gnu packages bison)
36 #:use-module (gnu packages check)
37 #:use-module (gnu packages compression)
38 #:use-module (gnu packages docbook)
39 #:use-module (gnu packages documentation)
40 #:use-module (gnu packages enlightenment)
41 #:use-module (gnu packages file)
42 #:use-module (gnu packages flex)
43 #:use-module (gnu packages gettext)
44 #:use-module (gnu packages gnome)
45 #:use-module (gnu packages gperf)
46 #:use-module (gnu packages gtk)
47 #:use-module (gnu packages libffi)
48 #:use-module (gnu packages linux)
49 #:use-module (gnu packages m4)
50 #:use-module (gnu packages nettle)
51 #:use-module (gnu packages pcre)
52 #:use-module (gnu packages package-management)
53 #:use-module (gnu packages perl)
54 #:use-module (gnu packages perl-check)
55 #:use-module (gnu packages pkg-config)
56 #:use-module (gnu packages python)
57 #:use-module (gnu packages selinux)
58 #:use-module (gnu packages web)
59 #:use-module (gnu packages xml)
60 #:use-module (gnu packages xorg)
61 #:use-module (guix build-system gnu)
62 #:use-module (guix build-system meson)
63 #:use-module (guix build-system perl)
64 #:use-module (guix build-system python)
65 #:use-module (guix download)
66 #:use-module ((guix licenses) #:prefix license:)
67 #:use-module (guix packages)
68 #:use-module (guix utils)
69 #:use-module (srfi srfi-1)
70
71 ;; Export variables up-front to allow circular dependency with the 'xorg'
72 ;; module.
73 #:export (dbus
74 glib
75 gobject-introspection
76 dbus-glib
77 intltool
78 itstool
79 libsigc++
80 glibmm
81 telepathy-glib
82 perl-net-dbus
83 perl-net-dbus-glib))
84
85 (define dbus
86 (package
87 (name "dbus")
88 (version "1.12.16")
89 (source (origin
90 (method url-fetch)
91 (uri (string-append
92 "https://dbus.freedesktop.org/releases/dbus/dbus-"
93 version ".tar.gz"))
94 (sha256
95 (base32
96 "107ckxaff1cv4q6kmfdi2fb1nlsv03312a7kf6lb4biglhpjv8jl"))
97 (patches (search-patches "dbus-helper-search-path.patch"))))
98 (build-system gnu-build-system)
99 (arguments
100 '(#:configure-flags
101 (list
102 ;; Install the system bus socket under /var.
103 "--localstatedir=/var"
104
105 ;; Install the session bus socket under /tmp.
106 "--with-session-socket-dir=/tmp"
107
108 ;; Build shared libraries only.
109 "--disable-static"
110
111 ;; Use /etc/dbus-1 for system-wide config.
112 ;; Look for configuration file under
113 ;; /etc/dbus-1. This is notably required by
114 ;; 'dbus-daemon-launch-helper', which looks for
115 ;; the 'system.conf' file in that place,
116 ;; regardless of what '--config-file' was
117 ;; passed to 'dbus-daemon' on the command line;
118 ;; see <https://bugs.freedesktop.org/show_bug.cgi?id=92458>.
119 "--sysconfdir=/etc")
120 #:phases
121 (modify-phases %standard-phases
122 (replace 'install
123 (lambda _
124 ;; Don't try to create /var and /etc.
125 (invoke "make"
126 "localstatedir=/tmp/dummy"
127 "sysconfdir=/tmp/dummy"
128 "install"))))))
129 (native-inputs
130 `(("pkg-config" ,pkg-config)
131 ;; Dependencies to generate the doc.
132 ("docbook-xml" ,docbook-xml-4.4)
133 ("docbook-xsl" ,docbook-xsl)
134 ("doxygen" ,doxygen)
135 ("xmlto" ,xmlto)
136 ("libxml2" ,libxml2) ;for XML_CATALOG_FILES
137 ("libxslt" ,libxslt)
138 ("yelp-tools" ,yelp-tools)))
139 (inputs
140 `(("expat" ,expat)
141 ;; Add a dependency on libx11 so that 'dbus-launch' has support for
142 ;; '--autolaunch'.
143 ("libx11" ,libx11)))
144 (outputs '("out" "doc")) ;22 MiB of HTML doc
145 (home-page "https://www.freedesktop.org/wiki/Software/dbus/")
146 (synopsis "Message bus for inter-process communication (IPC)")
147 (description
148 "D-Bus is a message bus system, a simple way for applications to
149 talk to one another. In addition to interprocess communication, D-Bus
150 helps coordinate process lifecycle; it makes it simple and reliable to
151 code a \"single instance\" application or daemon, and to launch
152 applications and daemons on demand when their services are needed.
153
154 D-Bus supplies both a system daemon (for events such as \"new hardware
155 device added\" or \"printer queue changed\") and a
156 per-user-login-session daemon (for general IPC needs among user
157 applications). Also, the message bus is built on top of a general
158 one-to-one message passing framework, which can be used by any two apps
159 to communicate directly (without going through the message bus
160 daemon). Currently the communicating applications are on one computer,
161 or through unencrypted TCP/IP suitable for use behind a firewall with
162 shared NFS home directories.")
163 (license license:gpl2+))) ; or Academic Free License 2.1
164
165 (define glib
166 (package
167 (name "glib")
168 (version "2.62.4")
169 (source (origin
170 (method url-fetch)
171 (uri (string-append "mirror://gnome/sources/"
172 name "/" (string-take version 4) "/"
173 name "-" version ".tar.xz"))
174 (sha256
175 (base32
176 "1g2vj9lyh032kcwij7avx5d6a99rcsnkd07sbl9i55zsfw6h712c"))
177 (patches (search-patches "glib-tests-timer.patch"))
178 (modules '((guix build utils)))
179 (snippet
180 '(begin
181 (substitute* "tests/spawn-test.c"
182 (("/bin/sh") "sh"))
183 #t))))
184 (build-system meson-build-system)
185 (outputs '("out" ; everything
186 "bin")) ; glib-mkenums, gtester, etc.; depends on Python
187 (propagated-inputs
188 `(("pcre" ,pcre) ; in the Requires.private field of glib-2.0.pc
189 ("libffi" ,libffi) ; in the Requires.private field of gobject-2.0.pc
190 ;; These are in the Requires.private field of gio-2.0.pc
191 ("util-linux" ,util-linux "lib") ;for libmount
192 ("libselinux" ,libselinux)
193 ("zlib" ,zlib)))
194 (native-inputs
195 `(("gettext" ,gettext-minimal)
196 ("m4" ,m4) ; for installing m4 macros
197 ("dbus" ,dbus) ; for GDBus tests
198 ("pkg-config" ,pkg-config)
199 ("python" ,python-wrapper)
200 ("perl" ,perl) ; needed by GIO tests
201 ("tzdata" ,tzdata-for-tests))) ; for tests/gdatetime.c
202 (arguments
203 `(#:disallowed-references (,tzdata-for-tests)
204 #:phases
205 (modify-phases %standard-phases
206 (add-after 'unpack 'patch-dbus-launch-path
207 (lambda* (#:key inputs #:allow-other-keys)
208 (let ((dbus (assoc-ref inputs "dbus")))
209 (substitute* "gio/gdbusaddress.c"
210 (("command_line = g_strdup_printf \\(\"dbus-launch")
211 (string-append "command_line = g_strdup_printf (\""
212 dbus "/bin/dbus-launch")))
213 #t)))
214 (add-after 'unpack 'patch-gio-launch-desktop
215 (lambda* (#:key outputs #:allow-other-keys)
216 (let ((out (assoc-ref outputs "out")))
217 ;; See also <https://gitlab.gnome.org/GNOME/glib/issues/1633>
218 ;; for another future fix.
219 (substitute* "gio/gdesktopappinfo.c"
220 (("gio-launch-desktop")
221 (string-append out "/libexec/gio-launch-desktop")))
222 #t)))
223 (add-before 'build 'pre-build
224 (lambda* (#:key inputs outputs #:allow-other-keys)
225 ;; For tests/gdatetime.c.
226 (setenv "TZDIR"
227 (string-append (assoc-ref inputs "tzdata")
228 "/share/zoneinfo"))
229
230 ;; Some tests want write access there.
231 (setenv "HOME" (getcwd))
232 (setenv "XDG_CACHE_HOME" (getcwd))
233 #t))
234 (add-after 'unpack 'disable-failing-tests
235 (lambda _
236 (let ((disable
237 (lambda (test-file test-paths)
238 (define pattern+procs
239 (map (lambda (test-path)
240 (cons
241 ;; XXX: only works for single line statements.
242 (format #f "g_test_add_func.*\"~a\".*" test-path)
243 (const "")))
244 test-paths))
245 (substitute test-file pattern+procs)))
246 (failing-tests
247 '(("glib/tests/thread.c"
248 (;; prlimit(2) returns ENOSYS on Linux 2.6.32-5-xen-amd64
249 ;; as found on hydra.gnu.org, and strace(1) doesn't
250 ;; recognize it.
251 "/thread/thread4"))
252
253 ;; This tries to find programs in FHS directories.
254 ("glib/tests/utils.c"
255 ("/utils/find-program"))
256
257 ;; This fails because "glib/tests/echo-script" cannot be
258 ;; found.
259 ("glib/tests/spawn-singlethread.c"
260 ("/gthread/spawn-script"))
261
262 ("glib/tests/timer.c"
263 (;; fails if compiler optimizations are enabled, which they
264 ;; are by default.
265 "/timer/stop"))
266
267 ("gio/tests/gapplication.c"
268 (;; XXX: proven to be unreliable. See:
269 ;; <https://bugs.debian.org/756273>
270 ;; <http://bugs.gnu.org/18445>
271 "/gapplication/quit"
272
273 ;; XXX: fails randomly for unknown reason. See:
274 ;; <https://lists.gnu.org/archive/html/guix-devel/2016-04/msg00215.html>
275 "/gapplication/local-actions"))
276
277 ("gio/tests/contenttype.c"
278 (;; XXX: requires shared-mime-info.
279 "/contenttype/guess"
280 "/contenttype/guess_svg_from_data"
281 "/contenttype/subtype"
282 "/contenttype/list"
283 "/contenttype/icon"
284 "/contenttype/symbolic-icon"
285 "/contenttype/tree"))
286
287 ("gio/tests/appinfo.c"
288 (;; XXX: requires update-desktop-database.
289 "/appinfo/associations"))
290
291 ("gio/tests/desktop-app-info.c"
292 (;; XXX: requires update-desktop-database.
293 "/desktop-app-info/delete"
294 "/desktop-app-info/default"
295 "/desktop-app-info/fallback"
296 "/desktop-app-info/lastused"
297 "/desktop-app-info/search"))
298
299 ("gio/tests/gdbus-peer.c"
300 (;; Requires /etc/machine-id.
301 "/gdbus/codegen-peer-to-peer"))
302
303 ("gio/tests/gdbus-address-get-session.c"
304 (;; Requires /etc/machine-id.
305 "/gdbus/x11-autolaunch"))
306
307 ("gio/tests/gsocketclient-slow.c"
308 (;; These tests tries to resolve "localhost", and fails.
309 "/socket-client/happy-eyeballs/slow"
310 "/socket-client/happy-eyeballs/cancellation/delayed"))
311
312 )))
313 (for-each (lambda (x) (apply disable x)) failing-tests)
314 #t)))
315 (replace 'check
316 (lambda _
317 (setenv "MESON_TESTTHREADS"
318 (number->string (parallel-job-count)))
319 ;; Do not run tests marked as "flaky".
320 (invoke "meson" "test" "--no-suite" "flaky")))
321 ;; TODO: meson does not permit the bindir to be outside of prefix.
322 ;; See https://github.com/mesonbuild/meson/issues/2561
323 ;; We can remove this once meson is patched.
324 (add-after 'install 'move-executables
325 (lambda* (#:key outputs #:allow-other-keys)
326 (let ((out (assoc-ref outputs "out"))
327 (bin (assoc-ref outputs "bin")))
328 (mkdir-p bin)
329 (rename-file (string-append out "/bin")
330 (string-append bin "/bin"))
331 ;; This one is an implementation detail of glib.
332 ;; It is wrong that that's in "/bin" in the first place,
333 ;; but that's what upstream is doing right now.
334 ;; See <https://gitlab.gnome.org/GNOME/glib/issues/1633>.
335 (mkdir (string-append out "/libexec"))
336 (rename-file (string-append bin "/bin/gio-launch-desktop")
337 (string-append out "/libexec/gio-launch-desktop"))
338 ;; Do not refer to "bindir", which points to "${prefix}/bin".
339 ;; We don't patch "bindir" to point to "$bin/bin", because that
340 ;; would create a reference cycle between the "out" and "bin"
341 ;; outputs.
342 (substitute* (list (string-append out "/lib/pkgconfig/gio-2.0.pc")
343 (string-append out "/lib/pkgconfig/glib-2.0.pc"))
344 (("bindir=\\$\\{prefix\\}/bin") "")
345 (("=\\$\\{bindir\\}/") "="))
346 #t))))))
347 ;; TODO: see above for explanation.
348 ;; #:configure-flags (list (string-append "--bindir="
349 ;; (assoc-ref %outputs "bin")
350 ;; "/bin"))
351
352 (native-search-paths
353 ;; This variable is not really "owned" by GLib, but several related
354 ;; packages refer to it: gobject-introspection's tools use it as a search
355 ;; path for .gir files, and it's also a search path for schemas produced
356 ;; by 'glib-compile-schemas'.
357 (list (search-path-specification
358 (variable "XDG_DATA_DIRS")
359 (files '("share")))
360 ;; To load extra gio modules from glib-networking, etc.
361 (search-path-specification
362 (variable "GIO_EXTRA_MODULES")
363 (files '("lib/gio/modules")))))
364 (search-paths native-search-paths)
365 (properties '((hidden? . #t)))
366
367 (synopsis "Thread-safe general utility library; basis of GTK+ and GNOME")
368 (description
369 "GLib provides data structure handling for C, portability wrappers,
370 and interfaces for such runtime functionality as an event loop, threads,
371 dynamic loading, and an object system.")
372 (home-page "https://developer.gnome.org/glib/")
373 (license license:lgpl2.1+)))
374
375 (define-public glib-with-documentation
376 ;; glib's doc must be built in a separate package since it requires gtk-doc,
377 ;; which in turn depends on glib.
378 (package
379 (inherit glib)
380 (properties (alist-delete 'hidden? (package-properties glib)))
381 (outputs (cons "doc" (package-outputs glib))) ; 20 MiB of GTK-Doc reference
382 (native-inputs
383 `(("gtk-doc" ,gtk-doc) ; for the doc
384 ("docbook-xml" ,docbook-xml)
385 ("libxml2" ,libxml2)
386 ,@(package-native-inputs glib)))
387 (arguments
388 (substitute-keyword-arguments (package-arguments glib)
389 ((#:configure-flags flags ''())
390 `(cons "-Dgtk_doc=true" ,flags))
391 ((#:phases phases)
392 `(modify-phases ,phases
393 (add-after 'install 'move-doc
394 (lambda* (#:key outputs #:allow-other-keys)
395 (let ((out (assoc-ref outputs "out"))
396 (doc (assoc-ref outputs "doc"))
397 (html (string-append "/share/gtk-doc")))
398 (copy-recursively (string-append out html)
399 (string-append doc html))
400 (delete-file-recursively (string-append out html))
401 #t)))))))))
402
403 (define gobject-introspection
404 (package
405 (name "gobject-introspection")
406 (version "1.62.0")
407 (source (origin
408 (method url-fetch)
409 (uri (string-append "mirror://gnome/sources/"
410 "gobject-introspection/" (version-major+minor version)
411 "/gobject-introspection-" version ".tar.xz"))
412 (sha256
413 (base32 "18lhglg9v6y83lhqzyifc1z0wrlawzrhzzxx0a3h1g7xaz97xvmi"))
414 (patches (search-patches
415 "gobject-introspection-cc.patch"
416 "gobject-introspection-girepository.patch"
417 "gobject-introspection-absolute-shlib-path.patch"))))
418 (build-system meson-build-system)
419 (arguments
420 `(#:phases
421 (modify-phases %standard-phases
422 (add-after 'unpack 'do-not-use-/usr/bin/env
423 (lambda _
424 (substitute* "tools/g-ir-tool-template.in"
425 (("#!@PYTHON_CMD@")
426 (string-append "#!" (which "python3"))))
427 #t)))))
428 (inputs
429 `(("bison" ,bison)
430 ("flex" ,flex)
431 ("glib" ,glib)
432 ("python" ,python-wrapper)
433 ("zlib" ,zlib)))
434 (native-inputs
435 `(("glib" ,glib "bin")
436 ("pkg-config" ,pkg-config)))
437 (propagated-inputs
438 `(;; In practice, GIR users will need libffi when using
439 ;; gobject-introspection.
440 ("libffi" ,libffi)))
441 (native-search-paths
442 (list (search-path-specification
443 (variable "GI_TYPELIB_PATH")
444 (files '("lib/girepository-1.0")))))
445 (search-paths native-search-paths)
446 (home-page "https://wiki.gnome.org/GObjectIntrospection")
447 (synopsis "Generate interface introspection data for GObject libraries")
448 (description
449 "GObject introspection is a middleware layer between C libraries (using
450 GObject) and language bindings. The C library can be scanned at compile time
451 and generate a metadata file, in addition to the actual native C library. Then
452 at runtime, language bindings can read this metadata and automatically provide
453 bindings to call into the C library.")
454 ; Some bits are distributed under the LGPL2+, others under the GPL2+
455 (license license:gpl2+)))
456
457 (define intltool
458 (package
459 (name "intltool")
460 (version "0.51.0")
461 (source (origin
462 (method url-fetch)
463 (uri (string-append "https://launchpad.net/intltool/trunk/"
464 version "/+download/intltool-"
465 version ".tar.gz"))
466 (patches (search-patches "intltool-perl-compatibility.patch"))
467 (sha256
468 (base32
469 "1karx4sb7bnm2j67q0q74hspkfn6lqprpy5r99vkn5bb36a4viv7"))))
470 (build-system gnu-build-system)
471 (inputs
472 `(("file" ,file)))
473 (propagated-inputs
474 `(;; Propagate gettext because users expect it to be there, and so does
475 ;; the `intltool-update' script.
476 ("gettext" ,gettext-minimal)
477
478 ("perl-xml-parser" ,perl-xml-parser)
479 ("perl" ,perl)))
480 (arguments
481 `(#:phases
482 (modify-phases %standard-phases
483 (add-after 'unpack 'patch-file-references
484 (lambda* (#:key inputs #:allow-other-keys)
485 (let ((file (assoc-ref inputs "file")))
486 (substitute* "intltool-update.in"
487 (("`file") (string-append "`" file "/bin/file")))
488 #t))))))
489 (home-page "https://launchpad.net/intltool/+download")
490 (synopsis "Tools to centralise translations of different file formats")
491 (description
492 "Intltool is a set of tools to centralise translations of many different
493 file formats using GNU gettext-compatible PO files.
494
495 The intltool collection can be used to do these things:
496
497 Extract translatable strings from various source files (.xml.in,
498 glade, .desktop.in, .server.in, .oaf.in).
499
500 Collect the extracted strings together with messages from traditional
501 source files (.c, .h) in po/$(PACKAGE).pot.
502
503 Merge back the translations from .po files into .xml, .desktop and
504 oaf files. This merge step will happen at build resp. installation time.")
505 (license license:gpl2+)))
506
507 (define itstool
508 (package
509 (name "itstool")
510 (version "2.0.6")
511 (source (origin
512 (method url-fetch)
513 (uri (string-append "http://files.itstool.org/itstool/itstool-"
514 version ".tar.bz2"))
515 (sha256
516 (base32
517 "1acjgf8zlyk7qckdk19iqaca4jcmywd7vxjbcs1mm6kaf8icqcv2"))))
518 (build-system gnu-build-system)
519 (inputs
520 `(("libxml2" ,libxml2)
521 ("python-libxml2" ,python-libxml2)
522 ("python" ,python)))
523 (arguments
524 '(#:phases
525 (modify-phases %standard-phases
526 (add-after 'install 'wrap-program
527 (lambda* (#:key outputs #:allow-other-keys)
528 (let ((prog (string-append (assoc-ref outputs "out")
529 "/bin/itstool")))
530 (wrap-program prog
531 `("PYTHONPATH" = (,(getenv "PYTHONPATH"))))
532 #t))))))
533 (home-page "http://www.itstool.org")
534 (synopsis "Tool to translate XML documents with PO files")
535 (description
536 "ITS Tool allows you to translate your XML documents with PO files, using
537 rules from the W3C Internationalization Tag Set (ITS) to determine what to
538 translate and how to separate it into PO file messages.
539
540 PO files are the standard translation format for GNU and other Unix-like
541 systems. They present translatable information as discrete messages, allowing
542 each message to be translated independently. In contrast to whole-page
543 translation, translating with a message-based format like PO means you can
544 easily track changes to the source document down to the paragraph. When new
545 strings are added or existing strings are modified, you only need to update the
546 corresponding messages.
547
548 ITS Tool is designed to make XML documents translatable through PO files by
549 applying standard ITS rules, as well as extension rules specific to ITS Tool.
550 ITS also provides an industry standard way for authors to override translation
551 information in their documents, such as whether a particular element should be
552 translated.")
553 (license license:gpl3+)))
554
555 (define dbus-glib
556 (package
557 (name "dbus-glib")
558 (version "0.108")
559 (source (origin
560 (method url-fetch)
561 (uri
562 (string-append "https://dbus.freedesktop.org/releases/dbus-glib/dbus-glib-"
563 version ".tar.gz"))
564 (sha256
565 (base32
566 "0b307hw9j41npzr6niw1bs6ryp87m5yafg492gqwvsaj4dz0qd4z"))))
567 (build-system gnu-build-system)
568 (propagated-inputs ; according to dbus-glib-1.pc
569 `(("dbus" ,dbus)
570 ("glib" ,glib)))
571 (inputs
572 `(("expat" ,expat)))
573 (native-inputs
574 `(("glib" ,glib "bin")
575 ("pkg-config" ,pkg-config)))
576 (home-page "https://dbus.freedesktop.org/doc/dbus-glib/")
577 (synopsis "D-Bus GLib bindings")
578 (description
579 "GLib bindings for D-Bus. The package is obsolete and superseded
580 by GDBus included in Glib.")
581 (license license:gpl2))) ; or Academic Free License 2.1
582
583 (define libsigc++
584 (package
585 (name "libsigc++")
586 (version "2.10.2")
587 (source (origin
588 (method url-fetch)
589 (uri (string-append "mirror://gnome/sources/libsigc++/"
590 (version-major+minor version) "/"
591 name "-" version ".tar.xz"))
592 (sha256
593 (base32
594 "163s14d1rqp82gc1vsm3q0wzsbdicb9q6307kz0zk5lm6x9h5jmi"))))
595 (build-system gnu-build-system)
596 (native-inputs `(("pkg-config" ,pkg-config)
597 ("m4" ,m4)))
598 (home-page "https://libsigcplusplus.github.io/libsigcplusplus/")
599 (synopsis "Type-safe callback system for standard C++")
600 (description
601 "Libsigc++ implements a type-safe callback system for standard C++. It
602 allows you to define signals and to connect those signals to any callback
603 function, either global or a member function, regardless of whether it is
604 static or virtual.
605
606 It also contains adaptor classes for connection of dissimilar callbacks and
607 has an ease of use unmatched by other C++ callback libraries.")
608 (license license:lgpl2.1+)))
609
610 (define glibmm
611 (package
612 (name "glibmm")
613 (version "2.62.0")
614 (source (origin
615 (method url-fetch)
616 (uri (string-append "mirror://gnome/sources/glibmm/"
617 (version-major+minor version)
618 "/glibmm-" version ".tar.xz"))
619 (sha256
620 (base32
621 "1ziwx6r7k7wbvg4qq1rgrv8zninapgrmhn1hs6926a3krh9ryr9n"))))
622 (build-system gnu-build-system)
623 (arguments
624 `(#:phases
625 (modify-phases %standard-phases
626 (add-before 'build 'pre-build
627 (lambda _
628 ;; This test uses /etc/fstab as an example file to read
629 ;; from; choose a better example.
630 (substitute* "tests/giomm_simple/main.cc"
631 (("/etc/fstab")
632 (string-append (getcwd)
633 "/tests/giomm_simple/main.cc")))
634
635 ;; This test does a DNS lookup, and then expects to be able
636 ;; to open a TLS session; just skip it.
637 (substitute* "tests/giomm_tls_client/main.cc"
638 (("Gio::init.*$")
639 "return 77;\n"))
640 #t)))))
641 (native-inputs `(("pkg-config" ,pkg-config)
642 ("glib" ,glib "bin")))
643 (propagated-inputs
644 `(("libsigc++" ,libsigc++)
645 ("glib" ,glib)))
646 (home-page "https://gtkmm.org/")
647 (synopsis "C++ interface to the GLib library")
648 (description
649 "Glibmm provides a C++ programming interface to the part of GLib that are
650 useful for C++.")
651 (license license:lgpl2.1+)))
652
653 (define-public python2-pygobject-2
654 (package
655 (name "python2-pygobject")
656 ;; This was the last version to declare the 2.0 platform number, i.e. its
657 ;; pkg-config files were named pygobject-2.0.pc
658 (version "2.28.7")
659 (source
660 (origin
661 (method url-fetch)
662 (uri (string-append "mirror://gnome/sources/pygobject/"
663 (version-major+minor version)
664 "/pygobject-" version ".tar.xz"))
665 (sha256
666 (base32
667 "0nkam61rsn7y3wik3vw46wk5q2cjfh2iph57hl9m39rc8jijb7dv"))
668 (patches (search-patches
669 "python2-pygobject-2-gi-info-type-error-domain.patch"))))
670 (build-system gnu-build-system)
671 (native-inputs
672 `(("which" ,which)
673 ("glib-bin" ,glib "bin") ;for tests: glib-compile-schemas
674 ("pkg-config" ,pkg-config)
675 ("dbus" ,dbus))) ;for tests
676 (inputs
677 `(("python" ,python-2)
678 ("glib" ,glib)
679 ("python2-pycairo" ,python2-pycairo)
680 ("gobject-introspection" ,gobject-introspection)))
681 (propagated-inputs
682 `(("libffi" ,libffi))) ;mentioned in pygobject-2.0.pc
683 (arguments
684 `(#:tests? #f ;segfaults during tests
685 #:configure-flags '("LIBS=-lcairo-gobject")))
686 (home-page "https://pypi.org/project/PyGObject/")
687 (synopsis "Python bindings for GObject")
688 (description
689 "Python bindings for GLib, GObject, and GIO.")
690 (license license:lgpl2.1+)))
691
692 (define-public python-pygobject
693 (package
694 (name "python-pygobject")
695 (version "3.34.0")
696 (source
697 (origin
698 (method url-fetch)
699 (uri (string-append "mirror://gnome/sources/pygobject/"
700 (version-major+minor version)
701 "/pygobject-" version ".tar.xz"))
702 (sha256
703 (base32
704 "06i7ynnbvgpz0gw09zsjbvhgcp5qz4yzdifw27qjwdazg2mckql7"))
705 (modules '((guix build utils)))
706 (snippet
707 '(begin
708 ;; We disable these tests in a snippet so that they are inherited
709 ;; by the Python 2 variant which is built differently.
710 (with-directory-excursion "tests"
711 ;; FIXME: These tests require Gdk and/or Gtk 4.
712 (for-each delete-file
713 '("test_atoms.py" "test_overrides_gtk.py"))
714 #t)))))
715 (build-system meson-build-system)
716 (native-inputs
717 `(("glib-bin" ,glib "bin")
718 ("pkg-config" ,pkg-config)
719 ("python-pytest" ,python-pytest)))
720 (inputs
721 `(("python" ,python)
722 ("python-pycairo" ,python-pycairo)
723 ("gobject-introspection" ,gobject-introspection)))
724 (propagated-inputs
725 ;; pygobject-3.0.pc refers to all these.
726 `(("glib" ,glib)
727 ("libffi" ,libffi)))
728 ;; For finding typelib files, since gobject-introscpetion isn't propagated.
729 (native-search-paths (package-native-search-paths gobject-introspection))
730 (home-page "https://live.gnome.org/PyGObject")
731 (synopsis "Python bindings for GObject")
732 (description
733 "Python bindings for GLib, GObject, and GIO.")
734 (license license:lgpl2.1+)
735 (properties `((python2-variant . ,(delay python2-pygobject))))))
736
737 (define-public python2-pygobject
738 (package (inherit (strip-python2-variant python-pygobject))
739 (name "python2-pygobject")
740
741 ;; Note: We use python-build-system here, because Meson only supports
742 ;; Python 3, and needs PYTHONPATH etc set up correctly, which makes it
743 ;; difficult to use for Python 2 projects.
744 (build-system python-build-system)
745 (arguments
746 `(#:python ,python-2
747 #:phases
748 (modify-phases %standard-phases
749 (add-after 'unpack 'delete-broken-tests
750 (lambda _
751 ;; FIXME: this test freezes and times out.
752 (delete-file "tests/test_mainloop.py")
753 ;; FIXME: this test fails with this kind of error:
754 ;; AssertionError: <Handlers.SIG_IGN: 1> != <built-in function default_int_handler
755 (delete-file "tests/test_ossig.py")
756 #t)))))
757 (inputs
758 `(("python-pycairo" ,python2-pycairo)
759 ("gobject-introspection" ,gobject-introspection)))
760 (native-inputs
761 `(("glib-bin" ,glib "bin")
762 ("pkg-config" ,pkg-config)
763 ("python-pytest" ,python2-pytest)))))
764
765 (define-public perl-glib
766 (package
767 (name "perl-glib")
768 (version "1.3291")
769 (source (origin
770 (method url-fetch)
771 (uri (string-append
772 "mirror://cpan/authors/id/X/XA/XAOC/Glib-"
773 version ".tar.gz"))
774 (sha256
775 (base32
776 "0whz5f87wvzq8zsva85h06mkfqim2ciq845ixlvmafwxggccv0xr"))))
777 (build-system perl-build-system)
778 (native-inputs
779 `(("perl-extutils-depends" ,perl-extutils-depends)
780 ("perl-extutils-pkgconfig" ,perl-extutils-pkgconfig)))
781 (inputs
782 `(("glib" ,glib)))
783 (home-page "https://metacpan.org/release/Glib")
784 (synopsis "Perl wrappers for the GLib utility and Object libraries")
785 (description "This module provides perl access to GLib and GLib's GObject
786 libraries. GLib is a portability and utility library; GObject provides a
787 generic type system with inheritance and a powerful signal system. Together
788 these libraries are used as the foundation for many of the libraries that make
789 up the Gnome environment, and are used in many unrelated projects.")
790 (license license:lgpl2.1+)))
791
792 (define telepathy-glib
793 (package
794 (name "telepathy-glib")
795 (version "0.24.1")
796 (source
797 (origin
798 (method url-fetch)
799 (uri
800 (string-append
801 "https://telepathy.freedesktop.org/releases/telepathy-glib/"
802 "telepathy-glib-" version ".tar.gz"))
803 (sha256
804 (base32
805 "1symyzbjmxvksn2ifdkk50lafjm2llf2sbmky062gq2pz3cg23cy"))
806 (patches
807 (list
808 (search-patch "telepathy-glib-channel-memory-leak.patch")
809 ;; Don't use the same test name for multiple tests.
810 ;; <https://bugs.freedesktop.org/show_bug.cgi?id=92245>
811 (origin
812 (method url-fetch)
813 (uri "https://bugs.freedesktop.org/attachment.cgi?id=118608")
814 (file-name (string-append "telepathy-glib-duplicate-tests.patch"))
815 (sha256
816 (base32
817 "0z261fwrszxb28ccg3hsg9rizig4s84zvwmx6y31a4pyv7bvs5w3")))))))
818 (build-system gnu-build-system)
819 (arguments
820 '(#:configure-flags '("--enable-vala-bindings")
821
822 ;; '../tools/glib-*.py' generate files but the target dependencies are
823 ;; (presumably) not fully specified in the makefile, leading to
824 ;; parallel build errors like:
825 ;;
826 ;; EOFError: EOF read where object expected
827 ;; make[2]: *** [Makefile:1906: _gen/register-dbus-glib-marshallers-body.h] Error 1
828 #:parallel-build? #f))
829 (native-inputs
830 `(("glib" ,glib "bin") ; uses glib-mkenums
831 ("gobject-introspection" ,gobject-introspection)
832 ("pkg-config" ,pkg-config)
833 ("python" ,python-2)
834 ("vala" ,vala)
835 ("xsltproc" ,libxslt)))
836 (propagated-inputs
837 ;; There are all in the Requires.private field of telepathy-glib.pc.
838 `(("dbus" ,dbus)
839 ("dbus-glib" ,dbus-glib)
840 ("glib" ,glib)))
841 (home-page "https://telepathy.freedesktop.org/wiki/")
842 (synopsis "GLib Real-time communications framework over D-Bus")
843 (description "Telepathy is a flexible, modular communications framework
844 that enables real-time communication over D-Bus via pluggable protocol
845 backends. Telepathy is a communications service that can be accessed by
846 many applications simultaneously.
847
848 This package provides the library for GLib applications.")
849 (license license:lgpl2.1+)))
850
851 (define-public dbus-c++
852 (package
853 (name "dbus-c++")
854 (version "0.9.0")
855 (source (origin
856 (method url-fetch)
857 (uri
858 (string-append
859 "mirror://sourceforge/dbus-cplusplus/dbus-c%2B%2B/"
860 version "/libdbus-c%2B%2B-" version ".tar.gz"))
861 (file-name (string-append name "-" version ".tar.gz"))
862 (patches (search-patches "dbus-c++-gcc-compat.patch"
863 "dbus-c++-threading-mutex.patch"))
864 (sha256
865 (base32
866 "0qafmy2i6dzx4n1dqp6pygyy6gjljnb7hwjcj2z11c1wgclsq4dw"))))
867 (build-system gnu-build-system)
868 (propagated-inputs
869 `(("dbus" ,dbus))) ;mentioned in the pkg-config file
870 (inputs
871 `(("efl" ,efl)
872 ("expat" ,expat)
873 ("glib" ,glib)))
874 (native-inputs
875 `(("pkg-config" ,pkg-config)))
876 (arguments
877 `(;; The 'configure' machinery fails to detect that it needs -lpthread.
878 #:configure-flags (list "LDFLAGS=-lpthread")
879 #:phases
880 (modify-phases %standard-phases
881 (add-before 'configure 'add-missing-header
882 (lambda _
883 (substitute* "include/dbus-c++/eventloop-integration.h"
884 (("#include <errno.h>")
885 "#include <errno.h>\n#include <unistd.h>"))
886 #t)))))
887 (synopsis "D-Bus API for C++")
888 (description "This package provides D-Bus client API bindings for the C++
889 programming language. It also contains the utility
890 @command{dbuscxx-xml2cpp}.")
891 (home-page "https://sourceforge.net/projects/dbus-cplusplus/")
892 (license license:lgpl2.1+)))
893
894 (define-public appstream-glib
895 (package
896 (name "appstream-glib")
897 (version "0.7.17")
898 (source (origin
899 (method url-fetch)
900 (uri (string-append "https://people.freedesktop.org/~hughsient/"
901 "appstream-glib/releases/"
902 "appstream-glib-" version ".tar.xz"))
903 (sha256
904 (base32
905 "0jg58m1p5xfrh8zkpqhhg00nqs727z5i1qy6sb0a3vyc98fyk9vw"))))
906 (build-system meson-build-system)
907 (native-inputs
908 `(("gettext" ,gettext-minimal)
909 ("glib:bin" ,glib "bin") ; for glib-compile-resources
910 ("pkg-config" ,pkg-config)))
911 (propagated-inputs
912 `(("gcab" ,gcab) ; for .pc file
913 ("gdk-pixbuf" ,gdk-pixbuf) ; for .pc file
914 ("libuuid" ,util-linux "lib"))) ; for .pc file
915 (inputs
916 `(("glib" ,glib)
917 ("gperf" ,gperf)
918 ("gtk+" ,gtk+)
919 ("json-glib" ,json-glib)
920 ("libarchive" ,libarchive)
921 ("libsoup" ,libsoup)
922 ("libyaml" ,libyaml)))
923 (arguments
924 `(#:configure-flags
925 (list "-Ddep11=false"
926 "-Dintrospection=false" ; avoid g-ir-scanner dependency
927 "-Drpm=false"
928 "-Dstemmer=false")
929 #:phases
930 (modify-phases %standard-phases
931 (add-after 'unpack 'patch-tests
932 (lambda _
933 (substitute* "libappstream-glib/as-self-test.c"
934 (("g_test_add_func.*as_test_store_local_appdata_func);") ""))
935 #t)))))
936 (home-page "https://github.com/hughsie/appstream-glib")
937 (synopsis "Library for reading and writing AppStream metadata")
938 (description "This library provides objects and helper methods to help
939 reading and writing @uref{https://www.freedesktop.org/wiki/Distributions/AppStream,AppStream}
940 metadata.")
941 (license license:lgpl2.1+)))
942
943 (define perl-net-dbus
944 (package
945 (name "perl-net-dbus")
946 (version "1.1.0")
947 (source
948 (origin
949 (method url-fetch)
950 (uri (string-append "mirror://cpan/authors/id/D/DA/DANBERR/Net-DBus-"
951 version ".tar.gz"))
952 (sha256
953 (base32
954 "0sg2w147b9r9ykfzjs7y9qxry73xkjnhnk4qf95kfv79p5nnk4c3"))))
955 (build-system perl-build-system)
956 (native-inputs
957 `(("pkg-config" ,pkg-config)
958 ("perl-test-pod" ,perl-test-pod)
959 ("perl-test-pod-coverage" ,perl-test-pod-coverage)))
960 (inputs
961 `(("dbus" ,dbus)))
962 (propagated-inputs
963 `(("perl-xml-twig" ,perl-xml-twig)))
964 (home-page "https://metacpan.org/release/Net-DBus")
965 (synopsis "Extension for the DBus bindings")
966 (description "@code{Net::DBus} provides a Perl XS API to the DBus
967 inter-application messaging system. The Perl API covers the core base level
968 of the DBus APIs, not concerning itself yet with the GLib or QT wrappers.")
969 (license license:perl-license)))
970
971 (define perl-net-dbus-glib
972 (package
973 (name "perl-net-dbus-glib")
974 (version "0.33.0")
975 (source
976 (origin
977 (method url-fetch)
978 (uri (string-append "mirror://cpan/authors/id/D/DA/DANBERR/"
979 "Net-DBus-GLib-" version ".tar.gz"))
980 (sha256
981 (base32
982 "1z4mbv8z0rad604xahijpg5szzi8qak07hbahh230z4jf96fkxvj"))))
983 (build-system perl-build-system)
984 (native-inputs
985 `(("pkg-config" ,pkg-config)))
986 (inputs
987 `(("dbus-glib" ,dbus-glib)))
988 (home-page "https://metacpan.org/release/Net-DBus-GLib")
989 (synopsis "Perl extension for the DBus GLib bindings")
990 (description "This package provides an extension to the @code{Net::DBus}
991 module allowing integration with the GLib mainloop. To integrate with the
992 main loop, simply get a connection to the bus via the methods in
993 @code{Net::DBus::GLib} rather than the usual @code{Net::DBus} module. Every
994 other API remains the same.")
995 (license license:gpl2+)))
996
997 (define-public template-glib
998 (package
999 (name "template-glib")
1000 (version "3.32.0")
1001 (source (origin
1002 (method url-fetch)
1003 (uri (string-append "mirror://gnome/sources/" name "/"
1004 (version-major+minor version) "/"
1005 name "-" version ".tar.xz"))
1006 (sha256
1007 (base32
1008 "1g0zx0sxpw8kqp7p3sgl9kngaqrg9xl6cir24nrahks0vgsk98rr"))))
1009 (build-system meson-build-system)
1010 (arguments
1011 `(#:configure-flags '("-D" "enable_gtk_doc=true")))
1012 (inputs
1013 `(("gettext" ,gettext-minimal)
1014 ("glib" ,glib)
1015 ("gobject-introspection" ,gobject-introspection)))
1016 (native-inputs
1017 `(("bison" ,bison)
1018 ("flex" ,flex)
1019 ("glib:bin" ,glib "bin") ;; For glib-mkenums
1020 ("gtk-doc" ,gtk-doc)
1021 ("pkg-config" ,pkg-config)
1022 ("vala" ,vala)))
1023 (home-page "https://gitlab.gnome.org/GNOME/template-glib")
1024 (synopsis "Library for template expansion")
1025 (description
1026 "Template-GLib is a library to help you generate text based on a template and
1027 user defined state. Template-GLib does not use a language runtime, so it is
1028 safe to use from any GObject-Introspectable language.
1029
1030 Template-GLib allows you to access properties on GObjects as well as call
1031 simple methods via GObject-Introspection.")
1032 (license license:lgpl2.1+)))
1033
1034 (define-public xdg-dbus-proxy
1035 (package
1036 (name "xdg-dbus-proxy")
1037 (version "0.1.2")
1038 (source (origin
1039 (method url-fetch)
1040 (uri (string-append "https://github.com/flatpak/xdg-dbus-proxy"
1041 "/releases/download/" version
1042 "/xdg-dbus-proxy-" version ".tar.xz"))
1043 (sha256
1044 (base32
1045 "03sj1h0c2l08xa8phw013fnxr4fgav7l2mkjhzf9xk3dykwxcj8p"))))
1046 (build-system gnu-build-system)
1047 (native-inputs
1048 `(("pkg-config" ,pkg-config)
1049
1050 ;; For tests.
1051 ("dbus" ,dbus)
1052
1053 ;; These are required to build the manual.
1054 ("docbook-xml" ,docbook-xml-4.3)
1055 ("docbook-xsl" ,docbook-xsl)
1056 ("libxml2" ,libxml2)
1057 ("xsltproc" ,libxslt)))
1058 (inputs
1059 `(("glib" ,glib)))
1060 (home-page "https://github.com/flatpak/xdg-dbus-proxy")
1061 (synopsis "D-Bus connection proxy")
1062 (description
1063 "xdg-dbus-proxy is a filtering proxy for D-Bus connections. It can be
1064 used to create D-Bus sockets inside a Linux container that forwards requests
1065 to the host system, optionally with filters applied.")
1066 (license license:lgpl2.1+)))