Merge branch 'master' into core-updates
[jackhill/guix/guix.git] / gnu / packages / owncloud.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015 Efraim Flashner <efraim@flashner.co.il>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages owncloud)
20 #:use-module ((guix licenses) #:prefix license:)
21 #:use-module (guix build-system cmake)
22 #:use-module (guix download)
23 #:use-module (guix packages)
24 #:use-module (gnu packages compression)
25 #:use-module (gnu packages databases)
26 #:use-module (gnu packages linux)
27 #:use-module (gnu packages perl)
28 #:use-module (gnu packages pkg-config)
29 #:use-module (gnu packages python)
30 #:use-module (gnu packages qt)
31 #:use-module (gnu packages ruby)
32 #:use-module (gnu packages tls))
33
34 (define-public owncloud-client
35 (package
36 (name "owncloud-client")
37 (version "2.0.2")
38 (source
39 (origin
40 (method url-fetch)
41 (uri (string-append "https://download.owncloud.com/desktop/stable/"
42 "owncloudclient-" version ".tar.xz"))
43 (sha256
44 (base32 "0a42nqx0gn10n7ikhxwif0lqddmb6gbvr45bqbbl30an9gixq598"))))
45 (build-system cmake-build-system)
46 (arguments
47 `(#:phases
48 (modify-phases %standard-phases
49 (add-after 'unpack 'change-rpath-dirs
50 (lambda _
51 (substitute* '("src/libsync/CMakeLists.txt"
52 "csync/src/CMakeLists.txt")
53 ;; We store the libs in out/lib and not /usr/lib/appname, so we
54 ;; need the executable to point to the libraries in /lib and not
55 ;; in /lib/appname.
56 (("\\/\\$\\{APPLICATION_EXECUTABLE\\}") ""))
57 (substitute* '("src/cmd/CMakeLists.txt"
58 "src/crashreporter/CMakeLists.txt"
59 "src/gui/CMakeLists.txt")
60 ;; This has the same issue as the substitution above.
61 (("\\/\\$\\{APPLICATION_EXECUTABLE\\}\\\"") "\"")))))))
62 (native-inputs `(("pkg-config" ,pkg-config)))
63 (inputs
64 `(("inotify-tools" ,inotify-tools)
65 ("openssl" ,openssl)
66 ("perl" ,perl)
67 ("python-wrapper" ,python-wrapper)
68 ("qt" ,qt)
69 ("qtkeychain" ,qtkeychain)
70 ("ruby" ,ruby)
71 ("sqlite" ,sqlite)
72 ("zlib" ,zlib)))
73 (home-page "https://owncloud.org")
74 (synopsis "Folder synchronization with an ownCloud server")
75 (description "The ownCloudSync system lets you always have your latest
76 files wherever you are. Just specify one or more folders on the local machine
77 to and a server to synchronize to. You can configure more computers to
78 synchronize to the same server and any change to the files on one computer will
79 silently and reliably flow across to every other.")
80 (license license:gpl2+)))