Merge branch 'master' into core-updates
[jackhill/guix/guix.git] / gnu / packages / autogen.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013,2014 Eric Bavier <bavier@member.fsf.org>
3 ;;; Copyright © 2015 Efraim Flashner <efraim@flashner.co.il>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages autogen)
21 #:use-module (guix packages)
22 #:use-module (guix licenses)
23 #:use-module (guix download)
24 #:use-module (guix build-system gnu)
25 #:use-module (gnu packages)
26 #:use-module (gnu packages perl)
27 #:use-module (gnu packages pkg-config)
28 #:use-module (gnu packages base)
29 #:use-module (gnu packages guile))
30
31 (define-public autogen
32 (package
33 (name "autogen")
34 (version "5.18.7")
35 (source
36 (origin
37 (method url-fetch)
38 (uri (string-append "mirror://gnu/autogen"
39 "/autogen-" version ".tar.xz"))
40 (sha256
41 (base32
42 "01d4m8ckww12sy50vgyxlnz83z9dxqpyqp153cscncc9w6jq19d7"))))
43 (build-system gnu-build-system)
44 (native-inputs `(("perl" ,perl) ;for doc generator mdoc
45 ("pkg-config" ,pkg-config)))
46 (inputs `(("which" ,which)
47 ("guile" ,guile-2.0)))
48 (arguments
49 '(#:phases (alist-cons-before
50 'patch-source-shebangs 'patch-test-scripts
51 (lambda _
52 (let ((sh (which "sh")))
53 (substitute*
54 (append (find-files "agen5/test" "\\.test$")
55 (find-files "autoopts/test" "\\.(test|in)$"))
56 (("/bin/sh") sh)
57 (("/usr/bin/tr") "tr"))))
58 %standard-phases)))
59 (home-page "http://www.gnu.org/software/autogen/")
60 (synopsis "Automated program generator")
61 (description
62 "AutoGen is a program to ease the maintenance of programs that contain
63 large amounts of repetitive text. It automates the construction of these
64 sections of the code, simplifying the task of keeping the text in sync. It
65 also includes an add-on package called AutoOpts, which is specialized for the
66 maintenance and documentation of program options.")
67 (license gpl3+)))