gnu: sdcc: Update to 4.1.0.
[jackhill/guix/guix.git] / gnu / packages / patches / clucene-contribs-lib.patch
1 # Source: http://sourceforge.net/p/clucene/bugs/200/
2 diff -NaurpBb clucene-core-2.3.3.4/CMakeLists.txt clucene-core-2.3.3.4-mod/CMakeLists.txt
3 --- clucene-core-2.3.3.4/CMakeLists.txt 2011-03-17 03:21:07.000000000 +0300
4 +++ clucene-core-2.3.3.4-mod/CMakeLists.txt 2011-08-16 16:56:55.968268152 +0400
5 @@ -163,7 +163,7 @@ IF ( BUILD_CONTRIBS )
6 SET(BUILD_CONTRIBS_LIB 1)
7 ENDIF ( BUILD_CONTRIBS )
8 IF ( BUILD_CONTRIBS_LIB )
9 - ADD_SUBDIRECTORY (src/contribs-lib EXCLUDE_FROM_ALL)
10 + ADD_SUBDIRECTORY (src/contribs-lib)
11 ENDIF ( BUILD_CONTRIBS_LIB )
12
13
14 diff -NaurpBb clucene-core-2.3.3.4/src/contribs-lib/CMakeLists.txt clucene-core-2.3.3.4-mod/src/contribs-lib/CMakeLists.txt
15 --- clucene-core-2.3.3.4/src/contribs-lib/CMakeLists.txt 2011-03-17 03:21:07.000000000 +0300
16 +++ clucene-core-2.3.3.4-mod/src/contribs-lib/CMakeLists.txt 2011-08-16 17:14:13.499275499 +0400
17 @@ -106,9 +106,26 @@ add_library(clucene-contribs-lib SHARED
18 )
19 TARGET_LINK_LIBRARIES(clucene-contribs-lib ${clucene_contrib_extra_libs})
20
21 +#install public headers.
22 +FOREACH(file ${HEADERS})
23 + get_filename_component(apath ${file} PATH)
24 + get_filename_component(aname ${file} NAME)
25 + file(RELATIVE_PATH relpath ${CMAKE_SOURCE_DIR}/src/contribs-lib ${apath})
26 + IF ( NOT aname MATCHES "^_.*" )
27 + install(FILES ${file}
28 + DESTINATION include/${relpath}
29 + COMPONENT development)
30 + ENDIF ( NOT aname MATCHES "^_.*" )
31 +ENDFOREACH(file)
32 +
33 #set properties on the libraries
34 SET_TARGET_PROPERTIES(clucene-contribs-lib PROPERTIES
35 VERSION ${CLUCENE_VERSION}
36 SOVERSION ${CLUCENE_SOVERSION}
37 COMPILE_DEFINITIONS_DEBUG _DEBUG
38 )
39 +
40 +#and install library
41 +install(TARGETS clucene-contribs-lib
42 + DESTINATION ${LIB_DESTINATION}
43 + COMPONENT runtime )