gnu: python-webtest: Update to 2.0.29.
[jackhill/guix/guix.git] / gnu / packages / docker.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2016 David Thompson <davet@gnu.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages docker)
20 #:use-module ((guix licenses) #:prefix license:)
21 #:use-module (gnu packages)
22 #:use-module (guix packages)
23 #:use-module (guix download)
24 #:use-module (guix git-download)
25 #:use-module (guix build-system python)
26 #:use-module (guix utils)
27 #:use-module (gnu packages python)
28 #:use-module (gnu packages python-web))
29
30 (define-public python-docker-py
31 (package
32 (name "python-docker-py")
33 (version "1.6.0")
34 (source
35 (origin
36 (method url-fetch)
37 (uri (pypi-uri "docker-py" version))
38 (sha256
39 (base32
40 "16ba4xyd46hkj9nkfpz15r8kskl7ljx1afjzchyrhdsrklvzgzim"))))
41 (build-system python-build-system)
42 ;; TODO: Tests require a running Docker daemon.
43 (arguments '(#:tests? #f))
44 (inputs
45 `(("python-requests" ,python-requests)
46 ("python-six" ,python-six)
47 ("python-websocket-client" ,python-websocket-client)))
48 (home-page "https://github.com/docker/docker-py/")
49 (synopsis "Python client for Docker")
50 (description "Docker-Py is a Python client for the Docker container
51 management tool.")
52 (license license:asl2.0)))
53
54 (define-public python-dockerpty
55 (package
56 (name "python-dockerpty")
57 (version "0.3.4")
58 (source
59 (origin
60 (method url-fetch)
61 (uri (pypi-uri "dockerpty" version))
62 (sha256
63 (base32
64 "0za6rr349641wv76ww9l3zcic2xyxrirlxpnzl4296h897648455"))))
65 (build-system python-build-system)
66 (native-inputs
67 `(("python-six" ,python-six)))
68 (home-page "https://github.com/d11wtq/dockerpty")
69 (synopsis "Python library to use the pseudo-TTY of a Docker container")
70 (description "Docker PTY provides the functionality needed to operate the
71 pseudo-terminal (PTY) allocated to a Docker container using the Python
72 client.")
73 (license license:asl2.0)))
74
75 (define-public docker-compose
76 (package
77 (name "docker-compose")
78 (version "1.5.2")
79 (source
80 (origin
81 (method url-fetch)
82 (uri (pypi-uri "docker-compose" version))
83 (sha256
84 (base32
85 "0ksg7hm2yvc977968dixxisrhcmvskzpcx3pz0v1kazrdqp7xakr"))))
86 (build-system python-build-system)
87 ;; TODO: Tests require running Docker daemon.
88 (arguments '(#:tests? #f))
89 (inputs
90 `(("python-docker-py" ,python-docker-py)
91 ("python-dockerpty" ,python-dockerpty)
92 ("python-docopt" ,python-docopt)
93 ("python-jsonschema" ,python-jsonschema)
94 ("python-pyyaml" ,python-pyyaml)
95 ("python-requests" ,python-requests-2.7)
96 ("python-six" ,python-six)
97 ("python-texttable" ,python-texttable)
98 ("python-websocket-client" ,python-websocket-client)))
99 (home-page "https://www.docker.com/")
100 (synopsis "Multi-container orchestration for Docker")
101 (description "Docker Compose is a tool for defining and running
102 multi-container Docker applications. A Compose file is used to configure an
103 application’s services. Then, using a single command, the containers are
104 created and all the services are started as specified in the configuration.")
105 (license license:asl2.0)))