gnu: js-filesaver: Don't use unstable tarball.
[jackhill/guix/guix.git] / gnu / packages / javascript.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2017 Arun Isaac <arunisaac@systemreboot.net>
3 ;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
4 ;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
5 ;;; Copyright © 2017, 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
6 ;;; Copyright © 2018 Nicolas Goaziou <mail@nicolasgoaziou.fr>
7 ;;;
8 ;;; This file is part of GNU Guix.
9 ;;;
10 ;;; GNU Guix is free software; you can redistribute it and/or modify it
11 ;;; under the terms of the GNU General Public License as published by
12 ;;; the Free Software Foundation; either version 3 of the License, or (at
13 ;;; your option) any later version.
14 ;;;
15 ;;; GNU Guix is distributed in the hope that it will be useful, but
16 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
17 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
18 ;;; GNU General Public License for more details.
19 ;;;
20 ;;; You should have received a copy of the GNU General Public License
21 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
22
23 (define-module (gnu packages javascript)
24 #:use-module ((guix licenses) #:prefix license:)
25 #:use-module (gnu packages)
26 #:use-module (gnu packages base)
27 #:use-module (gnu packages compression)
28 #:use-module (gnu packages lisp)
29 #:use-module (gnu packages readline)
30 #:use-module (guix packages)
31 #:use-module (guix download)
32 #:use-module (guix git-download)
33 #:use-module (guix build-system gnu)
34 #:use-module (guix build-system trivial)
35 #:use-module (guix build-system minify))
36
37 (define-public font-mathjax
38 (package
39 (name "font-mathjax")
40 (version "2.7.2")
41 (source
42 (origin
43 (method url-fetch)
44 (uri (string-append
45 "https://github.com/mathjax/MathJax/archive/"
46 version ".tar.gz"))
47 (file-name (string-append name "-" version ".tar.gz"))
48 (sha256
49 (base32
50 "1r72di4pg4i6pfhcskkxqmf1158m81ki6a7lbw6nz4zh7xw23hy4"))))
51 (build-system trivial-build-system)
52 (arguments
53 `(#:modules ((guix build utils))
54 #:builder
55 (begin
56 (use-modules (guix build utils)
57 (ice-9 match))
58 (set-path-environment-variable
59 "PATH" '("bin") (map (match-lambda
60 ((_ . input)
61 input))
62 %build-inputs))
63 (let ((install-directory (string-append %output "/share/fonts/mathjax")))
64 (mkdir-p install-directory)
65 (invoke "tar" "-C" install-directory "-xvf"
66 (assoc-ref %build-inputs "source")
67 ,(string-append "MathJax-" version "/fonts")
68 "--strip" "2")))))
69 (native-inputs
70 `(("gzip" ,gzip)
71 ("tar" ,tar)))
72 (home-page "https://www.mathjax.org/")
73 (synopsis "Fonts for MathJax")
74 (description "This package contains the fonts required for MathJax.")
75 (license license:asl2.0)))
76
77 (define-public js-mathjax
78 (package
79 (inherit font-mathjax)
80 (name "js-mathjax")
81 (arguments
82 `(#:modules ((guix build utils))
83 #:builder
84 (begin
85 (use-modules (guix build utils)
86 (ice-9 match)
87 (ice-9 popen)
88 (ice-9 regex))
89 (set-path-environment-variable
90 "PATH" '("bin") (map (match-lambda
91 ((_ . input)
92 input))
93 %build-inputs))
94 (set-path-environment-variable
95 "GUIX_LOCPATH" '("lib/locale")
96 (list (assoc-ref %build-inputs "glibc-utf8-locales")))
97 (setenv "LANG" "en_US.UTF-8")
98 (let ((install-directory (string-append %output "/share/javascript/mathjax")))
99 (invoke "tar" "xvf" (assoc-ref %build-inputs "source")
100 ,(string-append "MathJax-" (package-version font-mathjax)
101 "/unpacked")
102 "--strip" "2")
103 (mkdir-p install-directory)
104 (symlink (string-append (assoc-ref %build-inputs "font-mathjax")
105 "/share/fonts/mathjax")
106 (string-append install-directory "/fonts"))
107
108 (for-each
109 (lambda (file)
110 (let ((installed (string-append install-directory
111 ;; remove prefix "."
112 (string-drop file 1))))
113 (format #t "~a -> ~a~%" file installed)
114 (cond
115 ((string-match "\\.js$" file)
116 (mkdir-p (dirname installed))
117 (let ((minified (open-pipe* OPEN_READ "uglify-js" file)))
118 (call-with-output-file installed
119 (lambda (port)
120 (dump-port minified port)))
121
122 (let ((exit (close-pipe minified)))
123 (unless (zero? exit)
124 (error "dear, uglify-js failed" exit)))))
125 (else
126 (install-file file (dirname installed))))))
127 (find-files "."))
128
129 #t))))
130 (native-inputs
131 `(("font-mathjax" ,font-mathjax)
132 ("glibc-utf8-locales" ,glibc-utf8-locales)
133 ("uglify-js" ,uglify-js)
134 ,@(package-native-inputs font-mathjax)))
135 (synopsis "JavaScript display engine for LaTeX, MathML, and AsciiMath")
136 (description "MathJax is a JavaScript display engine for LaTeX, MathML,
137 and AsciiMath notation that works in all modern browsers. It requires no
138 plugins or software to be installed on the browser. So the page author can
139 write web documents that include mathematics and be confident that readers will
140 be able to view it naturally and easily.")))
141
142 (define-public js-respond
143 (package
144 (name "js-respond")
145 (version "1.4.2")
146 (source (origin
147 (method url-fetch)
148 (uri (string-append "https://github.com/scottjehl/Respond/"
149 "archive/" version ".tar.gz"))
150 (file-name (string-append name "-" version ".tar.gz"))
151 (sha256
152 (base32
153 "0ds1ya2a185jp93mdn07159c2x8zczwi960ykrawpp62bwk2n93d"))))
154 (build-system trivial-build-system)
155 (arguments
156 `(#:modules ((guix build utils))
157 #:builder
158 (begin
159 (use-modules (guix build utils)
160 (ice-9 match)
161 (ice-9 popen)
162 (srfi srfi-26))
163 (set-path-environment-variable
164 "PATH" '("bin") (map (match-lambda
165 ((_ . input)
166 input))
167 %build-inputs))
168 (let ((install-directory (string-append %output
169 "/share/javascript/respond/")))
170 (invoke "tar" "xvf"
171 (assoc-ref %build-inputs "source")
172 "--strip" "1")
173 (mkdir-p install-directory)
174 (let* ((file "src/respond.js")
175 (installed (string-append install-directory "respond.min.js")))
176 (let ((minified (open-pipe* OPEN_READ "uglify-js" file)))
177 (call-with-output-file installed
178 (cut dump-port minified <>)))))
179 #t)))
180 (home-page "https://github.com/scottjehl/Respond")
181 (native-inputs
182 `(("uglify-js" ,uglify-js)
183 ("source" ,source)
184 ("gzip" ,gzip)
185 ("tar" ,tar)))
186 (synopsis "Polyfill for min/max-width CSS3 Media Queries")
187 (description "The goal of this script is to provide a fast and lightweight
188 script to enable responsive web designs in browsers that don't support CSS3
189 Media Queries.")
190 (license license:expat)))
191
192 (define-public js-html5shiv
193 (package
194 (name "js-html5shiv")
195 (version "3.7.3")
196 (source (origin
197 (method git-fetch)
198 (uri (git-reference
199 (url "https://github.com/aFarkas/html5shiv")
200 (commit version)))
201 (file-name (git-file-name name version))
202 (sha256
203 (base32
204 "0y1c5nyq0brl9fjdihhax33vks4s1ij9iv113879sg3zflmgqpd0"))))
205 (build-system minify-build-system)
206 (home-page "https://github.com/aFarkas/html5shiv")
207 (synopsis "Enable HTML5 sectioning elements in legacy browsers")
208 (description "The HTML5 Shiv enables use of HTML5 sectioning elements in
209 legacy Internet Explorer and provides basic HTML5 styling for Internet
210 Explorer 6-9, Safari 4.x (and iPhone 3.x), and Firefox 3.x.")
211 ;; From the file "MIT and GPL2 licenses.md":
212 ;;
213 ;; This software is licensed under a dual license system (MIT or GPL
214 ;; version 2). This means you are free to choose with which of both
215 ;; licenses (MIT or GPL version 2) you want to use this library.
216 (license (list license:expat license:gpl2))))
217
218 (define-public js-json2
219 (let ((commit "031b1d9e6971bd4c433ca85e216cc853f5a867bd")
220 (revision "1"))
221 (package
222 (name "js-json2")
223 (version (string-append "2016-10-28." revision "-" (string-take commit 7)))
224 (source (origin
225 (method git-fetch)
226 (uri (git-reference
227 (url "https://github.com/douglascrockford/JSON-js.git")
228 (commit commit)))
229 (file-name (string-append name "-" version "-checkout"))
230 (sha256
231 (base32
232 "1fvb6b2y5sd3sqdgcj683sdxcbxdii34q0ysc9wg0dq1sy81l11v"))))
233 (build-system minify-build-system)
234 (arguments
235 `(#:javascript-files '("json2.js"
236 "json_parse.js"
237 "json_parse_state.js"
238 "cycle.js")))
239 (home-page "https://github.com/douglascrockford/JSON-js")
240 (synopsis "JSON encoders and decoders")
241 (description "The files in this collection implement JSON
242 encoders/decoders in JavaScript.
243
244 @code{json2.js}: This file creates a JSON property in the global object, if
245 there isn't already one, setting its value to an object containing a stringify
246 method and a parse method. The @code{parse} method uses the @code{eval}
247 method to do the parsing, guarding it with several regular expressions to
248 defend against accidental code execution hazards. On current browsers, this
249 file does nothing, preferring the built-in JSON object.
250
251 @code{json_parse.js}: This file contains an alternative JSON @code{parse}
252 function that uses recursive descent instead of @code{eval}.
253
254 @code{json_parse_state.js}: This files contains an alternative JSON
255 @code{parse} function that uses a state machine instead of @code{eval}.
256
257 @code{cycle.js}: This file contains two functions, @code{JSON.decycle} and
258 @code{JSON.retrocycle}, which make it possible to encode cyclical structures
259 and DAGs in JSON, and to then recover them. This is a capability that is not
260 provided by ES5. @code{JSONPath} is used to represent the links.")
261 (license license:public-domain))))
262
263 (define-public js-strftime
264 (package
265 (name "js-strftime")
266 (version "0.10.0")
267 (source (origin
268 (method git-fetch)
269 (uri (git-reference
270 (url"https://github.com/samsonjs/strftime")
271 (commit (string-append "v" version))))
272 (file-name (git-file-name name version))
273 (sha256
274 (base32
275 "131nmlivazwxyba25kh9lda99749fq4xsyin6lzfalaaydviby4p"))))
276 (build-system minify-build-system)
277 (arguments
278 `(#:javascript-files '("strftime.js")))
279 (home-page "https://github.com/samsonjs/strftime")
280 (synopsis "Implementation of strftime to JavaScript")
281 (description "This is an implementation of the @code{strftime} procedure
282 for JavaScript. It works in (at least) node.js and browsers. It supports
283 localization and timezones. Most standard specifiers from C are supported as
284 well as some other extensions from Ruby.")
285 (license license:expat)))
286
287 (define-public js-highlight
288 (package
289 (name "js-highlight")
290 (version "9.12.0")
291 (source (origin
292 (method git-fetch)
293 (uri (git-reference
294 (url "https://github.com/isagalaev/highlight.js")
295 (commit version)))
296 (file-name (git-file-name name version))
297 (sha256
298 (base32
299 "12qz22qjpd6svj58pwgcwg2x2rzhihfdrxg6lgj39nfpaln6dris"))))
300 (build-system minify-build-system)
301 (arguments
302 `(#:javascript-files '("src/highlight.js")))
303 (home-page "https://github.com/isagalaev/highlight.js")
304 (synopsis "Syntax highlighting for JavaScript")
305 (description "Highlight.js is a syntax highlighter written in JavaScript.
306 It works in the browser as well as on the server. It works with pretty much
307 any markup, doesn’t depend on any framework and has automatic language
308 detection.")
309 (license license:bsd-3)))
310
311 (define-public js-datatables
312 (package
313 (name "js-datatables")
314 (version "1.10.15")
315 (source (origin
316 (method url-fetch)
317 (uri (string-append "https://datatables.net/releases/DataTables-"
318 version ".zip"))
319 (sha256
320 (base32
321 "1y9xqyqyz7x1ls3ska71pshl2hpiy3qnw1f7wygyslbhy4ssgf57"))))
322 (build-system minify-build-system)
323 (arguments
324 `(#:javascript-files '("media/js/dataTables.bootstrap.js"
325 "media/js/jquery.dataTables.js")))
326 (native-inputs
327 `(("unzip" ,unzip)))
328 (home-page "https://datatables.net")
329 (synopsis "DataTables plug-in for jQuery")
330 (description "DataTables is a table enhancing plug-in for the jQuery
331 Javascript library, adding sorting, paging and filtering abilities to plain
332 HTML tables with minimal effort.")
333 (license license:expat)))
334
335 (define-public js-selectize
336 (package
337 (name "js-selectize")
338 (version "0.12.6")
339 (source (origin
340 (method git-fetch)
341 (uri (git-reference
342 (url "https://github.com/selectize/selectize.js")
343 (commit (string-append "v" version))))
344 (file-name (git-file-name name version))
345 (sha256
346 (base32
347 "15gichl8wi6yxag2ps723nxrgyan15976dzsnvw9h9py8sbyyzjn"))))
348 (build-system minify-build-system)
349 (arguments `(#:javascript-files '("src/selectize.js")))
350 (home-page "http://selectize.github.io/selectize.js/")
351 (synopsis "Hybrid widget between a textbox and <select> box")
352 (description "Selectize is the hybrid of a textbox and @code{<select>}
353 box. It's jQuery based and it has autocomplete and native-feeling keyboard
354 navigation; it is useful for tagging, contact lists, etc.")
355 (license license:asl2.0)))
356
357 (define-public js-es5-shim
358 (package
359 (name "js-es5-shim")
360 (version "4.5.13")
361 (source (origin
362 (method git-fetch)
363 (uri (git-reference
364 (url "https://github.com/es-shims/es5-shim")
365 (commit (string-append "v" version))))
366 (file-name (git-file-name name version))
367 (sha256
368 (base32
369 "142w384fbyllq4yggv173g82lw3wix4jqcg6hkhx1ymq89vvnpmh"))))
370 (build-system minify-build-system)
371 (arguments `(#:javascript-files
372 '("es5-sham.js"
373 "es5-shim.js")))
374 (home-page "https://github.com/es-shims/es5-shim")
375 (synopsis "ECMAScript 5 compatibility shims for legacy JavaScript engines")
376 (description "@code{es5-shim.js} patches a JavaScript context to contain
377 all ECMAScript 5 methods that can be faithfully emulated with a legacy
378 JavaScript engine. @code{es5-sham.js} patches other ES5 methods as closely as
379 possible. Many of these shams are intended only to allow code to be written
380 to ES5 without causing run-time errors in older engines. In many cases, this
381 means that these shams cause many ES5 methods to silently fail.")
382 (license license:expat)))
383
384 (define-public js-filesaver
385 (package
386 (name "js-filesaver")
387 (version "1.3.8")
388 (source (origin
389 (method git-fetch)
390 (uri (git-reference
391 (url "https://github.com/eligrey/FileSaver.js")
392 (commit version)))
393 (file-name (git-file-name name version))
394 (sha256
395 (base32
396 "0gvqk0hnr8fig0n4da7vj7q6z31bcyv52916xz3rbmdj3pgpiv1d"))))
397 (build-system minify-build-system)
398 (arguments
399 `(#:phases
400 (modify-phases %standard-phases
401 (add-after 'unpack 'fix-uglification
402 ;; Remove "export" keyword which prevents the file from being
403 ;; uglified by uglify-js. Moreover, that keyword is not present in
404 ;; the minified version of the library some projects are using,
405 ;; e.g.,
406 ;; <https://github.com/jmoenig/Snap--Build-Your-Own-Blocks/blob/master/FileSaver.min.js>
407 (lambda _
408 (substitute* "src/FileSaver.js"
409 (("export ") ""))
410 #t)))))
411 (home-page
412 "https://eligrey.com/blog/saving-generated-files-on-the-client-side/")
413 (synopsis "HTML5 saveAs() FileSaver implementation")
414 (description "@file{FileSaver.js} implements the @code{saveAs()}
415 FileSaver interface in browsers that do not natively support it.
416
417 @file{FileSaver.js} is the solution to saving files on the
418 client-side, and is perfect for webapps that need to generate files,
419 or for saving sensitive information that shouldn't be sent to an
420 external server.")
421 (license license:expat)))
422
423 (define-public mujs
424 (package
425 (name "mujs")
426 (version "1.0.6")
427 (source (origin
428 (method url-fetch)
429 (uri (string-append "https://mujs.com/downloads/mujs-"
430 version ".tar.xz"))
431 (sha256
432 (base32
433 "1q9w2dcspfp580pzx7sw7x9gbn8j0ak6dvj75wd1ml3f3q3i43df"))))
434 (build-system gnu-build-system)
435 (arguments
436 '(#:phases
437 (modify-phases %standard-phases
438 (delete 'configure) ; no configure
439 (add-after 'install 'install-shared-library
440 (lambda* (#:key (make-flags '()) #:allow-other-keys)
441 (apply invoke "make" "install-shared" make-flags))))
442 #:make-flags (list (string-append "prefix=" (assoc-ref %outputs "out"))
443 (string-append "CC=gcc"))
444 #:tests? #f)) ; no tests
445 (inputs
446 `(("readline" ,readline)))
447 (home-page "https://mujs.com/")
448 (synopsis "JavaScript interpreter written in C")
449 (description "MuJS is a lightweight Javascript interpreter designed for
450 embedding in other software to extend them with scripting capabilities. MuJS
451 was designed with a focus on small size, correctness, and simplicity. It is
452 written in portable C and implements ECMAScript as specified by ECMA-262. The
453 interface for binding with native code is designed to be as simple as possible
454 to use, and is very similar to Lua. There is no need to interact with byzantine
455 C++ template mechanisms, or worry about marking and unmarking garbage collection
456 roots, or wrestle with obscure build systems.")
457 (license license:isc)))