gnu: aegisub: Fix build with Make 4.3.
[jackhill/guix/guix.git] / gnu / packages / patches / aegisub-make43.patch
1 Fix build with GNU Make 4.3:
2
3 https://github.com/Aegisub/Aegisub/issues/171
4
5 Patch taken from upstream:
6
7 https://github.com/Aegisub/Aegisub/commit/6bd3f4c26b8fc1f76a8b797fcee11e7611d59a39
8
9 diff --git a/Makefile.target b/Makefile.target
10 --- a/Makefile.target
11 +++ b/Makefile.target
12 @@ -112,7 +112,7 @@ POST_FLAGS = $($@_FLAGS) -c -o $@ $<
13 # Libraries contain all object files they depend on (but they may depend on other files)
14 # Not using libtool on OS X because it has an unsilenceable warning about a
15 # compatibility issue with BSD 4.3 (wtf)
16 -lib%.a: $$($$*_OBJ)
17 +lib%.a: $$($$(*F)_OBJ)
18 @$(BIN_MKDIR_P) $(dir $@)
19 $(BIN_AR) cru $@ $(filter %.o,$^)
20 $(BIN_RANLIB) $@