gnu: gss: Update to 1.0.3.
[jackhill/guix/guix.git] / gnu / packages / gsasl.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012 Andreas Enge <andreas@enge.fr>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages gsasl)
20 #:use-module (gnu packages)
21 #:use-module ((gnu packages compression) #:prefix guix:)
22 #:use-module (gnu packages gnutls)
23 #:use-module (gnu packages libidn)
24 #:use-module (gnu packages nettle)
25 #:use-module (gnu packages shishi)
26 #:use-module (guix licenses)
27 #:use-module (guix packages)
28 #:use-module (guix download)
29 #:use-module (guix build-system gnu))
30
31 (define-public libntlm
32 (package
33 (name "libntlm")
34 (version "1.3")
35 (source (origin
36 (method url-fetch)
37 (uri (string-append "http://www.nongnu.org/libntlm/releases/libntlm-" version
38 ".tar.gz"))
39 (sha256 (base32
40 "101pr110ardcj2di940g6vaqifsaxc44h6hjn81l63dvmkj5a6ga"))))
41 (build-system gnu-build-system)
42 (synopsis "Library that implements NTLM authentication")
43 (description
44 "Libntlm is a library that implements NTLM authentication")
45 (license lgpl2.1+)
46 (home-page "http://www.nongnu.org/libntlm/")))
47
48 (define-public gss
49 (package
50 (name "gss")
51 (version "1.0.3")
52 (source (origin
53 (method url-fetch)
54 (uri (string-append "mirror://gnu/gss/gss-" version
55 ".tar.gz"))
56 (sha256 (base32
57 "1syyvh3k659xf1hdv9pilnnhbbhs6vfapayp4xgdcc8mfgf9v4gz"))))
58 (build-system gnu-build-system)
59 (inputs `(("nettle" ,nettle)
60 ("shishi" ,shishi)
61 ("zlib" ,guix:zlib)
62 ))
63 (synopsis "Generic Security Service library")
64 (description
65 "The GNU Generic Security Service provides a free implementation of the
66 GSS-API specification. It provides a generic application programming
67 interface for programs to access security services. Security services present
68 a generic, GSS interface, with which the calling application interacts via
69 this library, freeing the application developer from needing to know about
70 the underlying security implementation.")
71 (license gpl3+)
72 (home-page "http://www.gnu.org/software/gss/")))
73
74 (define-public gsasl
75 (package
76 (name "gsasl")
77 (version "1.8.0")
78 (source (origin
79 (method url-fetch)
80 (uri (string-append "mirror://gnu/gsasl/gsasl-" version
81 ".tar.gz"))
82 (sha256 (base32
83 "1rci64cxvcfr8xcjpqc4inpfq7aw4snnsbf5xz7d30nhvv8n40ii"))))
84 (build-system gnu-build-system)
85 (inputs `(("libidn" ,libidn)
86 ("libntlm" ,libntlm)
87 ("gss" ,gss)
88 ("zlib" ,guix:zlib)))
89 (propagated-inputs
90 ;; Propagate GnuTLS because libgnutls.la reads `-lnettle', and Nettle is a
91 ;; propagated input of GnuTLS.
92 `(("gnutls" ,gnutls)))
93 (synopsis "Simple Authentication and Security Layer library")
94 (description
95 "GNU SASL is an implementation of the Simple Authentication and
96 Security Layer framework. On network servers such as IMAP or SMTP servers,
97 SASL is used to handle client/server authentication. This package contains
98 both a library and a command-line tool to access the library.")
99 (license gpl3+)
100 (home-page "http://www.gnu.org/software/gsasl/")))