gnu: Use invoke and return #t from all builders.
[jackhill/guix/guix.git] / gnu / packages / rsync.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012, 2013 Andreas Enge <andreas@enge.fr>
3 ;;; Copyright © 2016 Mark H Weaver <mhw@netris.org>
4 ;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
5 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
6 ;;;
7 ;;; This file is part of GNU Guix.
8 ;;;
9 ;;; GNU Guix is free software; you can redistribute it and/or modify it
10 ;;; under the terms of the GNU General Public License as published by
11 ;;; the Free Software Foundation; either version 3 of the License, or (at
12 ;;; your option) any later version.
13 ;;;
14 ;;; GNU Guix is distributed in the hope that it will be useful, but
15 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
16 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
17 ;;; GNU General Public License for more details.
18 ;;;
19 ;;; You should have received a copy of the GNU General Public License
20 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
21
22 (define-module (gnu packages rsync)
23 #:use-module (gnu packages)
24 #:use-module (gnu packages perl)
25 #:use-module (gnu packages acl)
26 #:use-module (gnu packages base)
27 #:use-module (guix licenses)
28 #:use-module (guix packages)
29 #:use-module (guix download)
30 #:use-module (guix build-system gnu))
31
32
33 (define-public rsync
34 (package
35 (name "rsync")
36 (version "3.1.3")
37 (source (origin
38 (method url-fetch)
39 (uri (string-append "http://rsync.samba.org/ftp/rsync/src/rsync-"
40 version ".tar.gz"))
41 (sha256
42 (base32
43 "1h0011dj6jgqpgribir4anljjv7bbrdcs8g91pbsmzf5zr75bk2m"))))
44 (build-system gnu-build-system)
45 (inputs `(("perl" ,perl)
46 ("acl" ,acl)))
47 (synopsis "Remote (and local) file copying tool")
48 (description
49 "Rsync is a fast and versatile file copying tool. It can copy locally,
50 to/from another host over any remote shell, or to/from a remote rsync daemon.
51 Its delta-transfer algorithm reduces the amount of data sent over the network
52 by sending only the differences between the source files and the existing
53 files in the destination.")
54 (license gpl3+)
55 (home-page "http://rsync.samba.org/")))
56
57 (define-public librsync
58 (package
59 (name "librsync")
60 (version "0.9.7")
61 (source (origin
62 (method url-fetch)
63 (uri (string-append "mirror://sourceforge/librsync/librsync/"
64 version "/librsync-" version ".tar.gz"))
65 (sha256
66 (base32
67 "1mj1pj99mgf1a59q9f2mxjli2fzxpnf55233pc1klxk2arhf8cv6"))))
68 (build-system gnu-build-system)
69 (native-inputs
70 `(("which" ,which)
71 ("perl" ,perl)))
72 (arguments '(#:configure-flags '("--enable-shared")))
73 (home-page "http://librsync.sourceforge.net/")
74 (synopsis "Implementation of the rsync remote-delta algorithm")
75 (description
76 "Librsync is a free software library that implements the rsync
77 remote-delta algorithm. This algorithm allows efficient remote updates of a
78 file, without requiring the old and new versions to both be present at the
79 sending end. The library uses a \"streaming\" design similar to that of zlib
80 with the aim of allowing it to be embedded into many different applications.")
81 (license lgpl2.1+)))