gnu: kde: kdenlive: Make breeze theme available at runtime.
[jackhill/guix/guix.git] / gnu / packages / kde.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2016, 2017, 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
3 ;;; Copyright © 2016 David Craven <david@craven.ch>
4 ;;; Copyright © 2016, 2017 Thomas Danckaert <post@thomasdanckaert.be>
5 ;;; Copyright © 2017, 2018 Mark Meyer <mark@ofosos.org>
6 ;;; Copyright © 2017, 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
7 ;;; Copyright © 2018 Gábor Boskovits <boskovits@gmail.com>
8 ;;; Copyright © 2019 Nicolas Goaziou <mail@nicolasgoaziou.fr>
9 ;;; Copyright © 2018, 2019 Hartmut Goebel <h.goebel@crazy-compilers.com>
10 ;;; Copyright © 2019, 2020 Ludovic Courtès <ludo@gnu.org>
11 ;;; Copyright © 2020 Marius Bakke <marius@gnu.org>
12 ;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
13 ;;;
14 ;;; This file is part of GNU Guix.
15 ;;;
16 ;;; GNU Guix is free software; you can redistribute it and/or modify it
17 ;;; under the terms of the GNU General Public License as published by
18 ;;; the Free Software Foundation; either version 3 of the License, or (at
19 ;;; your option) any later version.
20 ;;;
21 ;;; GNU Guix is distributed in the hope that it will be useful, but
22 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
23 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
24 ;;; GNU General Public License for more details.
25 ;;;
26 ;;; You should have received a copy of the GNU General Public License
27 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
28
29 (define-module (gnu packages kde)
30 #:use-module (guix build-system cmake)
31 #:use-module (guix build-system qt)
32 #:use-module (guix deprecation)
33 #:use-module (guix download)
34 #:use-module (guix git-download)
35 #:use-module ((guix licenses) #:prefix license:)
36 #:use-module (guix packages)
37 #:use-module (guix utils)
38 #:use-module (gnu packages)
39 #:use-module (gnu packages algebra)
40 #:use-module (gnu packages apr)
41 #:use-module (gnu packages audio)
42 #:use-module (gnu packages boost)
43 #:use-module (gnu packages code)
44 #:use-module (gnu packages cpp)
45 #:use-module (gnu packages compression)
46 #:use-module (gnu packages curl)
47 #:use-module (gnu packages documentation)
48 #:use-module (gnu packages gettext)
49 #:use-module (gnu packages ghostscript)
50 #:use-module (gnu packages gl)
51 #:use-module (gnu packages gnome)
52 #:use-module (gnu packages graphics)
53 #:use-module (gnu packages image)
54 #:use-module (gnu packages kde-frameworks)
55 #:use-module (gnu packages kde-pim)
56 #:use-module (gnu packages kde-plasma)
57 #:use-module (gnu packages linux)
58 #:use-module (gnu packages llvm)
59 #:use-module (gnu packages maths)
60 #:use-module (gnu packages pdf)
61 #:use-module (gnu packages perl)
62 #:use-module (gnu packages photo)
63 #:use-module (gnu packages pkg-config)
64 #:use-module (gnu packages pulseaudio)
65 #:use-module (gnu packages python)
66 #:use-module (gnu packages tls)
67 #:use-module (gnu packages qt)
68 #:use-module (gnu packages version-control)
69 #:use-module (gnu packages video)
70 #:use-module (gnu packages xdisorg)
71 #:use-module (gnu packages xml)
72 #:use-module (gnu packages xorg))
73
74 (define-public baloo-widgets
75 (package
76 (name "baloo-widgets")
77 (version "20.04.1")
78 (source
79 (origin
80 (method url-fetch)
81 (uri (string-append "mirror://kde/stable/release-service/" version
82 "/src/baloo-widgets-" version ".tar.xz"))
83 (sha256
84 (base32 "1x4v79vhvc5ixkbsf3jyjz5ig1lf78rfw3r7g3llpb4j1kcp3wh0"))))
85 (build-system qt-build-system)
86 (native-inputs
87 `(("extra-cmake-modules" ,extra-cmake-modules)))
88 (inputs
89 `(("baloo" ,baloo)
90 ("kconfig" ,kconfig)
91 ("ki18n" ,ki18n)
92 ("kio" ,kio)
93 ("qtbase" ,qtbase)))
94 (arguments
95 `(#:phases
96 (modify-phases %standard-phases
97 (add-before 'check 'check-setup
98 (lambda _
99 (setenv "QT_QPA_PLATFORM" "offscreen")
100 #t)))))
101 (home-page "https://community.kde.org/Baloo")
102 (synopsis "Wigets for use with Baloo")
103 (description "Baloo is a framework for searching and managing metadata.
104 This package contains GUI widgets for baloo.")
105 (license license:lgpl2.0+)))
106
107 (define-public grantleetheme
108 (package
109 (name "grantleetheme")
110 (version "20.04.1")
111 (source
112 (origin
113 (method url-fetch)
114 (uri (string-append "mirror://kde/stable/release-service/" version
115 "/src/grantleetheme-" version ".tar.xz"))
116 (sha256
117 (base32 "0gabc5cb0sf00s7m5v2jnq55qsrdbrq6nqd15y1i15p788zifsjx"))
118 (patches (search-patches "grantlee-merge-theme-dirs.patch"))))
119 (build-system qt-build-system)
120 (native-inputs
121 `(("extra-cmake-modules" ,extra-cmake-modules)
122 ("libxml2" ,libxml2))) ;; xmllint required for tests
123 (inputs
124 `(("grantlee" ,grantlee)
125 ("kguiaddons" ,kguiaddons)
126 ("ki18n" ,ki18n)
127 ("kiconthemes" ,kiconthemes)
128 ("knewstuff" ,knewstuff)
129 ("qtbase" ,qtbase)))
130 (home-page "https://cgit.kde.org/grantleetheme.git")
131 (synopsis "Library providing Grantlee theme support")
132 (description "This library provides Grantlee theme support.")
133 (license ;; LGPL for libraries, FDL for documentation
134 (list license:lgpl2.1+ license:fdl1.2+))))
135
136 (define-public kdenlive
137 (let ((version "20.04.1"))
138 (package
139 (name "kdenlive")
140 (version version)
141 (source
142 (origin
143 (method git-fetch)
144 (uri (git-reference
145 (url "https://anongit.kde.org/kdenlive.git")
146 (commit (string-append "v" version))))
147 (file-name (string-append name "-" version "-checkout"))
148 (sha256
149 (base32
150 "0n0x34xmcn0k87rqnz0mk462b3al4gq56kn4m00rr428hafscdz7"))))
151 (build-system cmake-build-system)
152 (native-inputs
153 `(("extra-cmake-modules" ,extra-cmake-modules)
154 ("qttools" ,qttools)))
155 (inputs
156 `(("shared-mime-info" ,shared-mime-info)
157 ("frei0r-plugins" ,frei0r-plugins)
158 ("ffmpeg" ,ffmpeg)
159 ("rttr" ,rttr)
160 ("mlt" ,mlt)
161 ("qtbase" ,qtbase)
162 ("qtscript" ,qtscript)
163 ("qtsvg" ,qtsvg)
164 ("qtmultimedia" ,qtmultimedia)
165 ("kparts" ,kparts)
166 ("knotifications" ,knotifications)
167 ("karchive" ,karchive)
168 ("kdbusaddons" ,kdbusaddons)
169 ("kcrash" ,kcrash)
170 ("kguiaddons" ,kguiaddons)
171 ("knewstuff" ,knewstuff)
172 ("knotifyconfig" ,knotifyconfig)
173 ("kfilemetadata" ,kfilemetadata)
174 ("kdoctools" ,kdoctools)
175 ("kdeclarative" ,kdeclarative)
176 ("qtdeclarative" ,qtdeclarative)
177 ("qtquickcontrols" ,qtquickcontrols)
178 ("qtquickcontrols2" ,qtquickcontrols2)
179 ("kiconthemes" ,kiconthemes)
180 ("breeze" ,breeze)
181 ("qtgraphicaleffects" ,qtgraphicaleffects)
182 ("kplotting" ,kplotting)))
183 (arguments
184 `(#:tests? #f ;TODO needs X
185 #:phases
186 (modify-phases %standard-phases
187 (add-after 'install 'wrap-executable
188 (lambda* (#:key inputs outputs #:allow-other-keys)
189 (let* ((out (assoc-ref outputs "out"))
190 (qtquickcontrols (assoc-ref inputs "qtquickcontrols"))
191 (qtquickcontrols2 (assoc-ref inputs "qtquickcontrols2"))
192 (qtbase (assoc-ref inputs "qtbase"))
193 (qtdeclarative (assoc-ref inputs "qtdeclarative"))
194 (frei0r (assoc-ref inputs "frei0r-plugins"))
195 (ffmpeg (assoc-ref inputs "ffmpeg"))
196 (breeze (assoc-ref inputs "breeze"))
197 (qml "/lib/qt5/qml"))
198 (wrap-program (string-append out "/bin/kdenlive")
199 `("PATH" ":" prefix
200 ,(list (string-append ffmpeg "/bin")))
201 `("XDG_DATA_DIRS" ":" prefix
202 ,(list (string-append breeze "/share")))
203 `("QT_PLUGIN_PATH" ":" prefix
204 ,(map (lambda (label)
205 (string-append (assoc-ref inputs label)
206 "/lib/qt5/plugins/"))
207 '("qtbase" "qtsvg")))
208 `("FREI0R_PATH" ":" =
209 (,(string-append frei0r "/lib/frei0r-1/")))
210 `("QT_QPA_PLATFORM_PLUGIN_PATH" ":" =
211 (,(string-append qtbase "/lib/qt5/plugins/platforms")))
212 `("QML2_IMPORT_PATH" ":" prefix
213 (,(string-append qtquickcontrols qml)
214 ,(string-append qtquickcontrols2 qml)
215 ,(string-append qtdeclarative qml)))
216 `("MLT_PREFIX" ":" =
217 (,(assoc-ref inputs "mlt")))))
218 #t)))))
219 (home-page "https://kdenlive.org")
220 (synopsis "Non-linear video editor")
221 (description "Kdenlive is an acronym for KDE Non-Linear Video Editor.
222
223 Non-linear video editing is much more powerful than beginner's (linear)
224 editors, hence it requires a bit more organization before starting. However,
225 it is not reserved to specialists and can be used for small personal
226 projects.")
227 (license license:gpl2+))))
228
229 (define-public kdevelop
230 (package
231 (name "kdevelop")
232 (version "5.5.2")
233 (source
234 (origin
235 (method url-fetch)
236 (uri (string-append "mirror://kde/stable/kdevelop"
237 "/" version "/src/kdevelop-"
238 version ".tar.xz"))
239 (sha256
240 (base32 "1nkl3z1n1l7ly2zvmbx2sdhx5q72wcvpwhzsz3qgw1474qd9i3i2"))))
241 (build-system qt-build-system)
242 (native-inputs
243 `(("extra-cmake-modules" ,extra-cmake-modules)
244 ("pkg-config" ,pkg-config)
245 ("shared-mime-info" ,shared-mime-info)
246 ("qttools" ,qttools)))
247 (inputs
248 `(("boost" ,boost)
249 ("clang" ,clang)
250 ("grantlee" ,grantlee)
251 ("karchive" ,karchive)
252 ("kcmutils" ,kcmutils)
253 ("kcrash" ,kcrash)
254 ("kdeclarative" ,kdeclarative)
255 ("kdoctools" ,kdoctools)
256 ("kguiaddons" ,kguiaddons)
257 ("ki18n" ,ki18n)
258 ("kiconthemes" ,kiconthemes)
259 ("kio" ,kio) ;; not checked as requirement
260 ("kitemmodels" ,kitemmodels)
261 ("kitemviews" ,kitemviews)
262 ("kjobwidgets" ,kjobwidgets)
263 ("knotifications" ,knotifications)
264 ("knotifyconfig" ,knotifyconfig)
265 ("kparts" ,kparts)
266 ("kservice" ,kservice)
267 ("ktexteditor" ,ktexteditor)
268 ("kwindowsystem" ,kwindowsystem)
269 ("kxmlgui" ,kxmlgui)
270 ("libkomparediff2" ,libkomparediff2)
271 ("oxygen-icons" ,oxygen-icons)
272 ("qtbase" ,qtbase)
273 ("qtdeclarative" ,qtdeclarative)
274 ("qtquickcontrols" ,qtquickcontrols) ;; not checked as requirement
275 ("qtquickcontrols2" ,qtquickcontrols2) ;; not checked as requirement
276 ("qtwebkit" ,qtwebkit)
277 ("threadweaver" ,threadweaver)
278
279 ;; recommendes
280 ("astyle" ,astyle)
281 ("kdevelop-pg-qt" ,kdevelop-pg-qt)
282 ("libksysguard" ,libksysguard)
283
284 ;; optional
285 ("apr" ,apr) ; required for subversion support
286 ("apr-util" ,apr-util) ; required for subversion support
287 ("attica" ,attica)
288 ("kconfigwidgets" ,kconfigwidgets)
289 ("knewstuff" ,knewstuff)
290 ("krunner" ,krunner)
291 ;; TODO: OktetaGui, OktetaKastenControllers
292 ("plasma" ,plasma-framework)
293 ;; TODO: purpose
294 ("sonnet" ,sonnet)
295 ("subversion" ,subversion)))
296
297 ;; run-time packages - TODO
298 ;; ClazyStandalone
299 ;; Cppcheck
300 ;; heaptrack
301 ;; heaptrack_gui
302 ;; meson
303 (arguments
304 `(#:tests? #f ;; there are some issues with the test suite
305 #:phases
306 (modify-phases %standard-phases
307 (add-before 'configure 'add-include-path
308 (lambda* (#:key inputs #:allow-other-keys)
309 (substitute* "cmake/modules/FindClang.cmake"
310 (("^\\s*PATHS \"\\$\\{CLANG_LIBRARY_DIRS\\}\"" line)
311 (string-append line " " (assoc-ref inputs "clang") "/lib")))
312 #t)))))
313 (home-page "https://kdevelop.org")
314 (synopsis "IDE for C, C++, Python, Javascript and PHP")
315 (description "The KDevelop IDE provides semantic syntax highlighting, as
316 well as code navigation and completion for C, C++ (using Clang/LLVM), QML,
317 JavaScript, Python and PHP. It also integrates with a debugger, different
318 build systems (CMake, QMake, custom Makefiles) and version control
319 software (Git, Subversion, Mercurial, CVS and Bazaar).")
320 (license license:lgpl2.1+)))
321
322 (define-public kdevelop-pg-qt
323 (package
324 (name "kdevelop-pg-qt")
325 (version "2.2.1")
326 (source
327 (origin
328 (method git-fetch)
329 (uri (git-reference
330 (url "https://github.com/KDE/kdevelop-pg-qt")
331 (commit (string-append "v" version))))
332 (file-name (git-file-name name version))
333 (sha256
334 (base32 "1kfab4p717acbdkcdi41d98vwch7v431gb2qi6s38hmclsf8bf8g"))))
335 (native-inputs
336 `(("extra-cmake-modules" ,extra-cmake-modules)))
337 (inputs
338 `(("qtbase" ,qtbase)))
339 (build-system cmake-build-system)
340 (home-page "https://kde.org")
341 (synopsis "Parser generator library for KDevplatform")
342 (description "KDevelop-PG-Qt is the parser generator used in KDevplatform
343 for some KDevelop language plugins (Ruby, PHP, CSS...).")
344 (license license:lgpl2.0+)))
345
346 ;; kdevplatform was merged into kdevelop as of 5.2.x
347 (define-deprecated kdevplatform kdevelop)
348
349 (define-public kdiagram
350 (package
351 (name "kdiagram")
352 (version "2.7.0")
353 (source
354 (origin
355 (method url-fetch)
356 (uri (string-append "mirror://kde/stable/kdiagram/" version
357 "/kdiagram-" version ".tar.xz"))
358 (sha256
359 (base32 "1pgvf2q8b59hw0jg5ajmj5nrn4q8cgnifpvdd0fynk2ml6zym8k3"))
360 (patches (search-patches
361 "kdiagram-Fix-missing-link-libraries.patch"))))
362 (build-system qt-build-system)
363 (native-inputs
364 `(("extra-cmake-modules" ,extra-cmake-modules)
365 ("qttools" ,qttools)))
366 (inputs
367 `(("qtbase" ,qtbase)
368 ("qtsvg" ,qtsvg)))
369 (home-page "https://cgit.kde.org/kdiagram.git/")
370 (synopsis "Libraries for creating business diagrams")
371 (description "This package provides libraries for integrating business
372 diagrams in Qt-based applications.
373
374 @code{KCharts} provides an implementation of the ODF Chart specification. It
375 supports stock charts, box charts, and whisker charts. @code{KGantt} provides
376 a module for implementing ODF Gantt charts, which are bar charts that
377 illustrate project schedules.")
378 (license license:gpl2+)))
379
380 (define-public krita
381 (package
382 (name "krita")
383 (version "4.3.0")
384 (source (origin
385 (method url-fetch)
386 (uri (string-append
387 "mirror://kde/stable/krita/" version
388 "/krita-" version ".tar.gz"))
389 (sha256
390 (base32
391 "1njbxv7b56if838gv7ydzm1sprgmaabnp0jlj0bxryxzfdy8hwfh"))))
392 (build-system cmake-build-system)
393 (arguments
394 `(#:tests? #f
395 #:configure-flags
396 (list "-DBUILD_TESTING=OFF"
397 (string-append "-DCMAKE_CXX_FLAGS=-I"
398 (assoc-ref %build-inputs "openexr")
399 "/include/OpenEXR"))
400 #:phases
401 (modify-phases %standard-phases
402 ;; Ensure that icons are found at runtime.
403 ;; This works around <https://bugs.gnu.org/22138>.
404 (add-after 'install 'wrap-executable
405 (lambda* (#:key inputs outputs #:allow-other-keys)
406 (let ((out (assoc-ref outputs "out"))
407 (qt '("qtbase" "qtsvg")))
408 (wrap-program (string-append out "/bin/krita")
409 `("QT_PLUGIN_PATH" ":" prefix
410 ,(map (lambda (label)
411 (string-append (assoc-ref inputs label)
412 "/lib/qt5/plugins/"))
413 qt)))
414 #t))))))
415 (native-inputs
416 `(("curl" ,curl)
417 ("eigen" ,eigen)
418 ("extra-cmake-modules" ,extra-cmake-modules)
419 ("gettext-minimal" ,gettext-minimal)
420 ("kitemmodels" ,kitemmodels)
421 ("pkg-config" ,pkg-config)
422 ("qwt" ,qwt)
423 ("vc" ,vc)))
424 (inputs
425 `(("boost" ,boost)
426 ("exiv2" ,exiv2)
427 ("fftw" ,fftw)
428 ("gsl" ,gsl)
429 ("ilmbase" ,ilmbase)
430 ("karchive" ,karchive)
431 ("kcompletion" ,kcompletion)
432 ("kconfig" ,kconfig)
433 ("kcoreaddons" ,kcoreaddons)
434 ("kcrash" ,kcrash)
435 ("kguiaddons" ,kguiaddons)
436 ("ki18n" ,ki18n)
437 ("kiconthemes" ,kiconthemes)
438 ("kio" ,kio)
439 ("kitemviews" ,kitemviews)
440 ("kwidgetsaddons" ,kwidgetsaddons)
441 ("kwindowsystem" ,kwindowsystem)
442 ("kxmlgui" ,kxmlgui)
443 ("lcms" ,lcms)
444 ("libjpeg-turbo" ,libjpeg-turbo)
445 ("libpng" ,libpng)
446 ("libraw" ,libraw-0.18)
447 ("libtiff" ,libtiff)
448 ("libx11" ,libx11)
449 ("libxcb" ,libxcb)
450 ("libxi" ,libxi)
451 ("openexr" ,openexr)
452 ("perl" ,perl)
453 ("poppler-qt5" ,poppler-qt5)
454 ("qtbase" ,qtbase-for-krita)
455 ("qtdeclarative" ,qtdeclarative)
456 ("qtmultimedia" ,qtmultimedia)
457 ("qtsvg" ,qtsvg)
458 ("qtx11extras" ,qtx11extras)
459 ("quazip" ,quazip)
460 ("zlib" ,zlib)))
461 (home-page "https://krita.org")
462 (synopsis "Digital painting application")
463 (description
464 "Krita is a professional painting tool designed for concept artists,
465 illustrators, matte and texture artists, and the VFX industry. Notable
466 features include brush stabilizers, brush engines and wrap-around mode.")
467 (license license:gpl2+)))
468
469 (define-public libkomparediff2
470 (package
471 (name "libkomparediff2")
472 (version "20.04.1")
473 (source
474 (origin
475 (method url-fetch)
476 (uri (string-append "mirror://kde/stable/release-service/" version
477 "/src/libkomparediff2-" version ".tar.xz"))
478 (sha256
479 (base32 "0m8m7sgpf2f4nxpaaymyvihlk0pcyblyd99mcbibrnyr5kzkzzdc"))))
480 (native-inputs
481 `(("extra-cmake-modules" ,extra-cmake-modules)
482 ("pkg-config" ,pkg-config)))
483 (inputs
484 `(("kcodecs" ,kcodecs)
485 ("kconfig" ,kconfig)
486 ("kcoreaddons" ,kcoreaddons)
487 ("ki18n" ,ki18n)
488 ("kio" ,kio)
489 ("kxmlgui" ,kxmlgui)
490 ("qtbase" ,qtbase)))
491 (build-system cmake-build-system)
492 (home-page "https://kde.org")
493 (synopsis "Library to compare files and strings, used in Kompare and KDevelop")
494 (description "Libkomparediff2 is a library to work with diffs and patches,
495 used in KDE development tools Kompare and KDevelop.")
496
497 ;; GPL, some files are also licensed under LGPL or BSD, see COPYING in the
498 ;; source archive
499 (license (list license:gpl2+ license:lgpl2.0+ license:bsd-3))))
500
501 (define-public qca
502 (package
503 (name "qca")
504 (version "2.3.0")
505 (source
506 (origin
507 (method url-fetch)
508 (uri (string-append "mirror://kde/stable/qca/" version
509 "/qca-" version ".tar.xz"))
510 (sha256
511 (base32
512 "1mrj748yz1grgzmfbmffgjkpcqiaj1l3m4pbddwcj7dnl50yys0x"))))
513 (build-system cmake-build-system)
514 (native-inputs
515 `(("pkg-config" ,pkg-config)))
516 (inputs
517 `(("openssl" ,openssl)
518 ("qtbase" ,qtbase)))
519 (home-page "https://userbase.kde.org/QCA")
520 (synopsis "Libraries for the Qt Cryptographic Architecture")
521 (description "The Qt Cryptographic Architecture (QCA) provides a
522 straightforward and cross-platform API for a range of cryptographic features,
523 including SSL/TLS, X.509 certificates, SASL, OpenPGP, S/MIME CMS, and smart
524 cards.")
525 (license license:lgpl2.1)))
526
527 (define-public kpmcore
528 (package
529 (name "kpmcore")
530 (version "4.1.0")
531 (source (origin
532 (method url-fetch)
533 (uri (string-append
534 "mirror://kde/stable/kpmcore"
535 "/" version "/src/"
536 name "-" version ".tar.xz"))
537 (sha256
538 (base32
539 "0jsig7algmab9h0fb09my0axjqzw83zgscamhzl8931lribs6idm"))))
540 (build-system cmake-build-system)
541 (native-inputs
542 `(("extra-cmake-modules" ,extra-cmake-modules)
543 ("pkg-config" ,pkg-config)))
544 (inputs
545 `(("kauth" ,kauth)
546 ("kcoreaddons" ,kcoreaddons)
547 ("ki18n" ,ki18n)
548 ("kwidgetsaddons" ,kwidgetsaddons)
549 ("qtbase" ,qtbase)
550 ("qca" ,qca)
551 ("util-linux" ,util-linux "lib")))
552 (home-page "https://community.kde.org/Frameworks")
553 (synopsis "Library for managing partitions")
554 (description "Library for managing partitions.")
555 (license license:gpl3+)))
556
557 (define-public snorenotify
558 (package
559 (name "snorenotify")
560 (version "0.7.0")
561 (source
562 (origin
563 (method url-fetch)
564 (uri (string-append "mirror://kde/stable/snorenotify/"
565 version "/src/snorenotify-" version ".tar.xz"))
566 (sha256
567 (base32
568 "0jz6ivk90h7iwgyxar7xzzj8yvzn6s1my6cqs9bdnwqswfk1nhbd"))))
569 (build-system cmake-build-system)
570 (arguments
571 `(#:tests? #f)) ; both tests fail, require display
572 (inputs
573 `(("qtbase" ,qtbase)))
574 (native-inputs
575 `(("extra-cmake-modules" ,extra-cmake-modules)
576 ("qttools" ,qttools)))
577 (home-page "https://techbase.kde.org/Projects/Snorenotify")
578 (synopsis "Qt notification framework")
579 (description "Snorenotify is a multi platform Qt notification framework.
580 Using a plugin system it is possible to create notifications with many
581 different notification systems.")
582 (license license:lgpl3)))
583
584 (define-public kdeconnect
585 (package
586 (name "kdeconnect")
587 (version "20.04.2")
588 (source
589 (origin
590 (method url-fetch)
591 (uri (string-append "mirror://kde/stable/release-service/"
592 version "/src/kdeconnect-kde-"
593 version ".tar.xz"))
594 (sha256
595 (base32
596 "0yq3afbbcc9gmlcachvh3xz3gdj57092fpagp36l5knw8gr0d9ip"))))
597 (build-system qt-build-system)
598 (arguments
599 `(#:configure-flags '("-DBUILD_TESTING=ON"
600 "-DKDE_INSTALL_LIBEXECDIR=libexec")
601 #:phases (modify-phases %standard-phases
602 (add-after 'set-paths 'extend-CPLUS_INCLUDE_PATH
603 (lambda* (#:key inputs #:allow-other-keys)
604 ;; FIXME: <kcmutils_version.h> is not found during one
605 ;; of the compilation steps without this hack.
606 (setenv "CPLUS_INCLUDE_PATH"
607 (string-append (assoc-ref inputs "kcmutils")
608 "/include/KF5:"
609 (or (getenv "CPLUS_INCLUDE_PATH")
610 "")))
611 #t)))
612 #:tests? #f)) ; tests fail hard in our build environment
613 (native-inputs
614 `(("extra-cmake-modules" ,extra-cmake-modules)
615 ("kdoctools" ,kdoctools)
616 ("libxtst" ,libxtst)
617 ("pkg-config" ,pkg-config)
618 ("python" ,python-wrapper)))
619 (inputs
620 `(("kcmutils" ,kcmutils)
621 ("kconfigwidgets" ,kconfigwidgets)
622 ("kdbusaddons" ,kdbusaddons)
623 ("ki18n" ,ki18n)
624 ("kiconthemes" ,kiconthemes)
625 ("kio" ,kio)
626 ("kirigami" ,kirigami)
627 ("knotifications" ,knotifications)
628 ("kpeople" ,kpeople)
629 ("kpeoplevcard" ,kpeoplevcard)
630 ("kwayland" ,kwayland)
631 ("libfakekey" ,libfakekey)
632 ("pulseaudio-qt" ,pulseaudio-qt)
633 ("qca" ,qca)
634 ("qtbase" ,qtbase)
635 ("qtdeclarative" ,qtdeclarative)
636 ("qtmultimedia" ,qtmultimedia)
637 ("qtx11extras" ,qtx11extras)))
638 (home-page "https://community.kde.org/KDEConnect")
639 (synopsis "Enable your devices to communicate with each other")
640 (description "KDE Connect is a project that enables all your devices to
641 communicate with each other. Here's a few things KDE Connect can do:
642 @enumerate
643 @item Receive your phone notifications on your desktop computer and reply to messages
644 @item Control music playing on your desktop from your phone
645 @item Use your phone as a remote control for your desktop
646 @item Run predefined commands on your PC from connected devices
647 @item Check your phones battery level from the desktop
648 @item Ring your phone to help finding it
649 @item Share files and links between devices
650 @item Browse your phone from the desktop
651 @item Control the desktop's volume from the phone
652 @end enumerate")
653 (properties `((upstream-name . "kdeconnect-kde")))
654 (license (list license:gpl2 license:gpl3)))) ; dual licensed
655
656 (define-public kqtquickcharts
657 (package
658 (name "kqtquickcharts")
659 (version "20.04.1")
660 (source
661 (origin
662 (method url-fetch)
663 (uri (string-append "mirror://kde/stable/release-service/"
664 version "/src/kqtquickcharts-" version ".tar.xz"))
665 (sha256
666 (base32
667 "1wxp35mf9zlpgzi4msdl86b2krdq2ipqw371gyx23r7j84vdyxi3"))))
668 (build-system cmake-build-system)
669 (native-inputs
670 `(("extra-cmake-modules" ,extra-cmake-modules)))
671 (inputs
672 `(("qtbase" ,qtbase)
673 ("qtdeclarative" ,qtdeclarative)))
674 (home-page "https://phabricator.kde.org/source/kqtquickcharts/")
675 (synopsis "Interactive charts for Qt Quick")
676 (description
677 "Kqtquickcharts is a QtQuick plugin to render beautiful and interactive
678 charts.")
679 (license license:lgpl2.1+)))
680
681 (define-public kcachegrind
682 (package
683 (name "kcachegrind")
684 (version "20.04.1")
685 (source (origin
686 (method url-fetch)
687 (uri (string-append "mirror://kde/stable/release-service/" version
688 "/src/kcachegrind-" version ".tar.xz"))
689 (sha256
690 (base32
691 "0fx17s6fj1pxl1mgfrqhchk8sihkbji1x8y3nhb1r0971wzd1nsc"))))
692 (build-system cmake-build-system)
693 (native-inputs
694 `(("extra-cmake-modules" ,extra-cmake-modules)
695 ("perl" ,perl)
696 ("python" ,python)
697 ("qttools" ,qttools)
698 ("kdoctools" ,kdoctools)))
699 (inputs
700 `(("qtbase" ,qtbase)
701 ("karchive" ,karchive)
702 ("ki18n" ,ki18n)
703 ("kio" ,kio)
704 ("kdbusaddons" ,kdbusaddons)))
705 ;; Note: The 'hotshot2calltree' and 'pprof2calltree' scripts depend on
706 ;; Python and PHP, respectively. These are optional and we ignore them
707 ;; for now.
708 (home-page "https://kcachegrind.github.io/html/Home.html")
709 (synopsis "Visualize profiles produces by Valgrind's Cachegrind tool")
710 (description
711 "The data files generated by the Callgrind of Valgrind, an application
712 profiler, can be loaded into KCachegrind for browsing the performance results.
713 There is also a command-line tool to get ASCII reports from data files without
714 the need to use KCachegrind.
715
716 The format of Callgrind output is documented. With conversion scripts,
717 KCachegrind is able to visualize output of other profilers like OProfile, a
718 system-wide profiler for Linux using statistical sampling with hardware
719 performance counters. There also exist converters for profiling output of
720 Python, PHP, and Perl.")
721 (license license:gpl2)))
722
723 (define-public libkdegames
724 (package
725 (name "libkdegames")
726 (version "20.04.1")
727 (source
728 (origin
729 (method url-fetch)
730 (uri (string-append "mirror://kde/stable/release-service/" version
731 "/src/libkdegames-" version ".tar.xz"))
732 (sha256
733 (base32 "1xsrrvhwjwi5aajcaxydmzc69i4yx6shs8ly8vr85njc188ycg13"))))
734 (build-system qt-build-system)
735 (native-inputs
736 `(("extra-cmake-modules" ,extra-cmake-modules)))
737 (inputs
738 `(("karchive" ,karchive)
739 ("kbookmarks" ,kbookmarks)
740 ("kcodecs" ,kcodecs)
741 ("kcompletion" ,kcompletion)
742 ("kconfigwidgets" ,kconfigwidgets)
743 ("kcrash" ,kcrash)
744 ("kdbusaddons" ,kdbusaddons)
745 ("kdeclarative" ,kdeclarative)
746 ("kdnssd" ,kdnssd)
747 ("kglobalaccel" ,kglobalaccel)
748 ("kguiaddons" ,kguiaddons)
749 ("ki18n" ,ki18n)
750 ("kiconthemes" ,kiconthemes)
751 ;("kio" ,kio)
752 ("kitemviews" ,kitemviews)
753 ("kjobwidgets" ,kjobwidgets)
754 ("knewstuff" ,knewstuff)
755 ("kservice" ,kservice)
756 ("ktextwidgets" ,ktextwidgets)
757 ("kwidgetsaddons" ,kwidgetsaddons)
758 ("kxmlgui" ,kxmlgui)
759 ("libsndfile" ,libsndfile)
760 ("openal" ,openal)
761 ("qtbase" ,qtbase)
762 ("qtdeclarative" ,qtdeclarative)
763 ("qtsvg" ,qtsvg)))
764 (home-page "https://games.kde.org/")
765 (synopsis "Runtime library for kdegames")
766 (description "Runtime library for kdegames")
767 (license (list license:gpl2+ license:fdl1.2+))))
768
769 (define-public zeroconf-ioslave
770 (package
771 (name "zeroconf-ioslave")
772 (version "20.04.1")
773 (source
774 (origin
775 (method url-fetch)
776 (uri (string-append "mirror://kde/stable/release-service/" version
777 "/src/zeroconf-ioslave-" version ".tar.xz"))
778 (sha256
779 (base32 "1qck5jyc4psslpibhki8sz8aj0hsnx8z791vzyn10lmdzn71vx8c"))))
780 (build-system qt-build-system)
781 (native-inputs
782 `(("extra-cmake-modules" ,extra-cmake-modules)))
783 (inputs
784 `(("kdbusaddons" ,kdbusaddons)
785 ("kdnssd" ,kdnssd)
786 ("ki18n" ,ki18n)
787 ("kio" ,kio)
788 ("qtbase" ,qtbase)))
789 (home-page "https://kde.org/applications/internet/org.kde.zeroconf_ioslave")
790 (synopsis "DNS-SD Service Discovery Monitor")
791 (description "Adds an entry to Dolphin's Network page to show local
792 services such as printers which advertise themselves with DNSSD (called Avahi
793 or Bonjour by other projects).")
794 (license ;; GPL for programs, LGPL for libraries, FDL for documentation
795 (list license:gpl2+ license:lgpl2.0+ license:fdl1.2+))))