gnu: emacs-svg-icon: Fix grammar.
[jackhill/guix/guix.git] / gnu / packages / w3m.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
3 ;;; Copyright © 2016, 2017, 2018 Leo Famulari <leo@famulari.name>
4 ;;; Copyright © 2016 Kei Kebreau <kkebreau@posteo.net>
5 ;;; Copyright © 2016, 2019 Efraim Flashner <efraim@flashner.co.il>
6 ;;; Copyright © 2018 Rutger Helling <rhelling@mykolab.com>
7 ;;; Copyright © 2020 Tobias Geerinckx-Rice <me@tobias.gr>
8 ;;;
9 ;;; This file is part of GNU Guix.
10 ;;;
11 ;;; GNU Guix is free software; you can redistribute it and/or modify it
12 ;;; under the terms of the GNU General Public License as published by
13 ;;; the Free Software Foundation; either version 3 of the License, or (at
14 ;;; your option) any later version.
15 ;;;
16 ;;; GNU Guix is distributed in the hope that it will be useful, but
17 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
18 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
19 ;;; GNU General Public License for more details.
20 ;;;
21 ;;; You should have received a copy of the GNU General Public License
22 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
23
24 (define-module (gnu packages w3m)
25 #:use-module ((guix licenses) #:select (x11-style))
26 #:use-module (gnu packages gettext)
27 #:use-module (gnu packages bdw-gc)
28 #:use-module (gnu packages compression)
29 #:use-module (gnu packages gtk)
30 #:use-module (gnu packages ncurses)
31 #:use-module (gnu packages perl)
32 #:use-module (gnu packages pkg-config)
33 #:use-module (gnu packages tls)
34 #:use-module (gnu packages xorg)
35 #:use-module (gnu packages)
36 #:use-module (guix packages)
37 #:use-module (guix git-download)
38 #:use-module (guix build-system gnu))
39
40 (define-public w3m
41 (package
42 (name "w3m")
43 (version "0.5.3+git20200502")
44 (source (origin
45 (method git-fetch)
46 ;; Debian's fork of w3m is the only one that is still maintained.
47 (uri (git-reference
48 (url "https://salsa.debian.org/debian/w3m.git")
49 (commit (string-append "v" version))))
50 (file-name (git-file-name name version))
51 (sha256
52 (base32
53 "0yyfhwcwy1dvdbirj6zqwk4gl8z9npfavs0k7ipcg5fd16vnx7mi"))))
54 (build-system gnu-build-system)
55 (arguments
56 '(#:tests? #f ; no check target
57 ;; Use $EDITOR instead of a hard-coded value.
58 #:configure-flags '("--with-editor=")
59 #:phases
60 (modify-phases %standard-phases
61 (add-before 'configure 'fix-perl
62 (lambda _ (substitute* '("scripts/w3mmail.cgi.in"
63 "scripts/dirlist.cgi.in")
64 (("@PERL@") (which "perl")))
65 #t)))))
66 (inputs
67 `(("gdk-pixbuf" ,gdk-pixbuf)
68 ("libgc" ,libgc)
69 ("libx11" ,libx11)
70 ("ncurses" ,ncurses)
71 ("openssl" ,openssl)
72 ("zlib" ,zlib)))
73 (native-inputs
74 `(("gettext" ,gettext-minimal)
75 ("perl" ,perl)
76 ("pkg-config" ,pkg-config)))
77 (home-page "http://w3m.sourceforge.net/")
78 (synopsis "Text-mode web browser")
79 (description
80 "w3m is a text-based web browser as well as a pager like @code{more} or
81 @code{less}. With w3m you can browse web pages through a terminal emulator
82 window. Moreover, w3m can be used as a text formatting tool which
83 typesets HTML into plain text.")
84 (license (x11-style "file://doc/README"
85 "See 'doc/README' in the distribution."))))