gnu: emacs-svg-icon: Fix grammar.
[jackhill/guix/guix.git] / gnu / packages / stenography.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2020 Nicolas Goaziou <mail@nicolasgoaziou.fr>
3 ;;; Copyright © 2021 Christopher Baines <mail@cbaines.net>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages stenography)
21 #:use-module (guix build-system python)
22 #:use-module (guix git-download)
23 #:use-module ((guix licenses) #:prefix license:)
24 #:use-module (guix packages)
25 #:use-module (gnu packages)
26 #:use-module (gnu packages qt)
27 #:use-module (gnu packages check)
28 #:use-module (gnu packages libusb)
29 #:use-module (gnu packages python)
30 #:use-module (gnu packages python-xyz)
31 #:use-module (gnu packages wxwidgets))
32
33 (define-public plover
34 (package
35 (name "plover")
36 (version "4.0.0.dev8")
37 (source
38 (origin
39 (method git-fetch)
40 (uri (git-reference
41 (url "https://github.com/openstenoproject/plover")
42 (commit (string-append "v" version))))
43 (file-name (git-file-name name version))
44 (sha256
45 (base32 "1b2ys77bkjsdmyg97i7lq3lj45q56bycvsm06d4rs656kxhvc0a3"))))
46 (build-system python-build-system)
47 (native-inputs
48 `(("python-mock" ,python-mock)
49 ("python-pytest" ,python-pytest)
50 ("python-setuptools-scm" ,python-setuptools-scm)))
51 (inputs
52 `(("python-appdirs" ,python-appdirs)
53 ("python-pyqt" ,python-pyqt)
54 ("python-babel" ,python-babel)
55 ("python-dbus" ,python-dbus)
56 ("python-hidapi" ,python-hidapi)
57 ("python-pyserial" ,python-pyserial)
58 ("python-wxpython" ,python-wxpython)
59 ("python-xlib" ,python-xlib)))
60 (home-page "https://www.openstenoproject.org/plover/")
61 (synopsis "Stenography engine")
62 (description
63 "Plover (rhymes with @emph{lover}) is a desktop application that
64 allows anyone to use stenography to write on their computer, up to
65 speeds of 200WPM and beyond.")
66 (license license:gpl2+)))
67