gnu: emacs-svg-icon: Fix grammar.
[jackhill/guix/guix.git] / gnu / packages / sphinx.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014 David Thompson <davet@gnu.org>
3 ;;; Copyright © 2015, 2017, 2019, 2020, 2021 Ricardo Wurmus <rekado@elephly.net>
4 ;;; Copyright © 2015, 2016, 2017 Leo Famulari <leo@famulari.name>
5 ;;; Copyright © 2016 Hartmut Goebel <h.goebel@crazy-compilers.com>
6 ;;; Copyright © 2016, 2017, 2018, 2019 Marius Bakke <mbakke@fastmail.com>
7 ;;; Copyright © 2017 Danny Milosavljevic <dannym+a@scratchpost.org>
8 ;;; Copyright © 2017, 2018, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
9 ;;; Copyright © 2017 Frederick M. Muriithi <fredmanglis@gmail.com>
10 ;;; Copyright © 2017 Christopher Allan Webber <cwebber@dustycloud.org>
11 ;;; Copyright © 2017 Julien Lepiller <julien@lepiller.eu>
12 ;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
13 ;;; Copyright © 2019, 2021 Nicolas Goaziou <mail@nicolasgoaziou.fr>
14 ;;; Copyright © 2019 Alexandros Theodotou <alex@zrythm.org>
15 ;;; Copyright © 2019 Brett Gilio <brettg@gnu.org>
16 ;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
17 ;;; Copyright © 2021 Eric Bavier <bavier@posteo.net>
18 ;;;
19 ;;; This file is part of GNU Guix.
20 ;;;
21 ;;; GNU Guix is free software; you can redistribute it and/or modify it
22 ;;; under the terms of the GNU General Public License as published by
23 ;;; the Free Software Foundation; either version 3 of the License, or (at
24 ;;; your option) any later version.
25 ;;;
26 ;;; GNU Guix is distributed in the hope that it will be useful, but
27 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
28 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
29 ;;; GNU General Public License for more details.
30 ;;;
31 ;;; You should have received a copy of the GNU General Public License
32 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
33
34 (define-module (gnu packages sphinx)
35 #:use-module (guix packages)
36 #:use-module (guix download)
37 #:use-module (guix git-download)
38 #:use-module (guix utils)
39 #:use-module (guix build-system python)
40 #:use-module ((guix licenses) #:prefix license:)
41 #:use-module (gnu packages)
42 #:use-module (gnu packages check)
43 #:use-module (gnu packages graphviz)
44 #:use-module (gnu packages image)
45 #:use-module (gnu packages imagemagick)
46 #:use-module (gnu packages python-build)
47 #:use-module (gnu packages python-crypto)
48 #:use-module (gnu packages python-web)
49 #:use-module (gnu packages python-xyz)
50 #:use-module (gnu packages time))
51
52 (define-public python-sphinx
53 (package
54 (name "python-sphinx")
55 (version "3.3.1")
56 (source
57 (origin
58 (method url-fetch)
59 (uri (pypi-uri "Sphinx" version))
60 (sha256
61 (base32
62 "0023vc2i29pjxmvdqbz1wdbi7gbj56y1br1b2z8h8wa44li5k38y"))))
63 (build-system python-build-system)
64 (arguments
65 `(#:phases
66 (modify-phases %standard-phases
67 (replace 'check
68 (lambda _
69 ;; Requires Internet access.
70 (delete-file "tests/test_build_linkcheck.py")
71 (substitute* "tests/test_build_latex.py"
72 (("@pytest.mark.sphinx\\('latex', testroot='images'\\)")
73 "@pytest.mark.skip()"))
74 (invoke "make" "test"))))))
75 (propagated-inputs
76 `(("python-babel" ,python-babel)
77 ("python-docutils" ,python-docutils)
78 ("python-jinja2" ,python-jinja2)
79 ("python-imagesize" ,python-imagesize)
80 ("python-packaging" ,python-packaging)
81 ("python-pygments" ,python-pygments)
82 ("python-requests" ,python-requests)
83 ("python-snowballstemmer" ,python-snowballstemmer)
84 ("python-sphinx-alabaster-theme"
85 ,python-sphinx-alabaster-theme)
86 ("python-sphinxcontrib-applehelp" ,python-sphinxcontrib-applehelp)
87 ("python-sphinxcontrib-devhelp" ,python-sphinxcontrib-devhelp)
88 ("python-sphinxcontrib-htmlhelp" ,python-sphinxcontrib-htmlhelp)
89 ("python-sphinxcontrib-jsmath" ,python-sphinxcontrib-jsmath)
90 ("python-sphinxcontrib-qthelp" ,python-sphinxcontrib-qthelp)
91 ("python-sphinxcontrib-serializinghtml"
92 ,python-sphinxcontrib-serializinghtml)))
93 (native-inputs
94 `(("graphviz" ,graphviz)
95 ("imagemagick" ,imagemagick) ;for "convert"
96 ("python-html5lib" ,python-html5lib)
97 ("python-mock" ,python-mock)
98 ("python-nose" ,python-nose)
99 ("python-pytest" ,python-pytest)))
100 (home-page "https://www.sphinx-doc.org")
101 (synopsis "Python documentation generator")
102 (description "Sphinx is a tool that makes it easy to create documentation
103 for Python projects or other documents consisting of multiple reStructuredText
104 sources.")
105 (license license:bsd-2)
106 (properties `((python2-variant . ,(delay python2-sphinx))))))
107
108 ;; Sphinx 2 does not support Python 2, so we stick with this older version here.
109 (define-public python2-sphinx
110 (let ((base (package-with-python2 (strip-python2-variant python-sphinx))))
111 (package
112 (inherit base)
113 (version "1.7.7")
114 (source (origin
115 (method url-fetch)
116 (uri (pypi-uri "Sphinx" version))
117 (sha256
118 (base32
119 "0pkkbfj7cl157q550gcs45am5y78ps0h7q6455d64s1zmw01jlvi"))))
120 (arguments
121 (substitute-keyword-arguments (package-arguments base)
122 ((#:phases phases)
123 `(modify-phases ,phases
124 (add-before 'check 'disable-broken-tests
125 (lambda _
126 (for-each delete-file
127 ;; These tests are broken when using Python2:
128 ;; <https://github.com/sphinx-doc/sphinx/issues/4710>.
129 '("tests/test_api_translator.py"
130 "tests/test_setup_command.py"
131 ;; This one fails for unknown reasons.
132 "tests/test_correct_year.py"))))))))
133 (native-inputs `(("python2-mock" ,python2-mock)
134 ("python2-enum34" ,python2-enum34)
135 ,@(package-native-inputs base)))
136 ;; Sphinx 2 has some dependencies that do not support Python 2, so
137 ;; we keep our own propagated-inputs here instead of inheriting.
138 (propagated-inputs
139 `(("python2-pytz" ,python2-pytz)
140 ("python2-typing" ,python2-typing)
141 ("python2-imagesize" ,python2-imagesize)
142 ("python2-sphinx-alabaster-theme" ,python2-sphinx-alabaster-theme)
143 ("python2-babel" ,python2-babel)
144 ("python2-snowballstemmer" ,python2-snowballstemmer)
145 ("python2-docutils" ,python2-docutils-0.14)
146 ("python2-jinja2" ,python2-jinja2)
147 ("python2-packaging" ,python2-packaging)
148 ("python2-pygments" ,python2-pygments)
149 ("python2-requests" ,python2-requests)
150 ("python2-six" ,python2-six)
151 ("python2-sphinxcontrib-websupport" ,python2-sphinxcontrib-websupport))))))
152
153 (define-public python-sphinxcontrib-applehelp
154 (package
155 (name "python-sphinxcontrib-applehelp")
156 (version "1.0.2")
157 (source (origin
158 (method url-fetch)
159 (uri (pypi-uri "sphinxcontrib-applehelp" version))
160 (sha256
161 (base32
162 "0n5wrn4l7x6gxvi1g7c6y72hkxgc223axz1jykipaxhfr1g76wm0"))))
163 (build-system python-build-system)
164 (arguments
165 `(#:tests? #f)) ;XXX: circular dependency on Sphinx
166 (home-page "https://github.com/sphinx-doc/sphinxcontrib-applehelp")
167 (synopsis "Sphinx extension for creating Apple help books")
168 (description
169 "@code{sphinxcontrib-applehelp} is a Sphinx extension which outputs
170 Apple help books.")
171 (license license:bsd-2)))
172
173 (define-public python-sphinx-copybutton
174 (package
175 (name "python-sphinx-copybutton")
176 (version "0.2.6")
177 (source
178 (origin
179 (method url-fetch)
180 (uri (pypi-uri "sphinx-copybutton" version))
181 (sha256
182 (base32
183 "0ny9jpygj93z8jyjpi4v6jjz90pmns74s389wq16igzzq2mpgfjm"))))
184 (build-system python-build-system)
185 (arguments
186 `(#:tests? #f)) ; XXX: Check requires network access.
187 (propagated-inputs
188 `(("python-flit" ,python-flit)
189 ("python-setuptools" ,python-setuptools)
190 ("python-sphinx" ,python-sphinx)
191 ("python-wheel" ,python-wheel)))
192 (home-page "https://github.com/choldgraf/sphinx-copybutton")
193 (synopsis "Sphinx extension to add \"copy\" buttons to code blocks")
194 (description
195 "This package provides a small sphinx extension to add \"copy\" buttons
196 to code blocks.")
197 (license license:expat)))
198
199 (define-public python-sphinxcontrib-devhelp
200 (package
201 (name "python-sphinxcontrib-devhelp")
202 (version "1.0.2")
203 (source (origin
204 (method url-fetch)
205 (uri (pypi-uri "sphinxcontrib-devhelp" version))
206 (sha256
207 (base32
208 "1r1qngsbjqbg4rj93kpj44qqy7n4x5khldkr0c3ffhlnggx1lzzz"))))
209 (build-system python-build-system)
210 (arguments
211 `(#:tests? #f)) ;XXX: circular dependency on Sphinx
212 (home-page "https://github.com/sphinx-doc/sphinxcontrib-devhelp")
213 (synopsis "Sphinx extension for creating Devhelp documents")
214 (description
215 "@code{sphinxcontrib-devhelp} is a Sphinx extension which outputs
216 @url{Devhelp,https://wiki.gnome.org/Apps/Devhelp} documents.")
217 (license license:bsd-2)))
218
219 (define-public python-sphinxcontrib-github-alt
220 (package
221 (name "python-sphinxcontrib-github-alt")
222 (version "1.2")
223 (source
224 (origin
225 (method url-fetch)
226 (uri (pypi-uri "sphinxcontrib_github_alt" version))
227 (sha256
228 (base32
229 "1x9af78vamjjcdrrhiah3wg613jv7gm8yh9vvqfrmf4vam6mimyg"))))
230 (build-system python-build-system)
231 (propagated-inputs
232 `(("python-docutils" ,python-docutils)
233 ("python-sphinx" ,python-sphinx)))
234 (home-page "https://github.com/jupyter/sphinxcontrib_github_alt")
235 (synopsis "Link to GitHub pages from Sphinx docs")
236 (description
237 "This package lets you link to GitHub issues, pull requests, commits and
238 users from Sphinx docs.")
239 (license license:bsd-2)))
240
241 (define-public python-sphinxcontrib-htmlhelp
242 (package
243 (name "python-sphinxcontrib-htmlhelp")
244 (version "1.0.3")
245 (source (origin
246 (method url-fetch)
247 (uri (pypi-uri "sphinxcontrib-htmlhelp" version))
248 (sha256
249 (base32
250 "16v5jdnibwrqjdr5aqchgyzpwy3rgamwhdf4kidv5nxj65zbpxg8"))))
251 (build-system python-build-system)
252 (arguments
253 `(#:tests? #f)) ;XXX: circular dependency on Sphinx
254 (home-page "https://github.com/sphinx-doc/sphinxcontrib-htmlhelp")
255 (synopsis "Sphinx extension for rendering HTML help files")
256 (description
257 "@code{sphinxcontrib-htmlhelp} is a Sphinx extension which renders
258 HTML help files.")
259 (license license:bsd-2)))
260
261 (define-public python-sphinxcontrib-jsmath
262 (package
263 (name "python-sphinxcontrib-jsmath")
264 (version "1.0.1")
265 (source (origin
266 (method url-fetch)
267 (uri (pypi-uri "sphinxcontrib-jsmath" version))
268 (sha256
269 (base32
270 "1f64w19j33sp151jimibraw6qrbhd5gxy8hs3797w9478m55x4m9"))))
271 (build-system python-build-system)
272 (arguments
273 `(#:tests? #f)) ;XXX: circular dependency on Sphinx
274 (home-page "https://github.com/sphinx-doc/sphinxcontrib-jsmath")
275 (synopsis "Sphinx extension to render math equations")
276 (description
277 "@code{sphinxcontrib-jsmath} is a Sphinx extension which renders display
278 math in HTML via JavaScript.")
279 (license license:bsd-2)))
280
281 (define-public python-sphinxcontrib-newsfeed
282 (package
283 (name "python-sphinxcontrib-newsfeed")
284 (version "0.1.4")
285 (source (origin
286 (method url-fetch)
287 (uri (pypi-uri "sphinxcontrib-newsfeed" version))
288 (sha256
289 (base32
290 "1d7gam3mn8v4in4p16yn3v10vps7nnaz6ilw99j4klij39dqd37p"))))
291 (arguments '(#:tests? #f)) ; No tests.
292 (build-system python-build-system)
293 (propagated-inputs
294 `(("python-sphinx" ,python-sphinx)))
295 (synopsis "News Feed extension for Sphinx")
296 (description "Sphinxcontrib-newsfeed is an extension for adding a simple
297 Blog, News or Announcements section to a Sphinx website.")
298 (home-page "https://bitbucket.org/prometheus/sphinxcontrib-newsfeed")
299 (license license:bsd-2)))
300
301 (define-public python-sphinxcontrib-programoutput
302 (package
303 (name "python-sphinxcontrib-programoutput")
304 (version "0.15")
305 (source (origin
306 (method url-fetch)
307 (uri (pypi-uri "sphinxcontrib-programoutput" version))
308 (sha256
309 (base32
310 "155bz0z2cz544pphkd3nk7ph83mz7nn0ql135kzi62kqmd75ppc0"))))
311 (build-system python-build-system)
312 (arguments
313 ;; FIXME: Many tests are failing.
314 '(#:tests? #f))
315 (propagated-inputs
316 `(("python-sphinx" ,python-sphinx)))
317 (synopsis "Sphinx extension to include program output")
318 (description "A Sphinx extension to literally insert the output of arbitrary
319 commands into documents, helping you to keep your command examples up to date.")
320 (home-page "https://github.com/NextThought/sphinxcontrib-programoutput")
321 (license license:bsd-2)))
322
323 (define-public python2-sphinxcontrib-programoutput
324 (package-with-python2 python-sphinxcontrib-programoutput))
325
326 (define-public python-sphinxcontrib-qthelp
327 (package
328 (name "python-sphinxcontrib-qthelp")
329 (version "1.0.3")
330 (source (origin
331 (method url-fetch)
332 (uri (pypi-uri "sphinxcontrib-qthelp" version))
333 (sha256
334 (base32
335 "0wjsp96d262shzkx7pb7pra7mmf0j8c5rz56i6x0vdsqw1z7ccsc"))))
336 (build-system python-build-system)
337 (arguments
338 `(#:tests? #f)) ;XXX: circular dependency on Sphinx
339 (home-page "https://github.com/sphinx-doc/sphinxcontrib-qthelp")
340 (synopsis "Sphinx extension to output QtHelp documents")
341 (description
342 "@code{sphinxcontrib-qthelp} is a Sphinx extension which outputs QtHelp
343 documents.")
344 (license license:bsd-2)))
345
346 (define-public python-sphinxcontrib-serializinghtml
347 (package
348 (name "python-sphinxcontrib-serializinghtml")
349 (version "1.1.4")
350 (source (origin
351 (method url-fetch)
352 (uri (pypi-uri "sphinxcontrib-serializinghtml" version))
353 (sha256
354 (base32
355 "1g3pbx0g88zd9xzcrbaypa2k60axrh92vf5j76wsk0p9hv6fr87a"))))
356 (build-system python-build-system)
357 (arguments
358 `(#:tests? #f)) ;XXX: circular dependency on Sphinx
359 (home-page "https://github.com/sphinx-doc/sphinxcontrib-serializinghtml")
360 (synopsis "Sphinx extension to serialize HTML files")
361 (description
362 "@code{sphinxcontrib-serializinghtml} is a Sphinx extension which outputs
363 \"serialized\" HTML files.")
364 (license license:bsd-2)))
365
366 (define-public python-sphinxcontrib-svg2pdfconverter
367 (package
368 (name "python-sphinxcontrib-svg2pdfconverter")
369 (version "1.0.1")
370 (source (origin
371 (method url-fetch)
372 (uri (pypi-uri "sphinxcontrib-svg2pdfconverter" version))
373 (sha256
374 (base32
375 "1hhaxmqc7wh8gnyw5jaqckliknvk0p21y12wk3bdmncgkaf9ar8f"))))
376 (build-system python-build-system)
377 (propagated-inputs
378 `(("python-sphinx" ,python-sphinx)))
379 (home-page "https://github.com/missinglinkelectronics/sphinxcontrib-svg2pdfconverter")
380 (synopsis "Sphinx SVG to PDF converter extension")
381 (description "A Sphinx extension to convert SVG images to PDF in case the
382 builder does not support SVG images natively (e.g. LaTeX).")
383 (license license:bsd-2)))
384
385 (define-public python-sphinxcontrib-websupport
386 (package
387 (name "python-sphinxcontrib-websupport")
388 (version "1.2.0")
389 (source (origin
390 (method url-fetch)
391 (uri (pypi-uri "sphinxcontrib-websupport" version))
392 (sha256
393 (base32
394 "1smma7r0rhwcmbfvvkfs5djfz1qm8wbpcvp084ca6dmw2b9zplxs"))))
395 (build-system python-build-system)
396 (arguments
397 ;; FIXME: Tests depend on Sphinx, which depends on this.
398 `(#:tests? #f))
399 (home-page "https://sphinx-doc.org/")
400 (synopsis "Sphinx API for web applications")
401 (description "This package provides a Python API to easily integrate
402 Sphinx documentation into your web application. It provides tools to
403 integrate Sphinx documents in web templates and to handle searches.")
404 (license license:bsd-3)))
405
406 (define-public python2-sphinxcontrib-websupport
407 (package-with-python2 python-sphinxcontrib-websupport))
408
409 (define-public python-sphinx-gallery
410 (package
411 (name "python-sphinx-gallery")
412 (version "0.1.13")
413 (source (origin
414 (method git-fetch)
415 (uri (git-reference
416 (url "https://github.com/sphinx-gallery/sphinx-gallery")
417 (commit (string-append "v" version))))
418 (file-name (git-file-name name version))
419 (sha256
420 (base32
421 "14nbqh9krx2l2y2ylbln6l6w8iak3wac1lngvaf278y1cx7685kg"))))
422 (build-system python-build-system)
423 (arguments
424 ;; FIXME: Tests attempt to download <https://docs.python.org/3/objects.inv>,
425 ;; <https://docs.scipy.org/doc/numpy/objects.inv>, and
426 ;; <https://matplotlib.org/objects.inv>.
427 `(#:tests? #f))
428 (native-inputs
429 `(("python-pytest-runner" ,python-pytest-runner)))
430 (home-page "https://sphinx-gallery.github.io/")
431 (synopsis "Generate an examples gallery automatically")
432 (description
433 "@code{sphinx_gallery} is a Sphinx extension that builds an HTML version
434 from any set of Python scripts and puts it into an examples gallery.")
435 (license license:bsd-3)))
436
437 (define-public python2-sphinx-gallery
438 (package-with-python2 python-sphinx-gallery))
439
440 (define-public python-sphinx-me
441 (package
442 (name "python-sphinx-me")
443 (version "0.3")
444 (source
445 (origin
446 (method url-fetch)
447 (uri (pypi-uri "sphinx-me" version))
448 (sha256
449 (base32
450 "06jzgp213zihnvpcy2y5jy3ykid3apc2ncp2pg6a2g05lhiziglq"))))
451 (build-system python-build-system)
452 (home-page "https://github.com/stephenmcd/sphinx-me")
453 (synopsis "Create a Sphinx documentation shell")
454 (description
455 "Create a Sphinx documentation shell for your project and include the
456 README file as the documentation index. It handles extracting the required
457 meta data such as the project name, author and version from your project for
458 use in your Sphinx docs.")
459 (license license:bsd-2)))
460
461 (define-public python2-sphinx-me
462 (package-with-python2 python-sphinx-me))
463
464 (define-public python-sphinx-repoze-autointerface
465 (package
466 (name "python-sphinx-repoze-autointerface")
467 (version "0.8")
468 (source (origin
469 (method url-fetch)
470 (uri (pypi-uri "repoze.sphinx.autointerface" version))
471 (sha256
472 (base32
473 "08ycivzf7bh4a1zcyp31hbyqs1b2c9r26raa3vxjwwmbfqr3iw4f"))))
474 (build-system python-build-system)
475 (arguments '(#:tests? #f)) ; No tests.
476 (propagated-inputs
477 `(("python-sphinx" ,python-sphinx)
478 ("python-zope-interface" ,python-zope-interface)))
479 (synopsis "Auto-generate Sphinx API docs from Zope interfaces")
480 (description "This package defines an extension for the Sphinx documentation
481 system. The extension allows generation of API documentation by
482 introspection of @code{zope.interface} instances in code.")
483 (home-page "https://github.com/repoze/repoze.sphinx.autointerface")
484 (license license:repoze)))
485
486 (define-public python2-sphinx-repoze-autointerface
487 (package-with-python2 python-sphinx-repoze-autointerface))
488
489 (define-public python-sphinx-alabaster-theme
490 (package
491 (name "python-sphinx-alabaster-theme")
492 (version "0.7.12")
493 (source (origin
494 (method url-fetch)
495 (uri (pypi-uri "alabaster" version))
496 (sha256
497 (base32
498 "00nwwjj2d2ym4s2kk217x7jkx1hnczc3fvm8yxbqmsp6b0nxfqd6"))))
499 (build-system python-build-system)
500 (propagated-inputs
501 `(("python-pygments" ,python-pygments)))
502 (home-page "https://alabaster.readthedocs.io/")
503 (synopsis "Configurable sidebar-enabled Sphinx theme")
504 (description "Alabaster is a visually (c)lean, responsive, configurable
505 theme for the Sphinx documentation system. It's the default theme of Sphinx.")
506 (license license:bsd-3)))
507
508 (define-public python2-sphinx-alabaster-theme
509 (package-with-python2 python-sphinx-alabaster-theme))
510
511 (define-public python-sphinx-argparse
512 (package
513 (name "python-sphinx-argparse")
514 (version "0.2.5")
515 (source
516 (origin
517 (method url-fetch)
518 (uri (pypi-uri "sphinx-argparse" version))
519 (sha256
520 (base32 "05wc8f5hb3jsg2vh2jf7jsyan8d4i09ifrz2c8fp6f7x1zw9iav0"))))
521 (build-system python-build-system)
522 (propagated-inputs
523 `(("python-sphinx" ,python-sphinx)))
524 (native-inputs
525 `(("python-commonmark" ,python-commonmark)
526 ("python-pytest" ,python-pytest)
527 ("python-sphinx-rtd-theme" ,python-sphinx-rtd-theme)))
528 (home-page "https://github.com/ribozz/sphinx-argparse")
529 (synopsis "Sphinx extension for documenting argparse commands and options")
530 (description
531 "This package is a sphinx extension that automatically documents
532 argparse commands and options")
533 (license license:expat)))
534
535 (define-public python-sphinx-cloud-sptheme
536 (package
537 (name "python-sphinx-cloud-sptheme")
538 (version "1.8.0")
539 (source (origin
540 (method url-fetch)
541 (uri (pypi-uri "cloud_sptheme" version))
542 (sha256
543 (base32
544 "1dniqb6a39yh786f86c4jn666rwnyi1jvzn4616zhcchb7sfdshd"))))
545 (build-system python-build-system)
546 ;; FIXME: The 'pypi' release archive does not contain tests.
547 (arguments '(#:tests? #f))
548 (native-inputs
549 `(("python-sphinx" ,python-sphinx)))
550 (home-page "https://bitbucket.org/ecollins/cloud_sptheme")
551 (synopsis "'Cloud' theme for Sphinx documenter")
552 (description "This package contains the \"Cloud\" theme for Sphinx and some
553 related extensions.")
554 (license license:bsd-3)))
555
556 (define-public python2-sphinx-cloud-sptheme
557 (package-with-python2 python-sphinx-cloud-sptheme))
558
559 (define-public python-guzzle-sphinx-theme
560 (package
561 (name "python-guzzle-sphinx-theme")
562 (version "0.7.11")
563 (source
564 (origin
565 (method url-fetch)
566 (uri (pypi-uri "guzzle_sphinx_theme" version))
567 (sha256
568 (base32
569 "1rnkzrrsbnifn3vsb4pfaia3nlvgvw6ndpxp7lzjrh23qcwid34v"))))
570 (build-system python-build-system)
571 (propagated-inputs
572 `(("python-sphinx" ,python-sphinx)))
573 (home-page "https://github.com/guzzle/guzzle_sphinx_theme")
574 (synopsis "Sphinx theme used by Guzzle")
575 (description "This package provides guzzle_sphinx_theme, a theme for the
576 Sphinx documentation system, used by @uref{http://docs.guzzlephp.org, Guzzle}
577 and several other projects.")
578 (license license:expat)))
579
580 (define-public python2-guzzle-sphinx-theme
581 (package-with-python2 python-guzzle-sphinx-theme))
582
583 (define-public python-sphinx-rtd-theme
584 (package
585 (name "python-sphinx-rtd-theme")
586 (version "0.2.4")
587 (source
588 (origin
589 (method url-fetch)
590 (uri (pypi-uri "sphinx_rtd_theme" version))
591 (sha256
592 (base32
593 "05rlhjzdyapr2w74jjs7mrm8hi69qskcr5vya9f9drpsys7lpxrd"))))
594 (build-system python-build-system)
595 (arguments '(#:tests? #f)) ; No tests.
596 (propagated-inputs
597 `(("python-sphinx" ,python-sphinx)))
598 (home-page "https://github.com/snide/sphinx_rtd_theme/")
599 (synopsis "ReadTheDocs.org theme for Sphinx")
600 (description "A theme for Sphinx used by ReadTheDocs.org.")
601 (license license:expat)))
602
603 (define-public python2-sphinx-rtd-theme
604 (package-with-python2 python-sphinx-rtd-theme))
605
606 (define-public python-breathe
607 (package
608 (name "python-breathe")
609 (version "4.22.1")
610 (source
611 (origin
612 (method url-fetch)
613 (uri (pypi-uri "breathe" version))
614 (sha256
615 (base32
616 "0snk538xv60z4vfhl3f7v5g658za7257hddkg07cknkn33k6cjvf"))))
617 (build-system python-build-system)
618 (propagated-inputs
619 `(("python-docutils" ,python-docutils)
620 ("python-six" ,python-six)
621 ("python-sphinx" ,python-sphinx)))
622 (home-page "https://github.com/michaeljones/breathe")
623 (synopsis "ReStructuredText and Sphinx bridge to Doxygen")
624 (description "This package is an extension to reStructuredText and Sphinx
625 to be able to read and render the Doxygen xml output.")
626 (license license:bsd-3)))
627
628 (define-public python-sphinx-intl
629 (package
630 (name "python-sphinx-intl")
631 (version "2.0.1")
632 (source
633 (origin
634 (method url-fetch)
635 (uri (pypi-uri "sphinx-intl" version))
636 (sha256
637 (base32 "1d1q0sanjp4nkfvhsxi75zf3xjyyi8nzxvl3v7l0jy9ld70nwnmj"))))
638 (build-system python-build-system)
639 (propagated-inputs
640 `(("python-sphinx" ,python-sphinx)
641 ("python-click" ,python-click)))
642 (home-page "https://github.com/sphinx-doc/sphinx-intl")
643 (synopsis
644 "Sphinx utility that makes it easy to translate and to apply translation")
645 (description
646 "A utility tool that provides several features that make it easy to
647 translate and to apply translation to Sphinx generated document.")
648 (license license:bsd-2)))
649
650 (define-public python-sphinx-autobuild
651 (package
652 (name "python-sphinx-autobuild")
653 (version "0.7.1")
654 (source
655 (origin
656 (method url-fetch)
657 (uri (pypi-uri "sphinx-autobuild" version))
658 (sha256
659 (base32
660 "0kn753dyh3b1s0h77lbk704niyqc7bamvq6v3s1f6rj6i20qyf36"))))
661 (build-system python-build-system)
662 (arguments
663 `(#:phases
664 (modify-phases %standard-phases
665 ;; See https://github.com/GaretJax/sphinx-autobuild/pull/72
666 (add-after 'unpack 'use-later-port-for
667 (lambda _
668 (substitute* "requirements.txt"
669 (("port_for==.*") "port_for\n"))
670 #t))
671 (delete 'check)
672 (add-after 'install 'check
673 (lambda* (#:key inputs outputs tests? #:allow-other-keys)
674 (when tests?
675 (add-installed-pythonpath inputs outputs)
676 (invoke "pytest" "-v"))
677 #t)))))
678 (propagated-inputs
679 `(("python-argh" ,python-argh)
680 ("python-livereload" ,python-livereload)
681 ("python-pathtools" ,python-pathtools)
682 ("python-port-for" ,python-port-for)
683 ("python-pyyaml" ,python-pyyaml)
684 ("python-tornado" ,python-tornado)
685 ("python-watchdog" ,python-watchdog)))
686 (native-inputs
687 `(("python-pytest" ,python-pytest)))
688 (home-page "https://github.com/GaretJax/sphinx-autobuild")
689 (synopsis "Rebuild Sphinx documentation when a change is detected")
690 (description
691 "This package lets you watch a Sphinx directory and rebuild the
692 documentation when a change is detected. It also includes a livereload
693 enabled web server.")
694 (license license:expat)))
695
696 (define-public python-sphinx-autodoc-typehints
697 (package
698 (name "python-sphinx-autodoc-typehints")
699 (version "1.11.1")
700 (source
701 (origin
702 (method url-fetch)
703 (uri (pypi-uri "sphinx-autodoc-typehints" version))
704 (sha256
705 (base32
706 "086v9mg21pvfx0lfqjx2xf36hnzrsripfg345xi59f7xwb9scjr4"))))
707 (build-system python-build-system)
708 (propagated-inputs
709 `(("python-setuptools-scm" ,python-setuptools-scm)
710 ("python-sphinx" ,python-sphinx)))
711 (native-inputs
712 `(("python-dataclasses" ,python-dataclasses)
713 ("python-pytest" ,python-pytest)
714 ("python-sphinx" ,python-sphinx)
715 ("python-sphobjinv" ,python-sphobjinv)
716 ("python-typing-extensions" ,python-typing-extensions)))
717 (home-page "https://pypi.org/project/sphinx-autodoc-typehints/")
718 (synopsis "Type hints for the Sphinx autodoc extension")
719 (description "This extension allows you to use Python 3 annotations for
720 documenting acceptable argument types and return value types of functions.")
721 (license license:expat)))
722
723 (define-public python-nbsphinx
724 (package
725 (name "python-nbsphinx")
726 (version "0.7.1")
727 (source
728 (origin
729 (method url-fetch)
730 (uri (pypi-uri "nbsphinx" version))
731 (sha256
732 (base32
733 "0j56bxdj08vn3q1804qwb1ywhga1mdg1awgm7i64wfpfwi8df2zm"))))
734 (build-system python-build-system)
735 (propagated-inputs
736 `(("python-docutils" ,python-docutils)
737 ("python-jinja2" ,python-jinja2)
738 ("python-nbconvert" ,python-nbconvert)
739 ("python-nbformat" ,python-nbformat)
740 ("python-sphinx" ,python-sphinx)
741 ("python-traitlets" ,python-traitlets)))
742 (home-page "https://nbsphinx.readthedocs.io/")
743 (synopsis "Jupyter Notebook Tools for Sphinx")
744 (description "@code{python-nbsphinx} is a Sphinx extension that
745 provides a source parser for @code{*.ipynb} files. Custom Sphinx
746 directives are used to show Jupyter Notebook code cells (and of course
747 their results) in both HTML and LaTeX output. Un-evaluated notebooks
748 - i.e. notebooks without stored output cells - will be automatically
749 executed during the Sphinx build process.")
750 (license license:expat)))
751
752 (define-public python-sphobjinv
753 (package
754 (name "python-sphobjinv")
755 (version "2.0.1")
756 (source
757 (origin
758 (method url-fetch)
759 (uri (pypi-uri "sphobjinv" version))
760 (sha256
761 (base32
762 "126lgm54c94ay3fci512ap4l607gak90pbz0fk98syxvj5izrrzx"))))
763 (build-system python-build-system)
764 (propagated-inputs
765 `(("python-attrs" ,python-attrs)
766 ("python-certifi" ,python-certifi)
767 ("python-fuzzywuzzy" ,python-fuzzywuzzy)
768 ("python-jsonschema" ,python-jsonschema)
769 ("python-levenshtein" ,python-levenshtein)))
770 (home-page "https://github.com/bskinn/sphobjinv")
771 (synopsis "Sphinx cross-reference tool")
772 (description "Sphinx objects.inv inspection/manipulation tool.")
773 (license license:expat)))