gnu: emacs-svg-icon: Fix grammar.
[jackhill/guix/guix.git] / gnu / packages / serveez.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Eric Bavier <bavier@member.fsf.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages serveez)
20 #:use-module (guix packages)
21 #:use-module (guix licenses)
22 #:use-module (guix download)
23 #:use-module (guix build-system gnu)
24 #:use-module (gnu packages)
25 #:use-module (gnu packages guile))
26
27 (define-public serveez
28 (package
29 (name "serveez")
30 (version "0.2.2")
31 (source
32 (origin
33 (method url-fetch)
34 (uri (string-append "mirror://gnu/serveez/serveez-"
35 version ".tar.xz"))
36 (sha256
37 (base32
38 "09a5jh762ps71ivlg7vdlzp3y29ncl3nsad7qbcni78bq2mzwxsc"))))
39 (build-system gnu-build-system)
40 (inputs `(("guile" ,guile-2.0)))
41 (arguments
42 `(#:configure-flags '("--enable-libserveez-install")
43 #:phases
44 (modify-phases %standard-phases
45 (add-before 'patch-source-shebangs 'patch-test-source
46 (lambda _
47 (substitute*
48 (find-files "test" "^t[0-9]{3}$")
49 (("/bin/sh") (which "sh")))
50 #t)))))
51 (home-page "https://www.gnu.org/software/serveez/")
52 (synopsis "Framework for implementing IP-based servers")
53 (description
54 "GNU Serveez is a server framework providing the routines necessary to
55 easily implement IP-based servers in your application. It
56 demonstrates aspects of network programming in a portable manner,
57 making it convenient for both simplifying the process of adding a
58 server to your application or for learning about how network services
59 work. Several example servers are provided already, such as an HTTP
60 server and an IRC server.")
61 (license gpl3+)))