gnu: emacs-svg-icon: Fix grammar.
[jackhill/guix/guix.git] / gnu / packages / re2c.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2017, 2020 Sergei Trofimovich <slyfox@inbox.ru>
3 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages re2c)
21 #:use-module (guix licenses)
22 #:use-module (guix packages)
23 #:use-module (guix download)
24 #:use-module (guix build-system gnu))
25
26 (define-public re2c
27 (package
28 (name "re2c")
29 (version "2.0.3")
30 (source (origin
31 (method url-fetch)
32 (uri (string-append "https://github.com/skvadrik/" name
33 "/releases/download/" version "/"
34 name "-" version ".tar.xz"))
35 (sha256
36 (base32
37 "0y22fiyv2pqmq8asb2p5hzcf7ibjdrz7nl16rlpzy8damaw1xg5j"))))
38 (build-system gnu-build-system)
39 (home-page "https://re2c.org/")
40 (synopsis "Lexer generator for C/C++")
41 (description
42 "@code{re2c} generates minimalistic hard-coded state machine (as opposed
43 to full-featured table-based lexers). Flexible API allows generated code
44 to be wired into virtually any environment. Instead of exposing traditional
45 @code{yylex()} style API, re2c exposes its internals. Be sure to take a look
46 at examples, they cover a lot of real-world cases and shed some light on dark
47 corners of re2c API.")
48 (license public-domain)))