gnu: emacs-svg-icon: Fix grammar.
[jackhill/guix/guix.git] / gnu / packages / pv.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015 Claes Wallin <claes.wallin@greatsinodevelopment.com>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages pv)
20 #:use-module (guix licenses)
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (guix build-system gnu))
24
25 (define-public pv
26 (package
27 (name "pv")
28 (version "1.6.6")
29 (source
30 (origin
31 (method url-fetch)
32 (uri (string-append "https://www.ivarch.com/programs/sources/pv-"
33 version ".tar.bz2"))
34 (sha256
35 (base32
36 "1wbk14xh9rfypiwyy68ssl8dliyji30ly70qki1y2xx3ywszk3k0"))))
37 (build-system gnu-build-system)
38 (home-page "https://www.ivarch.com/programs/pv.shtml")
39 (synopsis "Pipeline progress indicator")
40 (description
41 "pv (Pipe Viewer) is a terminal-based tool for monitoring the progress
42 of data through a pipeline. It can be inserted into any normal pipeline
43 between two processes to give a visual indication of how quickly data is
44 passing through, how long it has taken, how near to completion it is, and an
45 estimate of how long it will be until completion.")
46 (license artistic2.0)))